The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"vlan-ы и trunk-порты (catalyst 2950T)"
Вариант для распечатки Архивированная нить - только для чтения! 
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"vlan-ы и trunk-порты (catalyst 2950T)" 
Сообщение от uzh emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 15-Апр-03, 12:23  (MSK)
Здравствуйте!
Есть cisco catalyst 2950T.
Можно ли на нем организовать следующее:
1. Создается несколько vlan-ов - для разграничения трафика между их пользователями.
2. Несколько портов конфигурируются как транковые (dot1Q) и к ним подключаются сервера.
Итог: пользователи, подключенные к разным vlan-ам друг друга не видят, но видят все сервера, подключенные через транк-порты.
На серверах соответственно стоят карточки, понимающие dot1Q (D-Link DGE 550T).
Будет ли это работать, какие могут быть потенциальные грабли?
  Рекомендовать в FAQ | Cообщить модератору | Наверх

 Оглавление

Индекс форумов | Темы | Пред. тема | След. тема
Сообщения по теме

1. "vlan-ы и trunk-порты (catalyst 2950T)" 
Сообщение от 8thc emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 15-Апр-03, 18:27  (MSK)
>Здравствуйте!
>Есть cisco catalyst 2950T.
>Можно ли на нем организовать следующее:
>1. Создается несколько vlan-ов - для разграничения трафика между их пользователями.
>2. Несколько портов конфигурируются как транковые (dot1Q) и к ним подключаются сервера.
>
>Итог: пользователи, подключенные к разным vlan-ам друг друга не видят, но видят
>все сервера, подключенные через транк-порты.
>На серверах соответственно стоят карточки, понимающие dot1Q (D-Link DGE 550T).
>Будет ли это работать, какие могут быть потенциальные грабли?
Должно работать, аккуратнее только с native vlan'ом

  Рекомендовать в FAQ | Cообщить модератору | Наверх

2. "vlan-ы и trunk-порты (catalyst 2950T)" 
Сообщение от bass Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 16-Апр-03, 05:14  (MSK)
>Здравствуйте!
>Есть cisco catalyst 2950T.
>Можно ли на нем организовать следующее:
>1. Создается несколько vlan-ов - для разграничения трафика между их пользователями.
>2. Несколько портов конфигурируются как транковые (dot1Q) и к ним подключаются сервера.
>
>Итог: пользователи, подключенные к разным vlan-ам друг друга не видят, но видят
>все сервера, подключенные через транк-порты.
>На серверах соответственно стоят карточки, понимающие dot1Q (D-Link DGE 550T).
>Будет ли это работать, какие могут быть потенциальные грабли?


да, работать будет. грабли могут быть с MTU сетевых карт на серверах

  Рекомендовать в FAQ | Cообщить модератору | Наверх

3. "vlan-ы и trunk-порты (catalyst 2950T)" 
Сообщение от uzh Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 17-Апр-03, 16:42  (MSK)
сервер подключен к порту Fa0/5,
клиент vlan2 - к порту Fa0/6,

Не работает :( - не видят друг друга. Если перевести клиента из vlan2 в default vlan, начинает работать - но это не то, чего хотелось бы иметь.

Вот конфигурация:

vlan-ы:

VLAN Name                             Status    Ports
---- -------------------------------- --------- --------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/4
                                                Fa0/7, Fa0/8, Fa0/9, ...
2    VLAN0002                         active    Fa0/3, Fa0/6
3    VLAN0003                         active
4    VLAN0004                         active
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 T2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ -
1    enet  100001     1500  -      -      -        -    -        0      0
2    enet  100002     1500  -      -      -        -    -        0      0
3    enet  100003     1500  -      -      -        -    -        0      0
4    enet  100004     1500  -      -      -        -    -        0      0

Вот транковый порт, общедоступный (на нем сервер с умной картой):

!
interface FastEthernet0/5
switchport trunk native vlan 14
switchport trunk allowed vlan 1-4
switchport mode trunk
switchport nonegotiate
no ip address
duplex full
speed 100

Вот обычный порт, vlan2 (на нем клиент с обычной картой):

!
interface FastEthernet0/6
switchport access vlan 2
switchport mode access
no ip address

Карточка на сервере D-Link DGE 550T: dot1Q: enabled, VLAN Id: 1, full duplex, speed 100

Может я где-то чего-то не так прописал?

  Рекомендовать в FAQ | Cообщить модератору | Наверх

4. "vlan-ы и trunk-порты (catalyst 2950T)" 
Сообщение от bass Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 19-Апр-03, 09:48  (MSK)
>
>!
>interface FastEthernet0/6
> switchport access vlan 2
> switchport mode access
> no ip address
>
>Карточка на сервере D-Link DGE 550T: dot1Q: enabled, VLAN Id: 1, full
>duplex, speed 100
>
>Может я где-то чего-то не так прописал?

no int fa 0/6 sw mod acc

  Рекомендовать в FAQ | Cообщить модератору | Наверх

5. "vlan-ы и trunk-порты (catalyst 2950T)" 
Сообщение от bass Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 19-Апр-03, 09:56  (MSK)
>>Карточка на сервере D-Link DGE 550T: dot1Q: enabled, VLAN Id: 1, full
>>duplex, speed 100
и ещё, у вас карточка в vlan 1 а хост в влане 2, естественно они не видят друг-друга

http://www.cisco.com/en/US/products/hw/switches/ps628/products_configuration_guide_chapter09186a008007e8c7.html

  Рекомендовать в FAQ | Cообщить модератору | Наверх

6. "vlan-ы и trunk-порты (catalyst 2950T)" 
Сообщение от 8thc emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 19-Апр-03, 10:00  (MSK)
>>>Карточка на сервере D-Link DGE 550T: dot1Q: enabled, VLAN Id: 1, full
>>>duplex, speed 100
>и ещё, у вас карточка в vlan 1 а хост в влане
>2, естественно они не видят друг-друга
>
>http://www.cisco.com/en/US/products/hw/switches/ps628/products_configuration_guide_chapter09186a008007e8c7.html


Это ешшо для чего? -
>> no int fa 0/6 sw mod acc

  Рекомендовать в FAQ | Cообщить модератору | Наверх

7. "vlan-ы и trunk-порты (catalyst 2950T)" 
Сообщение от bass Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 19-Апр-03, 10:45  (MSK)
>Это ешшо для чего? -
>>> no int fa 0/6 sw mod acc
это не прямая команда ;) но по логике видно - снять switchport mode access с интерфейса 0/6
  Рекомендовать в FAQ | Cообщить модератору | Наверх

8. "vlan-ы и trunk-порты (catalyst 2950T)" 
Сообщение от uzh Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 21-Апр-03, 10:30  (MSK)
>и ещё, у вас карточка в vlan 1 а хост в влане 2, естественно они не
>видят друг-друга

так ведь сервер-то подключен к транк-порту - а этот  порт должен быть доступен всем vlan-ам.

  Рекомендовать в FAQ | Cообщить модератору | Наверх

9. "vlan-ы и trunk-порты (catalyst 2950T)" 
Сообщение от bass Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 21-Апр-03, 10:53  (MSK)
>>и ещё, у вас карточка в vlan 1 а хост в влане 2, естественно они не
>>видят друг-друга
>
>так ведь сервер-то подключен к транк-порту - а этот  порт должен
>быть доступен всем vlan-ам.

switchport mode access - Set the port to static-access mode. i.e. Disable trunking on a port by returning it to the static-access mode.

не сталкивался с такими "умными" карточками d-link, делал подобное на стандартных 3com 905, eepro100, rl8139, и для того, чтобы виланы просто заработали, на catalyst 2950 на порту куда смотрит сетевая с пачкой виланов дастаточно одной директивы: switchport mode trunk

  Рекомендовать в FAQ | Cообщить модератору | Наверх

10. "vlan-ы и trunk-порты (catalyst 2950T)" 
Сообщение от 8thc emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 21-Апр-03, 10:58  (MSK)
>>>и ещё, у вас карточка в vlan 1 а хост в влане 2, естественно они не
>>>видят друг-друга
>>
>>так ведь сервер-то подключен к транк-порту - а этот  порт должен
>>быть доступен всем vlan-ам.
>
>switchport mode access - Set the port to static-access mode. i.e. Disable
>trunking on a port by returning it to the static-access mode.
>
>
>не сталкивался с такими "умными" карточками d-link, делал подобное на стандартных 3com
>905, eepro100, rl8139, и для того, чтобы виланы просто заработали, на
>catalyst 2950 на порту куда смотрит сетевая с пачкой виланов дастаточно
>одной директивы: switchport mode trunk

Насколько я понял к 6 порту подключена простая тачка - ей как раз нужен switchport mode access; sw access vlan X?


  Рекомендовать в FAQ | Cообщить модератору | Наверх

11. "vlan-ы и trunk-порты (catalyst 2950T)" 
Сообщение от uzh Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 21-Апр-03, 12:24  (MSK)
>Насколько я понял к 6 порту подключена простая тачка - ей как
>раз нужен switchport mode access; sw access vlan X?

да, на 6-м порту - клиент(access vlan 2) с обычной картой, на 5-м(trank), сервер - с картой, понимающей dot1Q.
Я вот подумал еще, может на сервере еще софт какой должен стоять чтоб роутинг vlan-ский был, типа как в Linux-е и Free сделано на уровне ядра. сервер - W2K Server.

  Рекомендовать в FAQ | Cообщить модератору | Наверх

12. "vlan-ы и trunk-порты (catalyst 2950T)" 
Сообщение от Monty emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 12-Дек-04, 12:30  (MSK)
А каким модулем в ядре определяется у Вас карточка D-link DGE-550T?
  Рекомендовать в FAQ | Cообщить модератору | Наверх


Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Пожалуйста, прежде чем написать сообщение, ознакомьтесь с данными рекомендациями.




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру