The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"установка policy-map"
Вариант для распечатки Архивированная нить - только для чтения! 
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"установка policy-map" 
Сообщение от happyboy Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 30-Июл-03, 10:08  (MSK)
Здраствуйте!
Я расписал policy-map для QoS (voip):
!
policy-map QoS
  class voipSignal
   bandwidth 8
  class voiptraffick
    priority 256
   set ip precedence 5
  class All_Traffik
   bandwidth 8
!
class-map match-all voipSignal
  description voipSignal
  match access-group 103
class-map match-all All_Traffik
  description All
  match access-group 104
class-map match-all voiptraffick
  description Voiptrafik
  match access-group 102
!
access-list 102 permit udp any any range 16384 37276
access-list 103 permit tcp any eq 1720 any
access-list 104 permit ip any any
!

Активизирую police-map на интерфейсе:

router(config-if)#service-policy output QoS (Ethernet 0/1)

Однако на интерфейсе QoS не активизирует:
!
interface Ethernet0/1
ip address 10.10.11.2 255.255.255.252
half-duplex
!
И во время теста слышимость плохая (ясно что QoS не пашет)
Так в чём же я ошибся?

  Рекомендовать в FAQ | Cообщить модератору | Наверх

 Оглавление

Индекс форумов | Темы | Пред. тема | След. тема
Сообщения по теме

1. "установка policy-map" 
Сообщение от ВОЛКА emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 30-Июл-03, 10:22  (MSK)
э... а смысл?
как проходить voice-тракт?
  Рекомендовать в FAQ | Cообщить модератору | Наверх

2. "установка policy-map" 
Сообщение от ВОЛКА emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 30-Июл-03, 11:00  (MSK)
упс...
через какие устройства и каналы проходит голосовой трафик?
  Рекомендовать в FAQ | Cообщить модератору | Наверх

3. "установка policy-map" 
Сообщение от happyboy Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 30-Июл-03, 11:02  (MSK)
>э... а смысл?
>как проходить voice-тракт?


Есть 2 роутера Cisco 2611 IOS=c2600-i-mz.122-6.
К каждому роутеру подключены по одной MC3800 IOS=mc3810-a2jk8sv5-mz.122-3.bin, и по одному компу. Между компами генерируется трафик, и проводятся тел. звонки. То есть на входе у роутеров 2 типа трафика. Таким образам в не зависемости от интенсивности трафика между компами надо обеспечить хорошее качество звука.
QoS естествено поставлен как на Cisco2611_1, так и на Cisco2611_2.

  Рекомендовать в FAQ | Cообщить модератору | Наверх

4. "установка policy-map" 
Сообщение от ВОЛКА emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 30-Июл-03, 11:20  (MSK)
есть ли на интерфейсах ошибки, дропы?
  Рекомендовать в FAQ | Cообщить модератору | Наверх

5. "установка policy-map" 
Сообщение от happyboy Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 30-Июл-03, 11:38  (MSK)
>есть ли на интерфейсах ошибки, дропы?


Ethernet0/1 is up, line protocol is up
********************************************
  Internet address is фиктивный
  Last clearing of "show interface" counters never
  Queueing strategy: fifo //может в этом проблема? а как исправить?
  Output queue 0/40, 0 drops (не одного); input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     777725 packets input, 852292465 bytes, 0 no buffer
     Received 132634 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     763329 packets output, 479493858 bytes, 0 underruns
     8544 output errors, 10123 collisions, 16 interface resets
     0 babbles, 0 late collision, 8733 deferred
     8544 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

  Рекомендовать в FAQ | Cообщить модератору | Наверх

6. "установка policy-map" 
Сообщение от ВОЛКА emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 30-Июл-03, 11:52  (MSK)
     763329 packets output, 479493858 bytes, 0 underruns
     8544 output errors, 10123 collisions, 16 interface resets
     0 babbles, 0 late collision, 8733 deferred
     8544 lost carrier, 0 no carrier
разбирайся с этим....
  Рекомендовать в FAQ | Cообщить модератору | Наверх

7. "установка policy-map" 
Сообщение от happyboy Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 30-Июл-03, 12:04  (MSK)
>     763329 packets output, 479493858 bytes, 0 underruns
>
>     8544 output errors, 10123 collisions, 16 interface
>resets
>     0 babbles, 0 late collision, 8733 deferred
>
>     8544 lost carrier, 0 no carrier
>разбирайся с этим....


А нельзя ли подробней.
Ведь по сравнению с количеством посланных пакетов количество ошибок меньше на 2 парядка. Да и как с этим боротся?
И к тому же почему после каманд:
c1_2611(config)#int e0/1
c1_2611(config-if)#service-policy out QoS

в конфигурации интерфейса ничего не меняется:
!
interface Ethernet0/1
ip address ****************
half-duplex
!

  Рекомендовать в FAQ | Cообщить модератору | Наверх

8. "установка policy-map" 
Сообщение от Vlad Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 30-Июл-03, 12:53  (MSK)
можно сделать проще
на интерфейсе
ip rtp priority 16384 16383 256
  Рекомендовать в FAQ | Cообщить модератору | Наверх

9. "установка policy-map" 
Сообщение от Vlad Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 30-Июл-03, 13:14  (MSK)
1% потерь это существенно
да и вообще падение изернета несколько ... хм "необычно" ;)
  Рекомендовать в FAQ | Cообщить модератору | Наверх

10. "установка policy-map" 
Сообщение от Sonne Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 30-Июл-03, 13:41  (MSK)
Откуда вобще коллиззии? Может быть надо везде принудительно full duplex прописать?

  Рекомендовать в FAQ | Cообщить модератору | Наверх

11. "установка policy-map" 
Сообщение от happyboy Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 30-Июл-03, 23:20  (MSK)
Ребята!
Коллизии коллизиями, но смысл QoS-а в том, что  этот 1% ообще не окакзывал влияния на качество звука.
И опять же, что я делаю не так, что команда: "service-policy output QoS", не оказывает своего воздейсртвия?
  Рекомендовать в FAQ | Cообщить модератору | Наверх

12. "установка policy-map" 
Сообщение от ВОЛКА emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 30-Июл-03, 23:40  (MSK)
ДА КАКАЯ РАЗНИЦА!!!
применишь ты полиси или нет, все равно не будет работать, потому что это начинает работать только когда на интерфейсе возникает затор (дропы на интерфейсе)...

проверяй физику...

  Рекомендовать в FAQ | Cообщить модератору | Наверх

14. "установка policy-map" 
Сообщение от Vlad Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 31-Июл-03, 13:02  (MSK)
>ДА КАКАЯ РАЗНИЦА!!!
>применишь ты полиси или нет, все равно не будет работать, потому что
>это начинает работать только когда на интерфейсе возникает затор (дропы
>на интерфейсе)...

дак он же вроде юзает LLQ
а тот работает всегда
он же приоритетную очередь пускает в первую очередь, а остальные все пакеты потом

  Рекомендовать в FAQ | Cообщить модератору | Наверх

13. "установка policy-map" 
Сообщение от Vlad Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 31-Июл-03, 13:00  (MSK)
>Ребята!
>Коллизии коллизиями, но смысл QoS-а в том, что  этот 1% ообще
>не окакзывал влияния на качество звука.
>И опять же, что я делаю не так, что команда: "service-policy output
>QoS", не оказывает своего воздейсртвия?

1% это тот рубеж когда у тебя начинается интерполяция звука, можешь кстати проверить во время звонка, сделай s call ac vo, или s call hi vo после, там есть один параметр, который более менее объективно показывает качество звука, GapFillWithInterpolation, если он не ноль значит звук - гавно
Qos тут совершенно не причем, он только может совать одни пакеты первее других и гарантировать пропускную полосу, вот в чем смысл QoS, а не в том чтобы гарантировать качество звука на барахлящей физике

  Рекомендовать в FAQ | Cообщить модератору | Наверх

15. "установка policy-map" 
Сообщение от Vlad Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 31-Июл-03, 13:14  (MSK)
вообще сходи сюда
http://www.cisco.com/en/US/tech/tk652/tk698/technologies_tech_note09186a0080094660.shtml

и посмотри как по человечески все конфигурицца
у тебя малость как то напутано

  Рекомендовать в FAQ | Cообщить модератору | Наверх

17. "установка policy-map" 
Сообщение от happyboy Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 31-Июл-03, 19:41  (MSK)
>вообще сходи сюда
>http://www.cisco.com/en/US/tech/tk652/tk698/technologies_tech_note09186a0080094660.shtml
>
>и посмотри как по человечески все конфигурицца
>у тебя малость как то напутано


Так я этим доком и пользовался.
***********************************
Кстати: GapFillWithInterpolation=0 ms

  Рекомендовать в FAQ | Cообщить модератору | Наверх

18. "установка policy-map" 
Сообщение от Vlad Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 01-Авг-03, 12:21  (MSK)
>Кстати: GapFillWithInterpolation=0 ms

тогда в чем заключается "плохая слышимость"?

  Рекомендовать в FAQ | Cообщить модератору | Наверх

19. "установка policy-map" 
Сообщение от happyboy Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 01-Авг-03, 12:59  (MSK)
>>Кстати: GapFillWithInterpolation=0 ms
>
>тогда в чем заключается "плохая слышимость"?


Cлышно плохо, речь неразборчивая, при интенсивном трафике не возможно даже смысл уловить.

  Рекомендовать в FAQ | Cообщить модератору | Наверх

26. "установка policy-map" 
Сообщение от Vlad Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 04-Авг-03, 12:57  (MSK)
а дропы есть по этой же команде?
  Рекомендовать в FAQ | Cообщить модератору | Наверх

27. "установка policy-map" 
Сообщение от Vlad Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 04-Авг-03, 13:01  (MSK)
>а дропы есть по этой же команде?
в диалпирах плэйауты прописал?
заодно покажи что у тебя на s in e0/1
и что говорит когда ты политику на интерфейс цепляешь
  Рекомендовать в FAQ | Cообщить модератору | Наверх

28. "установка policy-map" 
Сообщение от happyboy Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 05-Авг-03, 09:04  (MSK)
>>а дропы есть по этой же команде?
>в диалпирах плэйауты прописал?
>заодно покажи что у тебя на s in e0/1
>и что говорит когда ты политику на интерфейс цепляешь


А плэйаут за чем?

  Рекомендовать в FAQ | Cообщить модератору | Наверх

29. "установка policy-map" 
Сообщение от Vlad Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 05-Авг-03, 12:05  (MSK)
это выравнивающий буфер
пакеты могут запаздывать или наоборот поспешать на микродоли секунды, поэтому лучше сначала собирать эти пакеты в этот буфер а потому уже в речь
это создает задержку, но задержка в 100мсек практически неощутима, а вот джиттер из-за шатания пакетов огого
  Рекомендовать в FAQ | Cообщить модератору | Наверх

16. "установка policy-map" 
Сообщение от Sypher emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 31-Июл-03, 18:17  (MSK)
>есть ли на интерфейсах ошибки, дропы?

А если есть дропы? то как от них избавиться?

  Рекомендовать в FAQ | Cообщить модератору | Наверх

20. "установка policy-map" 
Сообщение от happyboy Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 01-Авг-03, 18:16  (MSK)
Ребята, вот  конфиг :

!
class-map match-all voice-signaling
  match access-group 103
class-map match-all voice-traffic
  match access-group 102
!
!
policy-map VOICE-POLICY
  class voice-traffic
    priority 1024 1024
  class voice-signaling
   bandwidth 8
  class class-default
   fair-queue
!
!
!
interface Ethernet0/0 //in интерфейс для простого трафика
ip address * 255.255.255.252
no ip mroute-cache
half-duplex
!

!
interface Ethernet0/1 //out интерфейс
ip address * 255.255.255.252
no ip mroute-cache
half-duplex
service-policy output VOICE-POLICY
!

interface Ethernet1/0 //in интерфейс для voice трафика (FXS плата для MS3800 )
ip address * 255.255.255.252
half-duplex
!
router eigrp 1
************************
auto-summary
no eigrp log-neighbor-changes
!
access-list 102 permit udp any any range 16384 32776
access-list 103 permit tcp any eq 1720 any
access-list 103 permit tcp any any eq 1720
!
end
*********************************************************
на соседнем Cisco2611 точно такой же конфиг.
На ms3800 интерполяций звука нет.
Создаётся впечатление, что police-map не пашет, так-как при отсуствии трафика слышимость хорошая (речь внятная, разбопчивая),после генерации трафика звук резко ухудшается.

З.Ы.
Роутеры соединены DSL модемами.

ՊծՍծ
Качетво "железа" высокое.

  Рекомендовать в FAQ | Cообщить модератору | Наверх

21. "установка policy-map" 
Сообщение от ВОЛКА emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 01-Авг-03, 18:28  (MSK)
в вашем случае надо делать что-то вроде этого...
!
policy-map child
class voice
  priority 512
!
policy-map VOICE
class class-default
  shape average 2000000
  service-policy child
!
  Рекомендовать в FAQ | Cообщить модератору | Наверх

22. "установка policy-map" 
Сообщение от happyboy Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 01-Авг-03, 19:21  (MSK)
>в вашем случае надо делать что-то вроде этого...
>!
>policy-map child
> class voice
>  priority 512
>!
>policy-map VOICE
> class class-default
>  shape average 2000000
>  service-policy child
>!

Можно по-подробней.
А то копи-паст не помог...

  Рекомендовать в FAQ | Cообщить модератору | Наверх

23. "установка policy-map" 
Сообщение от ВОЛКА emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 01-Авг-03, 19:34  (MSK)
я уже объяснял.... тот сервис-полиси, который вы вешаете на интерфейс, не работает, так как затор возникает на dsl линке, а не на ethernet.

поэтому надо прикинуть пропускную спосодность dsl линка, и сделать cbwfq внутри шейпинга...

подробности - www.cisco.com

  Рекомендовать в FAQ | Cообщить модератору | Наверх

24. "установка policy-map" 
Сообщение от happyboy Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 02-Авг-03, 15:08  (MSK)
>я уже объяснял.... тот сервис-полиси, который вы вешаете на интерфейс, не работает,
>так как затор возникает на dsl линке, а не на ethernet.
>
>
>поэтому надо прикинуть пропускную спосодность dsl линка, и сделать cbwfq внутри шейпинга...
>
>
>подробности - www.cisco.com
Означает ли это что повесив на этот интерфейс трафик-шейп равный пропускной спосодности dsl линка мой сервис-полиси заработает.

  Рекомендовать в FAQ | Cообщить модератору | Наверх

25. "установка policy-map" 
Сообщение от ВОЛКА emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 02-Авг-03, 15:11  (MSK)
>>я уже объяснял.... тот сервис-полиси, который вы вешаете на интерфейс, не работает,
>>так как затор возникает на dsl линке, а не на ethernet.
>>
>>
>>поэтому надо прикинуть пропускную спосодность dsl линка, и сделать cbwfq внутри шейпинга...
>>
>>
>>подробности - www.cisco.com
>Означает ли это что повесив на этот интерфейс трафик-шейп равный пропускной спосодности
>dsl линка мой сервис-полиси заработает.
не заработает...
делать надо подобно тому, как я показал в примере
и делать это надо с двух сторон...
  Рекомендовать в FAQ | Cообщить модератору | Наверх


Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Пожалуйста, прежде чем написать сообщение, ознакомьтесь с данными рекомендациями.




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру