The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"cisco 2621 проблема с route-map, не работает "
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"cisco 2621 проблема с route-map, не работает " 
Сообщение от accept emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 31-Мрт-05, 16:42  (MSK)

требуется завернуть траффик eq www на squid

no ip cef
;
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.0.254 255.255.255.0
ip access-group 10 in
no ip directed-broadcast
ip accounting output-packets
ip nat inside
no ip mroute-cache
ip policy route-map forced-proxy
;

route-map forced-proxy permit 10
match ip address 101
set ip next-hop 192.168.0.250
;
access-list 101 deny   tcp host 192.168.0.250 any eq www
access-list 101 permit tcp any any
;

не работает


  Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

 Оглавление

Индекс форумов | Темы | Пред. тема | След. тема
Сообщения по теме

1. "cisco 2621 проблема с route-map, не работает " 
Сообщение от Nailer emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 31-Мрт-05, 17:12  (MSK)
>
>
>требуется завернуть траффик eq www на squid
>
>no ip cef
>;
>interface FastEthernet0/0.10
> encapsulation dot1Q 10
> ip address 192.168.0.254 255.255.255.0
> ip access-group 10 in
> no ip directed-broadcast
> ip accounting output-packets
> ip nat inside
> no ip mroute-cache
> ip policy route-map forced-proxy
>;
>
>route-map forced-proxy permit 10
> match ip address 101
> set ip next-hop 192.168.0.250
>;
>access-list 101 deny   tcp host 192.168.0.250 any eq www
>access-list 101 permit tcp any any
>;
>
>не работает

sh ip int fa0/0


  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

3. "cisco 2621 проблема с route-map, не работает " 
Сообщение от accept emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 01-Апр-05, 09:04  (MSK)
>>
>>
>>требуется завернуть траффик eq www на squid
>>
>>no ip cef
>>;
>>interface FastEthernet0/0.10
>> encapsulation dot1Q 10
>> ip address 192.168.0.254 255.255.255.0
>> ip access-group 10 in
>> no ip directed-broadcast
>> ip accounting output-packets
>> ip nat inside
>> no ip mroute-cache
>> ip policy route-map forced-proxy
>>;
>>
>>route-map forced-proxy permit 10
>> match ip address 101
>> set ip next-hop 192.168.0.250
>>;
>>access-list 101 deny   tcp host 192.168.0.250 any eq www
>>access-list 101 permit tcp any any
>>;
>>
>>не работает
>
>sh ip int fa0/0
#sh ip int fa0/0
FastEthernet0/0 is up, line protocol is up
  Internet protocol processing disabled
#sh ip int fa0/0.10
FastEthernet0/0.10 is up, line protocol is up
  Internet address is 10.5.5.254/24
  Broadcast address is 255.255.255.255
  Address determined by non-volatile memory
  MTU is 1500 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Multicast reserved groups joined: 224.0.0.10
  Outgoing access list is not set
  Inbound  access list is 10
  Proxy ARP is enabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are always sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is enabled
  IP fast switching on the same interface is enabled
  IP Flow switching is disabled
  IP Feature Fast switching turbo vector
  IP multicast fast switching is disabled
  IP multicast distributed fast switching is disabled
  IP route-cache flags are Fast
  Router Discovery is disabled
  IP output packet accounting is enabled
  IP access violation accounting is disabled, system threshold is 512
  TCP/IP header compression is disabled
  RTP/IP header compression is disabled
  Probe proxy name replies are disabled
  Policy routing is disabled
  Network address translation is enabled, interface in domain inside
  WCCP Redirect outbound is disabled
  WCCP Redirect exclude is disabled
  BGP Policy Mapping is disabled


  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

4. "cisco 2621 проблема с route-map, не работает " 
Сообщение от bebebe Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 01-Апр-05, 09:06  (MSK)
>>>interface FastEthernet0/0.10
>>> encapsulation dot1Q 10
>>> ip address 192.168.0.254 255.255.255.0

>#sh ip int fa0/0.10
>FastEthernet0/0.10 is up, line protocol is up
>  Internet address is 10.5.5.254/24

это нормально?

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

6. "cisco 2621 проблема с route-map, не работает " 
Сообщение от Сайко Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 01-Апр-05, 09:13  (MSK)
>>>>interface FastEthernet0/0.10
>>>> encapsulation dot1Q 10
>>>> ip address 192.168.0.254 255.255.255.0
>
>>#sh ip int fa0/0.10
>>FastEthernet0/0.10 is up, line protocol is up
>>  Internet address is 10.5.5.254/24
>
>это нормально?
Вполне нормально, более чем.
Коллега, а что Вас смущяет?
  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

8. "cisco 2621 проблема с route-map, не работает " 
Сообщение от bebebe Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 01-Апр-05, 09:19  (MSK)
>>>>>interface FastEthernet0/0.10
>>>>> encapsulation dot1Q 10
>>>>> ip address 192.168.0.254 255.255.255.0
>>
>>>#sh ip int fa0/0.10
>>>FastEthernet0/0.10 is up, line protocol is up
>>>  Internet address is 10.5.5.254/24
>>
>>это нормально?
>Вполне нормально, более чем.
>Коллега, а что Вас смущяет?

Адреса разные

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

9. "cisco 2621 проблема с route-map, не работает " 
Сообщение от Сайко Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 01-Апр-05, 09:22  (MSK)
>Адреса разные
Так сегодня не 31 марта и не 2 апреля.

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

2. "cisco 2621 проблема с route-map, не работает " 
Сообщение от sh_ Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 31-Мрт-05, 19:00  (MSK)
А что не работает? Может на машинке со сквидом что-то не так? Чем ip подменяете?
Покажите tcpdump во время коннекта.
  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

5. "cisco 2621 проблема с route-map, не работает " 
Сообщение от accept emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 01-Апр-05, 09:10  (MSK)
>А что не работает? Может на машинке со сквидом что-то не так?
>Чем ip подменяете?
>Покажите tcpdump во время коннекта.

на squid ничего не попадает ...
подобную операцию проводил с соседней конторе на 2821 - усе работает, конфиг отличается только ip адресами

Помогайте коллеги ....

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

7. "cisco 2621 проблема с route-map, не работает " 
Сообщение от Сайко Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 01-Апр-05, 09:14  (MSK)
>Помогайте коллеги ....
  Policy routing is disabled
Добейтесь противоположного.
  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

10. "cisco 2621 проблема с route-map, не работает " 
Сообщение от GroundBeat Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 01-Апр-05, 09:30  (MSK)
WCCP Redirect outbound is disabled
WCCP Redirect exclude is disabled
В эту сторону надо копать имхо. WCCP для этого и сделан. Не нужно усложнять.
  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

12. "cisco 2621 проблема с route-map, не работает " 
Сообщение от accept emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 01-Апр-05, 09:40  (MSK)
>>Помогайте коллеги ....
>  Policy routing is disabled
>Добейтесь противоположного.
это не проблема:

Policy routing is enabled, using route map forced-proxy
проблема понять почему на 10.5.5.250 ничего не попадает

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

11. "cisco 2621 проблема с route-map, не работает " 
Сообщение от Сайко Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 01-Апр-05, 09:35  (MSK)
>на squid ничего не попадает ...
>подобную операцию проводил с соседней конторе на 2821 - усе работает, конфиг
>отличается только ip адресами
>
>Помогайте коллеги ....
Попробуйюе отключить/включить ip cef.
  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

14. "cisco 2621 проблема с route-map, не работает " 
Сообщение от accept emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 01-Апр-05, 09:51  (MSK)
>>на squid ничего не попадает ...
>>подобную операцию проводил с соседней конторе на 2821 - усе работает, конфиг
>>отличается только ip адресами
>>
>>Помогайте коллеги ....
>Попробуйюе отключить/включить ip cef.
пробовал и глобально и для int fa0/0.10
не помогает
пробовал поднимать wccp - gre up, cisco кэш видит, траффик на squid отсутствует ...
  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

16. "cisco 2621 проблема с route-map, не работает " 
Сообщение от Сайко Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 01-Апр-05, 09:57  (MSK)
Стоп, а какой у Вас входящий интерфейс для http трафика?
fa0/0.10 насколько я понял смотрит на squid, значит он исходящий. Policy применяется на входящем(по отношению к трафику) интерфейсе.
Вроде так...
  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

18. "cisco 2621 проблема с route-map, не работает " 
Сообщение от accept emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 01-Апр-05, 12:05  (MSK)
>Стоп, а какой у Вас входящий интерфейс для http трафика?
>fa0/0.10 насколько я понял смотрит на squid, значит он исходящий. Policy применяется
>на входящем(по отношению к трафику) интерфейсе.
>Вроде так...
Current configuration:
!
! Last configuration change at 11:33:11 MSD Fri Apr 1 2005 by accept
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname MVX_Router
!
aaa new-model
aaa authentication ppp default local
enable password 7 120D12181F0A0F0C3E392B3D313927
!
username accept password 7 1355464B595F5C
!
!
!
!
clock timezone MSK 3
clock summer-time MSD recurring last Sun Mar 3:00 last Sun Oct 3:00
ip subnet-zero
ip host-routing
no ip domain-lookup
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
no ip directed-broadcast
no ip mroute-cache
speed 100
full-duplex
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 10.5.5.254 255.255.255.0
ip access-group 10 in
no ip directed-broadcast
ip accounting output-packets
ip nat inside
no ip mroute-cache


!
interface Serial0/0
ip address 212.248.127.14 255.255.255.252
no ip directed-broadcast
ip accounting output-packets
ip nat outside
no ip route-cache
no ip mroute-cache
down-when-looped
!
interface FastEthernet0/1
ip address 195.210.157.81 255.255.255.240
no ip directed-broadcast
ip accounting output-packets
speed 100
full-duplex
!
ip nat pool MVX 195.210.157.81 195.210.157.81 netmask 255.255.255.240
ip nat inside source list 10 pool MVX overload
ip classless
ip route 0.0.0.0 0.0.0.0 212.248.127.13
no ip http server
!
logging facility local0
logging 10.5.5.204
access-list 10 permit any
access-list 101 permit tcp any any
access-list 101 deny   tcp host 10.5.5.204 any eq www
route-map forced-proxy permit 100
match ip address 101
set ip next-hop 10.5.5.204
!
end

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

20. "cisco 2621 проблема с route-map, не работает " 
Сообщение от BJ Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 03-Апр-05, 02:46  (MSK)
>enable password 7 120D12181F0A0F0C3E392B3D313927
>!
>username accept password 7 1355464B595F5C

019238

twomachtrouble

Пароли смени

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

13. "cisco 2621 проблема с route-map, не работает " 
Сообщение от sh_ Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 01-Апр-05, 09:47  (MSK)
А squid пингается с циски?
  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

15. "cisco 2621 проблема с route-map, не работает " 
Сообщение от accept emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 01-Апр-05, 09:56  (MSK)
>А squid пингается с циски?
я даже проверил...  :)

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

17. "cisco 2621 проблема с route-map, не работает " 
Сообщение от Сайко Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 01-Апр-05, 10:27  (MSK)
>>А squid пингается с циски?
>я даже проверил...  :)
Ну а результат какой?
Еще у Вас стоит какой то ACL 10 на вход - может дело в нем?

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

19. "не работает " 
Сообщение от Liaxa emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 01-Апр-05, 20:48  (MSK)
Есть сеть (Локальная)  чуть меньше 100 машин...  сеть работает идеально,Но иногда каскадами рушиться -То есть вырубаеться полностью и не падает признаков жизни (ни пингов ни компов в сетевом окружении ни качает вообщем как будто ее и нету) Спустя неопределенно время она опять ни с того ни с чего оживает и работает опять прекрасно....
>сеть имеет Топологию звезда(гланый свич ->к нему 24 второстепенных свича-> и уже к ним машины пользователей...)СЕРВАКА В СЕТИ НЕТУ....Я в сети сижу под разными тачками работает идеально и под виндой и под линухом...Что можеь быть???? в чем причина таких чудес????????
  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

21. "cisco 2621 проблема с route-map, не работает " 
Сообщение от bimax emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 03-Апр-05, 08:55  (MSK)
>
>
>требуется завернуть траффик eq www на squid
>
>no ip cef
>;
>interface FastEthernet0/0.10
> encapsulation dot1Q 10
> ip address 192.168.0.254 255.255.255.0
> ip access-group 10 in
> no ip directed-broadcast
> ip accounting output-packets
> ip nat inside
> no ip mroute-cache
> ip policy route-map forced-proxy
>;
>
>route-map forced-proxy permit 10
> match ip address 101
> set ip next-hop 192.168.0.250
>;
>access-list 101 deny   tcp host 192.168.0.250 any eq www
>access-list 101 permit tcp any any
>;
>
>не работает

А это зачем?
> encapsulation dot1Q 10

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

22. "cisco 2621 проблема с route-map, не работает " 
Сообщение от bimax emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 03-Апр-05, 09:05  (MSK)
>
>
>требуется завернуть траффик eq www на squid
>
>no ip cef
>;
>interface FastEthernet0/0.10
> encapsulation dot1Q 10
> ip address 192.168.0.254 255.255.255.0
> ip access-group 10 in
> no ip directed-broadcast
> ip accounting output-packets
> ip nat inside
> no ip mroute-cache
> ip policy route-map forced-proxy
>;
>
>route-map forced-proxy permit 10
> match ip address 101
> set ip next-hop 192.168.0.250
>;
>access-list 101 deny   tcp host 192.168.0.250 any eq www
>access-list 101 permit tcp any any
>;
>
>не работает


Кстати разве в ACL не пишется в начале сорс адрес а потом дестенейшин...

Судя по роут мапу приходит ко мне пакет с 192.168.0.250 на любой www сервер и я ему тут же некст хопом подставляю тот же адрес скоторого он пришёл.
Колеги поправте если я не прав.

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

23. "cisco 2621 проблема с route-map, не работает " 
Сообщение от One Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 03-Апр-05, 12:28  (MSK)
>Судя по роут мапу приходит ко мне пакет с 192.168.0.250 на любой
>www сервер и я ему тут же некст хопом подставляю тот
>же адрес скоторого он пришёл.
>Колеги поправте если я не прав.

приходит пакет с прокси - он не попадает под правила роутмапа и идет в согласии с обычным роутингом...

автору порекомендовал бы посмотреть в сторону сервера - пакеты приходят с дестинейшн портом 80, а прокси слушает 3128, нужно перекидывать пакеты... на squid.opennet.ru есть примеры как делать под фрей и линухом...

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх


Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Пожалуйста, прежде чем написать сообщение, ознакомьтесь с данными рекомендациями.




Спонсоры:
Слёрм
Inferno Solutions
Hosting by Ihor
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2019 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру