The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"проблема с Zebra"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"проблема с Zebra" 
Сообщение от RedAnt emailИскать по авторуВ закладки(ok) on 22-Июл-05, 13:30  (MSK)
Добрый день!
Я поднял 2 VMware машины с FreeBSD 5.3 + Zebra 0.95. Назвал их Vienna и NewYork. Поставил на каждую по 2 карточки и сконфигурировал их.
NewYork: lnc0 192.168.1.1 255.255.255.0
         lnc1 192.168.2.1 255.255.255.0
Vienna:  lnc0 192.168.1.254 255.255.255.0
         lnc1 192.168.3.1 255.255.255.0
Прописал конфиги:
NewYork:
/usr/local/etc/zebra.conf
!
interface lnc0
ip address 192.168.1.1/24
no shutdown
interface lnc1
ip address 192.168.2.1/24
no shutdown
!
log file zebra.log
-----------------------
/usr/local/etc/ripd.conf
!
hostname NewYork
!
router rip
network 192.168.1.0/24
network lnc0
network 192.168.2.0/24
network lnc1
!
log file ripd.log
!
log stdout
--------------------
--------------------
Vienna:
/usr/local/etc/zebra.conf
!
interface lnc0
ip address 192.168.1.254/24
no shutdown
interface lnc1
ip address 192.168.3.1/24
no shutdown
!
log file zebra.log
-----------------------
/usr/local/etc/ripd.conf
!
hostname Vienna
!
router rip
network 192.168.1.0/24
network lnc0
network 192.168.3.0/24
network lnc1
!
log file ripd.log
!
log stdout
-------------
потом я пустил ping  с NewYork 192.168.1.254 и мне в ответ
ping: send to: invalid argument
до запуска демонов пинг проходил.
В чем может быть загвоздка?
И как посмотреть что-то типа sh ip route?
  Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

 Оглавление

Индекс форумов | Темы | Пред. тема | След. тема
Сообщения по теме

1. "проблема с Zebra" 
Сообщение от Chris Искать по авторуВ закладки(??) on 22-Июл-05, 14:51  (MSK)
netstat -rn в студию 6-)
на зебре
sh ip
sh ip route
sh ip bgp summary
  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

2. "проблема с Zebra" 
Сообщение от RedAnt emailИскать по авторуВ закладки(ok) on 22-Июл-05, 15:26  (MSK)
>netstat -rn в студию 6-)
>на зебре
>sh ip
>sh ip route
>sh ip bgp summary
Извините, я там чуть напутал в конфигах. sh ip route работает и показывает, что он уже по рипу выучил маршруты!
Но когда я пингую все равно тоже самое выдает(((
Vienna# netstat -rn
Internet:
Destination    Gateway           Flags    Refs    Use    Netif Expire
127.0.0.1      127.0.0.1         UH       0       528    lo0
192.168.1      link#1            UC       0       0      lnc0
192.168.1.1    link#1            UHLW     1       8      lnc0
192.168.1.254  00:0c:29:84:5f:b8 UHLW     0       2      lo0
192.168.2      192.168.1.1       UG1      0       0      lnc0
192.168.3      link#2            UC       0       0      lnc1

NewYork# netstat -rn
Internet:
Destination    Gateway           Flags    Refs    Use    Netif Expire
127.0.0.1      127.0.0.1         UH       0       320    lo0
192.168.1      link#1            UC       0       0      lnc0
192.168.1.1    link#1            UHLW     1       2      lnc0
192.168.2      link#2            UC       0       0      lnc1
192.168.3      192.168.1.254     UG1      0       0      lnc0

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

3. "проблема с Zebra" 
Сообщение от RedAnt emailИскать по авторуВ закладки(ok) on 22-Июл-05, 22:56  (MSK)
Ребята, ну хоть кто-то может мне ответить?
Должны ли с машины на которой стоит зебра ping-оваться маршруты?
А то у меня выходит, что маршруты в netstat -rn есть а не пингуются хосты на этих маршрутах.
Подскажите кто знает!!!
  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

4. "проблема с Zebra" 
Сообщение от Alan_1 Искать по авторуВ закладки(??) on 26-Июл-05, 13:48  (MSK)
RedAnt - Вы получили мое письмо? Покажите sh ip route. вы пробовали половить пакеты сетевым анализатором - они доходят на сетевые карты на витуальных машинах?
  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

5. "проблема с Zebra" 
Сообщение от RedAnt emailИскать по авторуВ закладки(ok) on 27-Июл-05, 00:11  (MSK)
>RedAnt - Вы получили мое письмо? Покажите sh ip route. вы пробовали
>половить пакеты сетевым анализатором - они доходят на сетевые карты на
>витуальных машинах?
Спасибо, что ответили. Я был в командировке, поэтому не ответил. Маршрутизацию поднял, там в другом проблемка была. Нужно было сделать элементарный конфиг, а потом по телнету сконфигурить, а я конфигурацию руками вбил, а Зебра там подменяет названия интерфейсов, а я этого не сделал, прописал сразу на lnc0, lnc1.
Вот теперь только подскажите, а debug rip events пашет у кого-нибудь. У меня команду захавал, а ничего не дебагит.

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх


Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ]
Пожалуйста, прежде чем написать сообщение, ознакомьтесь с данными рекомендациями.




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру