The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Apache 2.0.45 + php4.3.1"
Вариант для распечатки Архивированная нить - только для чтения! 
Пред. тема | След. тема 
Форумы WEB технологии (Public)
Изначальное сообщение [Проследить за развитием треда]

"Apache 2.0.45 + php4.3.1"
Сообщение от Rodriges Искать по авторуВ закладки on 25-Апр-03, 20:32  (MSK)
У меня проблемы при установки сабжа.

Пробовал устанавливать их на линукс ред хат 8.0 под Интел и на Солярил 9 под процессор Спарк и всегда получал одну и ту же ошибку. Последовательность действий

1. распаковываю
2. cd ../apache; ./configure --enable-rewrite --enable-so (--enable-module=so); make; make install
3. cd ../php; ./configure --with-mysql --with-apxs=/usr/local/apache2/bin/apxs (--with-apxs2=/usr/local/apache2/bin/apxs)

И тут скрипт завершается и делает три вывода, чего же у меня в системе нет
1. Нет Перла
2. Апачи сконфигурирован без enable-so
3. Неверный путь к apxs

Все эти причины никуда не годятся, поскольку все я сделал верно.

Попробовал запустить апачи и обламался, значит, этоо не в пшп дело, а в веб-сервере. А вот что такое не пойму. Может, кто сталкивался с такой проблемой?

ЗЫ Если установить Апачи < 2, то все идет нормально, но мне действительно нужен 2 апачи, начальство требует

  Рекомендовать в FAQ | Cообщить модератору | Наверх

 Оглавление

Индекс форумов | Темы | Пред. тема | След. тема
Сообщения по теме

1. "Apache 2.0.45 + php4.3.1"
Сообщение от uldus Искать по авторуВ закладки on 25-Апр-03, 22:25  (MSK)
>1. распаковываю
>2. cd ../apache; ./configure --enable-rewrite --enable-so (--enable-module=so); make; make install
>3. cd ../php; ./configure --with-mysql --with-apxs=/usr/local/apache2/bin/apxs (--with-apxs2=/usr/local/apache2/bin/apxs)

Вполне достаточно:
Apache
./configure --enable-so
make
make install
PHP
./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql=/usr/local/mysql
make
make install


>1. Нет Перла
>2. Апачи сконфигурирован без enable-so
>3. Неверный путь к apxs
>
>Все эти причины никуда не годятся, поскольку все я сделал верно.

Если ругается, то одно из трех, как минимум, истина.


>ЗЫ Если установить Апачи < 2, то все идет нормально, но мне
>действительно нужен 2 апачи, начальство требует

Интересно для чего может потребоваться начальству apache2, помогать разработчикам apache тестировать нестабильный код ? ;-)

  Рекомендовать в FAQ | Cообщить модератору | Наверх

2. "Apache 2.0.45 + php4.3.1"
Сообщение от Rodriges Искать по авторуВ закладки on 25-Апр-03, 23:12  (MSK)
>Интересно для чего может потребоваться начальству apache2, помогать >разработчикам apache тестировать нестабильный код ? ;-)

Насчет нестабильного кода я уже успел заметить при установке, а зачем же начальству нужун именно 2.0.45, так разработчики объявили о дыре в защите во всех версиях апачи вплоть до 2.0.44

Насчет того, что в системе чего-то нет, так я и говорю - неверно апач установлен, поскольку не запускается, хотя ошибок при компиляции не выдавал. Вот и спрашиваю, может, это я все правильно делаю, а виноваты разработчики, и я действительно испытываю бета-код?


  Рекомендовать в FAQ | Cообщить модератору | Наверх

4. "Apache 2.0.45 + php4.3.1"
Сообщение от bulka Искать по авторуВ закладки on 26-Апр-03, 22:40  (MSK)
Дыра во всех версиях ВТОРОГО апача, т.е. с 2.0.0 по 2.0.43, к 1.3 это не имеет не малейшего отношения.
  Рекомендовать в FAQ | Cообщить модератору | Наверх

5. "Apache 2.0.45 + php4.3.1"
Сообщение от uldus Искать по авторуВ закладки on 27-Апр-03, 21:50  (MSK)
>зачем же начальству нужун именно 2.0.45, так разработчики объявили о дыре в >защите во всех версиях апачи вплоть до 2.0.44

Слышат звон да незнают где он. 1.3 и 2.0 - это _совершенно_ разные, никак не связанные между собой, ветки разработки. 1.3 - стабильная, 2.0 - пока еще эксперементальная, смысл использовать которую имеет место только в экстаординарных случаях либо под win платформой.

>виноваты разработчики, и я действительно испытываю бета-код?

точно.

  Рекомендовать в FAQ | Cообщить модератору | Наверх

3. "Apache 2.0.45 + php4.3.1"
Сообщение от michelle Искать по авторуВ закладки on 26-Апр-03, 09:10  (MSK)
>У меня проблемы при установки сабжа.
>
>Пробовал устанавливать их на линукс ред хат 8.0 под Интел и на
>Солярил 9 под процессор Спарк и всегда получал одну и ту
>же ошибку. Последовательность действий
>
>1. распаковываю
>2. cd ../apache; ./configure --enable-rewrite --enable-so (--enable-module=so); make; make install
>3. cd ../php; ./configure --with-mysql --with-apxs=/usr/local/apache2/bin/apxs (--with-apxs2=/usr/local/apache2/bin/apxs)
>
>И тут скрипт завершается и делает три вывода, чего же у меня
>в системе нет
>1. Нет Перла
    ^^^^^^^^^ см. файл apxs - там может надо подправить первую строку на реально существующий PERL (где он - можно узнать which perl)

>2. Апачи сконфигурирован без enable-so
>3. Неверный путь к apxs
>
>Все эти причины никуда не годятся, поскольку все я сделал верно.
>
>Попробовал запустить апачи и обламался, значит, этоо не в пшп дело, а
>в веб-сервере. А вот что такое не пойму. Может, кто сталкивался
>с такой проблемой?
>
>ЗЫ Если установить Апачи < 2, то все идет нормально, но мне
>действительно нужен 2 апачи, начальство требует


От себя - ставил всю связку и под RedHat и под FreeBSD - все работало!!!!

  Рекомендовать в FAQ | Cообщить модератору | Наверх

6. "Apache 2.0.45 + php4.3.1"
Сообщение от Rodriges Искать по авторуВ закладки on 28-Апр-03, 22:57  (MSK)
Все оказалось до банальности просто,

LD_LIBRARY_PATH=...;export LD_LIBRARY_PATH;

  Рекомендовать в FAQ | Cообщить модератору | Наверх

7. "Apache 2.0.45 + php4.3.0"
Сообщение от abm Искать по авторуВ закладки on 03-Май-03, 14:40  (MSK)

а у меня ни фига не работает.

Делаю всё, когфигурирцую как в мануале, инсталлю, добавляю в httpd.conf строчку, а он гад при попытке обратится к пхп документу хочет соъхранить его на диске :(((((

  Рекомендовать в FAQ | Cообщить модератору | Наверх

8. "Apache 2.0.45 + php4.3.0"
Сообщение от abm Искать по авторуВ закладки on 03-Май-03, 15:00  (MSK)
>
>а у меня ни фига не работает.
>
>Делаю всё, когфигурирцую как в мануале, инсталлю, добавляю в httpd.conf строчку, а
>он гад при попытке обратится к пхп документу хочет соъхранить его
>на диске :(((((
блин комп выкину скоро в окошко. Три дня пытаюсь потсавить апач и пхп.

Ну почему когда вызываешь пхп скрипт он его не исполняет, а пытается сохранить на диске???? :((((((((

  Рекомендовать в FAQ | Cообщить модератору | Наверх

9. "Apache 2.0.45 + php4.3.0"
Сообщение от michelle Искать по авторуВ закладки on 03-Май-03, 16:21  (MSK)
>>
>>а у меня ни фига не работает.
>>
>>Делаю всё, когфигурирцую как в мануале, инсталлю, добавляю в httpd.conf строчку, а
>>он гад при попытке обратится к пхп документу хочет соъхранить его
>>на диске :(((((
>блин комп выкину скоро в окошко. Три дня пытаюсь потсавить апач и
>пхп.
>
>Ну почему когда вызываешь пхп скрипт он его не исполняет, а пытается
>сохранить на диске???? :((((((((

В httpd.conf добавь
LoadModule php4_module modules/libphp4.so
AddType application/x-httpd-php .php .exe .phtml
                                     ^^^^^ даже ТАКОЙ прикол проходит (есстесственно в этом файле код php!!!!!)
Так что скорее всего это ТВОИ руки кривые, а не разработчиков APACHE и PHP

  Рекомендовать в FAQ | Cообщить модератору | Наверх


Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Пожалуйста, прежде чем написать сообщение, ознакомьтесь с данными рекомендациями.




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру