The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Представлен черновой вариант API для работы с файлами на JavaScript

26.11.2009 22:55

Консорциум W3C опубликовал первый черновой вариант нового JavaScript API, стандартизирующего средства для обработки локальных файлов в web-браузере. Для обработки файлов на локальной машине пользователя используется объект FileReader, при этом доступ предоставляется только к загруженным в рамках текущей сессии через web-формы файлам. Т.е. обработать произвольный файл в локальной файловой системе нельзя, а файл выбранный вручную пользователем - можно. Наглядный пример использования нового API можно посмотреть в данной заметке.

Дополнение: Поддержка данного файлового API уже реализована в вышедшем сегодня Firefox 3.6-beta4.

  1. Главная ссылка к новости (http://www.w3.org/News/2009#en...)
Лицензия: CC-BY
Тип: К сведению
Короткая ссылка: https://opennet.ru/24428-api
Ключевые слова: api, web, javascript, file
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (11) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, аноним (?), 23:48, 26/11/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Пока W3C придумывает новый велосипед, Opera и Mozilla построили себе по Bentley.
     
  • 1.2, tty (??), 23:53, 26/11/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    чёта у меня наглядный пример не заработал ):
     
  • 1.3, аноним (?), 00:36, 27/11/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Замечательно. Сразу выключаем.
     
  • 1.4, User294 (ok), 01:48, 27/11/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    А потом хакеры найдут баги и будут шариться по всей ФС или файлам скачаными кем попало и откуда попало? Замечательно, мля... :)
     
  • 1.5, hatewindows (ok), 07:11, 27/11/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    для гугла стараются
     
  • 1.7, Аноним (-), 09:30, 27/11/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    > API уже реализована в вышедшем сегодня Firefox 3.6-beta4

    берем на заметку - версию 3.6 и выше ставить нельзя, пока не удалят эти команды

     
     
  • 2.9, Аноним (-), 12:08, 27/11/2009 [^] [^^] [^^^] [ответить]  
  • +/
    > берем на заметку - версию 3.6 и выше ставить нельзя, пока не удалят эти команды

    а куда Вы денетесь? :) старые версии не поддерживаются...

     
     
  • 3.12, sHaggY_caT (ok), 18:28, 27/11/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Это opensource:) и diff рулит, как, кстати, и форк. Фокс форкать не красиво по отношению к удачному проекту, но угроза форка может заставить Мозиллу сделать фичу штатно отключаемой :)
     
  • 2.10, szh (ok), 17:00, 27/11/2009 [^] [^^] [^^^] [ответить]  
  • +/
    > берем на заметку - версию 3.6 и выше ставить нельзя, пока не удалят эти команды

    Знаешь сколько еще команд есть во всех современных браузерах?

    Держу пари при всех твоих понтах ты даже про noscript не знаешь.

     
  • 2.11, Crazy Alex (??), 17:20, 27/11/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Оно вам надо - параноить...
     

  • 1.13, Crazy Alex (??), 18:46, 15/04/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Хм, беру свои слова обратно. как минимум - пока вот здесьMAY не будет исправлено на MUST:
    "Post-selection file modifications occur when a file changes on disk after it has been selected. In such cases, if a read method is called on a file, user agents MAY raise a SECURITY_ERR."
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2020 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру