The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги | ]

13.09.2012 20:49  Релиз Qt 4.8.3

Туука Турунен (Tuukka Turunen), директор по разработке Qt в компании Digia, объявил о выходе новой версии кросс-платформенного фреймворка Qt 4.8.3. По сравнению с прошлым выпуском в Qt 4.8.3 внесено более 200 изменений, среди которых улучшение поддержки платформ Mac OS X 10.8 и QNX, обновление WebKit до версии 2.2.3, улучшение работы модулей QtCore, QtGui и QtNetwork.

В анонсе отмечается, что несмотря на то, что большая часть активности сосредоточена вокруг разработки Qt 5, ветка 4.8.х всё ещё на плаву и будет поддерживаться столько времени, сколько будет необходимо пользователям. В будущем планируется выпуск как минимум ещё двух корректирующих релизов. Тем не менее, пользователям рекомендуется обратить внимание на ветку Qt 5, которая обеспечивает достаточно хорошую совместимость с Qt 4, и начать миграцию своих проектов после публикации финального релиза Qt 5.0.

  1. Главная ссылка к новости (http://labs.qt.nokia.com/2012/...)
  2. OpenNews: Qt 5.0 перешёл на стадию бета-тестирования
  3. OpenNews: Digia намерена укрепить сотрудничество с KDE и обсудить с сообществом будущее развитие Qt
  4. OpenNews: Релиз Qt 4.8.2
  5. OpenNews: Релиз Qt 4.8
Автор новости: zoonman
Тип: Программы
Ключевые слова: qt
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение Ajax/Линейный | Раскрыть все сообщения | RSS
 
  • 1.1, Анонимка (?), 21:46, 13/09/2012 [ответить] [показать ветку] [···]    [к модератору]
  • +2 +/
    Ждем, не дождемся KDE 5
     
     
  • 2.2, Аноним (-), 21:48, 13/09/2012 [^] [ответить]    [к модератору]
  • +15 +/
    Примерно такие коменты были про гном 3.
     
     
  • 3.4, ВовкаОсиист (ok), 21:57, 13/09/2012 [^] [ответить]    [к модератору]
  • +5 +/
    Тем не менее, кде не гном. Хотя меня немножко пугает этот ихний qml. Ну чтож, значит ждём, но с некоторой опаской...
     
     
  • 4.14, Aram (??), 00:11, 14/09/2012 [^] [ответить]    [к модератору]
  • +1 +/
    извини, но зачем бояться qml?
     
     
  • 5.15, grayich (ok), 00:45, 14/09/2012 [^] [ответить]    [к модератору]
  • +4 +/
    боятся скорее не qml, а злоупотребление им, в итоге многое перепишут на него, что хренова скажется на скорости и потреблении
     
     
  • 6.19, Я (??), 09:41, 14/09/2012 [^] [ответить]     [к модератору]  
  • +3 +/
    Боятся не qml, а того, что опять придётся переписывать ВСЁ KDE не QT, они ломаю... весь текст скрыт [показать]
     
     
  • 7.21, Vkni (ok), 13:02, 14/09/2012 [^] [ответить]    [к модератору]  
  • +/
    > Боятся не qml, а того, что опять придётся переписывать ВСЁ.

    Как раз переход на KDE5 будет эволюционным, как переход с KDE2 на KDE3. Страшен будет переход на KDE6, аналогичный переходам на KDE2 (переписано всё, введён konqueror, вместивший в себя файловый менеджер и браузер, аналогично Windows Explorer+Internet Explorer того времени) и KDE4 (konqueror разделён, введён dolphin, plasma и т.д.).

    Поэтому KDE5 как раз обещает быть исключительно хорошо отлаженной версией DE.

     
     
  • 8.23, Я (??), 15:31, 14/09/2012 [^] [ответить]    [к модератору]  
  • +/
    Да? Когда готовился переход на KDE4, они тоже обещали оставить прослойку совместимости с KDE3, только на практике всё развалилось, покопайте старые письма разработчиков на кде, мне лень искать доказательства.
    Сейчас у кдешников не менее наполеоновские планы по поводу перевода ВСЕГО на QML, и оставления только "прослойки совместимости" для классического подхода.
    Заложите мой пост в закладки и прочтите его когда оно придёт.
    ПЫ.СЫ. прога написанная для win XP и использующая стандартные вызовы и т.д. работает и на семёрочке, да и на восьмёрочке, я думаю тоже будет. А тут между версиями KDE4 такие выкрутасы... Не даром Линус ругался, он говорил про GTK, а ведь это подход свего опенсорса - я меняю что хочу, когда хочу и как хочу, и вообще, я ничего никому не должен. А потом плачут, разрабы бегут, юзеры тоже, мелкософт торжествует.
     
     
  • 9.24, Vkni (ok), 15:44, 14/09/2012 [^] [ответить]    [к модератору]  
  • –1 +/
    > Да?

    Остаётся надежда.

    > Сейчас у кдешников не менее наполеоновские планы по поводу перевода ВСЕГО на QML, и оставления только "прослойки совместимости" для классического подхода.

    Посмотрим. Может быть вы и правы - KDEшники, как известно, живут на том, что тырят всё из MS Windows. И, поскольку, Win переезжает на Metro, они тоже могут начать какие-то жуткие действия.

    > ПЫ.СЫ. прога написанная для win XP и использующая стандартные вызовы и т.д. работает и на семёрочке, да и на восьмёрочке, я думаю тоже будет.

    Фирма Microsoft, как известно, имеет просто маниакальную тягу к совместимости. А KDEшники, почему-то, сделав какой-то интерфейс до конца, тут же его бросают и начинают ваять новый.

     
     
  • 10.25, Преподаватель информатики (?), 16:24, 14/09/2012 [^] [ответить]    [к модератору]  
  • +1 +/
    > KDEшники, как известно, живут на том, что тырят всё из MS Windows

    Пруф хоть один. Я столько слышал про это, что начинаю подозревать не слоупок ли?
    Неужели под «тырить всё» вы понимаете сходство в дефолтном расположении панелей и основном цвете дефолтного же оформления?
    На работе вынужден юзать W7, дома везде KDE4 — никаких сходств как в технологиях, лежащих в основе, так и интерфейсе не вижу в упор, в отличие от сходства убунтовского gnome2 и unity с macos.

     
     
  • 11.27, Я (??), 17:48, 14/09/2012 [^] [ответить]    [к модератору]  
  • +/
    > KDEшники, как известно, живут на том, что тырят всё из MS Windows

    Удваиваю ставку!
    Посмотрите, когда появились наработки кде4шного подхода, все эти карамбы в KDE3, это уже начало плазмы! Хотя если говорить кто у кого "тырит", так мелкософт даже гдей-то упоминает KDE как проект из которого черпались идеи !
    Историю знать надо, классиков читать!

     
     
  • 12.36, Vkni (ok), 01:10, 15/09/2012 [^] [ответить]    [к модератору]  
  • +/
    > мелкософт даже гдей-то упоминает KDE как проект из которого черпались идеи

    Это они, конечно, правильно делают. Т.к. KDEха обычно значительно удобнее тех Виндов, с которых копирована. :-)

     
  • 11.35, Vkni (ok), 01:09, 15/09/2012 [^] [ответить]    [к модератору]  
  • +/
    > Пруф хоть один. Я столько слышал про это, что начинаю подозревать не
    > слоупок ли?

    Есть малехо. Потому, что нужно смотреть на традиции UNIX WM и на то, какой вид у KDE. Берём OpenLook, Window Maker, Enlightenment, TWM, MotifWM и т.д. Потом смотрим на KDE1. Потом смотрим на Windows 95. И видим, что KDE1, в целом, является переходным мостиком между перечисленными мною WM и MS Windows 95.

    С остальными KDE всё очень похоже. В частности, в KDE2 появился Konqueror - одновременно и файловый менеджер и браузер. Появился он после того, как в Windows 98 тоже их совместили. В KDE4 уже откопировали модель Win XP и Vista - когда браузер и фм разъединили.

    В KDE3 в определённый момент откопировали меню Win XP, хотя и далеко не сразу.

    > На работе вынужден юзать W7, дома везде KDE4 — никаких сходств как
    > в технологиях, лежащих в основе, так и интерфейсе не вижу в
    > упор, в отличие от сходства убунтовского gnome2 и unity с macos.

    Ну это потому, что KDE4 тырили не с W7, а с Vista. Посмотрите, узреете.

     
  • 9.29, kurokaze (ok), 19:11, 14/09/2012 [^] [ответить]    [к модератору]  
  • +/
    >Да? Когда готовился переход на KDE4, они тоже обещали оставить прослойку совместимости с KDE3

    Таки не могу понять какие проблемы держать одновременно kdelibs:3.5 kdelibs:4 ?

    >А потом плачут, разрабы бегут, юзеры тоже,

    Шито? Перешел с пару месяцев назад на кде-4 с кде-3, все отлично и все устраивает.

    > мелкософт торжествует.

    Дай угадаю, у тебя небось вантуз в дуалбуте

     
     
  • 10.34, Я (??), 21:36, 14/09/2012 [^] [ответить]    [к модератору]  
  • +/
    > вантуз в дуалбуте

    Лет пять как не пользуюсь (другим чиню)
    > Шито? Перешел с пару месяцев назад на кде-4 с кде-3, все отлично и все устраивает.

    Если пользоваться KDE исключительно как WM, то да, если пользоваться КДЕшными программами (которые внутри компьютера, ну, в смысле не вконтакте там, не ютуб, не фейсбук) то...
    Особенно, если обновлять по мере выхода новых версий вместе с дистрибутивом (как большинство и делает)
    > Таки не могу понять какие проблемы держать одновременно kdelibs:3.5 kdelibs:4 ?

    Держал столько, сколько позволяли возможности. Разработчикам дистрибутивов не особо прикажешь держать программы, которые мне нужны, старых версий, а остальные обновлять. Пробовал компилить и держал "зоопарк", потом плюнул.
    Только не надо теперь говорить про "нормальный" генту. Если мне зимой будет холодно и отопление отключат, то я поставлю компилять мир и погреюсь.

     
  • 10.38, trdm (ok), 03:40, 16/09/2012 [^] [ответить]    [к модератору]  
  • +/
    > Шито? Перешел с пару месяцев назад на кде-4 с кде-3, все отлично и все устраивает.

    это обыкновенная фанатичная шиза в запущенной форме.
    "все устраивать" и "все отлично" - так никогда не бывает.
    всегда есть пара крупных недостатков и десятки мелких.
    вы просто не объективны, а фанатизм - он скорее источник бед, чем помошник.

     
  • 4.20, Аноним (-), 09:44, 14/09/2012 [^] [ответить]    [к модератору]  
  • +1 +/
    > Хотя меня немножко пугает этот их qml.

    fixed.

     
  • 2.3, Карбофос (ok), 21:50, 13/09/2012 [^] [ответить]    [к модератору]  
  • +/
    бета уже есть
     
     
  • 3.7, Аноным (ok), 22:40, 13/09/2012 [^] [ответить]    [к модератору]  
  • +/
    Чо-то даже скринов не нарою, оно в стиле "Метро" будет?
     
     
  • 4.11, Карбофос (ok), 23:32, 13/09/2012 [^] [ответить]    [к модератору]  
  • +4 +/
    стиль "метро" переименовали в "Баллмер в пальто"
     
  • 2.5, Sauron (??), 22:28, 13/09/2012 [^] [ответить]    [к модератору]  
  • +/
    Так а не будет kde5, по ходу они хотят kde4 просто собирать с Qt5 и потихоньку перепиливать некоторые части.
     
  • 2.6, Аноним (-), 22:34, 13/09/2012 [^] [ответить]    [к модератору]  
  • +2 +/
    Ждем, не дождемся "KDE 5.0 != KDE 5"
     
     
  • 3.8, Tuxoid (ok), 22:55, 13/09/2012 [^] [ответить]    [к модератору]  
  • +/
    Вот именно что не дождешься.
     
  • 2.10, 1q2w3e (?), 23:17, 13/09/2012 [^] [ответить]    [к модератору]  
  • +/
    Опять придется новый комп покупать.
     
     
  • 3.12, Аноным (ok), 23:59, 13/09/2012 [^] [ответить]    [к модератору]  
  • +/
    Скорее из-за Нвидии и Вейленда придётся покупать, если видюха от Нвидии.
     
  • 3.13, кверти (?), 00:00, 14/09/2012 [^] [ответить]    [к модератору]  
  • +4 +/
    ну если ума нет, то покупай
     
  • 2.32, Евгений (??), 20:05, 14/09/2012 [^] [ответить]    [к модератору]  
  • +/
    Читайте между строк:

    - Ждем не дождемся KDE 5.1, а то и 5.2
    - HTML5 рулит, но мы пойдем другим путем
    - Разработчики KDE4 и KDE5: Гном "г", так как слишком революционные изменения

    Дядя Вася за компьютером, которому ПРОСТО НУЖНО запустить WIN8 - игрушку на KDE4/5:
    ДОЛ***БЫ!!!!!! Перехожу на Виндоус!

     
  • 1.9, ябалдею (?), 23:02, 13/09/2012 [ответить] [показать ветку] [···]    [к модератору]  
  • +/
    Замечательно. Ещё б SDK один с 4-ой веткой успели сделать, а то лениво всё это с нуля по частям ставить/пересобирать на разных машинах
     
     
  • 2.17, zoonman (ok), 07:42, 14/09/2012 [^] [ответить]    [к модератору]  
  • +/
    В комментариях к новости Thiago Macieira пишет, что для сборки Qt SDK не хватает кадров. С SDK не все так просто, т.к. она завязана на поддержку нокиевских платформ.

     
  • 1.16, dddd (?), 00:48, 14/09/2012 [ответить] [показать ветку] [···]    [к модератору]  
  • +1 +/
    > Туука Турунен, директор по разработке Qt в компании Digia

    Посмотрел на фамилию, не посмотрев на имя, первым делом вспомнил про Тарью. Долго думал.

     
     
  • 2.18, anonymous (??), 08:57, 14/09/2012 [^] [ответить]    [к модератору]  
  • +/
    >> Туука Турунен, директор по разработке Qt в компании Digia
    > Посмотрел на фамилию, не посмотрев на имя, первым делом вспомнил про Тарью.
    > Долго думал.

    То же самое ;)
    Подумалось, не родственник ли - было бы крайне забавно ;)

     
  • 1.22, arisu (ok), 13:09, 14/09/2012 [ответить] [показать ветку] [···]    [к модератору]  
  • +1 +/
    > пользователям рекомендуется обратить внимание на ветку Qt 5

    обратил. не нашёл ничего, ради чего стоило бы туда уходить. подожду Qt 6, по сравнению с ним Qt 5 наверняка покажется великолепным релизом. тогда и перейду.

     
  • 1.26, ВовкаОсиист (ok), 16:53, 14/09/2012 [ответить] [показать ветку] [···]    [к модератору]  
  • +/
    Я так и не понял, они уже поставляют десктоп-компонентс вместе с Qt по дефолту? Почему я их не могу собрать с Qt5? Собирается только с Qt4. Как мне без Qml писать гуйню основанную на SceneGraph которая хардварно ускоряется? Тоесть, как к примеру, сущесвующий мой небольшой проект перевести на Qt5 и не использовать widgets? Как запилить нативный тырфейс на С++ без виджетс? Как я понял, модуль виджетов портировали на qpa систему, тоесть оно рендерятся старым добрым raster-engine. Я в замешательсве, везде упоротые интерфейсы куиков и Qml-ов, как писать десктопные приложения на этом? %)
     

     Добавить комментарий
    Имя:
    E-Mail:
    Заголовок:
    Текст:


      Закладки на сайте
      Проследить за страницей
    Created 1996-2018 by Maxim Chirkov  
    ДобавитьПоддержатьВебмастеруГИД  
    Hosting by Ihor