The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Новая версия интегрированной среды разработки приложений NetBeans IDE 7.3

22.02.2013 14:38

Компания Oracle представила релиз интегрированной среды разработки приложений NetBeans IDE 7.3, поддерживающей разработку на языках Java, JavaFX, PHP, HTML5, Groovy и C/C++. NetBeans распространяется в исходных текстах под лицензиями GPLv2 и CDDL.

Основные улучшения (скринкасты):

  • Средства для разработки интерактивных web-приложений и мобильных программ с использованием HTML5, JavaScript и CSS:
    • Поддержка автодополнения конструкций jQuery, стилей CSS3 и элементов, определённых в новых спецификациях HTML5;
    • Новый редактор JavaScript-кода, система инспектирования страниц и отладчик web-приложений, основанный на Nashorn, открытом JavaScript-движке, работающем поверх виртуальной машины Java;
    • Инструмент для редактирования стилей CSS в визуальном режиме;
    • Средства для разработки обособленных приложений, написанных с использованием web-технологий;
    • Интеграция в NetBeans встроенного браузера на базе движка WebKit, поддерживающего возможность live-синхронизации кода и web-страниц. Поддержка двухсторонней интеграции с Google Chrome;
    • Режим генерации готового JavaScript-клиента для существующих сервисов Java REST;
  • Улучшения для разработчиков на языке Java:
    • Новая система подсказок (hints) и средства для рефакторинга в редакторе кода;
    • Поддержка новой навигационной панели Breadcrumbs, отображающей текущее вложение в редакторе;
    • Новые обновляемые представления иерархии объектов и членов классов;
    • Поддержка определения дополнительных фильтров при поиске;
    • Добавление в редактор инструмента для доступа к истории работы с буфером обмена;
  • Улучшения для разработчиков на языке JavaFX:
    • Поддержка построения сцен/FXML;
    • Улучшенный редактор FXML-файлов с поддержкой автодополнения кода и пометки ошибок;
    • В FXML-файлы добавлен FXML Generate Controller;
    • Полная поддержка JDK 7u6+ и JavaFX 2.2.5 SDK;
  • Поддержка PHP:
    • Добавление парсеров для аннотаций в отдельных пространствах имён ( Namespaced Annotations, используемые в таких фреймворках, как Symfony 2 и Doctrine 2);
    • Базовая интеграции с менеджером зависимостей PHP;
    • Поддержка автодополнения кода для Twig;
    • Поддержка тегов Smarty, в том числе выявление ошибок и несбалансированных тегов;
  • Поддержка C/C++:
    • Для больших проектов потребление памяти сокращено как минимум в два раза;
    • Улучшена скорость работы парсера;
    • Поддержка сохранения индекса парсера и его поставка с проектом;
  • Поддержка Groovy:
    • Интеграция с Groovy 2.0;
    • Поддержка использования Groovy в проектах Java EE;
    • Поддержка тестирования с использованием Groovy JUnit;
    • Поставка базовых средств для рефакторинга кода (переименование типов классов и поиск применения);
  • Система профилирования:
    • Режим выборочного профилирования памяти;
    • Сравнение снапшотов состояния CPU;
    • Поддержка профилирования Java-приложений на поставляемых с Linux ARM-платформах, таких как Raspberry Pi;
  • Поддержка последних выпусков платформы Java EE и сервера GlassFish: новый обособленный редактор JPQL, позволяющий запускать и тестировать JPQL-запросы прямо из IDE; улучшенная поддержка разработки сервисов REST.


  1. Главная ссылка к новости (http://www.oracle.com/us/corpo...)
  2. OpenNews: Релиз интегрированной среды разработки приложений NetBeans IDE 7.2
  3. OpenNews: Компания Oracle выпустила интегрированную среду разработки NetBeans IDE 7.1
  4. OpenNews: Релиз интегрированной среды разработки приложений NetBeans IDE 7.0
  5. OpenNews: Oracle удалила поддержку Ruby из NetBeans
Лицензия: CC-BY
Тип: Программы
Короткая ссылка: https://opennet.ru/36199-netbeans
Ключевые слова: netbeans, ide
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (30) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.9, Аноним (-), 16:58, 22/02/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • –4 +/
    emerge -pv netbeans These are the packages that would be merged, in order Cal... большой текст свёрнут, показать
     
     
  • 2.11, хрюкотающий зелюк (?), 17:02, 22/02/2013 [^] [^^] [^^^] [ответить]  
  • +11 +/
    страдай гентушник! )))
     
     
  • 3.33, pavlinux (ok), 23:04, 22/02/2013 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Какой-то тупой гентушник нынче пошёл =)

    http://www.oracle.com/technetwork/java/javase/downloads/jdk-7-netbeans-downlo

     
  • 2.16, iZEN (ok), 18:31, 22/02/2013 [^] [^^] [^^^] [ответить]  
  • +/
    Во FreeBSD:

    % cd ~/ && fetch -r http://dlc.sun.com.edgesuite.net/netbeans/7.3/final/zip/netbeans-7.3-20130213

    Открыть архив в file-roller и мышкой перетащить папку netbeans из архива в удобный каталог внутри ~/. Отредактировать netbeans/etc/netbeans.conf для уточнения опций запуска среды и пути к OpenJDK7 (строка: netbeans_jdkhome="/usr/local/openjdk7").

    И всё! Никаких страданий с установкой!

     
     
  • 3.22, Anonus2 (?), 19:55, 22/02/2013 [^] [^^] [^^^] [ответить]  
  • +6 +/
    Это и есть хваленый пакетный менеджер FreeBSD?
     
  • 3.28, anonimous_last (?), 22:17, 22/02/2013 [^] [^^] [^^^] [ответить]  
  • +/
    Так любая линуха может. Речь шла о том, что чтобы собрать все зависимости из сорцов, необходимо скомпилять более чем полгига! У меня например вся система мегьше занимает (не пользуюсь DE) =)
     
     
  • 4.31, iZEN (ok), 22:39, 22/02/2013 [^] [^^] [^^^] [ответить]  
  • +/
    > Так любая линуха может. Речь шла о том, что чтобы собрать все
    > зависимости из сорцов, необходимо скомпилять более чем полгига! У меня например
    > вся система мегьше занимает (не пользуюсь DE) =)

    Но зачем компилировать байткод, если он везде один и тот же?! Это Eclipse нужно перекомпилировать под конкретную платформу, а NetBeans нет.


     
  • 3.48, Michael Shigorin (ok), 00:47, 02/03/2013 [^] [^^] [^^^] [ответить]  
  • +/
    [snip]
    > И всё! Никаких страданий с установкой!

    Изенька, с Вашего позволения -- в рамочку и в архив.  Это было прелестно.

     
  • 2.45, FSA (??), 11:36, 25/02/2013 [^] [^^] [^^^] [ответить]  
  • +/
    Пора бы уже привыкнуть. Да и не так долго собирается, это не Chromium, Firefox или LibreOffice.
     

  • 1.13, Okarin (ok), 17:49, 22/02/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Хотя для html некоторое время пользовался. Так и не смог в нем приемлимые шрифты настроить, и медленновато работает.

    Поддержка Питона у них до сих пор куцая?

     
     
  • 2.30, Atterratio (ok), 22:37, 22/02/2013 [^] [^^] [^^^] [ответить]  
  • +/
    Python вообще выпилен.
     
  • 2.40, sam002 (ok), 01:18, 23/02/2013 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Ставим все - это произведение. Для сей использую - летает, мгновенно индексирует, за 10% оперативы так и не вылез (а проектики до 30 метров либ выплёвывать могут).
    Эклипс нервно курит (м.б. кривизна моих рук неподходящая), отзывчивость, как у анюты!!!

    Гоняю с беты последней, уже второй месяц.

    Интеграция с chromium гладкая, к redmine прицепился, шрифты/темы/etc пару дней потыкать в менюшки и настроено, selenium крутит.

     

  • 1.15, iZEN (ok), 18:04, 22/02/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    NetBeans — это хорошая замена Eclipse для Web-разработки. В Eclipse до сих пор используют устаревший libxul 1.9.2, а в NetBeans двухсторонняя интеграция с WebKit, Firefox и Chrome.
     
     
  • 2.27, exn (??), 21:59, 22/02/2013 [^] [^^] [^^^] [ответить]  
  • +/
    > NetBeans — это хорошая замена Eclipse для Web-разработки. В Eclipse до сих
    > пор используют устаревший libxul 1.9.2, а в NetBeans двухсторонняя интеграция с
    > WebKit, Firefox и Chrome.

    хорошая мягко сказано, после jдеволупера =) самая вменяемая для EE. на то оно и Net Beans , бины под спринг вообще шикарно работают, эклипс отдыхает. хотя это не камень в эклипс, тот для других задачь идеален, да и свт в кучу плюсов .

     

  • 1.23, Аноним (-), 19:56, 22/02/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Знающие люди подскажите, а эта IDE поддерживает систему подсказок для правильного построения кода? Меня интересует для языка C/C++
     
     
  • 2.26, exn (??), 21:57, 22/02/2013 [^] [^^] [^^^] [ответить]  
  • –5 +/
    вообще это java ide , никаких сей там нет. eclipse cdt умеет индексировать для автокомплита под си и ++ если речь об этом
     
     
  • 3.29, It (?), 22:37, 22/02/2013 [^] [^^] [^^^] [ответить]  
  • +3 +/
    есть даже специальная редакция Netbeans под C/C++, автокомплит и рефракторинг, все в комплекте
     
     
  • 4.32, exn (??), 22:57, 22/02/2013 [^] [^^] [^^^] [ответить]  
  • +3 +/
    >  есть даже специальная редакция Netbeans под C/C++, автокомплит и рефракторинг, все в комплекте

    хм, действительно есть.. раньше небыло, какой я блин стал старый маразматик ))

     
     
  • 5.35, pavlinux (ok), 23:15, 22/02/2013 [^] [^^] [^^^] [ответить]  
  • +2 +/
    >>  есть даже специальная редакция Netbeans под C/C++, автокомплит и рефракторинг, все в комплекте
    >  хм, действительно есть.. раньше небыло, какой я блин стал старый маразматик

    Здрастье, с версии 6.1 оно уже там, с версии 5.5 отдельным пакетом http://cnd.netbeans.org
    Чуть ранее, с бубном, работало через Sun Studio Compiler, и замену ссылок с suncc на gcc.  

     
     
  • 6.36, exn (??), 23:25, 22/02/2013 [^] [^^] [^^^] [ответить]  
  • +/
    > Здрастье, с версии

    каждый день кликаю посмотреть есть ли версия бинса для сей )))

     
     
  • 7.37, pavlinux (ok), 23:28, 22/02/2013 [^] [^^] [^^^] [ответить]  
  • +/
    >> Здрастье, с версии
    >  каждый день кликаю посмотреть есть ли версия бинса для сей )))

    А чё кликать, если вы её юзаете, там апдейты сами выскакивают.  

     
     
  • 8.38, exn (??), 23:41, 22/02/2013 [^] [^^] [^^^] [ответить]  
  • +/
    ну выскакивают , и что я же не сишную юзаю ... текст свёрнут, показать
     
  • 4.39, Аноним (-), 23:53, 22/02/2013 [^] [^^] [^^^] [ответить]  
  • +/
    > есть даже специальная редакция Netbeans под C/C++, автокомплит и рефракторинг, все в
    > комплекте

    Автокомплит без нормального парсера? Ого!

     
     
  • 5.41, exn (??), 03:08, 23/02/2013 [^] [^^] [^^^] [ответить]  
  • +/
    > Автокомплит без нормального парсера? Ого!

    все так печально ? даже пробовать тогда не буду , не знал и знать не хочу )

     

  • 1.34, Аноним (-), 23:11, 22/02/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    даешь интеграцию с JIRA!
    отвалилась насовсем.
     
  • 1.42, Аноним (-), 16:08, 23/02/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Task-focused developement Netbeans очень не хватает. Будем надеяться что запилят все-таки: http://wiki.netbeans.org/TaskFocusedNetBeans
     
  • 1.43, жабабыдлокодер (ok), 17:43, 23/02/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Что нового появилось - тут уже написано. А вот что исчезло по сравнению с версией 6.8:
    - визуальный редактор JSF страниц (не то что бы необходимо, но иногда может сэкономить время)
    - построение UML схем с конвертированием их в готовые классы (полезно для тех, кто умеет работать с UML схемами, опять же, экономит время)
    - работа с OpenOffice (возможность использовать Writer в качестве построителя отчетов, просто создав документ и динамически заполняя его из Java программы - БЕСЦЕННА)
    - поддержка Swing Application Framework (взамен впихивают платформу NetBeans, это все равно, как вместо фарфоровой кисы предлагать чугунную конную статую Чапаева).
    Поэтому приходится держать и 6.8, и текущую версии...
     
     
  • 2.44, iZEN (ok), 18:14, 24/02/2013 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Что нового появилось - тут уже написано. А вот что исчезло по
    > сравнению с версией 6.8:

    ...
    > - поддержка Swing Application Framework (взамен впихивают платформу NetBeans, это все равно,
    > как вместо фарфоровой кисы предлагать чугунную конную статую Чапаева).
    > Поэтому приходится держать и 6.8, и текущую версии...

    Swing Application Framework
    Версия: 1.0 Исходный файл: Сертифицированные подключаемые модули  
    Описание подключаемого модуля
    Contains the Swing Application Framework library only. It doesn't include support for the design of GUI forms that are using this library. You should use NetBeans 7.0 if you need such support.


     

  • 1.46, qwerty (??), 15:34, 25/02/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    по пробовал, ставить пока нельзя, подглючивает.
     
  • 1.47, DmA (??), 13:32, 26/02/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    netbeans oracle не испохабила как solaris и mysql ?
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2020 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру