The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Тестирование Qt 5.6, который станет первым LTS-выпуском в серии Qt 5

21.12.2015 18:09

Доступен для тестирования бета-выпуск кроссплатформенного фреймворка Qt 5.6 продолжившего развитие ветки Qt 5.x. Финальный релиз ожидается в первом квартале 2016 года. Qt 5.6 станет первым выпуском Qt 5.x для которого будет обеспечена длительная поддержка. Обновления для Qt 5.6 будут выпускаться в течение трёх лет, в то время как обычные выпуски поддерживаются только год. Время поддержки прошлого LTS-выпуска Qt 4.8 истекает в конце 2015 года, пользователям Qt 4.x рекомендуется перейти на Qt 5.

Разработка релиза Qt 5.6 ведётся с использованием новой системы непрерывной интеграции Coin, позволяющей повысить оперативность выявления ошибок и перейти на новый уровень тестирования, охватывая различные платформы и конфигурации. Как и при разработке Qt 5.5 в рамках подготовки LTS-выпуска значительное внимание будет уделено повышению качества и обеспечению паритета функциональности для различных платформ. Из поставки будут удалены Webkit и Qt Quick 1, которые оставлены в репозиториях исходных текстов, но не войдут в состав пакета Qt 5.6. Qt Script пока оставлен в Qt 5.6, но имеет статус устаревшей технологии. Кодовая база будет оптимизирована для использования компиляторов C++98 и C++11, но продолжит поддержку и старых компиляторов. Начиная с выпуска Qt 5.7 в модулях начнут применяться специфичные для C++11 конструкции, а поддержка старых компиляторов будет прекращена.

Главным новшеством Qt 5.6 является полная переработка кода для кросс-платформенной поддержки экранов со сверхвысоким разрешением (High-DPI). Новая реализация позволяет автоматически масштабировать интерфейс приложений, написанных для обычных экранных разрешений, для экранов с высоким DPI. Размеры шрифтов, элементов окон, пиктограмм и прочих графических объектов автоматически подстраиваются под имеющееся разрешение. В конфигурациях с несколькими мониторами подобное масштабирование производится на лету при перемещении окна между обычным и High-DPI экраном. Из других улучшений отмечается полная поддержка платформы Windows 10 и подготовка бинарных сборок Qt для Visual Studio 2015.

  1. Главная ссылка к новости (http://blog.qt.io/blog/2015/12...)
  2. OpenNews: Выпуск интегрированной среды разработки Qt Creator 3.6.0
  3. OpenNews: Представлен Qt для Native Client
  4. OpenNews: Релиз фреймворка Qt 5.5
  5. OpenNews: Библиотеке Qt исполнилось 20 лет
Лицензия: CC-BY
Тип: Программы
Короткая ссылка: https://opennet.ru/43563-qt
Ключевые слова: qt
Поддержать дальнейшую публикацию новостей на OpenNET.


Обсуждение (29) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, Аноним (-), 20:51, 21/12/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    В 16.04 какая версия Qt будет?
     
     
  • 2.2, Lester (?), 20:58, 21/12/2015 [^] [^^] [^^^] [ответить]  
  • +/
    На данный момент там 5.5.1, учитывая, что релизы Qt обычно выходят с опозданиями, то вероятно он и останется. Ну или будет какой-нибудь rc.
     
  • 2.3, anonymous (??), 21:00, 21/12/2015 [^] [^^] [^^^] [ответить]  
  • +/
    5.5.1 скорее всего.
     
  • 2.4, Аноним (-), 22:02, 21/12/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Что такое 16.О4?
     
     
  • 3.5, Александр (??), 22:17, 21/12/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Ubuntu 16.04
     
  • 3.7, _KUL (ok), 00:44, 22/12/2015 [^] [^^] [^^^] [ответить]  
  • +7 +/
    День работника полиции в Армении.
     
  • 3.20, Аноним (-), 14:27, 22/12/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Апрель 2016-го. Человеку интересен график релизов.
     
  • 2.6, цырроз (?), 23:23, 21/12/2015 [^] [^^] [^^^] [ответить]  
  • +/
    LTS и будет
     
  • 2.17, neon1ks (ok), 11:55, 22/12/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Уверен, что в Ubuntu 16.04 воздет Qt 5.6.
     

  • 1.10, annual slayer (?), 02:44, 22/12/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    >В конфигурациях с несколькими мониторами подобное масштабирование производится на лету при перемещении окна между обычным и High-DPI экраном.

    джва года этого ждал

     
  • 1.11, Vitold S (ok), 05:57, 22/12/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • –3 +/
    Привязки к Python, Lua, Java из коробки когда будет?
     
     
  • 2.12, Usaga (ok), 08:49, 22/12/2015 [^] [^^] [^^^] [ответить]  
  • +4 +/
    Вероятно, когда ребята занимающиеся разработкой Python, Lua и Java начнут над этим работать...
     
     
  • 3.15, asd (??), 11:08, 22/12/2015 [^] [^^] [^^^] [ответить]  
  • –3 +/
    Интересно, а зачем ИМ это? Может, таки qt-шники должны заниматься этим?
    Не гора к Магомеду, нет.
     
     
  • 4.16, Чаёвник (?), 11:33, 22/12/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    А зачем Qt-шникам тянуть в апстрим всякое, особенно джаву?
     
     
  • 5.27, Vitold S (ok), 14:41, 23/12/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > А зачем Qt-шникам тянуть в апстрим всякое, особенно джаву?

    Как бы не оказалось наоборот. Опять таки для разработки прототипов Python, Lua и Java вполне себе отличные инструменты.

    Главное только вырасти из прототипов потом.

    А вообще Вам не надоело переписывать одно и тоже на C++? Хорошо если там еще прослойка кая-то есть, ну а если нет, то каждые 10 лет переписывать интерфейс на новую версию.

    Это мне напоминает Microsoft со своей эволюцией Forms, WPF и так далее. Уже правдо надоело. То ли дело Swing как написали так и забили и теперь спустя сто лет все равботает, а для извращенцев даже сделали JavaFX.

     
  • 4.18, Usaga (ok), 13:03, 22/12/2015 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > Интересно, а зачем ИМ это? Может, таки qt-шники должны заниматься этим?
    > Не гора к Магомеду, нет.

    Хм. А кто Вам сказал, что Qt-шники кому-то что-то должны? Они и так за бесплатно раздают весьма неплохой инструмент всем желающим.

     
     
  • 5.26, qwe (??), 09:02, 23/12/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Равно как и другие.
     
  • 2.13, Чаёвник (?), 10:56, 22/12/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Я понимаю, зачем там нужен PyQt. А остальное из коробки зачем? Это огромный гемор и затраты на поддержку того, ради чего люди бы даже не додумались ставить Qt.
     
     
  • 3.14, Чаёвник (?), 10:59, 22/12/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    В том же PyQt сейчас всё ок и без затягивания в коробку, не хватает только чуть более плотной интеграции UI, чтобы можно было как в оригинальных плюсах канву мышкой накидать и дальше заниматься уже кодовой начинкой.
     

  • 1.19, noname133 (?), 13:19, 22/12/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    pepper плагины включая flash и widevine поддерживаются, как заявляли?
     
  • 1.21, Дуплик (?), 16:11, 22/12/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • –9 +/
    Когда они уже свяжут Qt с GTK+, чтобы рендеринг шёл через него?

    Qt под MS Windows использует контролы WinAPI, Qt под OS X использует контролы Cocoa. Так какого хрена они выкобениваются под GNU/Linux и не используют контролы GTK+? Из-за этого все Qt-приложения выглядят инородно, причём даже мимикрия -style gtk не спасает.

    Все популярные и юзабельные браузеры зависят от GTK+, Java рендерит свои контролы с помощью GTK+, Mono тоже. Так какого фига Qt поступает иначе?

     
     
  • 2.22, Чаёвник (?), 16:36, 22/12/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Оттого так частенько UI на джава расползается, а Monodevelop без доустановки либ методом "догадайся сам" не запускается?
     
  • 2.23, Shtirliz72 (ok), 18:00, 22/12/2015 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Согласен!!! Что за безобразие? Почему KDE до сих пор не использует GTK? Да и вообще, GTK тоже отстой! Даёшь WinAPI под Linux!!!
     
  • 2.24, anononimouse (?), 20:13, 22/12/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Так заведено в мире X Window System с давних времен. Наслаждайся свободой выбора и не капризничай
     
  • 2.25, kachsheev (ok), 21:37, 22/12/2015 [^] [^^] [^^^] [ответить]  
  • +6 +/
    Тогда же, когда и перестреляют разработчиков GTK+ за отвратительную архитектуру их тулкита.
     

  • 1.30, Аноним (-), 07:51, 28/12/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    До сих пор не реализован QDecimal
     
  • 1.31, Harrix (?), 09:26, 07/02/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Они выпиливают WebKit, предлагаю заменить его на WebEngine. Но который работает, как я понял, только под компилятором Visual Studio.

    Так и не понял, а что они предлгают использовать для отображения web страниц под mingw и под android. Может кто знает?

     
     
  • 2.32, Аноним (32), 12:33, 04/03/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Самому собирать WebKit пока совсем не выпилят
     

  • 1.33, Аноним (33), 23:19, 05/03/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    в qt 5.6 в multimedia уже можно получать разрешения камер? в qt 5.5 выдает пустой список разрешений при вызове QCameraImageCapture
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:
    При перепечатке указание ссылки на opennet.ru обязательно



    Спонсоры:
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2022 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру