The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Проект openSUSE прекращает поддержку пакетов с драйвером AMD Catalyst

08.12.2016 09:40

Разработчики дистрибутива openSUSE сообщили о прекращении поддержки rpm-пакетов с классическим драйвером AMD Catalyst (fglrx), который не обновлялся компанией AMD с декабря прошлого года и поддерживает работу только с X-server 1.17 и ядрами Linux до 3.19. Пакеты для ныне развиваемого в AMD гибридного проприетарного драйвера AMDGPU-PRO, построенного на базе модуля AMDGPU, поддерживать не планируется. Пользователям современных графических карт AMD на базе архитектуры GCN, рекомендуется перейти на использование открытых драйверов AMDGPU/RadeonSI, для работы со старыми сериями GPU AMD можно применять открытые mesa-драйверы radeon и r600 в связке с drm-модулем ядра radeon.

  1. Главная ссылка к новости (https://lizards.opensuse.org/2...)
  2. OpenNews: В Ubuntu 16.04 будет прекращена поддержка драйвера AMD Catalyst
  3. OpenNews: AMD сокращает число видеокарт, поддерживаемых в проприетарном драйвере для Linux
  4. OpenNews: Выпуск проприетарного драйвера AMD Radeon Software Crimson Edition Linux 15.12
  5. OpenNews: Компания AMD начала тестирование гибридного драйвера на базе модуля AMDGPU
  6. OpenNews: Компания AMD выпустила обновление проприетарного драйвера Catalyst Pro для Linux
Лицензия: CC-BY
Тип: К сведению
Ключевые слова: fglrx, amd, catalyst
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (86) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, Zenitur (ok), 09:45, 08/12/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    Я надеюсь что в платной версии оставят? А то мне надо.
     
     
     
    Часть нити удалена модератором

  • 3.6, Zenitur (ok), 09:54, 08/12/2016 [ответить]  
  • –1 +/
    Поясню. В коммерческом SLED, когда вводишь серийник (в т.ч. триал на 60 дней) сразу появляется окошко "добавляем репозитории NVIDIA и ATi". http://www2.ati.com/suse/ и нам сразу ставят проприетарный драйвер. Это типа убунтовская фишка с "Менеджером проприетарных драйверов" без ручной возни, но в убунте - бесплатно.

    Если щас репо пропадёт, мне будет печально. Ну хоть рабочее место уже настроено.

     
     
  • 4.16, АНГЫВНАГЫНВАШЩ (?), 11:20, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    До следующего обновления SLE не должны.
     
  • 2.50, Аноним (-), 17:31, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +3 +/
    > Я надеюсь что в платной версии оставят? А то мне надо.

    Чтобы специально ради тебя тянули старые ядра и иксы или реанимировали разработку древнего проприетарного драйвера - надо быть или очень состоятельным человеком, или очень крутым разработчиком.

     
     
  • 3.68, Аноним (-), 20:16, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    А вот этому что помешало? "Пакеты для ныне развиваемого в AMD гибридного проприетарного драйвера AMDGPU-PRO, построенного на базе модуля AMDGPU, поддерживать не планируется".

    Состояние нестояния у разрабов Суси?

     
     
  • 4.69, Аноним (-), 20:21, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • –2 +/
    > Состояние нестояния у разрабов Суси?

    Смысла в этом все меньше и меньше. Vulkan чувак из RH запилил, OpenCL амд откроет. Что там у каталиста в плюсах? Мифический GL 3.x и новее в compat context? Это надо только на воркстэйшнах полутора программам на всю планету. В общем ИМХО открытый стэк FTW.

     
     
  • 5.76, Аноним (-), 23:27, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • –2 +/
    > Это надо только на воркстэйшнах полутора программам на всю планету.

    та-та, а вообще, чего уж стесняться: кому нужны пользователи с 1% рынка, да?

     
     
  • 6.83, Аноним (-), 00:24, 09/12/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > та-та, а вообще, чего уж стесняться: кому нужны пользователи с 1% рынка, да?

    АМД видимо нужны, раз пилят. А так - знаешь, есть такая фигня как топ500 суперкомпьютеров. И там 1% далеко не линухов. Наверное АМД и туда метит. А почему не должны? Вычисления на GPU традиционно сильная область и я не понимаю как они так пробакланили HPC. Но сейчас они это могут и поднаверстать наверное, переманив на свою сторону developers, developers и причастных :)

     
  • 4.72, Онаним (?), 20:50, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    В openSUSE не поддерживают закрытые драйвера. Для Leap нвидия собирает пакеты.
    Нужно качать инсталлятор с сайта и ручками устанавливать.
     
     
  • 5.91, Дмитрий Марков (?), 10:10, 10/12/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    фигню городишь, есть репо с блобами для nvidia на opensuse прямо на серверах nvidia
     

  • 1.3, anonymous (??), 09:47, 08/12/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Я, конечно, понимаю, что у невидии всё плохо, но тут вообще ужас.
     
     
  • 2.4, fdgergfaewfdghsdgaertg (?), 09:51, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Помимо проблем с конфигурацией интегрированная+дискретная насколько там все плохо?
    У самого Gtx750ti, жаловаться вообще не на что. Может, я чего-то не замечаю? Да, есть проблемы с 2d ускорением. Такое ощущение, что оно работает наполовину, но я привык винить иксы.
     
  • 2.7, Zenitur (ok), 09:57, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • –2 +/
    > Я, конечно, понимаю, что у невидии всё плохо, но тут вообще ужас.

    У NVIDIA только одна проблема - в 361.xx некоторые конигурации с Оптимусами отвалились. Например 740M работает, а 650M - нет. Решается патчем на X-Server, который я нашёл в убунтовском DEB-SRC.

    А в остальном всё вообще шикарно. Я поднял KMS на дискретке. Я сделал Glvnd на Оптимусе (теперь Intel и NVIDIA работают одновременно). Прикольный конструктор. Два дня долбался.

     
     
  • 3.12, AlexYeCu_not_logged (?), 10:31, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • –5 +/
    Вот если б на десктопах так можно было сделать.
     
     
  • 4.18, th3m3 (ok), 11:42, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +5 +/
    Долбанный optimus на десктопе? Боже упаси!
     
     
  • 5.65, AlexYeCu (ok), 19:01, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Долбанный optimus на десктопе? Боже упаси!

    Одновременная работа дискретки и интеграшки, причём вторая — в полном, а не урезанном варианте.

     
     
  • 6.70, Аноним (-), 20:24, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Одновременная работа дискретки и интеграшки, причём вторая — в полном, а не
    > урезанном варианте.

    А что, если в систему с APU воткнуть вторую видеокарту - желаемое не получится? Минус геморрой с энергосбережением и переключениями  - менее актуально в системах подеключенных к розетке. Да и извращения с тяганием DMA картинки из безголового GPU не требуются - можно мониторы к выходам видях прицепить.

    Только нафиг тебе на десктопе интеграт? Чтобы GPU гонял сотни гигз по системной шине памяти, просаживая CPU? Даже GDDR5 - быстрее обычной памяти на графических задачах раз в 10. А если HBM вспомнить... ух...

     
     
  • 7.74, AlexYeCu (ok), 22:43, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • –2 +/
    >А что, если в систему с APU воткнуть вторую видеокарту - желаемое не получится?

    Нет. По крайней мере в связке intel + nvidia. Причём проблема эта не на уровне оси.  AMD + AMD, вроде как, могут и работать.

    >Только нафиг тебе на десктопе интеграт?

    Во-первых, он уже есть на всех современных x86 матерях. Во-вторых, было б не лишним пробросить оный в виртуалку. К сожалению, запустить интеграшку одновременно с дискреткой можно только в сильно урезанном варианте и с неродным драйвером, что делает идею с пробрасыванием бессмысленной.

     
     
  • 8.78, Аноним (-), 23:30, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    здрасьти 8212 он не на матерях, а в ЦПУ... текст свёрнут, показать
     
     
  • 9.86, AlexYeCu_not_logged (?), 11:45, 09/12/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Привет Это детали О чём речь 8212 ты понял... текст свёрнут, показать
     
     
  • 10.92, Аноним (-), 00:38, 11/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    детали, не детали, но особенностью современных систем как раз является интеграци... текст свёрнут, показать
     
     
  • 11.93, Аноним (-), 03:49, 11/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    А нехрен брать АПУ вместо ЦПУ ... текст свёрнут, показать
     
  • 8.80, Аноним (-), 23:35, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Это скорее всего проблема на уровне интеграции с осью Что у нвидии традиционно ... текст свёрнут, показать
     
     
  • 9.88, AlexYeCu_not_logged (?), 11:54, 09/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Разные идентификаторы карт при разных настройках в биосе и залоченый в том же би... текст свёрнут, показать
     
  • 4.77, Аноним (-), 23:29, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Вот если б на десктопах так можно было сделать.

    мсье является идеологическим последователем маркиза де-Сада?

     
  • 3.29, Sunderland93 (ok), 13:11, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >>Я поднял KMS на дискретке.

    Я тоже. Чел, объясни, что это даёт? Высокое разрешение в консоли один хрен не работает с fbdev, нужен efifb.

     
     
  • 4.34, Аноним (-), 14:25, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    У меня работает. Ты сделал options nvidia-drm modeset=1?
     
     
  • 5.53, Аноним (-), 17:34, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > У меня работает. Ты сделал options nvidia-drm modeset=1?

    Вот как-то так нвидия и "работает". Единственная компания у которой установка и запуск драйвера такой же гемор как и виндовые блобы.

     
  • 5.85, ryoken (ok), 11:18, 09/12/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > У меня работает. Ты сделал options nvidia-drm modeset=1?

    ПОдскажите, а это куда надо вкрутить? В /etc/default/grub про modeset уже написано, а вот nvidia-drm..?

     
  • 3.54, Аноним (-), 17:36, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > отвалились. Например 740M работает, а 650M - нет. Решается патчем на
    > X-Server, который я нашёл в убунтовском DEB-SRC.

    Нвидия - очень дружественные к пользователям видеокарты :)

    > А в остальном всё вообще шикарно. Я поднял KMS на дискретке.

    Теперь еще попробуй им попользоваться и чтобы это все не глючило по черному.

     
     
  • 4.79, Аноним (-), 23:32, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    #нажифорсахпраблемнет!!111

     
  • 3.73, электронщег (?), 21:47, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > У NVIDIA только одна проблема

    Не только лишь не одна проблема, есть ещё их.

    Например, последний на данный момент релиз 304.132 вообще нафиг сломан (OpenGL не работает), половина дистров уже откатилась на предыдущий (131).

    https://devtalk.nvidia.com/default/topic/968892/geforce-7300le-with-304-132-gl

     
  • 2.51, Аноним (-), 17:32, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Я, конечно, понимаю, что у невидии всё плохо, но тут вообще ужас.

    У амд в отличие от - с открытыми дровами работает DRM/KMS, а у нвидии он до сих пор урезанный и с кучей глюков. Поэтому нвидиафаны наслаждаются всем чем могут - от расколбасов при переключении режимов до тиринга в видео.

     
  • 2.87, Denis (??), 11:48, 09/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    А я вот ровно вчера купил AMD вместо NVIDIA. Достали тиринг на проприетарных или мертвое зависание без них. С амд поставил открыте драйвера и все работает. Наконец можно не ждать проблем при обновлении ядра и нормально федорой пользоваться.
     

  • 1.8, Аноним (-), 09:58, 08/12/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +3 +/
    "рекомендуется перейти ..." на другой дистрибутив.
     
     
  • 2.14, J.L. (?), 10:52, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > "рекомендуется перейти ..." на другой дистрибутив.

    не они первые выкинули, сабайон уже несколько месяцев как удалил из репа проприетарные дрова (вроде модули для всех ядер вообще, а не только для новых/будущих)

     
     
  • 3.23, анн (?), 12:03, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    кто все эти люди?
     
  • 3.38, Аноним (-), 15:25, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Пфе. В федоре уже оно два года как не работает. В общем, если у вас ATI/AMD, то сидите на Debian Jessie и не тявкайте.
     
     
  • 4.56, Аноним (-), 17:39, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Пфе. В федоре уже оно два года как не работает. В общем,
    > если у вас ATI/AMD, то сидите на Debian Jessie и не тявкайте.

    Удачи там что-нибудь на основе GCN запустить. AMD - это GCN как раз, а VLIW-ы это наследие ATI.

     
  • 2.55, Аноним (-), 17:37, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > "рекомендуется перейти ..." на другой дистрибутив.

    На другой глобус. Классический каталист более никто не разрабатывает.

     
     
  • 3.94, Аноним (-), 03:51, 11/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    А чем этот ваш котоглист лучше свободных дров?
     

  • 1.9, Аноним (-), 10:03, 08/12/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    Открытые драйверы это конечно здорово, но у них в крайнем релизе ядро 4.4 и меза старая, которые вышедшие летом карточки АМД не поддерживают в принцципе, и никакого решения этого вопроса не планируется. Десктопный дистр, чо. Только не рассказывайте мне про репозиторий X11:Xorg, он даже отдаленно на хорошее решение проблемы свежих драйверов не похож.
     
  • 1.11, Аноним (-), 10:27, 08/12/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +4 +/
    "Пакеты для ныне развиваемого в AMD гибридного проприетарного драйвера AMDGPU-PRO, построенного на базе модуля AMDGPU, поддерживать не планируется."

    Почему?

     
     
  • 2.15, Аноним (-), 10:53, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > "Пакеты для ныне развиваемого в AMD гибридного проприетарного драйвера AMDGPU-PRO, построенного
    > на базе модуля AMDGPU, поддерживать не планируется."
    > Почему?

    AMD распространяет пакеты только в формате deb и бывший мэйнтейнер fglrx в openSUSE не намерен больше горбатиться на проприетарщину без какой-то обратной отдачи (речь про помощь в решении проблем и в сопровождении).

     
     
  • 3.26, Аноним (-), 12:41, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Плюсую. У меня всё никак не получалось поставить этот DEB в Gentoo. Теперь добрые люди написали ebuild - хрен знает, работает ли.

    Я советую всем, кто хочет ставить amdgpu-pro на не-Ubuntu, использовать пакеты из SteamOS. Там модуль ядра - отдельным DKMS-модулем. В то время как официальный DEB-пакет для Ubuntu требует ядра, в составе которого есть этот модуль.

     
     
  • 4.27, Анончик (?), 12:49, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Плюсую. У меня всё никак не получалось поставить этот DEB в Gentoo.
    > Теперь добрые люди написали ebuild - хрен знает, работает ли.
    > Я советую всем, кто хочет ставить amdgpu-pro на не-Ubuntu, использовать пакеты из
    > SteamOS. Там модуль ядра - отдельным DKMS-модулем. В то время как
    > официальный DEB-пакет для Ubuntu требует ядра, в составе которого есть этот
    > модуль.

    По-моему всё правильно, не включил amdgpu в ядре - ССЗБ. Ну а использовать дистры в которых оно не включено - это надо быть мазохистом наверное.

     
     
  • 5.35, Аноним (-), 14:26, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    >> Плюсую. У меня всё никак не получалось поставить этот DEB в Gentoo.
    >> Теперь добрые люди написали ebuild - хрен знает, работает ли.
    >> Я советую всем, кто хочет ставить amdgpu-pro на не-Ubuntu, использовать пакеты из
    >> SteamOS. Там модуль ядра - отдельным DKMS-модулем. В то время как
    >> официальный DEB-пакет для Ubuntu требует ядра, в составе которого есть этот
    >> модуль.
    > По-моему всё правильно, не включил amdgpu в ядре - ССЗБ. Ну а
    > использовать дистры в которых оно не включено - это надо быть
    > мазохистом наверное.

    В SteamOS просто Linux 4.1. Они один раз бампнули ядро с 3.18 (дефолт в Debian 8.0) а потом их достало ради одного драйвера обновлять целое ядро. И они просто сделали DKMS-модуль отдельным пакетом.

     
  • 3.57, Аноним (-), 17:40, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > AMD распространяет пакеты только в формате deb и бывший мэйнтейнер fglrx в
    > openSUSE не намерен больше горбатиться на проприетарщину без какой-то обратной отдачи
    > (речь про помощь в решении проблем и в сопровождении).

    Нехай рулит открытый драйвер :)

     
  • 2.21, анонимус (??), 12:00, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Потому-что на подходе мерж DAL в открытый драйвер. А когда его смержат от AMDGPU-pro останется только реализация OpenCL. Которую кстати энтузиасты уже перенесли на сусе.
     
     
  • 3.58, Аноним (-), 17:42, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Потому-что на подходе мерж DAL в открытый драйвер. А когда его смержат
    > от AMDGPU-pro останется только реализация OpenCL. Которую кстати энтузиасты уже перенесли на сусе.

    Они работают над открытием реалиации OpenCL из каталиста. И единственный смысл проприетари останется вообще только в профессиональных рабочих станциях где GL 3.x и новее доступен не только в core-profile, но и в compatible.

     

  • 1.13, J.L. (?), 10:50, 08/12/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    кто знает - подскажите куда писать чтоб была реакция если дискретка амд в ноуте при попытке включения питания (DRI_PRIME=1) сыпет ошибками в лог и активной остаётся интеграшка (амд) онли (временами падает в сегфолт при этом)
    а при попытке стартовать иксы в конфиге "только дискретка" видеовывод или виснет нафиг (экран отключается, управление с клавиатуры остаётся, можно перейти в текстовую консольку, даж графическую консольку (видимо рисуемую интеграшкой)) или опять не стартует с ошибкой
    на этапе загрузки ядра тоже что-то ошибочное про видеокарту
    карточке уже года три, и года 1,5 назад свободные дрова умели один раз включить дискретку и если не выключать то так и работала
     
     
  • 2.17, АНГЫВНАГЫНВАШЩ (?), 11:25, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > подскажите куда писать

    сюда https://bugs.freedesktop.org/

     
     
  • 3.59, Аноним (-), 17:43, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > сюда https://bugs.freedesktop.org/

    Только там надо не
    > на этапе загрузки ядра тоже что-то ошибочное про видеокарту

    указать а точную копипасту все-таки.

     

  • 1.19, Аноним (-), 11:59, 08/12/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    А что у амд все так плохо? Они же там грозились все открыть и взяться за линукс...
     
     
  • 2.22, анонимус (??), 12:02, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +7 +/
    Именно это они и сделали. Они написали открытый драйвер AMDGPU, а старый Catalyst забросили. Вот его поддержку и прекратили.
     
     
  • 3.24, Аноним (-), 12:06, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Драйвер сформирован только для Ubuntu 16.04
     
  • 3.25, Аноним (-), 12:34, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Вот только открытый драйвер AMDGPU (не путать AMDGPU-PRO) составе самого свежего релиза дистрибутива, openSUSE 42.2, очень старый, и не поддерживает целую кучу видеокарт. И его обновление не предвидится до следующего релиза.
     
     
  • 4.28, Анончик (?), 12:55, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Вот только открытый драйвер AMDGPU (не путать AMDGPU-PRO) составе самого свежего релиза
    > дистрибутива, openSUSE 42.2, очень старый, и не поддерживает целую кучу видеокарт.
    > И его обновление не предвидится до следующего релиза.

    Это проблема всех СТАБИЛЬНЫХ дистров и дистров с жёсткими релизами. В этом плане разве что убунта выделяется с регулярным бекпортированием свежих ядра и мезы в текущий релиз.

     
     
  • 5.37, Sluggard (ok), 14:46, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +3 +/
    > Это проблема всех СТАБИЛЬНЫХ дистров и дистров с жёсткими релизами. В этом
    > плане разве что убунта выделяется с регулярным бекпортированием свежих ядра и
    > мезы в текущий релиз.

    В Сусе можно подключить репы Kernel и X11 и будет тебе самый свежак ядер и Месы даже в стабильной версии дистра.

     
     
  • 6.44, Аноним (-), 15:56, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    kernel это еще куда ни шло, но X11 подключать категорически не рекомендуется, там с завидной регулярностью оказываются сломанные пакеты, а все потому, что этот реп для разработчиков openSUSE, а не для его пользователей.
     
     
  • 7.46, Sluggard (ok), 16:26, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Категорически не рекомендуется кем? А то я два года с ним живу, и всё хорошо. А может и дольше, не помню, был ли он подключен на старом ноуте. Откуда ты взял, что это какой-то там «реп для разработчиков» — без понятия.
     
  • 5.41, Аноним (-), 15:48, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Раньше такой фигни в openSUSE небыло, при релизе всегда были актуальные ядра и меза, а то, что сейчас там уже было окаменелостью еще до выхода первой беты.
     
  • 4.32, Аноним (-), 13:18, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    А аналога backports debian'а в opensuse нет?
     
  • 4.36, Sluggard (ok), 14:45, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Речь про драйвер xf86-video-amdgpu, как я понимаю? Так в Leap 42.2 вроде версия 1.2.0 в репах, это самый последний релиз (от 17 ноября 2016), где ты новее нашёл?
     
     
  • 5.40, Аноним (-), 15:46, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Сам по себе он бесполезен, без относительно свежего ядра и мезы.
     
  • 5.45, Аноним (-), 16:13, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Нет, про комплект драйверов, где xf86-video-amdgpu лишь малая его часть, причём заменяемая на xf86-video-modesetting теоретически без потерь функционала и скорости.
    Драйвер ещё состоит из модуля ядра radeon/amdgpu, libdrm и state tracker'а мезы.
     
     
  • 6.47, Sluggard (ok), 16:28, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    То есть подразумевается относительная старость ядра и месы. Где взять новые я писал выше, было бы желание.
    А можно вообще на Перекати-поле перекатиться.
     

  • 1.20, Аноним (-), 12:00, 08/12/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    "proprietary crap", ога, ничего не изменилось.
     
     
  • 2.31, Прист (?), 13:17, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • –6 +/
    И bash в Win10 уже есть... и не только.
     
     
  • 3.64, AlexYeCu (ok), 18:59, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    И bash в Win10 уже есть... а толку?
    FIXED.
     
     
  • 4.90, Michael Shigorin (ok), 19:01, 09/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > И bash в Win10 уже есть... а толку?

    А ещё там есть замечательный шрифт Segoe UI, как сегодня выяснилось.
    Вот его бы дезигнеров с манагерами отправить на потеху "умеренной оппозиции".
    Потому как профилактическое вырывание рук из ж**ы и втыкание их обратно другим концом в случае ТАКОГО явно не поможет.

    (тем, чьим глазам посчастливилось: оно расплывается, причём в принципе -- а "настройки" предлагают выбрать между нескольких вариантов смеси мыла с г-ном)

    Боюсь, ближайшие дни пытающимся поагитировать за некрософт будет особенно больно.

     
  • 2.60, Аноним (-), 17:55, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +5 +/
    Напротив - это единственный нормальный вендор видях под линь, у которого видеока... текст свёрнут, показать
     
     
  • 3.62, Аноним (-), 18:10, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > В ядре 4.9 (релизнется буквально через несколько дней) - модуль AMDGPU уже умеет SI

    экспериментальная поддержка, которая будет выключена по умолчанию.

     
     
  • 4.71, Аноним (-), 20:41, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > экспериментальная поддержка,

    Ну разумеется она экспериментальная - ее только что накодили! Ядро 4.9 с ней вот-вот релизнется, ИМХО в пределах нескольких дней, если не случится ничего экстраординарного требующего еще один -RC выпускать.

    > которая будет выключена по умолчанию.

    А еще экспериментальные лекарства не продают в аптеке, блин. А может на экспериментальной модели самолета покатать?

    ...народ вокруг DRM/KMS решил что для GCNов в перспективе будет AMDGPU и на него так или иначе смигрируют. Но это будет попозже. Сначала мыши должны откушать таблеток, тестовые пилоты обкатают самолет. А потом ты сможешь прийти в аптеку или к трапу самолета. И никак не наоборот.

     
  • 3.89, Аноним (-), 12:01, 09/12/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > прямо сейчас активнейше запиливают

    Да и пускай еще столько же лет этим занимаются.

     
  • 2.84, Аноним (-), 08:37, 09/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    HD7970 нормально работает на radeonsi, а если не хватает чего то и для amdgpu-pro эксперементальную поддержку запилили, которую Суся не поддерживает, так это вопросы к Сусе-ментейнерам. Сусе не слишьком меньше РедХата и Каконикл, и что, они не могут связаться с АМД если им что-то не нравится в нынешней упаковке дров? Даже Валв смогли запилить dkms потому что юзают старые ядра, а Сусе, не новичок в Линуксах, не смогли?
     

  • 1.33, vantoo (ok), 14:01, 08/12/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –5 +/
    Развели зоопарк драйверов так, что черт ногу сломит. Пусть другие в этом разбираются, следующая видяха будет от Нвидии, как и до этого. Там хоть и блоб, но ты хотя бы знаешь, что поставишь этот блоб и все заработает.
     
     
  • 2.42, J.L. (?), 15:50, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > Развели зоопарк драйверов так, что черт ногу сломит. Пусть другие в этом
    > разбираются, следующая видяха будет от Нвидии, как и до этого. Там
    > хоть и блоб, но ты хотя бы знаешь, что поставишь этот
    > блоб и все заработает.

    новое ядро с этим блобом заработает ? *тролфейс*

     
     
  • 3.43, Andrey Mitrofanov (?), 15:53, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    >> Развели зоопарк драйверов так, что черт ногу сломит. Пусть другие в этом
    >> разбираются, следующая видяха будет от Нвидии, как и до этого. Там
    >> хоть и блоб, но ты хотя бы знаешь, что поставишь этот
    >> блоб и все заработает.
    > новое ядро с этим блобом заработает ? *тролфейс*

    Ты его приглашаешь к логичному выводу "развели зоопарк ядер -- ухожу на десяточку"?

    Ему слабо.

     
  • 3.49, vantoo (ok), 17:13, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    А что, бывало такое, что новая "бубунта" уже вышла, а под ее ядро еще нет драйвера от Нвидии? Самые свежие ядра мне могут понадобится разве что на серверах, но там мне драйвер видеокарты не нужен.
     
  • 3.61, Аноним (-), 17:56, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > новое ядро с этим блобом заработает ? *тролфейс*

    Более того - с модулем от нвидии - баги ядра репортить можно только в спортлото. Ну или нвидии. Пусть нвидия все ядро и поддержвает со своим модулем, если пупок не развяжется.

     
  • 3.63, Аноним (-), 18:12, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > новое ядро с этим блобом заработает ? *тролфейс*

    Тем не менее это амдшный блоб выбросили в убунте 16.04, а теперь и в сузе.

     

  • 1.48, Игорь (??), 16:30, 08/12/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Господа, а какова судьба fglrx-legasy в openSUSE?
     
     
  • 2.52, Sluggard (ok), 17:33, 08/12/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Она в целом никакова, его судьба, не поддерживаются новые ядра и иксы (1.13 и выше) этим драйвером, в AMD забили уже давно.
     

  • 1.75, Аноним (-), 23:20, 08/12/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Какие драйвера для ATI RS600 самые свежие?
     
     
  • 2.82, Аноним (-), 00:18, 09/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Какие драйвера для ATI RS600 самые свежие?

    Распоследний linux kernel, свежая MESA, ну и не очень древний libdrm. Это даже не затычка для слота по современным меркам - что ты от него хочешь? По идее должен просто работать с свежими пингвинами. Вывешивая OpenGL 2.1 - больше там железо не умеет. Это, блин, R400. Т.е. совсем уж винтаж в архитектурно-железячном плане.

    Как максимум... нннну.... оно наверное будет не очень круто тормозить в 0ad и warzone2100, которые как-то ползают даже на древнем интеловском интеграте.

     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Слёрм
    Inferno Solutions
    Hosting by Ihor
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2019 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру