The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Релиз OpenWrt 18.06

01.08.2018 15:14

Представлен релиз дистрибутива OpenWrt 18.06, ориентированного на применение в различных сетевых устройствах, таких как маршрутизаторы и точки доступа. OpenWrt поддерживает множество различных платформ и архитектур и обладает системой сборки, позволяющей просто и удобно производить кросс-компиляцию, включая в состав сборки различные компоненты, что позволяет легко сформировать адаптированную под конкретные задачи готовую прошивку или образ диска с желаемым набором предустановленных пакетов. Сборки подготовлены для 37 целевых платформ.

Это первый значительный выпуск после объединения проектов OpenWrt и LEDE. В качестве основы для релиза использован репозиторий проекта LEDE. Разработка объединённого проекта ведётся в соответствии с правилами LEDE, подразумевающими открытый процесс принятия решений с привлечением сообщества, прозрачность взаимодействия разработчиков, регулярный предсказуемый цикл подготовки релизов, первоочередное внимание стабильности дистрибутива, более либеральные правила приёма изменений и получения права коммита.

Среди основных изменений:

  • Для большинства основных платформ осуществлен переход на ядро Linux 4.14.52: apm821xx, archs38, armvirt, ath25, bcm53xx, brcm47xx, cns3xxx, gemini, imx6, ipq40xx, ipq806x, kirkwood, malta, mediatek, mvebu, mxs, octeon, octeontx, omap, oxnas, pistachio, ramips, sunxi и x86;
  • До ядра 4.9.111 обновлены сборки для устройств ar7, ar71xx, arc770, at91, brcm2708, brcm63xx, ixp4xx, lantiq, layerscape, mpc85xx, orion, rb532 и uml;
  • Для платформ с ядром 4.14 задействована инфраструктура ускоренной обработки трафика (flow offload). Для установившегося потока пакетов ядро использует облегченный, более производительный путь обработки трафика, благодаря чему скорость маршрутизации повышается в 2-3 раза. Для SoC MT7621 дополнительно задействованы аппаратные блоки для ускоренной обработки трафика, в том числе NAT;
  • Прекращена поддержка платформ adm5120, adm8668, au1000, mcs814x, omap24xx, ppc40x, ppc44x, xburst и zynq;
  • Обновлены версии базовых библиотек и инструментов: musl libc 1.1.19, uClibc-ng 1.0.30, glibc 2.26+, gcc 7.3.0, binutils 2.29.1. Обновлены драйверы для всех поддерживаемых платформ;
  • Добавлены патчи для противодействия атакам Spectre и Meltdown;
  • Добавлена поддержка опций DHCPv6 со стороны клиента. Исправлены ошибки в реализации DHCPv6;
  • В odhcpd по умолчанию обеспечена поддержка RFC6704;
  • В межсетевом экране добавлена поддержка настройки conntrack helper и улучшена интеграция с ipset;
  • Добавлены настройки для конфигурации GRE, GRE-TAP, VETH, VTI, VXLAN;
  • Улучшена работа с планировщиком пакетов CAKE и произведен переход на версию v20180716;
  • Wireguard VPN обновлен до версии v20180718 с оптимизациями для архитектуры MIPS и улучшенной работой с оффлоадингом.
  • Улучшена процедура обновления системы;
  • В web-интерфейсе добавлена возможность автоматического отката конфигурации на рабочую при потере связи, по аналогии с режимом Safe в RouterOS. Улучшено отображение виртуальных интерфейсов.


  1. Главная ссылка к новости (https://lists.openwrt.org/pipe...)
  2. OpenNews: Релиз OpenWrt/LEDE 17.01.5
  3. OpenNews: Проекты OpenWrt и LEDE объявили о слиянии
  4. OpenNews: Выпуск LEDE 17.01, форка дистрибутива OpenWrt
  5. OpenNews: Активные разработчики OpenWrt основали форк дистрибутива
  6. OpenNews: Обновление дистрибутива OpenWrt 15.05.1
Автор новости: EvilWirelessMan
Тип: Программы
Ключевые слова: openwrt, lede
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (118) Ajax | 1 уровень | Линейный | Раскрыть всё | RSS
  • 1.1, Аноним (1), 16:00, 01/08/2018 [ответить] [﹢﹢﹢] [ · · · ]  
  • +11 +/
    Рад, что объединились. Долгих лет проекту!
     
     
  • 2.58, Аноним (-), 18:29, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +5 +/
    Они бы сайт хоть обновили, ничего же не найти. Половина документации устарело, приходится за ответами идти на сторонние форумы.
     
     
  • 3.108, чебурнет.рф (ok), 18:53, 03/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Кстати, типичная ситуация для опенсорс. Ну и такой сигнал пользователю о качестве проекта. Правда здесь такие сигналы принято игнорировать. Всё равно религиозно верный выбор невелик или вообще отсутствует.
     

  • 1.3, athost (??), 16:14, 01/08/2018 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Вчера обновился и даже ничего не отвалилось.
     
     
  • 2.7, Catwoolfii (ok), 17:13, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • –8 +/
    держите нас в курсе!
     
     
  • 3.71, Аноним (71), 21:19, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Нет постойте, с чего и как обновлялись?
     
     
  • 4.88, athost (??), 08:37, 02/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    > Нет постойте, с чего и как обновлялись?

    Buffalo WZR-HP-G300NH
    С 17.1.5 через веб-интерфейс с сохранением конфигов.
    Потом восстановил нужные пакеты. Методика в сообщении ниже по теме.

     

  • 1.4, имя (?), 16:38, 01/08/2018 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    давно сижу на https://github.com/infinitnet/lede-ar71xx-optimized-archer-c7-v2 .
    Обновлюсь-ка я на свежую ночнушку.
     
     
  • 2.22, имя (?), 17:31, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    отвалилось..
     
  • 2.36, Аноним (36), 18:02, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    А я на V4 использую с OpenWrt
     
  • 2.77, имямямя (?), 22:57, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    оно настолько специфичное, что нужно быть весьма искушённым, чтобы оценить это.
     

  • 1.5, Аноним (5), 17:03, 01/08/2018 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Wireguard там в базовой прошивке или нужно пакет отдельный ставить?
     
     
  • 2.25, Foi (?), 17:35, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Отдельный пакет. И кстати он идет 0718… а не 0625 как указано в статье. Я установил все отлично, быстро и стабильно
     
     
  • 3.51, EvilWirelessMan (ok), 18:18, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    На opennet такой херовый способ редактирования статьи, что он не принимает мои правки и думает, что такой вариант уже есть.
     
  • 2.60, Аноним (-), 18:30, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Объясните плз что такое Wireguard? Это как OpenVPN, только более новое/лучшее? И OpenVPN и Wireguard уже встроены в OpenWRT?
     
     
  • 3.72, AnonPlus (?), 21:56, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    https://www.opennet.ru/opennews/art.shtml?num=44695
     
  • 3.73, AnonPlus (?), 21:59, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Плюс в том, что WG реализован в ядре. Ставить надо только тулзы для того, чтобы его дёргать из ядра (ну и по желанию аддон для вебморды, добавляющий страничку в гуй). А OpenVPN это юзерспейс-решение со всеми вытекающими минусами.
     
     
  • 4.80, Аноним (-), 23:44, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +1 +/
    А WireGuard поможет против тирании Роскомпозора? Насколько он эффективен против блокировок и DPI?
     
     
  • 5.81, AnonPlus (?), 23:51, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Настолько же, насколько любой другой VPN-клиент/сервер.
     
  • 4.109, чебурнет.рф (ok), 18:58, 03/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    > Плюс в том, что WG реализован в ядре ... А OpenVPN это юзерспейс-решение со всеми вытекающими минусами.

    Это значит, что скорость передачи данных увеличится при прочих равных? Если так, то насколько? Имеются ли результаты конкретных тестов?

     
     
  • 5.113, AnonPlus (?), 17:11, 06/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Ради интереса можете потестировать на AzuneVPN. Они на сутки дают бесплатно OpenVPN и пока бессрочно - WireGuard.
     

  • 1.6, Аноним (6), 17:06, 01/08/2018 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    если tiny версия то без gui?
     
     
  • 2.61, Пепяка (?), 18:44, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    С гуём
     

  • 1.8, Аноним (8), 17:15, 01/08/2018 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Забыли описать баги. Там у части платформ (как, например, у меня на DIR-300 B1) нет нормальной постоянной памяти, из-за чего до перезапуска даже пароль от логина не сохраняется.
     
     
  • 2.11, EvilWirelessMan (ok), 17:20, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +4 +/
    Потому что пользователи DIR-300 должны страдать!
     
  • 2.20, EvilWirelessMan (ok), 17:28, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Кстати, этот баг должны были пофиксить.
     
  • 2.103, anon666 (?), 23:43, 02/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Одному это jffs2reset помогло, пробуйте, если есть у кого проблема с сохранением. Но там из-за нехватки памяти не сохраняет, кмк, при размере образа 3.5мб. Можно без luci ещё попробовать собрать, там 3.3мб получается.
     

  • 1.9, Аноним (9), 17:16, 01/08/2018 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    >  Для платформ с ядром 4.14 задействованы аппаратные ускорители обработки трафика.

    Читаем оригинал:

    Backported network flow offloading support for targets using kernel 4.14

    Ну и где же тут про hw?

     
     
  • 2.12, EvilWirelessMan (ok), 17:21, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Это завязано на драйверы hwnat
     
     
  • 3.17, Аноним (17), 17:26, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    там сбэкпорчен банальный flowoffload таргет у netfilter
     
     
  • 4.28, EvilWirelessMan (ok), 17:46, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    https://people.netfilter.org/pablo/netdev0.1/slides/IPQ806x-Hardware-accelerat

    Было проделано много работы касательно именно хардварной ускорялки QCA NSS.
    для MTK добавили.
    https://github.com/openwrt/openwrt/commit/424a9ae128bd2045cd4bfd6e3229f2529d15

    Как обычно, чукча не читатель.

     
     
  • 5.48, Аноним (17), 18:16, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Если что - чукча юзер того самого ipq806x, то что добавили - обычный soft offload, почитай уже коммит разраба, который его добавлял. А qca nss к этому отношения не имеет.
     
     
  • 6.53, EvilWirelessMan (ok), 18:21, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Мир не вертится вокруг QCA. И писать с разбивкой по платформам мне лень.
    Но это уже сделал кто-то другой. Хвала небесам!
     
     
  • 7.56, Аноним (9), 18:25, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    да, hw пока есть только у mt7621, но по сообщениям форума - тоже достаточно глючноват, поэтому заявлять про поддержку аппаратного offload в целом релизе - некорректно
     

  • 1.10, Аноним (10), 17:20, 01/08/2018 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    tp-link tl-mr3420 v2 больше не поддерживается? Нету прошивок.

    Ну чорт. Весь кайф опенврт был в том, чтобы не покупать раз в три года новый роутер.

     
     
  • 2.13, 1 (??), 17:21, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    А чем старая прошивка не устраивает ?
     
     
  • 3.19, Аноним (5), 17:28, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +1 +/
    А если дырка обнаружится?
     
     
  • 4.21, 1 (??), 17:29, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Ну как обнаружится - так или патчить или плакать
     
  • 2.15, EvilWirelessMan (ok), 17:24, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Шейте TL-WR841N/ND v8
    Они почти одинаковые
     
     
  • 3.117, Аноним (10), 20:09, 08/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Насколько почти, что отвалится? Спасибо)
     
  • 2.18, EvilWirelessMan (ok), 17:27, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Судя по изменениям поддержка осталась.
    Можете сами собрать или подождать, возможно еще не собралось.
     
  • 2.26, имя (?), 17:42, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • –4 +/
    ничего что ему уже лет 8?
     
     
  • 3.54, Q2W (?), 18:21, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +3 +/
    Ничего. Тем более его ещё можно купить с новья.
     
  • 2.110, чебурнет.рф (ok), 19:04, 03/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Может просто не стоит покупать низкобюджетное Г? Тогда и срок удовлетворённости продуктом увеличится. Я роутер с подобными характеристиками покупал 10 лет назад. Вот только недавно сменил на в несколько раз более могучий ящичек, в том числе и по общей скорости передачи. И опять это была покупка не на три года, а на более.
     

  • 1.14, tensor (?), 17:21, 01/08/2018 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Возможно, глупый вопрос, но может кто подскажет: после апгрейда опять нужно устанавливать руками пакеты, или есть какой-то более хитрый способ?
     
     
  • 2.16, EvilWirelessMan (ok), 17:24, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Все с чистого листа
     
  • 2.44, Гентушник (ok), 18:10, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Для упрощения я добавил файл /etc/opkg-print-extra с таким содержимым:
    (opkg -o /rom/ list-installed ; opkg list-installed) | sort | uniq -u | awk '{print $1}' | grep -v '^lib\|^luci-lib-'

    Добавил /etc/opkg-print-extra и /etc/opkg-extra в /etc/sysupgrade.conf для того чтобы они сохранялись между обновлениями и при бэкапе конфига из веб-интерфейса.

    Перед обновлением на новую прошивку делаю так:
    /etc/opkg-print-extra > /etc/opkg-extra

    После обновления:
    opkg install 'cat /etc/opkg-extra'
    Если какие-то пакеты удалились/переименовались и вышла ошибка, то правим лист и ставим пакеты заново.

     
     
  • 3.59, tensor (?), 18:30, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Спасибо, довольно неплохой гайд.
    Сам пока решил редеплоить при помощи ansible, конфиги прописываю в /etc/sysupgrade.conf
    Остаётся одна, самая главная, проблема: после апдейта падает туннель. А без менеджмента придётся ехать далеко и глубоко, чего не очень хотелось бы.
     
  • 3.75, x3who (?), 22:31, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Спасибо, как раз сидел и думал с чего бы начать подготовку к неминуемому апгрейду.
     
     
  • 4.76, x3who (?), 22:53, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +1 +/
    ... только вызов awk надо перед юником ставить, а то номера версий не уникальны:

    (opkg -o /rom/ list-installed ; opkg list-installed) | awk '{print $1}' | sort | uniq -u | grep -v '^lib\|^luci-lib-'

     
     
  • 5.92, SuinoSuin (ok), 10:42, 02/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    + экономим один пайп через 'sort -u'
     
  • 5.96, Гентушник (ok), 12:26, 02/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    > ... только вызов awk надо перед юником ставить, а то номера версий
    > не уникальны:
    > (opkg -o /rom/ list-installed ; opkg list-installed) | awk '{print $1}' |
    > sort | uniq -u | grep -v '^lib\|^luci-lib-'

    Да, верно. Просто я видимо никогда не напарывался, т.к. обычно не обновляю пакеты которые уже есть в прошивке через opkg.

     
  • 3.85, athost (??), 08:13, 02/08/2018 [^] [^^] [^^^] [ответить]  
  • +1 +/
    >[оверквотинг удален]
    > (opkg -o /rom/ list-installed ; opkg list-installed) | sort | uniq -u
    > | awk '{print $1}' | grep -v '^lib\|^luci-lib-'
    > Добавил /etc/opkg-print-extra и /etc/opkg-extra в /etc/sysupgrade.conf для того чтобы
    > они сохранялись между обновлениями и при бэкапе конфига из веб-интерфейса.
    > Перед обновлением на новую прошивку делаю так:
    > /etc/opkg-print-extra > /etc/opkg-extra
    > После обновления:
    > opkg install 'cat /etc/opkg-extra'
    > Если какие-то пакеты удалились/переименовались и вышла ошибка, то правим лист и ставим
    > пакеты заново.

    У меня как-то попроще.
    В кроне стоит opkg list-installed > /etc/config/packlist.txt
    После прошивки cut /etc/config/packlist.txt -f 1 -d '"'"' '"'"' | xargs opkg install

     
     
  • 4.95, Гентушник (ok), 12:23, 02/08/2018 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > У меня как-то попроще.
    > В кроне стоит opkg list-installed > /etc/config/packlist.txt

    Так сохранится список всех пакетов, включая те что уже есть в прошивке (в /rom/).
    Состав пакетов в прошивке же может измениться после её обновления. Из-за этого ваша команда может доставить пакеты которые уже не нужны (особенно всякие либы) или выдать ошибку если пакеты были удалены/переименованы.

    Ну ещё я обычно собираю прошивку через image builder, так что состав пакетов в прошивке у меня однозначно меняется при обновлении.

     

  • 1.23, Аноним (23), 17:34, 01/08/2018 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    На TP-Link TL-WR841N/ND v8 пробовал кто-нибудь ставить с LuCI? А то я у себя до сих пор 14.07 держу, потому что пугали, что LuCI в память не влезет
     
     
  • 2.27, Пепяка (?), 17:45, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Не ну ты бы хоть в релизы то залез? зачем спрашивать то что можно самому посмотреть?

    https://downloads.openwrt.org/releases/18.06.0/targets/ar71xx/tiny/ Почему я должен за тебя все это искать?

     
     
  • 3.29, Аноним (23), 17:48, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Где там хотя бы слово про LuCI? Сделайте скриншот и обведите красненьким, пожалуйста, а то Ctrl+F в моём фаерфоксе никакого LuCI не видит
     
     
  • 4.30, Пепяка (?), 17:51, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Ты глупенький? У них все релизы идут с веб-интерфейсом. только транк консольный. Те какие то нехорошие дяди тебя в интеренете напугали что Люся сдохла, а ты и обкакался ничего сам не проверив?
     
     
  • 5.31, Аноним (23), 17:53, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Обведите красненьким, пожалуйста, где написано, что "них все релизы идут с веб-интерфейсом"?

    Я вот захожу на https://openwrt.org/supported_devices и там английским по светло-синему написано, что "4MB min (won't be able to install GUI (LuCI))". Ну и кому мне верить?

     
     
  • 6.32, Пепяка (?), 17:56, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Инстал ты и не сможешь лол. Оно уже поставлено. А любые манипуляции с установкой и обновлением пакетов - невозможны. Глупенький, да.
     
     
  • 7.33, Аноним (23), 17:58, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Тогда почему не написано про "won't be able to install GUI (LuCI)" для всех остальных девайсов, если оно уже поставлено, лол? Если тут кто-то глупенький, то или разработчики OpenWrt, или вы.

    >любые манипуляции с установкой и обновлением пакетов - невозможны.

    А вот на 14.07 возможны. Значит, видимо, прошиваться на новую версию нельзя. Окей.

     
     
  • 8.35, Пепяка (?), 18:01, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Еще раз Ты тупой https openwrt org toh tp-link tl-wr841nd Warning in some c... текст свёрнут, показать
     
     
  • 9.40, Аноним (23), 18:06, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Вот да, три разные ссылки на сайте OpenWrt пишут совершенно разные вещи про LuCI... текст свёрнут, показать
     
     
  • 10.47, Пепяка (?), 18:14, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • –2 +/
    А в чем проблема поставить проверить и откатить если не нравится Или что черная... текст свёрнут, показать
     
     
  • 11.49, Аноним (23), 18:16, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +3 +/
    Проблем никаких, но если будет заранее известно, что не понравится, то зачем тра... текст свёрнут, показать
     
  • 8.37, Пепяка (?), 18:03, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    А ты и на 14 версии не сможешь пакеты постаить Места то не прибавится от того ч... текст свёрнут, показать
     
     
  • 9.39, Аноним (23), 18:05, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Сотня с лишним килобайт была свободная Воткнул и LuCI с bootstrap-скином, и IPv... текст свёрнут, показать
     
     
  • 10.41, Пепяка (?), 18:08, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Коороче, хорош ныть Есть там люся Ивсегда была У меня 941 с 4 метрами и на 1... текст свёрнут, показать
     
     
  • 11.42, Аноним (23), 18:09, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Вот так и нужно было ответить с самого начала, спасибо... текст свёрнут, показать
     
     
  • 12.43, Пепяка (?), 18:10, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Если отвечать на все очевидные вещи люди никога не научатся сами чтото делать ... текст свёрнут, показать
     
     
  • 13.46, Аноним (23), 18:14, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Есть там люся Ивсегда была и ццпу возросло в 2 раа это совершенно не очевид... текст свёрнут, показать
     
     
  • 14.50, Пепяка (?), 18:17, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • –1 +/
    поставил - посмотрел - откатил дело буквально 5 минут С этим я сейчас через п... текст свёрнут, показать
     
     
  • 15.52, Аноним (23), 18:20, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Поставил, посмотрел, откатил - отсутствующий интернет с отвалом всего подряд на ... текст свёрнут, показать
     
     
  • 16.55, Пепяка (?), 18:25, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    А смысл от вебинтерфейса в работе 24 7 я полгода сидл на транке с сохарненым к... текст свёрнут, показать
     
     
  • 17.57, Аноним (23), 18:26, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Очень рад за вас, если у вас всё настраивается ровно один раз и или если вы люби... текст свёрнут, показать
     
     
  • 18.78, имямямя (?), 23:03, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    ваши все пользуют виндовс десяточку, и им ок норм , но я не считаю, что на ва... текст свёрнут, показать
     
     
  • 19.91, Аноним (23), 10:20, 02/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Я никого и не заставляю на них равняться... текст свёрнут, показать
     
  • 3.97, leap42 (ok), 13:43, 02/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    спасибо за линк, обновил свой 841v7, конфиг подхватился, luci на месте, ядро почему-то 4.9, полёт нормальный
     
  • 2.89, Анонимм (??), 09:23, 02/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    > На TP-Link TL-WR841N/ND v8 пробовал кто-нибудь ставить с LuCI? А то я
    > у себя до сих пор 14.07 держу, потому что пугали, что
    > LuCI в память не влезет

    Приношу свои извинения всем, кого напугал. 4 Mb flash, сборка tiny, ядро 4.9, luci в комплекте, но свободно 80 kb флэша вместо 208 kb на 17.01.5. Чесслово, лучше бы Luci не было. l2tp не влезает, pptp не проверял, но по расчётам тоже. Если свободно менее 50 kb, ФС монтируется в режиме только для чтения.

     

  • 1.24, Пепяка (?), 17:35, 01/08/2018 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Что-то они перестарались. На tp-link 941nd v2/v3 18.06.0-RC1 и релиз отличаются по потреблению проца в 2 раза ровно. RC2 не проверял.
     
     
  • 2.34, EvilWirelessMan (ok), 17:59, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Думаю, это повод для багрепорта с приаттаченным выводом ps.
     
     
  • 3.38, Пепяка (?), 18:04, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • –3 +/
    Эм... я бы с радостью но я баг репортами не занимаюсь. (и не надо говорить что я плохой)
    Тем более Сам роутер от меня находится на другом конце земного шара. Что тоже не добавляет желания ковыряться "что где и почему"
     
     
  • 4.93, SuinoSuin (ok), 10:44, 02/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    А смысла тогда было сюда об этом писать?
     

  • 1.45, Аноним (45), 18:12, 01/08/2018 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    На TL-WDR3600 обновился с 15.05 до 18.06 с сохранением конфига.
    Пока одна проблема: IphoneIOS11 перестал видеть скрытую сеть 5Ghz (хотя остальные устройства, в том числе старый IpadIOS8, подключаются).
    Пришлось пока раскрыть сеть 5GHz. Айфон для
     
  • 1.62, Аноним (62), 18:46, 01/08/2018 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Глупый вопрос от глупого анона: если накатить OpenWrt на роутер и ничего по сути не настраивать кроме некоторых сетевых интерфейсов, в плане безопасности в "стоке" у OpenWrt всё нормально? Анон хочет перелезть с прошивки от производителя, а в настройках безопасности есть всякие непонятные штуки которые включены по умолчанию.
     
     
  • 2.64, dalco (ok), 19:17, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    По умолчанию там вполне вменяемые настройки и лезть в глубины конфигов для какого-то особо хитрого тюнинга большинству юзеров смысла нет.
     
     
  • 3.86, ryoken (ok), 08:24, 02/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Только веб-морду перекинуть на внутренний интерфейс стоит, не помню, куда оно там ставится по дефолту.
     
     
  • 4.114, AnonPlus (?), 17:14, 06/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    По дефолту биндится на 0.0.0.0 и [::]

    Нужно в /etc/config/uhttpd поменять 0.0.0.0 на 192.168.1.1 (короче, локальный адрес, на котором висит роутер).

    И убрать всю строчку, где [::]. Или тоже поменять, чтобы локальный адрес был (но я не силён в IPv6, да и вряд ли кому-то нужно ходить на вебморду вот прям по IPv6 и не иначе)

     
  • 2.66, noname.htm (ok), 19:37, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Если сразу после входа пароль нормальный поставишь, то норм.
     
  • 2.104, Аноним (-), 15:23, 03/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    ну, если не считать необходимость настраивать вифи руками (в 17.04, во всяком случае, оно было так - искаропки вифи не работал), то да - в принципе, можно пользоваться с дефолтом
     

  • 1.63, Аноним (63), 19:07, 01/08/2018 [ответить] [﹢﹢﹢] [ · · · ]  
  • +2 +/
    Пользователи с 4/32 теперь отрезаны окончательно, или можно себе собрать свежее без лишнего? У кого-то получилось/поместилось?
     
     
  • 2.70, Аноним_админ (?), 21:16, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    > Пользователи с 4/32 теперь отрезаны окончательно, или можно себе собрать свежее без лишнего? У кого-то получилось/поместилось?

    Нет, но функционал будет ограничен.
    Вот тут больше подробностей: https://openwrt.org/supported_devices/432_warning
    Правда, последние правки вышли ДО текущего релиза, может ситуация изменилась. Сам сейчас хочу собрать прошивку для своего DIR-320 A2

     
     
  • 3.83, Аноним (83), 02:44, 02/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Поделитесь изысканиями, имеется такая железка...
     
  • 2.94, SuinoSuin (ok), 10:48, 02/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Пришло время расчехлить паяльник и перепаять флешку. С памятью уже сложнее, но впринципе на 32М оно еще бегает
     

  • 1.65, Аноним (-), 19:33, 01/08/2018 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    как там с dnscrypt? В 17.04 настраивалось костылями, к 18.06 обещали конфигурялку из вебморды в два клика
     
     
  • 2.68, Аноним (68), 20:09, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Никак, ставьте отдельно. v2 настраивается чуть проще: https://github.com/jedisct1/dnscrypt-proxy/wiki/Installation-on-OpenWRT
     
  • 2.74, AnonPlus (?), 22:06, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    > 17.04 настраивалось костылями

    Для 17.04 есть подробный мануал на русском в вики проекта. Править конфиги не через веб-морду это уже "костыли"?

     
     
  • 3.79, Другой Аноним (?), 23:38, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    >подробный мануал на русском

    это тот, который на половину на русском, а потом автор ниасилил?

     
     
  • 4.82, AnonPlus (?), 23:53, 01/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Я говорю про этот https://openwrt.org/ru/inbox/dnscrypt
    Переводил практически в одиночку, переведено всё, что было в английском, да и английский я дополнял во многом.
     
     
  • 5.99, Аноним (-), 16:29, 02/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    аноны выше пишут что надо собирать с гитхаба. В мануале же - что после chaos calmer все в репах. Кому верить?
     
     
  • 6.105, AnonPlus (?), 16:20, 03/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    DNSCrypt v1 - в репах

    DNSCrypt v2 - с гитхаба

     
     
  • 7.106, AnonPlus (?), 16:26, 03/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    P.S. Если вам нужен просто DNSCrypt - вам вполне подойдёт v1. v2 переписана с нуля на Go, имеет дополнительные фичи и поддержку некоторых плагинов типа Filter, Cloak и т.д. О них написано в https://github.com/jedisct1/dnscrypt-proxy/wiki В openwrt-шном билде они отключены.
     
     
  • 8.112, Аноним (-), 12:23, 04/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Спасибо ... текст свёрнут, показать
     
  • 2.84, 123 (??), 07:59, 02/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Используйте stubby
     

  • 1.67, Аноним (67), 19:45, 01/08/2018 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Никто не знает, в RT-N66U заработал 5ГГц wi-fi?
     
     
  • 2.98, Аноним (98), 15:44, 02/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Скорее всего нет. С чего бы ему заработать, если соответсвующие wifi-дрова никто не открывал?
     
  • 2.107, чебурнет.рф (ok), 18:28, 03/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Надо же быть таким страдальцем. Чем Asus-WRT не устроил?
    "Бороду то я сбрею, а мысли куда я дену? Мысли!?", да?
     
     
  • 3.111, Аноним (98), 21:26, 03/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Asus-WRT со стороны выглядит прилично, но внутри кривой как рога оленя. Как и почти всё, что написано китайскими программистами. И даже Merlin не в состоянии эту кривизну и глючность исправить. И старый он как говно мамонта. Конечно, хорошо, что там ядро уже проапгрейдили до 2.6 с 2.4, но и это уже старьё, как и сопутствующие утилиты.
     

  • 1.69, Gannet (ok), 20:50, 01/08/2018 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Снова порты для aMule не открывает miniupnpd. Правили уже этот баг и опять вылез :(
     
     
  • 2.87, ryoken (ok), 08:24, 02/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    А чо, Осёл ещё жив? Что там есть? :)
     
     
  • 3.100, Аноним (-), 16:32, 02/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    >Что там есть

    хорошая попытка, Товарищ Майор. А если серьезно - после некоторых судебных дел в европке, популярность альтернативных торрентам мест обмена честно спираченым возросла. Так что, по большей части - там все тоже самое, только метод обмена другой

     
  • 3.101, Gannet (ok), 20:55, 02/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    > А чо, Осёл ещё жив? Что там есть? :)

    Зайди и посмотри.

     
  • 2.90, athost (??), 09:48, 02/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    > Снова порты для aMule не открывает miniupnpd. Правили уже этот баг и
    > опять вылез :(

    Использование upnp -- большое несекьюрное зло.

     
     
  • 3.102, Gannet (ok), 20:55, 02/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    >> Снова порты для aMule не открывает miniupnpd. Правили уже этот баг и
    >> опять вылез :(
    > Использование upnp -- большое несекьюрное зло.

    Да боян же. Но на домашней тачке это удобно.

     
     
  • 4.115, AnonPlus (?), 17:16, 06/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    Да руками единожды пробросить порты нетрудно. Вы же не меняете порт ежедневно в aMule?
     
     
  • 5.116, Gannet (ok), 01:29, 07/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    > Да руками единожды пробросить порты нетрудно. Вы же не меняете порт ежедневно
    > в aMule?

    Нетрудно. Но ещё нужно пробрасывать их и для Deluge. Можно, но влом.

     

  • 1.118, phil (??), 23:11, 17/08/2018 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Ребят, какой роутер порекомендуете купить под OpenWRT цена/качество, с двумя и более usb и все такое
     
     
  • 2.119, d000 (?), 06:47, 24/08/2018 [^] [^^] [^^^] [ответить]  
  • +/
    linksys 3200acm и выше.
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Слёрм
    Inferno Solutions
    Hosting by Ihor
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2019 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру