The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги | ]

21.09.2018 10:18  Выпуск сервера приложений NGINX Unit 1.4

Опубликован выпуск сервера приложений NGINX Unit 1.4, в рамках которого развивается решение для обеспечения запуска web-приложений на различных языках программирования (Python, PHP, Perl, Ruby и Go). Под управлением NGINX Unit может одновременно выполняться несколько приложений на разных языках программирования, параметры запуска которых можно изменять динамически без необходимости правки файлов конфигурации и перезапуска. Код написан на языке Си и распространяется под лицензией Apache 2.0. С особенностями NGINX Unit можно познакомиться в анонсе первого выпуска.

Основные изменения:

  • Добавлена поддержка TLS для шифрования клиентских соединений;
  • Добавлен API для управления хранением TLS-сертификатов;
  • Реализована библиотека libunit для интеграции в приложения модулей поддержки языков программирования;
  • Управляющий API ограничен отражением только объектов конфигурации из раздела "/config/";
  • Добавлена поддержка HTTP-ответа "408 Request Timeout" при обращении по закрываемому keep-alive соединению;
  • Улучшена поддержка платформы OpenBSD.
  • Исправлены ошибки, в том числе крах при переконфигурации, проблемы сборки на системах с локалью не по умолчанию, некорректная работа директивы "header_read_timeout" и проблемы с обработкой в модуля для Python 3 значений с не-ASCII символами в заголовках.


  1. Главная ссылка к новости (https://github.com/nginx/unit/...)
  2. OpenNews: Выпуск сервера приложений NGINX Unit 1.3
  3. OpenNews: Выпуск сервера приложений NGINX Unit 1.2
  4. OpenNews: Первый стабильный релиз сервера приложений NGINX Unit
  5. OpenNews: Релиз nginx 1.14.0
  6. OpenNews: Выпуск nginx 1.15.3
Лицензия: CC-BY
Тип: Программы
Ключевые слова: nginx, unit
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение Ajax/Линейный | Раскрыть все сообщения | RSS
 
  • 1.1, Аноним (1), 10:50, 21/09/2018 [ответить] [показать ветку] [···]    [к модератору]
  • +/
    >  Добавлена поддержка TLS для шифрования клиентских соединений;
    > Добавлен API для управления хранением TLS-сертификатов;

    Джва года ждал.

     
  • 1.2, Аноним (2), 11:28, 21/09/2018 [ответить] [показать ветку] [···]    [к модератору]
  • +/
    Для php это лучше php-fpm ?
     
     
  • 2.11, ыы (?), 14:30, 21/09/2018 [^] [ответить]    [к модератору]
  • +2 +/
    нет
     
  • 2.13, Аноним (13), 15:02, 21/09/2018 [^] [ответить]    [к модератору]
  • +3 +/
    На порядок лучше.
     
     
  • 3.16, Аноним (16), 17:26, 21/09/2018 [^] [ответить]    [к модератору]
  • +/
    а чем именно?
     
     
  • 4.17, Аноним (17), 17:28, 21/09/2018 [^] [ответить]    [к модератору]  
  • –2 +/
    чем php-fpm
     
  • 1.3, lone_wolf (ok), 11:42, 21/09/2018 [ответить] [показать ветку] [···]    [к модератору]  
  • –7 +/
    Я правильно понимаю что это современная замена HTTPD Apache2?
     
     
  • 2.4, Аноним (4), 12:35, 21/09/2018 [^] [ответить]    [к модератору]  
  • +2 +/
    Microservice Mesh это для Кубернетосов, Мезосов и остального Zero-Config..
     
  • 2.5, Аноним (4), 12:37, 21/09/2018 [^] [ответить]    [к модератору]  
  • +/
    В Апатче тоже есть автоконфигурирование контейнеров? Нет это и близко не Apache.
     
     
  • 3.7, rshadow (ok), 12:42, 21/09/2018 [^] [ответить]    [к модератору]  
  • –3 +/
    В продакшене никто не складывает все яйца в одну корзину. Такое использование подобно докеру - для программистов круто, но в продакшене никто не использует ибо разваливается.
     
     
  • 4.8, anonymous (??), 13:24, 21/09/2018 [^] [ответить]    [к модератору]  
  • +/
    Такое использование подобно операционным системам - для программистов круто, но в продакшене никто не использует ибо разваливается.
     
  • 2.6, rshadow (ok), 12:41, 21/09/2018 [^] [ответить]    [к модератору]  
  • –1 +/
    Почти. Если у вас на апаче, то скорее шило на мыло менять. А вот если у вас любят свои кастомные сервера ваять, да еще вдруг все на разных языках, то конечно лучше. Преимущественно для администрирования.
     
  • 2.9, Аноним (9), 13:34, 21/09/2018 [^] [ответить]    [к модератору]  
  • +1 +/
    Никаким боком это к веб-серверу апач не относится. Это — сервер приложений, админы локалхостов с апачем о таких и не слышали никогда
     
  • 2.12, ыы (?), 14:32, 21/09/2018 [^] [ответить]    [к модератору]  
  • –2 +/
    до апача ему еще расти и расти. в некотором смысле... вам бы чего нить почитать по теме...
     
  • 2.20, lone_wolf (ok), 19:40, 21/09/2018 [^] [ответить]    [к модератору]  
  • +/
    Понял, значит я ошибся. Над будет по теме почитать.
     
     
  • 3.25, Аноним (4), 06:16, 22/09/2018 [^] [ответить]    [к модератору]  
  • +/
    https://cdn-1.wp.nginx.com/wp-content/uploads/2018/03/nginx.com-NAP-diagram-01

    https://www.nginx.com/blog/introducing-nginx-application-platform/

     
  • 1.19, Аноним (19), 19:26, 21/09/2018 [ответить] [показать ветку] [···]    [к модератору]  
  • +1 +/
    А зачем надо решение "для запуска web-приложений на <...> Go", ежели приложение на Go компилируется в бинарник и само себя радостно без всяких костылей запускает?
     
     
  • 2.23, SubGun (ok), 21:04, 21/09/2018 [^] [ответить]    [к модератору]  
  • –2 +/
    И часто у вас приложения на go "наружу смотрят"?
     
     
  • 3.29, Аноним (29), 14:55, 23/09/2018 [^] [ответить]    [к модератору]  
  • +/
    У вас с этим проблема? Ну поставь балансер, но явно не appserver
     
  • 1.22, Лютор (?), 20:07, 21/09/2018 [ответить] [показать ветку] [···]    [к модератору]  
  • +/
    Поясните анонимам, для чего это, а то они запутались
     
     
  • 2.26, Аноним (4), 06:53, 22/09/2018 [^] [ответить]    [к модератору]  
  • +/
    Tags: Microservices, Monolith
     
  • 1.24, Sfinx (ok), 01:46, 22/09/2018 [ответить] [показать ветку] [···]    [к модератору]  
  • +1 +/
    подождем nodejs, потом посмотрим
     
     
  • 2.27, Александр Борисов (?), 23:25, 22/09/2018 [^] [ответить]    [к модератору]  
  • +/
    Я могу вам хоть сейчас патч выдать с поддержкой nodejs в unit.
    Скажите, а как вы пользуете ноду, то есть, чем не устраивает pm?
     
     
  • 3.28, Sfinx (ok), 14:01, 23/09/2018 [^] [ответить]    [к модератору]  
  • +/
    > Я могу вам хоть сейчас патч выдать с поддержкой nodejs в unit.
    > Скажите, а как вы пользуете ноду, то есть, чем не устраивает pm?

    Имеется ввиду pm2 ? Полностью устраивает, но nginx все равно торчит наружу. Патч не горит -
    интересно было бы пощупать и это решение.


     

     Добавить комментарий
    Имя:
    E-Mail:
    Заголовок:
    Текст:


      Закладки на сайте
      Проследить за страницей
    Created 1996-2018 by Maxim Chirkov  
    ДобавитьПоддержатьВебмастеруГИД  
    Hosting by Ihor