The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Релиз Polemarch 1.0.0, web-интерфейса для Ansible

06.02.2019 03:10

Состоялся выпуск Polemarch 1.0.0, web-интерфейса для управления серверной инфраструктурой на базе Ansible. Код проекта написан на языках Python и JavaScript с использованием фреймворков Django и Celery. Проект распространяется под лицензией AGPL. Для запуска системы достаточно установить пакет и запустить 1 сервис. Для промышленного применения рекомендуется дополнительно использовать MariaDB и Redis/RabbitMQ+Redis (кэш и брокер MQ). Для каждой версии формируется образ Docker, основанный на образе Alpine 3.8.

Это первый стабильный релиз продукта, в котором нет кардинальных изменений по сравнению с версией 0.2.8 в плане функциональности, а только внесены исправления мелких ошибок в GUI и проведён рефакторинг кода. Исключение сделано только для новой функции, позволяющей при создании проекта GIT сразу указать необходимую ветку. Дополнительно можно отметить, что был исправлен код для поддержки Python 3.7, но сборок wheels для данной версии Python пока не планируется.

  1. Главная ссылка к новости (https://github.com/vstconsulti...)
  2. OpenNews: Релиз Polemarch 0.2.7, web-интерфейса для Ansible
  3. OpenNews: Релиз Red Hat Enterprise Linux 7.6
  4. OpenNews: Серьёзная уязвимость в системе управления конфигурацией Ansible
  5. OpenNews: Red Hat представил проект AWX, в рамках которого открыт код Ansible Tower
  6. OpenNews: Выпуск системы управления конфигурацией Ansible 2.3
Автор новости: vstconsulting
Тип: Программы
Ключевые слова: polemarch, ansible
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (22) Ajax | 1 уровень | Линейный | Раскрыть всё | RSS
  • 1.1, Аноним (1), 09:28, 06/02/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    круто =)
     
  • 1.2, Петр (??), 09:29, 06/02/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Воу воу, пошел обновляться)
     
     
  • 2.6, Qwerty (??), 11:16, 06/02/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Молодой человек, вы лукавите. Ни один админ не побежит за новой версией ПО, пока её не обкатают. Тем более, если это версия X.0.0
     
     
  • 3.9, Петр (??), 11:33, 06/02/2019 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Я сначала все проверяю на небольшой сети, созданной специально для тестов, потом уже внедряю далее.
    Тем более кто-то ж должен обкатывать новые релизы продуктов)
     

  • 1.4, Аноним (4), 10:56, 06/02/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Чем оно лучше/хуже AWX?
     
     
  • 2.17, Аноним (17), 04:56, 07/02/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Чем оно лучше/хуже Cockpit/Foreman/spacewalkproject
     

  • 1.5, dddd (?), 11:15, 06/02/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +2 +/
    тот случай когда с интерфейсом сложнее чем без него
     
  • 1.7, бублички (?), 11:27, 06/02/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    едва слепили но уже продают Polemarch+ (100 серверов $2500)
     
     
  • 2.10, эффехтивный манагер (?), 12:57, 06/02/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    зато я могу уволить админа и кликать мышкой не хуже него!
    На все 100 серверов!
     
     
  • 3.11, бублички (?), 13:13, 06/02/2019 [^] [^^] [^^^] [ответить]  
  • +/
    100 серверов за $2500 это без поддержки (http://polemarch.org/#calculate_price). прежде чем кликать мышкой, настраивать всё (включая 100 серверов) будешь сам :)
     
     
  • 4.13, эффехтивный манагер (?), 15:38, 06/02/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    так ты ж уже один раз настроил! Все, свободен, можешь собирать манатки - секьюрить присмотрит, чтоб клавиатуру не трогал, а я побежал докладывать генеральному, как классно сэкономил.

    А если чо сломается - куплю премиум, 8000, это твоя зарплата за три месяца в лучшем случае, а пользы от тебя - никакой, хахаха!

     
  • 2.12, Тимофей (??), 13:47, 06/02/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Не для небогатыхбродов просто))
    А если по делу, то они с год уже выпускаются.
     
     
  • 3.15, бублички (?), 16:02, 06/02/2019 [^] [^^] [^^^] [ответить]  
  • +/
    с год? немыслимо! сейчас же бегу менять ansible tower на эту поделку
     

  • 1.8, бублички (?), 11:32, 06/02/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    помню они требовали древнюю версию OpenSSL (1.0.0 или 1.0.1) - с более новой (1.0.2 или 1.1.0) не работало. интересно, хоть это исправили?
     
     
  • 2.16, vstconsulting (ok), 02:24, 07/02/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Вообще мы никак не привязаны к версии OpenSSL. К библиотеке привязывался uWSGI, который используется "под капотом", и, насколько я помню, какая-то из зависимостей Ansible, но мы перешли на pyuwsgi и перестали поставлять .deb и .rpm (думаю что на время, пока с более актуальными задачами не разберёмся). А когда ставится через pip, то все зависимости сами привязываются установленным к либам.

    Для тех кто не хочет заморачиваться с зависимостями или установкой есть Docker-образ.

     
     
  • 3.18, бублички (?), 14:29, 07/02/2019 [^] [^^] [^^^] [ответить]  
  • –2 +/
    к сожалению номеров версий не приведу, но примерно декабрь 2017 - январь 2018. это был не первый, но скорей всего последний раз когда я тратил время на то чтоб посмотреть этот продукт

    uwsgi (/opt/polemarch/bin/uwsgi) что шёл тогда в составе Debian-пакета (!) требовал старой версии libssl (1.0.0 или 1.0.1) и не работал (плевался exception) с современной и стабильной тогда (в рамках Debian 9) версией (1.0.2 или 1.1.0)

    зачем вообще было совать в пакет cвой uwsgi вместо того чтоб просто указать его в зависимостях пакета (Depends: uwsgi) и спокойно пользоваться тем что идёт в составе Debian (https://packages.debian.org/stretch/uwsgi) описав это буквально двумя строчками в документации? потому считаю верным ваше решение отказаться от поставки .deb

     
     
  • 4.20, Аноним (20), 17:35, 07/02/2019 [^] [^^] [^^^] [ответить]  
  • +2 +/
    >uwsgi (/opt/polemarch/bin/uwsgi) что шёл тогда в составе Debian-пакета (!) требовал старой версии libssl (1.0.0 или 1.0.1) и не работал (плевался exception) с современной и стабильной тогда (в рамках Debian 9) версией (1.0.2 или 1.1.0)

    Вы так говорите, как будто в дебиане эта проблема не решается установкой одного пакета

     
  • 4.22, vstconsulting (ok), 02:54, 08/02/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    http://antirao.ru/faq/16-ogranichenie-otvetstvennosti-0

    В общем-то открытая лицензия как и всё Open Source говорит о том, что использовать OS-приложение - ваше право (а не обязанность), а решать что поддерживать или нет - наше.
    Мы очень расположены к сообществу и готовы поддержать любую идею, которая поможет развитию продукта и на данном этапе мы не видим, чтоб было какое-то особое препятствие в установке и настройке Polemarch.

     
  • 3.19, бублички (?), 14:32, 07/02/2019 [^] [^^] [^^^] [ответить]  
  • –2 +/
    > Для тех кто не хочет заморачиваться с зависимостями или установкой есть Docker-образ.

    вы это серьёзно? понимаете ли, далеко не все считают Docker пригодным для использование где бы то ни было кроме среды разработки (dev)

     
     
  • 4.21, vstconsulting (ok), 02:35, 08/02/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Всем не угодишь =) Мы же не заставляем кого-либо использовать его или Polemarch? У каждого свой workflow, поэтому и набор инструментов свой: у кого-то Kubernates+Docker, у кого-то OpenStack, у кого-то VmWare - всё зависит от задач.
     

  • 1.23, Аноним (23), 19:17, 08/02/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Я никогда пипом для штук не пользовался, обычно беру тарболы с готовым и ставлю, основные файлы не трогаются, конфигурация отдельно обычно, в custom/ например, можно спокойно обновлять. А тут как сделать, чтобы не гадило? Хочу отдельно от проги разместить конфиги, логи, sqlite базу, итд, чтобы если что, обновлять раз в год, но тут захардкоржен основной конфиг в /etc/polemarch/settings.ini. Непорядок.
     
     
  • 2.24, vstconsulting (ok), 06:44, 11/02/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Ну если очень сильно хочется, то можно конфиг перегрузить через переменную POLEMARCH_DEV_SETTINGS_FILE. Чтобы основные файлы не трогать, специально в инструкции описывается процесс установки в virtualenv, который может быть хоть где в системе. Ну а где-что складывать легко настраивается в конфиге.
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Слёрм
    Inferno Solutions
    Hosting by Ihor
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2019 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру