The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Выпуск Wine 4.11

22.06.2019 09:00

Доступен экспериментальный выпуск открытой реализации Win32 API - Wine 4.11. С момента выпуска версии 4.10 было закрыто 17 отчётов об ошибках и внесено 370 изменений.

Наиболее важные изменения:

  • Продолжена работа по сборке DLL по умолчанию со встроенной библиотекой msvcrt (предоставляемой проектом Wine, а не DLL из Windows) в формате PE (Portable Executable). По сравнению с прошлым выпуском на формат PE переведены ещё 143 DLL;
  • Обновлена версия движка Mono 4.9.0 и фреймворка Windows.Forms;
  • Представлена более быстрая реализация SRW-блокировок (Slim Reader/Writer) для Linux, переведённая на Futex;
  • В библиотеке user32 реализована начальная поддержка вызова EnumDisplayDevicesW() для получения информации об используемых в текущем сеансе экранах;
  • В winex11.drv добавлен обработчик экранов на базе Xinerama и обеспечена обработка изменения устройств вывода;
  • В состав wined3d включён код для операций с текстурами wined3d_texture_gl;
  • Закрыты отчёты об ошибках, связанные с работой игр и приложений: SWAT4 Areas, AutoIt v3.x, Max Payne 3, Port Royale 2, Catzilla 1.0, 7-Zip 15.06, Legacy of Kain: Soul Reaver, Fallout 4, .NET Framework 4.0, приложения на базе Chromium Embedded Framework (CEF), Nero CoverDesigner.

Дополнительно можно отметить проведение разработчиком из компании Canonical эксперимента по запуску игр из каталога GOG в тестовой сборке Ubuntu 19.10 без 32-разрядных библиотек, используя Wine64. В итоге, из 6 случайно выбранных протестированных игр, работающих в Wine с 32-разрядными библиотеками, в Wine64 ни одна игра не заработала. В частности, не удалось добиться установки трёх игр (Theme Hospital, Quake The Offering, Shadow Warrior), одна игра не запустилась (GOG Braid), а оставшиеся две (FTL Advanced Edition, GOG Surgeon Simulator 2013) ограничились выводом чёрного экрана (возможно из-за ограничений поддержки OpenGL в VirtualBox).

  1. Главная ссылка к новости (https://www.winehq.org//announ...)
  2. OpenNews: Прекращение поддержки i386 в Ubuntu приведёт к проблемам с поставкой Wine
  3. OpenNews: Выпуск Wine 4.10 и Proton 4.2-6
  4. OpenNews: В Wine Staging добавлены патчи для повышения производительности многопоточных игр
  5. OpenNews: Вышел WineVDM 0.7
  6. OpenNews: Проект Wine выпустил Vkd3d 1.0 с реализацией Direct3D 12
Лицензия: CC-BY
Тип: Программы
Ключевые слова: wine
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (54) Ajax | 1 уровень | Линейный | Раскрыть всё | RSS
  • 1.1, Ключевский (?), 09:47, 22/06/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • –17 +/
    А зачем пытаться запустить под вайном Braid, если он есть нативный??? Что бы жизнь медом не казалась что ли? Я специально зашел на GOG и проверил, что там нативный Braid есть, могу его скачать спокойно из своей библиотеки.
     
     
  • 2.2, Аноним (2), 10:07, 22/06/2019 [^] [^^] [^^^] [ответить]  
  • +10 +/
    Для проведения
    >эксперимента по запуску игр из каталога GOG в тестовой сборке Ubuntu 19.10 без 32-разрядных библиотек, используя Wine64

    К.О.

     
     
  • 3.5, адмирал третьего флота очевидно (?), 10:21, 22/06/2019 [^] [^^] [^^^] [ответить]  
  • –2 +/
    вайн64 не готов, но убунта всёравно выпилит 32хбитные либы необходимые для работы вайн32. остаётся присосаться к 32хбитному рантайму стима
     
     
  • 4.17, Анимус (?), 13:57, 22/06/2019 [^] [^^] [^^^] [ответить]  
  • +10 +/
    Остается послать нафиг Убунту.
     
     
  • 5.27, Онаним (?), 16:34, 22/06/2019 [^] [^^] [^^^] [ответить]  
  • –2 +/
    > Остается послать нафиг Убунту.

    Забавно, что до сих пор не все это сделали. После смерти Unity не вижу в Ubuntu смысла. Есть же Manjaro.

     
     
  • 6.31, lucentcode (ok), 18:55, 22/06/2019 [^] [^^] [^^^] [ответить]  
  • –4 +/
    Есть же Arch. А всё остальное - для не оссиляторов.
     
     
  • 7.37, Аноним (37), 22:19, 22/06/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Есть же FLS. А всё остальное - для не оссиляторов.
    А если серьезно, арче-воды очень странные ребята, они при каждой возможности сообщают, что у них арч. Они уверены, что тратить время на сборку системы это есть линукс. Хотя нормальные люди понимают, что ОС для человека, а не человек для ОС. Нормальные люди выбирают Debian или Centos и просто работают или развлекаются. У меня есть знакомый с подпольной кличкой Арчи - это самый неадекватный человек из всех кого встречал в жизни. Сложилось мнение, что арчеводы позёры.
     
     
  • 8.42, Аноним (42), 10:21, 23/06/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    готовый к работе десктоп на арче ставится за 30 минут, в зависимости от качеств... текст свёрнут, показать
     
     
  • 9.44, Аноним (44), 12:00, 23/06/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Ага, только пакеты к нему собираются Дядями Васями, которым Arch предлагает тебе... текст свёрнут, показать
     
     
  • 10.47, Аноним (47), 18:50, 23/06/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Особенно ppa, ага ... текст свёрнут, показать
     
  • 9.49, Michael Shigorin (ok), 22:31, 24/06/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Хренассе, а что он там делает остальные 25 А, это на соседском модеме, наверное... текст свёрнут, показать
     
  • 7.48, Michael Shigorin (ok), 22:28, 24/06/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Aussie'ляторов? 8)

    (pro hint: на каникулах можно подтянуть географию!)

     
  • 6.35, Аноним (35), 22:12, 22/06/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Manjaro отказывалось загружаться после обновлений, после установки. Два раза с переустановкой. Вероятно проблема в драйверах видео, но не стал разбираться. На убунту ничего такого не было и близко, чтобы после обновлений система не грузилась.
     
     
  • 7.50, Michael Shigorin (ok), 22:33, 24/06/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > На убунту ничего такого не было и близко, чтобы после обновлений
    > система не грузилась.

    Поискал "ubuntu updates fail reboot", повспоминал, сколько мне в подобных случаях советовали писать "imho" или в эквиваленте -- думаю, Вам тоже пригодится подобный совет. :)

     
  • 4.23, Тот_Самый_Анонимус (?), 15:57, 22/06/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Ну так и в тoпку её. Тем более и обои скучные.
     
  • 2.4, A.Stahl (ok), 10:09, 22/06/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Понятия не имею что такое Braid, но иногда под Линукс собирают откровенно хреново: линкуются с устаревшими либами, либо наоборот с тем, чего ещё нет в репах. Или ещё что-то в этом духе.
    Иногда проще попробовать через Вайн.
     
     
  • 3.12, 143267 (?), 12:01, 22/06/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Понятия не имею что такое Braid

    Известный платформер.

    > линкуются с устаревшими либами, либо наоборот с тем, чего ещё нет в репах

    А причем тут репы, если речь про проприетарную игру, которая поставляется со всем что есть?

     
     
  • 4.19, Аноним (19), 15:04, 22/06/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    не совсем так. Иногда то, что поставляется вместе с игрой действительно требует чего-то древнего, например libc. При этом иногда бывает достаточно выкинуть все, что идет с игрой и уже есть в репах.
     
     
  • 5.33, Аноним (33), 19:18, 22/06/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Древний Libc это хорошо Чем более старого Glibc хочет прога, тем большее количе... текст свёрнут, показать
     
  • 5.51, Michael Shigorin (ok), 22:34, 24/06/2019 [^] [^^] [^^^] [ответить]  
  • +/
    В смысле libc4?
     
  • 3.13, Аноним (13), 12:05, 22/06/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Куда проще скопировать нужные либы, чем уповать на вайн.
     
  • 3.16, Аноним (33), 13:41, 22/06/2019 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Я согласен В русскоязычной части интернета я пропагандирую сборку ПО в CentOS 6... текст свёрнут, показать
     
     
  • 4.25, Mr. Cake (?), 15:58, 22/06/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Ну соберите какую-нибудь нехелловорлдную библиотеку типа Skia под CentOS 6. Сразу вылезет слишком древняя версия libfontconfig или что-то подобное. Да и тулчейн сборке с ней поставляется далеко не свежий, хоть это и решается частично с holy-build-box.
     
  • 4.28, Crazy Alex (ok), 16:37, 22/06/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    А нахрена париться с докером? Поднял виртуалку - и вперёд. Чуть медленнее, зато на порядок меньше странного
     
  • 4.40, Аноним (33), 02:07, 23/06/2019 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Не совсем там Бинарник не развалится и не окажется неработоспособным в новой ве... текст свёрнут, показать
     
     
  • 5.52, Michael Shigorin (ok), 22:37, 24/06/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > Просто нужно будет доустановить недостающие библиотеки.

    Интересно, насколько _более_ на пальцах надо объяснять, чтоб понять, что это как раз тот самый dll hell в другой упаковке -- "вон та библиотечинка слинкована с..., а там ещё с..., и дальше по списку ..., и так продолжаем обходить всё дерево, пока не выходит половина новой-версии-убунты".

    Про ldd слышали?  Посмотрите им, с чем линкуется "недостающая библиотека".

     
  • 3.56, Kuromi (ok), 01:19, 26/06/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Это, к сожалению, напрямую зависит от разработчиков игры\порта. Есть игры которые вполне нормально собраны, а есть такие, которые были собраны явно по принципу "ну хоть как нибудь", что особенно характерно к билдам с Humble Bundle, большинство которых были брошены сразу после завершения акций.
     
  • 2.26, Аноним (26), 16:29, 22/06/2019 [^] [^^] [^^^] [ответить]  
  • +/
    >А зачем пытаться запустить под вайном Braid, если он есть нативный???

    Ага, нативность которого заключается в поставке виндового клиента уже обёрнутого в вайн, труба шатал я такие нативные клиенты, лучше уж с вайна запускать виндовый!

     
     
  • 3.32, Аноним (33), 19:04, 22/06/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Ну, это ты зря. Я приобрёл Linux-версию в 2010 году на Humble Bundle 2. Играл на нетбуке, весьма слабом. Там был видеочип ATi Mobility Radeon 4250. Игра при запуске автоматически определяла разрешение, при котором не тормозит. Это было 640x480. Ну, не знаю, может на винде и быстрее работает. Мне странно видеть, как 2D-игра не тормозит только на 640x480, а Unreal Tournament 2004 нативный и в 1024x768 играется на "средних" настройках. Я смотрел сам бинарник, собран вполне грамотно. Зависит от GLIBC 2.4 или новее (первые бандлы вообще грамотно собрали), все стандартные зависимости берёт из системы, все нестандартные лежат в архиве с игрой, и подцепляются сами. Как я понял, игра полностью нативна. Единственное, что не нативно, это шейдеры, которые транслируются из HLSL в GLSL.
     
  • 2.36, НяшМяш (ok), 22:16, 22/06/2019 [^] [^^] [^^^] [ответить]  
  • +/
    В том же треде на реддите пишут, что Braid 32-битный. Так что он тоже умрёт, когда бубунтятина выкинет i686 из своих дистров.
     
     
  • 3.57, Kuromi (ok), 01:32, 26/06/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Все верно пишут https://www.gog.com/game/braid - this game comes with a 32-bit binary only

    К огромному сожалению, как минимум половина Linux игр на том же ГОГ не поддерживает 64 бит. В последние годы имеется некоторая теденция что новые релизы идут 64-bit only, взять тот же совсем не старый ремастер Грим Фанданго 2015-ого года - 32 бит и все. Выпустят ли свежие билды? Кто-то - может быть, но точно не все.

     

  • 1.3, Лапчатый девляпс бубунтёнак (?), 10:08, 22/06/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +3 +/
    Цигвин в вайне всё ещё не работает?
     
     
  • 2.7, IronMan (?), 11:08, 22/06/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Но зачем?
     
     
  • 3.11, Аноним (11), 11:36, 22/06/2019 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Чтобы в нём собрать и запускать собственный Wine!
     

  • 1.6, Аноним (6), 10:57, 22/06/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Сборку i386 выпилили. Ладно. Но выпилиывют и сами пакеты для совместимости. Не слишком ли быстро? Я понимаю, есть LTS, но они не бесконечные. А где гарантии что потом не будет проблем с запуском 32-битного софта? Далеко не всё можно портировать, либо не всё портируют по тем или иным причинам.
     
     
  • 2.18, Ключевский (?), 14:03, 22/06/2019 [^] [^^] [^^^] [ответить]  
  • –2 +/
    LTS это 5 лет бесплатной поддержки. У тебя времени до 2023 года, что бы выкинуть старье.
    Блин, когда на смену 16 битам пришли 32 никто не пищал «ААААА! У меня еще старое дерьмо!»
    Дропают и правильно делают.
    Зайчики, AMD64 существует 15 лет. 15 лет, понимаете? У вас было 15 лет на то, что бы все сделать. Вы 15 лет плевали в потолок и теперь ноете.
     
     
  • 3.20, анон (?), 15:04, 22/06/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Объясни теперь это моей бабушке, у которой после обновления ферма не запускается.
     
  • 3.22, Аноним84701 (ok), 15:13, 22/06/2019 [^] [^^] [^^^] [ответить]  
  • +3 +/
    > Блин, когда на смену 16 битам пришли 32 никто не пищал «ААААА!
    > У меня еще старое дерьмо!»

    Угу. Только поддержку 16-бит DOS-программ из винды официально (a неофициально есть патчи, позволяющии запускать NTVDM - NT Virtual DOS Machine на 64 битной винде) убрали только при переходе на 64-битные версии. Массовый переход на 64-битную винду - никак не раньше Win8.  Ну и возможность установки DOSBox никто и не думал выпиливать, совсем наоборот.

     

  • 1.8, 111 (??), 11:19, 22/06/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +3 +/
    надо попробовать :)

    последовательно в wine пытаюсь запустить студенческий компас-17 - если в 4.8 оно только запускалось, то в 4.10 staging пропали артефакты и оно уже работает не как вьювер - для целей обучения вполне можно пользоваться (правда, при попытке сохранить чертеж как pdf - валится... но есть виртуальный принтер :)

     
     
  • 2.53, Michael Shigorin (ok), 22:41, 24/06/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Его, кстати, вроде как всё-таки тащат на линукс нативно.  Поздно, но лучше, чем никогда.
     
     
  • 3.54, 111 (??), 00:08, 25/06/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > Его, кстати, вроде как всё-таки тащат на линукс нативно.  Поздно, но
    > лучше, чем никогда.

    этого не может быть , так как этого не может быть!

    kompas уже так сильно обляпался дотнетом, что никуда им не слезть...

    так что если только нативный дотнет с винформами будет под линукс :)))


    ЗЫ:
    kompas-17 коряво генерирует stl - правда не знаю косяк ли это 17-го вообще или это так он себя под вайном ведет... Еще размеры на эскизе (3д деталь) не отображаются, а в 2Д - хорошо... Стандартные изделия не вставляются... но частых падений нет... отличий в 4.11 от 4.10 для компаса 17 не заметил


     

  • 1.9, Аноним (11), 11:32, 22/06/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    >По сравнению с прошлым выпуском на формат PE переведены ещё 143 DLL

    Только вот такое чувство, глядя на увлечение WSL, WSL 2, что сама MS скоро начнёт переползать на ELF.

     
     
  • 2.10, тоже Аноним (ok), 11:35, 22/06/2019 [^] [^^] [^^^] [ответить]  
  • +3 +/
    Да плевать Linux-сообществу, на что там Редмонд в очередной раз переползает.
    Вайн работает с легаси, оно не меняется.
     

  • 1.14, Kron4ek (ok), 12:35, 22/06/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    > эксперимента по запуску игр из каталога GOG в тестовой сборке Ubuntu 19.10 без 32-разрядных библиотек, используя Wine64

    Таким образом они ни одну игру из GOG не смогут запустить, а причина проста - в GOG даже 64-битные игры имеют 32-битный установщик. Видимо они не знали, что wine64 без 32-битных либ не может запускать 32-битные приложения.

    В принципе, если распаковывать установщики какими-то сторонними средствами, то можно будет запускать 64-битные игры.

     
     
  • 2.39, совсемнеаноним (?), 00:05, 23/06/2019 [^] [^^] [^^^] [ответить]  
  • +/
    В винде в принципе все установщики - 32-х битные. Типа для совместимости.
     
  • 2.58, Kuromi (ok), 01:35, 26/06/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Значит гогачей пинать надо, они ребята странные, иногда прислушиваются.
     

  • 1.15, commiethebeastie (ok), 13:29, 22/06/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Странно, winforms добавили, а запустить приложения на дотнете так ни разу не удалось.
     
     
  • 2.30, Ретроград (?), 17:08, 22/06/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Да ладно? Лет десять как работают уже. С косяками, некоторые сложные хаки отваливаются, но большая часть софта работает и не жужжит.
     
     
  • 3.46, commiethebeastie (ok), 16:34, 23/06/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > Да ладно? Лет десять как работают уже. С косяками, некоторые сложные хаки
    > отваливаются, но большая часть софта работает и не жужжит.

    Что для примера можно запустить?

     

  • 1.34, pda (?), 20:00, 22/06/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Объясние, что значит "dll переведены на PE"? А раньше там что было? LE? LX? ELF? a.out?
     
     
  • 2.41, Аноним (41), 09:45, 23/06/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Были "fakedlls" в формате ELF.
     
  • 2.55, Аноним (55), 18:39, 25/06/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Суть в том, что виндовый бинарь запущенный в wine, прозрачно загружает библитеки в PE, а для взаимодействия с библиотеками в формате ELF требовались дополнительные хаки.
     

  • 1.45, Аноним 80_уровня (ok), 12:09, 23/06/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Как и двадцать пять лет назад, основной набор претензий к линуксу сводится к "а виндовые программы этот ваш линукс запускать умеет? А?"

    Только двадцать пять лет назад линуксовое сообщество не пинало с такой радостью дистрибутивы, которые не умели запускать виндовые программы.

     
     
  • 2.59, Аноним (59), 15:12, 30/06/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Забавно, что за годы существования Wine особого прогресса нет. Как было плохо, так и осталось плохо.
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Слёрм
    Inferno Solutions
    Hosting by Ihor
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2019 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру