The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Выпуск Ubuntu 18.04.3 LTS c обновлением графического стека и ядра Linux

08.08.2019 21:59

Сформировано обновление дистрибутива Ubuntu 18.04.3 LTS, в которое включены изменения, связанные с улучшением поддержки оборудования, обновлением ядра Linux и графического стека, исправлением ошибок в инсталляторе и загрузчике. В состав также включены актуальные обновления для нескольких сотен пакетов, связанные с устранением уязвимостей и проблем, влияющих на стабильность. Одновременно представлены аналогичные обновления Kubuntu 18.04.3 LTS, Ubuntu Budgie 18.04.3 LTS, Ubuntu MATE 18.04.3 LTS, Lubuntu 18.04.3 LTS, Ubuntu Kylin 18.04.3 LTS и Xubuntu 18.04.3 LTS.

В состав выпуска вошли некоторые улучшения, бэкпортированные из выпуска Ubuntu 19.04:

  • Предложено обновление пакетов с ядром 5.0 (в Ubuntu 18.04 использовалось ядро 4.15, а в Ubuntu 18.04.2 - 4.18 ).
  • Обновлены компоненты графического стека, включая новые выпуски mutter 3.28.3 и Mesa 18.2.8, которые были протестированы в Ubuntu 19.04. Добавлены свежие версии видеодрайверов для чипов Intel, AMD и NVIDIA.
  • Обновлены версии пакетов OpenJDK 11, LLVM 8, Firefox 66.0.4, cloud-init 18.5-21, ceph 12.2.11, PostgreSQL 10.7, snapd 2.38, modemmanager 1.10;
  • В установщике серверной редакции появилась поддержка шифрованных групп разделов LVM и возможность использования при установке существующих дисковых разделов. Реализована автоматическая проверка новой версии snap-пакета с установщиком, при наличии которой выводится предложение установить обновление;
  • Из Ubuntu 19.04 бэкпортирована новая версия системы Livepatch, предоставляющей обновления с устранением опасных уязвимостей в ядре Linux, которые применяются к работающей системе на лету, не требуя перезагрузки.

В сборках для рабочего стола новые ядро и графический стек предложены по умолчанию. Для серверных систем новое ядро добавлено в качестве опции в инсталляторе. Использовать новые сборки имеет смысл только для новых установок - системы, установленные ранее, могут получить все присутствующие в Ubuntu 18.04.3 изменения через штатную систему установки обновлений.

Напомним, что для поставки новых версий ядра и графического стека применяется rolling-модель поддержки обновлений, в соответствии с которой бэкпортированные ядра и драйверы будут поддерживаться только до выхода следующего корректирующего обновления LTS-ветки Ubuntu. Например, предложенное в текущем выпуске ядро Linux 5.0 будет поддерживаться до выхода Ubuntu 18.04.4, в котором будет предложено ядро из состава Ubuntu 19.10. Изначально поставляемое базовое ядро 4.15 будет поддерживаться в течение всего цикла сопровождения.

Для перевода уже существующих установок на новые версии ядра и графического стека следует выполнить команду:


   sudo apt-get install --install-recommends linux-generic-hwe-18.04 xserver-xorg-hwe-18.04 


  1. Главная ссылка к новости (https://lists.ubuntu.com/archi...)
  2. OpenNews: Canonical пересмотрела планы по прекращению поддержки архитектуры i386 в Ubuntu
  3. OpenNews: Выпуск дистрибутива Ubuntu 19.04
  4. OpenNews: Обновление Ubuntu 14.04.6 LTS
  5. OpenNews: Выпуск Ubuntu 18.04.2 LTS c обновлением графического стека и ядра Linux
  6. OpenNews: Релиз дистрибутива Ubuntu 18.04 LTS
Лицензия: CC-BY
Тип: Программы
Ключевые слова: ubuntu
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (74) Ajax | 1 уровень | Линейный | Раскрыть всё | RSS
  • 1.1, andy (??), 22:07, 08/08/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    mesa старенькая
    ядрышко 5.0 особо без изменений, ждем 5.2 в репах с ускорением 3д в графике интел и новом менеджере очередей
     
     
  • 2.4, Аноним (4), 22:18, 08/08/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Не заметил что бы что то ускорилось на 5.2 на встройке интела
     
  • 2.7, segesg (?), 22:56, 08/08/2019 [^] [^^] [^^^] [ответить]  
  • +/
    https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers
     
     
  • 3.44, Аноним (44), 10:40, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Не стал бы я ставить на рабочую систему со всеми там паролями и доступами неофициальные видеодрайвера. Лучше свежие от самой canonical ставить https://launchpad.net/~ubuntu-x-swat/+archive/ubuntu/updates
     
  • 2.35, dkg (?), 09:46, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • +3 +/
    Не надо ждать - ukuu Вам в помощь!
     
  • 2.38, Аноним (38), 10:11, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Про 5.2 была же новость, что что-то в нём со свопом накуралесили и в результате толком не работает. Поэтому лучше на 5.2 не спешить, пока не вернут всё взад.
     
     
  • 3.45, andy (??), 10:54, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    проблема со Swap Это общая проблема всех ядер
     

  • 1.2, KHD (ok), 22:11, 08/08/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Отлично, надо обновится
     
     
  • 2.13, zzz (??), 00:35, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Казалось бы, при чем тут DKMS
     
     
  • 3.39, Аноним (38), 10:13, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Проприетарные драйвера не использую, поэтому пофиг на DKMS.
     
     
  • 4.61, Канифоль Патрика (?), 18:24, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    И вот эта вот картинка-мем "НЕТ!" здесь должна быть.
     
  • 4.90, Аноним (90), 20:32, 12/08/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Как будто DKMS нужен только для проприетарных драйверов
     
  • 2.86, Temr (?), 22:20, 11/08/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Вы или тире поставьте или мягкий знак, а то нипанятна
     

  • 1.3, VINRARUS (ok), 22:12, 08/08/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • –7 +/
    То есть KDE оставили дырявым?
     
     
  • 2.5, maximnik0 (?), 22:27, 08/08/2019 [^] [^^] [^^^] [ответить]  
  • +/
    >То есть KDE оставили дырявым?

    Читайте внимательно первоисточник, там дырявый файловый менеджер с общей библиотекой, весь КДЕ падчить не надо .

     
     
  • 3.12, VINRARUS (ok), 00:34, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Так библиотека же КДЭшная...
     
  • 2.17, iPony129412 (?), 04:11, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Да, так какая разница?
    При установке всё равно нормальные люди накатывают обновления.
    А так пакеты постоянно уязвимы в готовой сборке, к примеру то же ядро и браузер Firefox.
     
  • 2.57, Вуыкло (?), 15:44, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • +/
    В Неоне - нет.
     
     
  • 3.58, VINRARUS (ok), 17:01, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > В Неоне - нет.

    По этому у меня резервный дистрибутив - Неон, а не Кубунта. :)

     
  • 3.82, Аноним (82), 09:42, 10/08/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Почему-то в Неоне "из коробки" не работает Kmail, а в Кубунте работает сразу.
     

  • 1.6, Оффтоп (?), 22:40, 08/08/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    >Предложено обновление пакетов с ядром 5.0

    а есть ли на самом деле необходимость так часто обновлять ядро, особенно не на lts версию?
    А то сам до сих пор пользуюсь 4.4 и все работает - может не понимаю чего?

     
     
  • 2.8, Аноним (8), 23:10, 08/08/2019 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Когда купишь новый комп вопрос может стать не актуальным.
     
     
  • 3.30, Аноним (30), 08:17, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • +6 +/
    когда научишься ставить запятые перестанешь понимать что сейчас читаешь
     
     
  • 4.41, Аноним (38), 10:15, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • –4 +/
    А сам-то?
     
     
  • 5.75, Аноним (75), 02:12, 10/08/2019 [^] [^^] [^^^] [ответить]  
  • +/
    А',,с,а,м,'-'т,о,?'
     
  • 2.9, Аноним (9), 23:12, 08/08/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Если всё работает, то не надо. Это для тех, у кого новое железо, но нет желания обмазываться не-LTS дистром.
     
  • 2.10, th3m3 (ok), 23:13, 08/08/2019 [^] [^^] [^^^] [ответить]  
  • +3 +/
    Почитай описание нового ядра, посмотри, что там исправили, что запилили, что выпилили. На основе этого принимай решение.
     
  • 2.11, НяшМяш (ok), 00:30, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Зависит от железа. У меня китаепланшет на атоме на ядрах старше 5.0 не заводит bluetooth и wifi.
     
     
  • 3.15, Crazy Alex (ok), 01:06, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Китаепланшет с линуксом? А можно поподробнее?
     
     
  • 4.46, Аноним (46), 11:33, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > Китаепланшет с линуксом? А можно поподробнее?

    http://4pda.ru/forum/index.php?showtopic=650808
    Тема старая и многое стало не актуально, некоторые новые дистрибутивы просто ставятся и работают.

     
  • 4.52, НяшМяш (ok), 13:11, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Chuwi Hi12 - из коробки дуалбут винды и 5 андроида. Там обычный uefi, хоть и кривой, но зато 64-битный. Но китайцы как всегда напихали туда своих уникальных китайских датчиков и кривой чип реалтека с одной антенной на блютуз и вайфай. Как раз в новых ядрах под это дело пофикшены драйвера, фирмваря тут не поможет. Я мог бы заняться сборкой модулей под старое ядро, но я хочу в свободное время смотреть котиков на ютубе и пускать пузыри.
     
  • 3.16, Аноним (8), 02:56, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Скорее всего блобы еще под новое ядро не обновили. Обычное дело для bluetooth, wifi и lan.
     
     
  • 4.42, Аноним (38), 10:20, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Firmware, вроде как, от версии ядра не зависит.
     
     
  • 5.47, Аноним (46), 11:34, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > Firmware, вроде как, от версии ядра не зависит.

    Для RTL8723BS фирмаврь осталась без изменений, но надо переименовать файлы.

     
  • 2.22, Аноним (22), 06:48, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • +/
    В 5 ядре есть поддержка PSI, в отличие от старых. С новым ядром можешь накатить nohang, включить в его конфиге поддержку PSI и начать инновационным способом предотвращать фризы при конкуренции за память.
     
  • 2.49, Zenitur (ok), 11:47, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Если ты пользуешься открытым драйвером Radeon или Amdgpu, то смысл есть. На Форониксе есть такая традиция: писать про релиз-кандидат будущего ядра в контексте того, что там появились новые возможности этого драйвера. Что бенчмарки выросли на много процентов, что всё будет круто. Но в дистрах это окажется не скоро, потому что в ядре Linux, которое выйдет через неделю, эти изменения не успели войти из-за заморозки перед релизом, поэтому используйте следующее-следующее ядро.

    И так - каждый раз. Ты дожидаешься наконец-то ядра 5.2, в котором настолько сильно увеличили производительность открытого драйвера Radeon. Но радости тебе это не приносит, потому что в ядре 5.4 обещали ещё сильнее увеличить производительность

     
     
  • 3.63, Канифоль Патрика (?), 18:31, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Когда у вас будет 400 FPS в Shadow of Tomb Rider, перейду на Линукс. А пока на ядре 5.2 у вас там наверное не более 200 - не катит.
     

  • 1.18, Поставить говно вместо новья (?), 04:47, 09/08/2019 Скрыто [﹢﹢﹢] [ · · · ]
  • –13 +/
     
     
  • 2.24, Tifereth (?), 06:49, 09/08/2019 Скрыто
  • +4 +/
     
  • 2.25, iPony129412 (?), 07:43, 09/08/2019 Скрыто
  • +/
     

     ....нить свёрнута, показать (2)

  • 1.19, helloworld (?), 04:55, 09/08/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    При этом на kernel.org longterm ядра 4.14 и 4.19, а 5.0 уже и не упоминается. У убунты свой путь...
     
     
  • 2.28, Аноним (28), 08:00, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • +/
    В linux mint 4.15 LTS.
     
     
  • 3.31, Аномномномнимус (?), 09:02, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Который радостно у них же апается до 5.0
    И Mesa 19.0.2
     
  • 2.48, Аноним (46), 11:37, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > При этом на kernel.org longterm ядра 4.14 и 4.19, а 5.0 уже
    > и не упоминается. У убунты свой путь...

    Они сами (или Debian?) их поддерживают, перенося исправления из новых веток. "Свой путь" у Росы, которая эти ядра тупо скопировала.

     

  • 1.20, Аноним (20), 05:27, 09/08/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    Когда ядро обновил до 5.0, vlc начал файлы жевать mp3 при нажатии на паузу.
     
     
  • 2.23, Вася (??), 06:48, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Что значит жевать? Портить что ли?
     
     
  • 3.29, Аноним (29), 08:02, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • +13 +/
    Пленку зажевывать. У вас что нет магнитофона?
     
  • 3.55, Аноним (20), 14:44, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Нет, когда на паузу нажимаешь на пробел ( раз нажал пробел ), а потом чтобы продолжило играть, оно как бы прокручивает секунды (2-3), не четкости. Если на ядре 4, то там нажал пробел, остановил, потом еще раз нажали и с того места он сразу начал воспроизведение.
     
     
  • 4.72, AlexYeCu_not_logged (?), 21:21, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Вот на 5.2 глянул — всё нормально.
    Проблема явно не в ядре, просто одновременно с ядром обновилось что-то ещё, может в vlc какой фильтр включён, или какая-нибудь фигня типа PA используется.
     
  • 2.26, iPony129412 (?), 07:45, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    У меня кстати тоже.
    Но что-то я сомневаюсь, что это вина ядра. VLC тоже наверно обновлялся...
     
     
  • 3.56, Аноним (20), 15:35, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Нет, после отката на 4, все стало нормально.
     

  • 1.21, Аноним (22), 06:44, 09/08/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    DKMS исправили или еще нет?
     
     
  • 2.43, iPony129412 (?), 10:24, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    В дистрибутиве непонятно, а так апдейты исправления прилетали
     
     
  • 3.53, Аноним (53), 14:42, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Из коробки нет никакого dkms. А так в принципе можно приделать.
     

  • 1.27, 64_bit_boy (?), 07:48, 09/08/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    >Firefox 66.0.4

    Свежачок

     
     
  • 2.32, вейланд (?), 09:03, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    В lts версии убунту стоит lts версия файрфокса, срочно в новость!
     
     
  • 3.34, iPony129412 (?), 09:34, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Нет. В LTS версии Ubuntu обычная версия дефолтом.
     
  • 3.50, Mike Lee (?), 12:07, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    нет. lts версия файерфокса 60.x. https://www.mozilla.org/en-US/firefox/organizations/
     
     
  • 4.51, iPony129412 (?), 13:03, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Типа того, хотя 60 и 68-ая.

    У них при переходном периоде обе поддерживаются.

    https://www.mozilla.org/media/img/firefox/organizations/release-overview.d8ca1

     
  • 2.36, Аноним (36), 10:04, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Если тебе нужна самая свежайшая версия лисы, то скачай с оф. сайта
     
     
  • 3.74, Аноним (74), 00:31, 10/08/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > самая свежайшая версия

    ночная сборка

     

  • 1.33, Аноним (33), 09:33, 09/08/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    >Выпуск Ubuntu 18.04.3 LTS (8.8.2019)
    >Обновлены версии пакетов Firefox 66.0.4

    68.0.1 (18 июля 2019)!!!

     
     
  • 2.40, m (??), 10:13, 09/08/2019 [^] [^^] [^^^] [ответить]  
  • +/
    В обновлениях Firefox 68.0.1.
     

  • 1.37, Аноним (37), 10:07, 09/08/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    У меня ядро 4.15 но NVIDIA драйвер обновился до 430.26 причем первый раз после рестарта система свалилась на не пропреитарный. Потом вручную ещё раз выставил  на 430 теперь вроде система работает нормально.
     
  • 1.68, Аноним (68), 19:11, 09/08/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    > Поставить говно вместо новья

    На это говно устанавливаются драйверы от АМД, в отличие от новья, в котором, как и здесь вложенные - говно.

     
  • 1.71, Gannet (ok), 21:16, 09/08/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Ядро обновилось само-собой уже где-то с неделю назад. А вот xserver-xorg-hwe-18.04 всё ещё версии 18.04.2. К чему команда обновления приведённая в статье - непонятно.
     
     
  • 2.78, iPony129412 (?), 05:45, 10/08/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Насколько я понял из этого
    https://wiki.ubuntu.com/Kernel/LTSEnablementStack

    В десктопной версии
    Если ты ставил Ubuntu 18.04 или 18.04.1, то ты по умолчанию будешь иметь стабильную связку, которая не будет обновляться на новые версии (только вон приведённую команду выполнять).
    А если ты ставил Ubuntu 18.04.2 или дальше, то по умолчанию поскачешь по ядрам с обновлениями.

    То есть первые версии в LTS дают стабильность, а последующие скачку. Разное поведение.

     
     
  • 3.79, iPony129412 (?), 05:48, 10/08/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Хотя не, бред написал...

    Десктопные LTS кажись все скачут вперёд.
    А серверные нет.

     
  • 3.87, Gannet (ok), 22:35, 11/08/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Изначально на ряде машин у меня была 18.04, потом она обновлялась по порядку. Подобного поведения: сначала сама обновилась, а потом новость через неделю, да ещё и без обновления графического стека, хотя в новости о нём указано, не было ещё ни разу.
     

  • 1.73, Аноним (73), 22:20, 09/08/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Неконтролируемые автообновления - зло. Это про Snap.
     
     
  • 2.77, iPony129412 (?), 05:37, 10/08/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Так они контролируются
     
     
  • 3.83, Аноним (83), 10:28, 10/08/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Кем?
     

  • 1.76, Аноним (75), 02:27, 10/08/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Пытаюсь и не могу понять как Шаттлворт, Марк зарабатывает на Убунту.
     
  • 1.80, Theory (?), 08:21, 10/08/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Вот странно: Ubuntu Mate 1.20, а в Mint Mate 1.22. Ubuntu даже в 19.04 стоит 1.20. Разработчики мотивируют нетабильностью версии 1.20 и тем, что в 10 Debian тоже 1.20. Так что же, и в 20.04 будет старая версия Mate???
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Слёрм
    Inferno Solutions
    Hosting by Ihor
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2019 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру