The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Доступна альфа-версия Qt 6.0

06.10.2020 16:03

Компания Qt Company объявила о переводе ветки Qt 6 на стадию альфа-тестирования. Qt 6 включает значительные архитектурные изменения, а для сборки требуется компилятор, поддерживающий стандарт C++17. Релиз намечен на 1 декабря 2020 года.

Ключевые особенности Qt 6:

  • Абстрагированный графический API, не зависящий от 3D API операционной системы. Ключевым компонентом нового графического стека Qt является движок рендеринга сцен, использующий прослойку RHI (Rendering Hardware Interface) для обеспечения работы приложений Qt Quick не только с OpenGL, но и поверх API Vulkan, Metal и Direct 3D.
  • Модуль Qt Quick 3D с API для создания интерфейсов пользователя на базе Qt Quick, сочетающих элементы 2D и 3D графики. Qt Quick 3D позволяет использовать QML для определения 3D-элементов интерфейсов без задействования формата UIP. В Qt Quick 3D для 2D и 3D можно использовать один runtime (Qt Quick), один макет сцены и один анимационный фреймворк, а для визуальной разработки интерфейса применять Qt Design Studio. Модуль решает такие проблемы, как большие накладные расходы при интеграции QML с контентом из Qt 3D или 3D Studio, и предоставляет возможность синхронизации анимации и преобразований на уровне отдельных кадров между 2D и 3D.
  • Реструктуризация кодовой базы с разбиением на более мелкие составные части и сокращением размера базового продукта. Инструменты для разработчиков и специализированные компоненты будут поставляться в виде дополнений, распространяемых через каталог-магазин Qt Marketplace.
  • Существенная модернизация QML:
    • Поддержка строгой типизации.
    • Возможность компиляции QML в представление на C++ и машинный код.
    • Перевод полной поддержки JavaScript в разряд опций (использование полнофункционального JavaScript-движка требует больших ресурсов, что мешает применению QML на таком оборудовании, как микроконтроллеры).
    • Отказ от версионирования в QML.
    • Унификация структур данных, дублирующихся в QObject и QML (позволит сократить потребление памяти и ускорить запуск).
    • Уход от генерации структур данных во время выполнения в пользу генерации во время компиляции.
    • Скрытие внутренних компонентов через использование приватных методов и свойств.
    • Улучшенная интеграция с инструментами разработки для рефакторинга и диагностики ошибок во время компиляции.
  • Добавление инструментов для обработки связанных с графикой ресурсов на этапе компиляции, например, для преобразования PNG-изображений в сжатые текстуры или для конвертации шейдеров и мешей в оптимизированные бинарные форматы для конкретного оборудования.
  • Встраивание унифицированного движка для тем оформления и стилей, позволяющего добиться внешнего вида приложений на базе Qt Widgets и Qt Quick, родного для разных мобильных и настольных платформ.
  • В качестве системы сборки решено использовать CMake вместо QMake. Поддержка сборки приложений при помощи QMake будет сохранена, но сам Qt будет собираться с использованием CMake. CMake выбран, так как данный инструментарий получил широкое распространение в среде разработчиков проектов на C++ и поддерживается во многих интегрированных средах разработки. Разработка сборочной системы Qbs, которая претендовала на роль замены QMake, продолжена сообществом.
  • Переход при разработке на стандарт C++17 (ранее использовался C++98, а с Qt 5.7 — C++11). В Qt 6 планируют реализовать поддержку многих современных возможностей C++, но без потери обратной совместимости с кодом на основе прошлых стандартов.
  • Возможность использования в коде на C++ некоторой функциональности, предлагаемой для QML и Qt Quick. В том числе будет представлена новая система свойств для QObject и подобных классов. Из QML в ядро Qt будет интегрирован движок для работы с привязками (binding), что позволит снизить нагрузку и потребление памяти для биндингов и сделать их доступными для всех частей Qt, а не только для Qt Quick.
  • Расширение поддержки дополнительных языков, таких как Python и WebAssembly.


  1. Главная ссылка к новости (https://www.qt.io/blog/qt-6.0-...)
  2. OpenNews: Qt 6 в Debian может оказаться без сопровождения
  3. OpenNews: Первый тестовый выпуск Qt 6
  4. OpenNews: Релиз фреймворка Qt 5.15
  5. OpenNews: Qt Company обдумывает переход к публикации свободных релизов Qt через год после платных выпусков
  6. OpenNews: LTS-версии Qt будут доступны только под коммерческой лицензией
Лицензия: CC-BY
Тип: Программы
Короткая ссылка: https://opennet.ru/53841-qt
Ключевые слова: qt
Поддержать дальнейшую публикацию новостей на OpenNET.


Обсуждение (187) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, Аноним (1), 16:07, 06/10/2020 Скрыто модератором [﹢﹢﹢] [ · · · ]
  • +10 +/
     
     
  • 2.2, Аноним (2), 16:10, 06/10/2020 Скрыто модератором
  • +8 +/
     

  • 1.3, InuYasha (??), 16:12, 06/10/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • +14 +/
    После последних новостей об их лицензионной политике, как-то даже не хочется это трогать. :-|
     
     
  • 2.4, n00by (ok), 16:17, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Анонсировано же:

    Реструктуризация ... с ... сокращением размера базового продукта. компоненты ... через каталог-магазин Qt Marketplace.

     
     
  • 3.15, Lex (??), 16:53, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Одно другому не мешает
     
     
  • 4.145, n00by (ok), 10:02, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Изменения в лицензионной политике и анонс "декомпозиции для оптимизации" -- это одно и тоже (насколько понял, будут форсировать переходы на новые версии, что бы удешевить тестирование). А что другое?
     
  • 2.5, Аноним (5), 16:19, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +2 +/
    >> После последних новостей об их лицензионной политике, как-то даже не хочется это трогать. :-|

    Новости неприятные, согласен, но какая есть альтернатива?

     
     
  • 3.6, Аноним (6), 16:23, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • –14 +/
    GNOME ToolKit 3.10
     
     
  • 4.22, Аноним (22), 17:03, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +16 +/
    > GNOME ToolKit

    О да, поржал.

     
     
  • 5.179, Аноним (179), 09:31, 08/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    А что с GTK не так?
     
  • 4.30, gavr (ok), 17:29, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • –4 +/
    Почему 3.10? Сейчас уже четверка со стабильным API
     
  • 4.39, Тот_Самый_Анонимус (?), 17:57, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    >GNOME ToolKit 3.10

    зачем вам бутер, когда рядом куча гамна? Выбор очевиден!

     
     
  • 5.46, Аноним (46), 18:08, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Мало у какой компании есть +1000500 денег на лицензию Qt
     
     
  • 6.69, Тот_Самый_Анонимус (?), 20:24, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • –1 +/
    То-то я посмотрю что XnView, Ultimaker Cura пишут свои далеко не последнего места шедевры угадайте на чём? Да на гтк остаются только маргиналы, которым лень переписывать кучу старого кода. Новых проектов нет.
     
     
  • 7.82, 7331 (?), 21:37, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    очевидно, что новое лучше писать на новом, если новое этого заслуживает.
     
  • 6.91, Skullnet (?), 22:29, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    У меня нет +1005000 денег на шоколад, поэтому я буду есть говно. (С)
     
     
  • 7.95, Аноним (46), 23:26, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Если вам не нравится GNOME Toolkit - то держите нас в курсе, мы с вами свяжемся.
     
  • 4.47, Аноним (47), 18:08, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Или таки Gimp Tool Kit?
     
     
  • 5.48, Аноним (46), 18:10, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Они переименовались.
     
     
  • 6.88, Аноним (88), 22:20, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +7 +/
    Что, в Glimpse Tool Kit?
     
  • 3.7, Im banana man (?), 16:23, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    wxWidgets
    Epic Games на чем-то свой Unreal написали. Blender тоже свой тулкит сделали. Вот
     
     
  • 4.31, InuYasha (??), 17:32, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +7 +/
    > wxWidgets

    С бак-ендом в виде wxQT на основе 5.0-.
    wx - это абстракция над тулкитами.

     
  • 3.17, Аноним (17), 16:56, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Tcl/Tk
     
     
  • 4.79, Аноним (79), 21:26, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • –4 +/
    Это язык или набор UI с псевдоязыком что это вообще?
     
  • 3.29, Ю.Т. (?), 17:22, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Motif. Простите, Open Motif.
     
     
  • 4.80, Аноним (79), 21:26, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Там половины контролов нет и под половину систем оно в принципе не работает.
     
  • 3.32, InuYasha (??), 17:34, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > Новости неприятные, согласен, но какая есть альтернатива?

    Оставаться на 5.0.

     
     
  • 4.132, Аноним (132), 05:58, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    хуепумполь. на 5.13, т.к. в 5.14 и 5.15 поломаты нафиг windeployqt, а фиксить это уже пару лет, как всем не надо
     
     
  • 5.143, Аноним (143), 09:22, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Да ничего там не поломали, просто windeployqt.exe нужно теперь запускать с ключом --release-with-debug-info вместо --release иначе эта программа не понимает что это релиз и не находит соответствующие библиотеки.
     
  • 5.147, Sin2x (ok), 10:06, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Тикет на это есть?
     
  • 3.53, Аноним (53), 18:48, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Fox toolkit
     
  • 3.55, ИмяХ (?), 18:57, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    FLTK
     
  • 3.63, proninyaroslav (ok), 19:51, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • –6 +/
    Flutter. P.S: привет минусующим хейтерам гугла
     
     
  • 4.81, Кэп (?), 21:27, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Привет
     
  • 4.92, Аноним (88), 22:37, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Вредное явление https://wiki2.org/ru/Флаттер_(авиация)
     
  • 4.133, Аноним (132), 06:04, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    пишу только на нехайповых языках неоднодневках типа руби, флаттэра и скАлы. ещё на джаве всё стабильное юзаю, ноджс там, нпм, электрон. ястабой, брат
     
  • 3.78, Dd (?), 21:22, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >альтернатива

    ftlk

     
  • 3.111, Ilya Indigo (ok), 00:52, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Разве что wxWidgets с Qt бэкендом как бы глупо это не звучало.
     
  • 3.151, bykka (?), 11:00, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    А как же https://kivy.org ?
     
  • 3.160, Аноним (47), 13:04, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Смотря для чего?
     
  • 2.126, Аноним (126), 03:49, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Вам чем-то не нравится LGPL и GPL? Отличный вклад коммерческой либы в опенсурс
     

     ....большая нить свёрнута, показать (38)

  • 1.8, Аноним (8), 16:27, 06/10/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Тема лицензирования и распространения не раскрыта...
     
     
  • 2.89, Аноним (89), 22:21, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +2 +/
    *base под LGPL. А вот если с вяленым захочешь поиграть, то покупай лицуху.
     
     
  • 3.124, Аноним (126), 03:46, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    GPL хватит всем!
     
     
  • 4.162, Аноним (162), 13:51, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Мне хватит.
     
  • 3.135, Аноним (132), 06:08, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    так вяленый это ж вроде как лукашенко: к 2025 году обещаем достичь показателей 2012 года. и так каждый день
     
     
  • 4.173, Аноним (-), 21:53, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Завернул так, что выставление и плюса, и минуса вызывает боль.
     
  • 3.144, Аноним (143), 09:29, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Немного не так. Если захочешь написать при помощи Qt свой композитор вяленоко. А так обычные программы без проблем и без перекомпиляции запускаются в стороннем вяленом композиторе.
     
  • 2.189, Аноним (-), 00:43, 10/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Тема сисек тоже... Где скриншоты то?!
     

  • 1.9, Total Anonimus (?), 16:28, 06/10/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • +2 +/
    И обновление минимальных требований к ОС :
    Windows 10 2004 (64bit Intel; msvc2019 or mingw81/gcc8.1)
    macOS 10.15 (64bit Intel; XCode 11)
    Linux:
      Ubuntu 20.04 (64bit Intel; gcc9)
      CentOS 8.1 (64bit Intel; gcc9)
      SLES 15 (SUSE Linux Enterprise Server, 64bit Intel; gcc10)
      Open SUSE 15.1 (64bit; gcc9)
    Плюшкиных послали лесом ...

     
     
  • 2.71, Денис (??), 20:30, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    > Ubuntu 20.04 (gcc9)
    > Плюшкиных послали лесом

    Недавно gcc10 поставил в Ubuntu 16.04.

    > 64bit

    VirtualBox, Chromium, Darktable, Handbrake тоже дропнули 32bit, но в дистрах собирают. Не все дистры, не везде свежие версии, правда, но новее даты дропа.

     
     
  • 3.167, Денис (??), 15:16, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    > Недавно gcc10 поставил в Ubuntu 16.04

    Обновил системную libstdc++.so.6 (6.0.28 из gcc10) и мне кажется система быстрее бегать стала. Такое возможно?

     
  • 2.75, Денис (??), 21:00, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > GCC 9

    Вообще-то C++17 появился в GCC 8. В GCC9 он перестал был экспериментальным.
    Я думаю, не проблема будет вкатить Qt6 на дистры 2019 года (Debian 10, Mageia 7).

     
     
  • 3.136, Аноним (132), 06:11, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Я думаю, не проблема будет вкатить Qt6 на дистры 2019 года (Debian 10, Mageia 7).

    это дистры 1019 года. очепятался, прощаю

     
     
  • 4.159, Денис (??), 13:00, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Да, свежачок, н.э.
     
  • 2.94, Аноним (94), 23:11, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • –7 +/
    >Windows 10
    >64bit Intel

    Шли бы они на хрен с такими требованиями. Ещё бы SGX/TrustZone/Trusted Media Path потребовали.

    Qt всё в общем.

     
     
  • 3.96, Аноним (94), 23:26, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Удивительно, но они действительно дропнули А ларчик просто открывался В общем ... большой текст свёрнут, показать
     
     
  • 4.100, Денис (??), 23:51, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Both Windows 7 or 8.x version support will not be available for Qt 6. Microsoft discontinued the support for both Windows versions some time ago

    У Windows 8.1 Extended support until January 10, 2023
    Еще 2 года и 3 месяца.

     
     
  • 5.109, Аноним (94), 00:33, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Знаешь, в компании, где я работаю, не принято выбрасывать деньги на лицензии вин... большой текст свёрнут, показать
     
     
  • 6.110, iPonya (?), 00:41, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Ты не понимаешь. Старые технологии надо выкидывать!
     
  • 6.113, Аноньимъ (?), 01:58, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +6 +/
    По моему этот текст нейросеть сгенерила.
     
     
  • 7.146, Аноним (94), 10:04, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Все осмысленные тексты в интернете нейросеть сгенерила.
     
  • 6.150, mumu (ok), 10:15, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Это дословная выдержка из приказа "Положения о жизненном цикле ПО", принятого в вашем желтом доме? НДА не нарушаете, копипастя это сюда?
     
     
  • 7.152, Аноним (94), 11:17, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Это вы правила приличия нарушаете.
     
  • 4.125, Аноним (126), 03:48, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Насколько я понимаю, это всего лишь означает потерю активного тестирования. Возможность запустить по идеи должна остаться
     
     
  • 5.149, Аноним (94), 10:10, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Не, там явно написано, что баги, затрагивающие неподдерживаемые системы фиксится не будут.

    >For Technical Support to accept issue tickets, the issues need to be reproducible on one of the supported hosts, or there needs to be a corresponding, customer-specific, additional service to cover the issue.

     
     
  • 6.153, Аноним (94), 11:18, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    *фикситься
     
  • 4.127, Аноним (2), 04:35, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Всё в порядке. Никто ничего не будет делать. Если я правильно понял, то работоспособность на они будут гарантировать только на современных системах.

    Нет смысла поддерживать 8, к тому моменту как кути зарелизятся, 8 уже 5 лет не будет поддерживаться вендором, и тем более нет смысла тянуть lts ради полутора додиков (особенно бесплатно). 7 уже сегодня 5 лет не поддерживается, был какой-то смысл её тянуть из-за того, что там был свой устаревший тулчейн без метро, сегодня уже совсем не актуально поддерживать некроос, которую никто не использует (тем более, обеспечивать лтс совместимость -- это завязка на махровое легаси на годы вперёд).

     
     
  • 5.180, Аноним (132), 09:31, 08/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    если и юзаю винду, то 7, плиточное уг никогда в жизни не накачу
     
  • 3.104, Денис (??), 23:59, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Это проблема винды. На линуксе можно вкатить новый компилятор, C либы и завезти прогу.
     
  • 3.148, Sin2x (ok), 10:09, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Qt 5.15 будет поддерживаться ещё 3 года. Если поддержка старых ОС необходима, надо использовать этот релиз.
     
  • 3.175, СССР (?), 23:52, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • –1 +/
    тебе чего нужно, шел бы ты на ...
     

  • 1.10, Аноним (10), 16:35, 06/10/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Подскажите. Компорт завезли? Я бы потыкал.
     
     
  • 2.27, Аноним (27), 17:13, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +3 +/
    его никуда не увозили, тыкун
     
     
  • 3.36, James Bond (?), 17:55, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • –1 +/
    До этого его в шестерке не было, поэтому вопрос привезли или нет актуален
     
  • 3.41, James Bond (?), 18:00, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    https://doc-snapshots.qt.io/qt6-dev/classes.html#s тыкун
     
  • 2.51, 7134956 (ok), 18:40, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Project ERROR: Unknown module(s) in QT: serialport
     

  • 1.11, Fracta1L (ok), 16:40, 06/10/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • +3 +/
    Офигенно, ждём релиза. Связка Qt6 + KDE6 обещает быть бомбезной.
     
     
  • 2.14, Козлетто (?), 16:42, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Опять будет глюкодром, опять будет плазма падать
     
     
  • 3.98, Аноним (94), 23:49, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Она и так падает. А с прогрессбаром в области уведомлений вообще лучше никаких дел не иметь - если в него пгслать много событий, то всё зависнет. Особенно любит зависать dolphin при копировании большого числа файлов.
     
     
  • 4.141, ryoken (ok), 08:22, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Вы простите на чём сидите? У меня даже в генте таких ужасов не наблюдается, хотя я кроме KDE ничего и не использую.
     
     
  • 5.154, Аноним (94), 11:20, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Kubuntu 20.10. Но такое поведение и раньше было.
     
     
  • 6.157, ryoken (ok), 12:56, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    > Kubuntu 20.10. Но такое поведение и раньше было.

    Убунту давно не трогаю, частично из-за подобных приколов. А с железом всё в порядке? Память там потестить..? Если вы про тот индикатор, который в области уведоилений всякие вещи типа копирования или там сообщений от KDE Konnect-а показывает - вот уж с ним вообще проблем отроду в этой установке генты не было. (Хотя я файлы только с телефона разве что Долфином гоняю, винты\сеть - через mc :D ).

     
  • 3.178, СССР (?), 00:05, 08/10/2020 [^] [^^] [^^^] [ответить]  
  • –1 +/
    слышишь дурак? иди на ...
     
  • 2.16, swine (ok), 16:55, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Толстишь. Ты точно фрактал?
     
     
  • 3.20, Аноним (2), 16:59, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Да не, он искренне так считает. Я, впрочем, тоже. Ещё вейланд допилят и наступит всеобщий коммунизм.
     
  • 2.19, анонимус (??), 16:58, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Хрень будет. Опять будет хрень. Тем более, что с новой лицензией большой вопрос о связке qt6+(kde6|plasma 6)
     
     
  • 3.21, Аноним (2), 17:02, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Пятокеды были прекрасны. Если ты выкидывал совместимость с 4кедами, ты отказывался от большинства программ, но их где-то за полгода допилили и уже можно нормально пользоваться было и без 4зависимостей. С лицензией всё нормально.
     
     
  • 4.34, анонимус (??), 17:51, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    А пятой плазме на 5х кьютях все прекрасно. Ужасно будет на 6-х с новой лицензионной политикой. Насколько я помню, не договорились
     
  • 4.139, funny.falcon (?), 07:45, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Прекрассны были KDE3. Можно было прям в Konqueror файлики просматривать (и редактировать?).  KEdit был клевый. И все летало.
     
     
  • 5.140, funny.falcon (?), 07:49, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Вернее, Kate
     
     
  • 6.165, Nemton (?), 14:22, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Kwrite наверное?
     
  • 3.174, Аноним (-), 21:57, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Хрен редьки не слаще.
     
  • 2.35, Annoynymous (ok), 17:54, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Года через три-четыре после релиза первой версии, как KDE4.
     
     
  • 3.97, Аноним (97), 23:41, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Ну как тебе пятые? Или ещё не поставил?
     
  • 2.72, Аноним84701 (ok), 20:34, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +2 +/
    >Связка Qt6 + KDE6 обещает быть бомбезной.

    В смысле, бомбить на опеннете (и не только) от нее будет у многих?

     
     
  • 3.155, Аноним (94), 11:21, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Не только на опеннете.
     
  • 2.76, Odalist (?), 21:04, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Офигенно, ждём релиза. Связка Qt6 + KDE6 обещает быть бомбезной.

    И много много сишных дыр?

     
  • 2.83, Аноним (47), 21:51, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Это с чего такие выводы?
     
  • 2.130, dt (??), 05:52, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > ждём релиза

    KDE6 != KDE6.0

    А все почему? Потому что не на Расте!

     
     
  • 3.138, Рева RarogCmex Денис (?), 07:19, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Пока раст хейтится, хаскель пилится
     
  • 3.163, Аноним (162), 13:55, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    А биндинг Qt для Раста хоть есть?
     
     
  • 4.181, Аноним (132), 09:34, 08/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    нафиг полумеры, пусть перепишут qt на раст
     

  • 1.12, m.makhno (ok), 16:40, 06/10/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    > В Qt 6 планируют реализовать поддержку многих современных возможностей C++, но без потери обратной совместимости с кодом на основе прошлых стандартов

    С 98 на 17?! Удачи...

     
     
  • 2.18, Аноним (18), 16:57, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Разверните мысль, любезный.
     
     
  • 3.23, m.makhno (ok), 17:04, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    > Разверните мысль, любезный.

    В контексте C++ это весьма нетривиальная задача. Проще переписать всё наследие под новый стандарт, чем городить костыли.

     
     
  • 4.44, Andrey (??), 18:05, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Все костыли уже есть в старом C++98 коде, компилятор C++17 их примет как есть.
     
  • 2.24, Аноним (22), 17:04, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +7 +/
    11 уже давно как, это так новости пишут.
     
  • 2.106, Аноним (-), 00:05, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    А я думаю, что по большому счёту они всё делали правильно - вероятно а до С ... большой текст свёрнут, показать
     

  • 1.13, Козлетто (?), 16:41, 06/10/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    Для простых смертных, как я слыхал, будет доступно только через год? Или от приступов копирасти они уже отошли?
     
     
  • 2.42, Аноним (89), 18:00, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Это 5.15 LTS скоро закроют.
     
  • 2.56, Аноним (56), 19:08, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Ага, дадут через год, когда все продукты комков будут уже на Qt7. А тебе только Qt6 дадут... афигеть...
     
     
  • 3.73, Денис (??), 20:37, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    > афигеть

    А некоторым нравится.

     
  • 2.62, Аноним (62), 19:49, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Что тебе здесь недоступно: https://code.qt.io ?

    Или приступ сверхинтеллекта мешает смотреть на код?

     
     
  • 3.87, Аноним (89), 22:19, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • –1 +/
    5.15 LTS будут прятать например. Но ты продолжай жевать.
     
     
  • 4.93, Аноним (62), 22:41, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Я продолжаю жевать Debian, в котором LTS-версии Qt не задерживаются: в oldstable Qt 5.7, в stable Qt 5.11, в testing Qt 5.14. И оно без LTS работает. Но если отсутствие трех буковок нервирует, то тут ничего не поделаешь - надо бежать на опеннет и стонать. После этого отпускает, видимо.
     
     
  • 5.102, Аноним (89), 23:55, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Так это минус дебиана, раз он про LTS не знает. Но ты давай наворачивай дальше, не отвлекайся.
     
     
  • 6.107, Денис (??), 00:26, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    В Ubuntu ситуация лучше. В 16.04 были 5.5 не LTS, но поддерживались разрабом тоже 3 года (на самом деле чуть поменьше), как 5.6 LTS. В 18.04 и 20.04 Qt LTS. В groovy не LTS 5.14 (чуть меньше), но сам groovy не LTS.
    В Mageia везде LTS 5.12 и 5.15
    В openSUSE везде LTS 5.9, 5.12, 5.15
    В ALT везде LTS 5.9, 5.12 и 5.15

    > давай наворачивай дальше

    Debian один из самых популярных и важных дистрибутивов GNU/Linux
    https://ru.wikipedia.org/wiki/Debian

     
     
  • 7.166, Аноним (166), 14:30, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Это существенный минус дебиана. Автор программы выпускает _специальную_ версию с багфиксами, а эти умники игнорируют и наворачивают debian/patches. Уже автор xscreensaver психовал по этому поводу.
     
     
  • 8.168, Денис (??), 15:19, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    А почему они так делают кто-нибудь спрашивал Прокачивают навыки в патчинге Не ... текст свёрнут, показать
     
  • 8.169, Денис (??), 15:43, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Напрашивается вывод, что они сами хотят контроллировать патчи, а не бездумно ест... текст свёрнут, показать
     
     
  • 9.170, _ (??), 20:00, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Ага Правда хотеть - мало Надо ещё и уметь - А то помниццо как слишком умные ... текст свёрнут, показать
     
  • 5.108, Денис (??), 00:29, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • –2 +/
    > в Debian LTS-версии Qt не задерживаются

    Это говорит о чем? Что они сами себе хозяева и хотят сами все контроллировать.

     
     
  • 6.171, _ (??), 20:04, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    >они сами себе хозяева

    Из оффиса RH раздаётся такой ржач, что из стен вылетают кирпичи :-)

     

  • 1.26, Агл (?), 17:12, 06/10/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    оффтоп, но: возможно ли компилировать и запускать на linux без gui программки с использованием qtnetwork  и qtmultimedia (audio)?
     
     
  • 2.38, Annoynymous (ok), 17:56, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Раньше можно было, шестую версию пока никто не видел.
     
  • 2.114, Аноним (-), 02:24, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +2 +/
    всегда можно было
     

  • 1.28, Аноним (89), 17:21, 06/10/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    А теперь весёлое. qtx11extras выпилили, QTextCodec тоже того. Так что придётся левые либы тащить, чтобы хоть что-то получилось сделать.
     
     
  • 2.33, Аноним (22), 17:37, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    # apt-cache search qtx11extras
    python-pyqt5.qtx11extras - Python 2 bindings for QtX11Extras module
    python-pyqt5.qtx11extras-dbg - Python 2 bindings for QtX11Extras module (debug extension)
    python3-pyqt5.qtx11extras - Python 3 bindings for QtX11Extras module
    python3-pyqt5.qtx11extras-dbg - Python 3 bindings for QtX11Extras module (debug extension)
    python-pyside2.qtx11extras - Python bindings for Qt5 X11Extras module (Python 2)
    python3-pyside2.qtx11extras - Python bindings for Qt5 X11Extras module (Python 3)
    qtx11extras5-doc - Qt 5 X11 extras documentation
    qtx11extras5-doc-html - Qt 5 X11 extras HTML documentation

    Так его и небыло толком. Так что фиалетово.

     
     
  • 3.37, Аноним (89), 17:56, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Давно с венды слез? Уже пора бы знать свой дистрибутив.

    $ apt-cache search libqt5x11extras5
    libqt5x11extras5 - Qt 5 X11 extras
    libqt5x11extras5-dev - Qt 5 X11 extras development files

     
     
  • 4.49, niger (??), 18:26, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Ой ой ой, знаток. Тебе там написали что целый слой абстракции чтобы этим не заниматься.
     
     
  • 5.66, Аноним (89), 20:04, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Какой слой абстракции? Пост выше был про отсутствие модуля. Но тебя несёт куда-то. Афазия что ли?
     
  • 4.68, Fracta1L (ok), 20:11, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • –3 +/
    Ты понтуешься тем, что вызубрил названия пакетов в дебиане? ахахаха клиника
     
     
  • 5.129, Аноним (129), 05:18, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +4 +/
    Нет, он показал что человек не знает о чём пишет.
     
  • 2.40, Annoynymous (ok), 17:57, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Это кроссплатформенность, не везде есть X11.

    И тут нужны не левые либы, а переписывание правых либ с учётом нового метода отрисовки.

     
     
  • 3.43, Аноним (89), 18:03, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Какая атрисовка, ты о чём вообще?
     
  • 2.54, niger (??), 18:49, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Не плакай.

    remove QTextCodec as a dependency in Qt (it’ll get moved to libQt5Compat), and introduce a new QStringConverter class, that can handle transcoding between Unicode encodings, Latin1 and the system locale.

     
     
  • 3.67, Аноним (89), 20:07, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Оно deprecated, значит не нужно.
     
  • 2.61, Аноним (62), 19:43, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Вот же: https://code.qt.io/cgit/qt/qt5.git/commit/.gitmodules?id=24d977a1881d745221c3b

    Где выпилили, в буйном воображении? Английским языком написано: "All
    others are set to "ignore" and the objective is to bring them back later
    when qtbase/declarative/quick3d development has settled"

    Доведут до ума базу и будут подтягивать временно исключенные из разработки модули.

     
     
  • 3.86, Аноним (89), 22:17, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    А теперь читай тут https://wiki.qt.io/New_Features_in_Qt_6.0

    Code from these Qt <platform> Extras modules will find new homes in more relevant modules over time, and any remaining APIs considered for inclusion in later 6.x releases: Qt Android Extras, Qt Mac Extras, Qt X11 Extras


    А теперь главный вопрос, когда и под какой лицензией?

     

  • 1.45, Аноним (45), 18:06, 06/10/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Только пересел на KDE с Xfce, а там уже намечается релиз Qt 6, и, следовательно, Plasma 6. Видать придётся опять на Xfce пересаживаться, ОЧЕНЬ не хочу кривого релиза, как было с релизом SC или Plasma...
     
     
  • 2.50, Аноним (50), 18:30, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Так есть возможность посидеть на последней LTS 5, тем более кеды не сразу же будут переходить.
     
     
  • 3.52, niger (??), 18:45, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Он очевидно живёт в ролинге. Только новое, только с багами. Круглосуточные обновления.
     
     
  • 4.59, Аноним (2), 19:29, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • –3 +/
    Так-то в новом багов в среднем меньше, а вот лтс постоянно рассыпается из-за багов. Не исправленных, не исправляемых, не исправимых, а то и вовсе бэкпортированных. Круглосуточные баги.
     
     
  • 5.74, Денис (??), 20:40, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • –2 +/
    > Не исправленных, не исправляемых, не исправимых

    Если пользоваться ЖирноDE.

     
  • 5.99, Аноним (97), 23:50, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    В xfce глючить мало чему, но старый исторически сложившийся доширакокод к хорошему не приводит.
    Может, маргинальный дистр? Скорее дело в сборке, у меня суся 15.1 артефактила, до сих пор баг второй год висит поди-ка.
     
  • 4.64, Аноним (64), 19:53, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Мне что, делать нечего? Я хоть и студент, но и мне нужна стабильная работа, роллинги и тестинги вообще недолюбливаю.
     
     
  • 5.101, Аноним (97), 23:51, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Оперативную память ластиком чистил?
     
  • 3.65, Аноним (45), 19:57, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Я скажу даже больше: я сейчас сижу на openSUSE 15.2, посмотрю, почитаю, как там будут вести себя новые кеды. Но, видать, придётся посидеть на 15.2 подольше, даже после окончания поддержки.
     
  • 3.176, СССР (?), 23:53, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    да это всякие покемоны собрались и пукают пукают
     
  • 2.115, Аноним (-), 02:25, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    скатертью дорога
     

  • 1.57, Nicho (ok), 19:16, 06/10/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Значит весной может выйти Кде 6
     
     
  • 2.112, Аноним (112), 01:08, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    А следом KDE 5 может отправиться на свалку истории — туда, где уже лежат кеды всех предыдущих версий.
     
     
  • 3.117, Денис (??), 02:33, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    KDE3 живы и ОФИЦИАЛЬНО поддерживаются openSUSE.
     
     
  • 4.118, Денис (??), 02:38, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Я их ставил в Tumbleweed (!), в принципе няшно. Но
    1. Выключение через разлогинивание (в DM), монтирование разделов вручную, ну или я не осилил
    2. Ад зависимостей, как всегда (конфликты, каких-то пакетов нет, но YaST позволяет забить на это), трясет только по началу
    3. В Dolphin зазор у скроллбара, как всегда (надо патчить, но я не знаю как)

    Из достоинств: Меню пуск не такое запутанное, как в KDE4/5 (где по сути, юзабелен только поиск).

     
     
  • 5.128, Аноним (2), 04:39, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    >Меню пуск не такое запутанное, как в KDE4/5

    Извините, что там запутанного? Application menu примитивней пуска из вын95, мне норм.

     
     
  • 6.158, Денис (??), 12:58, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Долгий доступ к ярлыкам и переключению категорий, в сравнении с Whisker Menu Xfce.
     
  • 5.192, Nxx (ok), 10:47, 29/04/2021 [^] [^^] [^^^] [ответить]  
  • +/
    > Выключение через разлогинивание (в DM),

    Что мешает выбрать десктоп-менеджер kdm3?
    Если используешь kdm4 с kde3, чему удивляешься?

    > монтирование разделов вручную

    Не может такого быть.

     
  • 4.119, Денис (??), 02:41, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • –1 +/
    А KDE4 ОФИЦИАЛЬНО поддерживается в Rosa (R11) http://wiki.rosalab.ru/ru/index.php/ROSA_Desktop_Fresh_R11
     
     
  • 5.120, Денис (??), 02:45, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    KDE4 http://wiki.rosalab.ru/ru/images/e/e1/Rs1.png
    KDE5 http://wiki.rosalab.ru/ru/images/3/3e/RosaR11plasma.png
    Обожаю как выглядят кнопки закрытия (такие были в первых билдах Windows 8). Но там тоже зазоры, к сожалению. Можно попробовать поковырять тему.
     
     
  • 6.121, Денис (??), 02:57, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Если не ошибаюсь, там и меню пуск в стиле Metro Windows 8 (крутое). Надо поставить что-ли. Когда еще выпадет возможность поюзать KDE4. Ведь и KDE4 и Metro официально убиты.
    В этом плане Rosa круче ALT'а, который ничем таким не выделяется (кроме ненужных на десктопе Эльбрусов).
     
     
  • 7.122, Денис (??), 03:27, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    > ничем таким не выделяется
    > Эльбрус

    OpenMandriva примечательна тем, что там всё собирают Clang'ом. Я знаю, что у нее 0 русскоязычных пользователя. Даже у Mageia их 1.5.
    Где-то слышал слух, что это RedHat'овский полигон для отладки шланга.

    Вообще, я смотрю, русские линуксоиды не интересуются экзотикой. Все какую-то попсу юзают: Ubuntu, Debian, Manjaro, openSUSE, Fedora, Arch, Gentoo, Windows, Mac.

     
     
  • 8.123, Денис (??), 03:44, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Аниме, рок, американские фильмы и сериалы ... текст свёрнут, показать
     
  • 5.142, n00by (ok), 09:07, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    > А KDE4 ОФИЦИАЛЬНО поддерживается в Rosa (R11) http://wiki.rosalab.ru/ru/index.php/ROSA_Desktop_Fresh_R11

    Во-первых, ОДНИМ человеком.
    Во-вторых, ОФИЦИАЛЬНЫЙ срок жизни платформы, согласно http://wiki.rosalab.com/ru/index.php/Политика_выпуска_ROSA_Desktop
    составляет 2 (тестирование на пользователях Fresh) + 2 (продажа Enterprise Desktop), то есть 4 года, и по плану закончился. Другое дело, что выпуск новой платформы малость буксует, потому растянули (пока) до конца 21-го.

     

  • 1.58, None (??), 19:26, 06/10/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    > Переход при разработке на стандарт C++17 (ранее использовался C++98

    С++11 он уже давно требует(c Qt 5.7). Иначе ошибка вида "Qt requires C++11 support". Насколько помнится, данная опция уже давным давно по дефолту сама прописывается.

     
  • 1.60, user90 (?), 19:40, 06/10/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • –3 +/
    Так эта, а хде картинки?? Или там что, не как в Gtk, без "моднейших инноваций" в дизайне со сменой версии? Непривычно такое :)
     
     
  • 2.70, Аноним (56), 20:27, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Qt6 написали, но не смогли ещё запустить, что б наделать картинок.
     
     
  • 3.90, Аноним (89), 22:22, 06/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    А какие там отличия? Визуально не отличить же.
     

  • 1.77, Аноним (77), 21:06, 06/10/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    >Доступна альфа-версия Qt 6.0

    Самое время дропать пятокеды и пилить шестые! Шестые сами себя не запилят!

     
  • 1.85, MVE88 (ok), 22:16, 06/10/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • –4 +/
    Что, Viber наконец перестанет тормозить?
     
     
  • 2.116, Аноним (-), 02:26, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    хоть один мессенджер быстрее qt-шного телеграмма сможешь привести в пример, трепло?
     
     
  • 3.186, marios (ok), 10:30, 09/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Telegram Desktop не очень корректно приводить в пример, поскольку там не применяется QML
     

  • 1.103, Аноним (89), 23:58, 06/10/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    >Существенная модернизация QML

    Там уже не надо будет обёртки вокруг классов наворачивать?

     
     
  • 2.187, marios (ok), 10:31, 09/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Надо!
     

  • 1.105, ZULUL (?), 00:03, 07/10/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • +2 +/
    > Please start testing Alpha now; it is essential to get your reports as soon as possible. So remember to report all your findings in Jira immediately. We should move in the beta phase quite soon so all API related issues should be reported now.  Know issues for Alpha can be found from here.

    Ну да конечно. Выглядит это как "эй вы опенсорц макаки делайте свое дело находите баги чтобы наши заказчики были довольны в будущем".

     
  • 1.156, плюплюсер (?), 12:46, 07/10/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Тут вот на лицензию жалуются. А какая у Qt есть альтернатива, которая тоже на C++ ?

    Вопрос без подвоха.

     
     
  • 2.161, Аноним (161), 13:16, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Жалуются не на лицензию, а на то, что официальных LTS-релизов под LGPL/GPL не будет.

    Теперь по факту в дистрибутивах будут свои LTS-форки Qt 5.15, которые будут поддерживать майнтейнеры дистрибутивов, а не Qt Company.

    Какая разница для админов локалхостов, которые тут ноют?

     
     
  • 3.164, Аноним (166), 14:21, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    >будут поддерживать майнтейнеры дистрибутивов

    И будет в каждом дистрибутиве своя версия со своими багами. Но ты давай и дальше любую критику нытьём закрывай.

     
     
  • 4.190, JL2001 (ok), 22:13, 13/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    >>будут поддерживать майнтейнеры дистрибутивов
    > И будет в каждом дистрибутиве своя версия со своими багами.

    так убедите убунту с редхатом взять одну общую версию за лтс, чего вы тут ноете то? ныть надо в их суппорте

     
  • 3.172, плюплюсер (?), 21:46, 07/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    > Жалуются не на лицензию, а на то, что официальных LTS-релизов под LGPL/GPL не будет.

    Так это и есть "жалуются на лицензию". Или речь лишь о бинарных сборках LTS-релизов, которые можно собрать самому?

     
  • 3.182, Аноним (132), 09:45, 08/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    > Жалуются не на лицензию, а на то, что официальных LTS-релизов под LGPL/GPL не будет.

    будут, не будет билдов под винду без авторизации в maintainance tool, уже нет. а под линуксом вообще пофиг

     

  • 1.177, СССР (?), 23:54, 07/10/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    хочется пощупать Qt Http Server на альфе
     
  • 1.183, Аноним (183), 19:22, 08/10/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    не забудьте xcb dev пакеты, линуксоиды. иначе как в 5.15.1 примеры не будут запускаться
     
     
  • 2.184, Аноним (183), 19:38, 08/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    там реально в конфиге только xcb и egl пока. у меня xfce 20.04 и studio 20.10 kde plasma desctop. сначала поставлю на 20.04 потом буду на плазму...
     
     
  • 3.185, qt6 (?), 23:55, 08/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    ну все собралось примеры работают в обоих системах
     
     
  • 4.188, Android qt (?), 16:47, 09/10/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Ну теперь надо под Андроид собрать и все круто. 6.0 альфа получается лучше сборок 15.0 и 15.1 из-за отсутствия в тех сборки с xcb. Вообще подстава от разработчиков. Хорошо, что хоть так разрешилось...
     

  • 1.191, Аноним (183), 12:38, 14/10/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    в альфе отсутствует multimedia module это уже точно. что там еще не хватает думаю много чего...
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:
    При перепечатке указание ссылки на opennet.ru обязательно



    Спонсоры:
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2021 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру