The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Red Hat не будет поставлять GTK 2 в RHEL 10

26.08.2022 19:31

Компания Red Hat предупредила о прекращении поддержки библиотеки GTK 2, начиная со следующей ветки Red Hat Enterprise Linux. Пакет gtk2 не будет включён в состав релиза RHEL 10, в котором останется только поддержка GTK 3 и GTK 4. В качестве причины удаления GTK 2 называется устаревание тулкита и отсутствие поддержки современных технологий, таких как Wayland, HiDPI и HDR.

Предполагается, что программы, которые остаются привязаны к GTK 2, например, GIMP и Ardour, успеют перейти на новые ветки GTK до 2025 года, в котором ожидается релиз RHEL 10. В Ubuntu 22.04 504 пакета используют libgtk2 в качестве зависимости.

  1. Главная ссылка к новости (https://lists.fedoraproject.or...)
  2. OpenNews: Используемый в Fedora и RHEL инсталлятор Anaconda переводят на web-интерфейс
  3. OpenNews: Red Hat объясняет трансформацию CentOS желанием сделать более открытой разработку RHEL
  4. OpenNews: Представлен дистрибутив Red Hat Enterprise Linux 9
  5. OpenNews: Рассматривается возможность прекращения в GTK5 поддержки X11
Лицензия: CC-BY
Тип: К сведению
Короткая ссылка: https://opennet.ru/57681-rhel
Ключевые слова: rhel, gtk
При перепечатке указание ссылки на opennet.ru обязательно


Обсуждение (111) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, torvn77 (ok), 19:42, 26/08/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +13 +/
    >Предполагается, что программы, которые остаются привязаны к GTK 2, например, GIMP, успеют перейти на новые ветки GTK  

    Или не успеют, или не станут и мы увидим RHEL без кучи полезного софта.

     
     
  • 2.2, Аноним (2), 19:44, 26/08/2022 [^] [^^] [^^^] [ответить]  
  • +11 +/
    можно подумать rhel ставят ради гимпа
     
     
  • 3.6, Аноним (6), 20:11, 26/08/2022 [^] [^^] [^^^] [ответить]  
  • +14 +/
    RHEL ставят ради наклейки, других причин не существует.
     
     
  • 4.11, Аноним (11), 20:32, 26/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Что за наклейка?
     
     
  • 5.22, Аноним (6), 20:56, 26/08/2022 [^] [^^] [^^^] [ответить]  
  • +5 +/
    > Что за наклейка?

    Лицензия и суппорт, разделение ответственности.

     
     
  • 6.26, ip1982 (ok), 21:04, 26/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    > разделение ответственности

    Почему все так пытаются спихнуть ответвенность за своё дело на чужих людей?

     
     
  • 7.37, Аноним (37), 22:05, 26/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Для максимизации прибыли. Учи матчасть «Капитал. Критика политической экономии» К. Маркс
     
  • 7.67, офисный раб (?), 09:05, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Потому что это не мое дело. Это дело моего рабовладельца.

    Мне оно не приносит ни удовольствия, ни прибыли - только головную боль за зарплату.

    Рабовладельцу же тоже удобнее не зависеть от конкретного раба - сегодня он есть, завтра его пришлось казнить за недостаточно резвый поклон - а чинить вот это теперь кто будет?
    Плюс с расходов на поддержку налоги - вычитаются. А с моей зарплаты - наоборот.

    Было бы оно мое - личный проект для хобби или для прямого зарабатывания на нем - разумеется, я бы и близко никаких индусов туда не подпустил (что не исключает использования там редхата, просто их поддержка мне не нужна).

     
     
  • 8.79, gogo (?), 13:34, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • –1 +/
    поэтому админы никогда не были рабами - они всегда были особой кастой а крупн... текст свёрнут, показать
     
     
  • 9.84, Аноним (84), 17:45, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Давно так не смеялся 20 лет админю, но чушь про 171 особую касту 187 слышу ... текст свёрнут, показать
     
  • 9.116, Anonimous (?), 07:22, 29/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Незаменимых нет, вопрос во времени и цене замены ... текст свёрнут, показать
     
  • 3.54, Аноним (54), 00:28, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Чтобы гтк2 пропал в РХЕЛ10, надо чтобы он через пару версий пропал в федоре... ну где то через год?
     
  • 2.5, Голум (?), 19:54, 26/08/2022 [^] [^^] [^^^] [ответить]  
  • +5 +/
    А есть что-то ещё полезное кроме гимпа?
     
     
  • 3.9, prokoudine (ok), 20:22, 26/08/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > А есть что-то ещё полезное кроме гимпа?

    Ardour всё ещё использует упаковщик виджетов GTK2 и несколько виджетов оттуда же (treeview, файловые диалоги, поле ввода, ещё что-то). На более новые версии gtk переезжать планов нет, переписывать оставшиеся виджеты — тоже.

     
     
  • 4.10, Голум (?), 20:29, 26/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Тоже про него вспомнил, но это уже из разряда проф софта, не для повседневного использования на обычном десктопе.
     
     
  • 5.39, Роман (??), 22:12, 26/08/2022 [^] [^^] [^^^] [ответить]  
  • –8 +/
    так ведь и линукс не про это, так подкладка под докером. Гики не согласятся конечно, но как обычно их можно игнорировать, к счастью.
     
  • 5.58, Аноним (58), 05:23, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Главное чтобы из репозиториев не выпилили.
     
  • 4.91, Аноним (84), 21:40, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Ну не будут под Линукс сборки больше делать, останется только для Макоси и Винды. Делов-то.
     
     
  • 5.92, prokoudine (ok), 22:03, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    > Ну не будут под Линукс сборки больше делать, останется только для Макоси
    > и Винды. Делов-то.

    С фига ли это? Пол и Робин могут делать сборки для линукса сколько угодно. Редхэт им не указ.

     
  • 4.108, Admino (ok), 20:39, 28/08/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Флатпак есть? На RHEL 10 это будет явно основной способ доставки софта.
     
     
  • 5.112, prokoudine (ok), 21:06, 28/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    > Флатпак есть? На RHEL 10 это будет явно основной способ доставки софта.

    Есть, но кроме того есть вопрос упаковки плагинов,не входящих в состав проекта.

     
     
  • 6.113, Admino (ok), 21:08, 28/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    > есть вопрос упаковки плагинов,не входящих в состав проекта.

    Наверное, имеет смысл задавать этот вопрос г-ну Ларсону сейчас, чтобы к тому времени он бы уже был.

    Думаю, вы там и без меня обойдётесь, впрочем :-)

     
  • 3.62, лютый ж.... (?), 07:34, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • –5 +/
    > есть что-то ещё полезное кроме гимпа

    а что, гимп полезный? на мой взгляд самый бесящий софт в поппенсорсе, и годами ничего не меняется
    fotoxx и то лучше )

     
  • 2.32, user90 (?), 21:32, 26/08/2022 [^] [^^] [^^^] [ответить]  
  • +3 +/
    > и мы увидим RHEL без кучи полезного софта.

    Правда переживаешь чего там в RHEL будет?

     
     
  • 3.78, torvn77 (ok), 13:28, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Чем меньше а RHEL полезного софта, тем меньше у неё возможностей для пропихивания systemd и wayland
     
  • 2.46, Аноним (46), 23:00, 26/08/2022 [^] [^^] [^^^] [ответить]  
  • –3 +/
    Вся суть так называемого свободного по.
    В винде будет gimp, не нужный потому что есть Фотошоп. А в линуксе не будет ни gimp, ни Фотошоп.
    Винда свободнее чем Линукс
     
     
  • 3.57, iPony129412 (?), 04:19, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > В винде будет GIMP

    Причём даже в Windows App Store 😀

     
  • 3.102, Аноним (102), 08:54, 28/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    >> В винде будет gimp, не нужный потому что есть Фотошоп

    А зачем нужен фотошоп (и зачем ты его пишешь с Большой Буквы?)
    Реально интересно...
    Ведь есть гимп!

    Регулярно запускаю гимп, не из аппсторы, просто из msys2
    Фотошопа в работе никогда не видел, ни на своей машине, ни у кого из коллег, знакомых...
    Это что за зверь вообще?
    Нет, не троллю, правда интересно в чём прикол, что в нём такого...

     
     
  • 4.105, n00by (ok), 13:27, 28/08/2022 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Написанное со строчной «фотошоп» - это фото магазин, а Фотошоп - имя собственное, название программы. Пишет он так, что бы триггернуть любителей писать издевательства над языком типа «Рэ-О-Сэ-А», кто в вузах не учился.
     

  • 1.3, Аноним (3), 19:46, 26/08/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Конец эпохи.
     
     
  • 2.13, Аноним (13), 20:39, 26/08/2022 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Конец эпохи RedHat?
     
     
  • 3.28, RedHat Support (?), 21:27, 26/08/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Конечно, редхат без гтк2 же обанкротится.
     
  • 3.40, Аноним (40), 22:13, 26/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Закат IBM
     
     
  • 4.80, Аноним (80), 14:34, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    вручную
     
  • 4.118, AnonymOZ (?), 19:53, 29/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Да они уже начали закатываться после ухода из РФ. Всё остальное - последствия))))))
     
  • 4.120, Аноним (120), 14:49, 01/09/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Закат губы
     
  • 3.66, n00by (ok), 08:59, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Конец эпохи клонов RedHat с  ̶н̶е̶с̶к̶у̶ч̶н̶ы̶м̶и̶ ̶о̶б̶о̶я̶м̶и̶  «оригинальным сетом иконок, отвечающим современным трендам». (ц)
     
     
  • 4.69, офисный раб (?), 09:08, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    С чего вдруг? Просто привыкнете обходиться без gtk2, и будете еще и радоваться.

    Вон вам даже пару лет дали на привыкание.
    rhbm лучше знать, какими библиотеками вам пользоваться.

     

  • 1.4, Аноним (4), 19:48, 26/08/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    > В качестве причины удаления GTK 2 называется

    ...желание быть котом, которому делать нечего.

     
  • 1.7, Хруст (??), 20:13, 26/08/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Омг! Действительно, единственный выживший на gtk2.

    Какие ставки, успеют на gtk5?
    Или еще лет 20-25 торопится не будут, а релизнут на 3-м?

     
  • 1.8, prokoudine (ok), 20:17, 26/08/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +3 +/
    > Предполагается, что программы, которые остаются привязаны к GTK 2, например, GIMP, успеют перейти на новые ветки GTK до 2025 года

    $ apt-cache rdepends libgtk2.0-0 | wc
        508     509    6658

    Вызов принят? :)

     
     
  • 2.43, Skullnet (ok), 22:37, 26/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    662     663    9135
     
  • 2.51, Аноним (4), 00:04, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
       1359    1360   20261
     
  • 2.74, Аноним (74), 11:34, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
        527     528    7244
     
     
  • 3.75, Аноним (74), 11:35, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Debian 11 btw
     
     
  • 4.77, Аноним (77), 12:04, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    433     434    5661

    debian testing

     
     
  • 5.104, Аноним (104), 10:02, 28/08/2022 [^] [^^] [^^^] [ответить]  
  • –1 +/
    zsh: command not found: apt-cache
          0       0       0
     

  • 1.12, Аноним (11), 20:34, 26/08/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • –4 +/
    що Red Hat що GTK 2

    Теорема Эскобара

    Не пользовался ни тем не другим

     
     
  • 2.106, Аноним (106), 14:06, 28/08/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    ...но осуждаю
     

  • 1.16, Аноним (13), 20:43, 26/08/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    > 504 пакета используют libgtk2 в качестве зависимости

    А не проще сообществу приспособить API Gtk2 к Wayland, чем стелиться под корпорастов? Пусть и дальше клепают свою блоатварь.

     
     
  • 2.29, Хруст (??), 21:28, 26/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Проще и gtk2 и сопутствующее собрать в libblender.so
     
     
  • 3.76, Аноним (58), 11:41, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Которому нужен opengl 4.x...

    И ради чего? Менюшки рисовать?

     
  • 2.36, Аноним (36), 21:56, 26/08/2022 [^] [^^] [^^^] [ответить]  
  • +3 +/
    Проще забить на вялого.
     
  • 2.109, Admino (ok), 20:42, 28/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    К Wayland может быть, но HiDPI и HDR туда всё равно не засунешь.

    Проще таскать нужные библиотеки во флатпаках.

     

  • 1.17, Аноним (17), 20:45, 26/08/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +4 +/
    А кто-нибудь верит, что в 2025 году будет существовать redhat ??
     
     
  • 2.31, RedHat Support (?), 21:30, 26/08/2022 [^] [^^] [^^^] [ответить]  
  • +3 +/
    Мы уверены
     
     
  • 3.42, Аноним (17), 22:31, 26/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Закупленны ли трансиверы для окаания техподдержки по радио ??
     
     
  • 4.81, Аноним (36), 15:12, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Лучше! Наняты трансвеститы.
     
  • 2.110, Admino (ok), 20:43, 28/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    IBM/RH существует на госзаказе. Пока живы США и пока они финансируют госзаказ, IBM/RH будут существовать.

    Будет ли существовать США к 2025, это, конечно, вопрос.

     
     
  • 3.119, AnonymOZ (?), 19:56, 29/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    США будут существовать. А вот про количество штатов в его составе уже сложно сказать...
     

  • 1.18, Kuromi (ok), 20:45, 26/08/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    "В Ubuntu 22.04 504 пакета используют libgtk2 в качестве зависимости."

    Посмотрел обратные зависимости от libgtk2.0-0 - приуныл.

     
  • 1.19, Мозилла (?), 20:50, 26/08/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +4 +/
    > Предполагается, что программы, которые остаются привязаны к GTK 2, например, GIMP, успеют перейти на новые ветки GTK до 2025 года

    а разработчики GIMP'а в курсе, что они кому-то должны успеть?

     
  • 1.20, Аноним (40), 20:51, 26/08/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +4 +/
    Как-то прямо не энтерпрайзно
     
     
  • 2.21, васёк (?), 20:53, 26/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    в натуре блин,
    win16 проги до сих пор можно запустить, а в лине даже gtk2 выкидывают :-(
     
     
  • 3.23, НяшМяш (ok), 20:56, 26/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    > win16 проги до сих пор можно запустить

    В 64-битной винде нельзя.

     
     
  • 4.38, Аноним (37), 22:05, 26/08/2022 [^] [^^] [^^^] [ответить]  
  • +4 +/
    Мне можно.  
     
  • 4.86, U202204161753 (?), 18:07, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Для запуска 16bit ПО на x64 есть NTVDMX64 "от умельцев".

    И от их конкурентов есть другое ПО для Win16 на x64

     
     
  • 5.111, Admino (ok), 20:44, 28/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Ну так и gtk2 для RHEL10 могут собрать "умельцы".
     
  • 5.115, НяшМяш (ok), 23:00, 28/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    > Для запуска 16bit ПО на x64 есть NTVDMX64 "от умельцев"

    Где же эти умельцы были лет 10 назад, когда эта штука была бы незаменима.

     
  • 3.25, Аноним (25), 21:02, 26/08/2022 [^] [^^] [^^^] [ответить]  
  • +2 +/
    А в винде есть win16 проги, или их выкинули? Ну дак и gtk2 не перестанет работать после выкидывания.
     
     
  • 4.87, U202204161753 (?), 18:08, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Выкинули; в x64 точно.

    Но см. чуть выше про NTVDMX64 и умельцев

     
  • 3.33, trolleybus (?), 21:40, 26/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    > win16 проги до сих пор можно запустить, а в лине даже gtk2 выкидывают

    давно уже нельзя (а вот в лине, кстати, можно в вайне запускать win16 на 64 битах в том числе)

     
  • 3.72, llolik (ok), 10:59, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • +3 +/
    GTK1 проги тоже можно запустить в современном лине (проверено). Но никто не нанимался их пакетить в репы. Впрочем, если кто-то настаивает, то может заняться этим сам.
     
  • 3.88, Аноним (88), 19:26, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    В линуксе до сих пор работает GTK1, fvwm1.24, twm и т.д. Что сказать то хотел?
     
  • 2.27, user90 (?), 21:26, 26/08/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Зато красношапочно
     

  • 1.44, Аноним (44), 22:49, 26/08/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    gtk2 релизнулся в 2002, последняя версия 2.х - в 2011
    Удивительно что этот хлам еще кто-то поддерживает...
     
     
  • 2.48, Аноним (46), 23:11, 26/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    А почему бы нет? Что мешает запускать его в xwayland ещё 10 лет?
     
     
  • 3.50, Аноним (44), 23:20, 26/08/2022 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Нет потому что раз ты оказываешь платную поддержку (как шапка), то тебе придется исправлять баги.
    А в это г никто ковыряться не хочет.
     
     
  • 4.55, Аноним (46), 01:28, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Логично, спасибо
     
  • 4.68, Аноним (68), 09:08, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Парадокс - платно не хотят. А бесплатно тут половина опеннета будет пилить, судя по комментам
     
     
  • 5.85, Аноним (84), 17:51, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Половина опеннета будет пилить только комменты как они готовы пилить для другой половины, уже вот-вот, уже почти. А завтра поменяются.
     
  • 5.98, Аноним (98), 01:45, 28/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    > половина опеннета сидит на COre2 Duo судя по комментам

    Фиксанул, не благодари

     
  • 2.49, Аноним (-), 23:16, 26/08/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > gtk2 релизнулся в 2002, последняя версия 2.х - в 2011
    > Удивительно что этот хлам еще кто-то поддерживает...

    Тебя поди тоже релизнули в 2002, сразу "последней версии".


     
  • 2.59, Аноним (58), 05:27, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Но только к нему куча софта прибито гвоздями, например ardour
     
  • 2.61, Alladin (?), 06:02, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Встречное,

    GTK1 релизнулся в 98 году.
    Удивительно, что этот хлам GTK кто-то поддерживает.. 1.  2. 3. 4. Хлам!

     
     
  • 3.64, Анонн (?), 08:42, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Безотносительно сабжа, а разве GTK1 где-то еще используется?
     
     
  • 4.89, Аноним (88), 19:27, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    xmms наверно
     
  • 2.101, Skullnet (ok), 03:07, 28/08/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Потому что GTK2 и GTK3 обратно не совместимы. Софт приходится переписывать чуть ли не с нуля. Старые приложения так и остались на GTK2. Qt5 до сих пор не умеет в GTK3 темы.
     

  • 1.45, Аноним (46), 22:54, 26/08/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    В составе rhel есть gimp?
     
     
  • 2.47, Аноним (46), 23:07, 26/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Даже если был, но не станет, тем кому надо могут поставить из epel или flatpak. Вряд-ли на веб-серверах, серверах баз данных, хостах виртуальных машин и подобных вещах кому-то потребуется gimp
     
     
  • 3.52, Аноним (4), 00:12, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Чтобы скриншот ошибки сделать и подрисовать стрелочкой, где красношапочники накосячили.
     
     
  • 4.73, амоним (?), 11:09, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    нене, это под виндой можно, можно под маком. не хватало еще раз стрелочек линь ставить.
     
     
  • 5.103, Аноним (102), 09:27, 28/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Скриншот с линукса отправлять на венду (или мак, он вообще есть или просто для связки слов привёл?) ради пары стрелочек?!
    Серьёзно?!
    В натуре?!!
    Охренеть, это уже что-то жостко альтернативное...
     
     
  • 6.117, другой аноним (?), 08:31, 29/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    > Скриншот с линукса отправлять на венду

    а зачем его куда-то "отправлять"? Прямо в винде и сфоткай свою wsl'ечку. Стрелку в mspaint нарисуешь (MS вот - прислушивается к своим пользователям, а не только к своей телеметрии, и эту нужную и полезную вещь оставила, хотя и не знает как ее теперь скомпилять)

    А никакой другой linoops сегодня уже и не нужен вообще. Безнадежно устаревшая корявая компиляция технологий 70х с дерьмоподелками девляпсов. И чтоб нарисовать стрелочку на скриншоте нужно будить гимпа.

    (тру никсер конечно же просто быстренько напишет "однострочник" для mogrify, километров на пять. Но стрелочка будет стоять не совсем туда, поскольку визифиг "нинужна" и "тармазит")

     
  • 3.99, Аноним (99), 01:47, 28/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    > кому-то потребуется gimp

    Он никому и нигде не требуется. Это мусор непригодный ни для чего

     

  • 1.56, Аноним (56), 02:57, 27/08/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    > отсутствие поддержки современных технологий, таких как Wayland, HiDPI и HDR

    Wayland не нужен ввиду своей ущербности, а поддержки HDR под линукс не было и нет. Хотя мне трудно даже представить зачем она нужна для десктопных приложений (игры и видеоплееры как бы не используют GTK для вывода видео). Что там в HDR выводить-то? Выжигающие глаза высокой яркостью таблицы? Потрясающего динамического диапазона диалоги открытия файлов?

    Что за бред?

     
     
  • 2.70, prokoudine (ok), 09:53, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • –3 +/
    > Хотя мне трудно даже представить зачем она нужна для десктопных приложений (игры и видеоплееры как бы не используют GTK для вывода видео). Что там в HDR выводить-то?

    Все, что выводят инструменты производства контента в HDR. И да, они под Линукс есть.

     
     
  • 3.96, Аноним (98), 01:43, 28/08/2022 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > они под Линукс есть

    во влажных манямирках линпуксоидов

     
     
  • 4.100, prokoudine (ok), 01:48, 28/08/2022 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >> они под Линукс есть
    > во влажных манямирках линпуксоидов

    Почти вся индустрия VFX/3D сидит в линуксе на нативном софте, но тут на опеннет приходит анонимный толстячок и начинает срыв покровов. Это даже не смешно.

     

  • 1.60, Alladin (?), 05:58, 27/08/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +3 +/
    А если встречное предложение...

    Ваш Wayland не поддерживает современные технологии, то что тогда)

     
  • 1.65, Аноним (65), 08:47, 27/08/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    А вы знали, что в GTK3 есть встроенный зонд?
    https://web.archive.org/web/20211025013400/https://archlinux.org.ru/forum/topi
     
     
  • 2.83, Griggorii (?), 16:54, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Эта приблуда может отвечать за поиск в каком нибудь проводнике или еще где нить , так что тоже надо уточнять для веба или для поиска по директориям , а то того и гляди не наидешь фаил
     

  • 1.71, crypt (ok), 10:08, 27/08/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +2 +/
    можно подумать, RH поддерживал gtk2 последние годы. их разработчики прислали патчи в LO с удалением интерфейса на gtk2.

    а жаль. gtk2 хоть и не поддерживает современные технологии, зато был местами заметно более удобен, чем гейский gtk после этого.

     
     
  • 2.93, Аноним (4), 23:10, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > gtk2 хоть и не поддерживает современные технологии

    gtk2 для приложения - это просто API. Кто мешает внутри gtk2 делать современные технологии?! В gtk3 же как-то сделали, и в gtk4...

     

  • 1.90, Golangdev (?), 19:37, 27/08/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Давно пора слезать с легаси. Ред Хат - молодцы, коммеррчески успешная компания, двигающая опенсорс вперёд.
     
     
  • 2.94, Аноним (4), 23:11, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • +/
    > коммеррчески успешная компания

    Ха-ха-ха! Посчитаешь, сколько им донатов заносят?

     
     
  • 3.95, Golangdev (?), 23:51, 27/08/2022 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Я - нет, не посчитаю. Уже посчитано специалистами, на, держи, изучай.
    https://www.annualreports.com/Company/red-hat-inc
    https://www.annualreports.com/Company/international-business-machines-corp
     

  • 1.97, Аноним (98), 01:44, 28/08/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +2 +/
    Одобряю и одновременно удивлён почему так долго этот мусор тащили. Старьё нужно выкидывать.
     
  • 1.114, хрю (?), 22:59, 28/08/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    >Предполагается, что программы, которые остаются привязаны к GTK 2, например, GIMP и Ardour  успеют перейти на новые ветки GTK

    Ну если они проспонсируют сие "успевание", то я даже за. Только терзают меня смутные сомнения ...

     
  • 1.121, mikhailnov (ok), 04:48, 02/09/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Gtk+2, кстати, вполне норм на HiDPI в KDE. Кнопки мелковаты, но для мыши, а не пальца, сойдёт.
     
  • 1.122, mikhailnov (ok), 04:49, 02/09/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Беда, на чем же теперь запускать Ardour?
     
     
  • 2.123, n00by (ok), 11:34, 02/09/2022 [^] [^^] [^^^] [ответить]  
  • +/
    > Беда, на чем же теперь запускать Ardour?

    В смысле, из новой Федоры теперь просто так не покопируешь, а «программирование» на cmake не помогает? Тогда примечательно, что ты, как вы любите выражаться, «разнылся» именно про музыкальный редактор -- у меня с ними давний феншуй. ;)

     
     
  • 3.124, mikhailnov (ok), 11:40, 02/09/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Запрограммируем на автокрапе

     
     
  • 4.125, n00by (ok), 13:31, 02/09/2022 [^] [^^] [^^^] [ответить]  
  • +/
    > автокрапе

    Надеюсь, теперь ты объяснишь всем своим подельникам, что именно ты дал мне право писать «Rosa Tresh», а Потапова называть «Володий». С той разницей, что я вам не хамлю, а ты гадишь в руку кормящую.

     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    PostgresPro
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2022 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру