The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Установка Firefox 3 в Debian Etch и дистрибутивах со старой версией GTK+
Официальная сборка Firefox 3 требует GTK+2.10, в то время как в Debian Etch только 2.8.
Нужную версию gtk можно установить из бэкпортов:

Разархивируем firefox 3 в директорию /opt/firefox3

Загружаем http://apt.linex.org/linex/gtk-2.10/libgtk2.0-0_2.10.13-2%7Ebpo.1_i386.deb

Ставим libgtk 2.10 в директорию gtk2-10:
   dpkg-deb -x libgtk2.0-0_2.10.13-2~bpo.1_i386.deb gtk2-10

Перемещаем содержимое gtk2-10 в /opt/firefox3

В начало скрипта /opt/firefox3/firefox дописываем:

   export LD_LIBRARY_PATH=" /opt/firefox3/gtk2-10/usr/lib"

Для других дистрибутивов, при отсутствии бэкпорта, можно собрать gtk+ 2.10 из исходных текстов:

   cd /usr/local/src
   wget http://ftp.gnome.org/pub/GNOME/sources/gtk+/2.10/gtk+-2.10.14.tar.bz2
   tar xjf gtk+-2.10.14.tar.bz2
   mkdir gtk210
   cd gtk+-2.10.14
   ./configure --prefix=/opt/firefox3/gtk2-10
   make
   make install
 
Ключи: firefox / Лицензия: CC-BY
Раздел:    Корень / Пользователю / Работа с Web и Ftp

 Добавить комментарий
Имя:
E-Mail:
Заголовок:
Текст:




Спонсоры:
Слёрм
Inferno Solutions
Hosting by Ihor
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2019 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру