The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Проблемы с монтированием CDROM  в VMware"
Вариант для распечатки Архивированная нить - только для чтения! 
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [Проследить за развитием треда]

"Проблемы с монтированием CDROM  в VMware"
Сообщение от Valentyn emailИскать по авторуВ закладки on 20-Мрт-05, 14:05  (MSK)
CDROM пи загрузке Linux Debian опознается следующим образом:
Loading modules: ide-cd Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
ide: Assuming 33 MHz system bus speed for PIO modes; override with idebus=xx
ide-detect hdc: VMware Virtual IDE CDROM Drive, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177, 0x376 on irq 15
sd_mod

В /etc/fstab есть такая строка:
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0

При попытке монтировать CDROM командой:
mount /dev/hdc

Возникает следующая ошибка:
ide-scsi: hdc: unsupported command in request queue (0)
end_request: I/O errror, dev 16:00 (hdc), sector 64
isofs_read_super: bread failed, dev=16:00, iso_blknum=16, block=32
mount: wrong fs type, bad option, bad superblock on /dev/hdc,
       or too many mounted file systems
       (could this be the IDE device wyhere you in fact use
       ide-scsi so that sr0 or sda or so is needed?)

Вот в общем такая ситуация. Коментировать не хочу потому как достаточно слаб в Linux. Поэто просто прошу растолкуйте мне почему так поисходит и наставте на путь истинный :). Заранее благодарен.

  Рекомендовать в FAQ | Cообщить модератору | Наверх

 Оглавление

Индекс форумов | Темы | Пред. тема | След. тема
Сообщения по теме

1. "Проблемы с монтированием CDROM  в VMware"
Сообщение от Hawk Искать по авторуВ закладки(??) on 20-Мрт-05, 22:22  (MSK)
>CDROM пи загрузке Linux Debian опознается следующим образом:
>Loading modules: ide-cd Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
>ide: Assuming 33 MHz system bus speed for PIO modes; override with
>idebus=xx
>ide-detect hdc: VMware Virtual IDE CDROM Drive, ATAPI CD/DVD-ROM drive
>ide1 at 0x170-0x177, 0x376 on irq 15
>sd_mod
>
>В /etc/fstab есть такая строка:
>/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0
>
>При попытке монтировать CDROM командой:
>mount /dev/hdc
>
>Возникает следующая ошибка:
>ide-scsi: hdc: unsupported command in request queue (0)
>end_request: I/O errror, dev 16:00 (hdc), sector 64
>isofs_read_super: bread failed, dev=16:00, iso_blknum=16, block=32
>mount: wrong fs type, bad option, bad superblock on /dev/hdc,
>       or too many mounted file
>systems
>       (could this be the IDE
>device wyhere you in fact use
>       ide-scsi so that sr0 or
>sda or so is needed?)
>
>Вот в общем такая ситуация. Коментировать не хочу потому как достаточно слаб
>в Linux. Поэто просто прошу растолкуйте мне почему так поисходит и
>наставте на путь истинный :). Заранее благодарен.

Это эмуляция scsi идешным приводом СД. Ранешние ядра (до 2.6) не умели писать компашки на иде-устройствах. А как /dev/sr0 монтируется? Обычно append=ide-scsi прописывается в lilo.conf, если конечно не запихнуто в ядро. Возможно и как модуль грузится.

  Рекомендовать в FAQ | Cообщить модератору | Наверх

2. "Проблемы с монтированием CDROM  в VMware"
Сообщение от admin Искать по авторуВ закладки(??) on 21-Мрт-05, 06:41  (MSK)
Монтирование CD-Rom`a зависит толькo от /dev/hands
  Рекомендовать в FAQ | Cообщить модератору | Наверх

4. "Проблемы с монтированием CDROM  в VMware"
Сообщение от Valentyn emailИскать по авторуВ закладки on 21-Мрт-05, 13:07  (MSK)
>Монтирование CD-Rom`a зависит толькo от /dev/hands

а подробнее можно или где почитать?

  Рекомендовать в FAQ | Cообщить модератору | Наверх

3. "Проблемы с монтированием CDROM  в VMware"
Сообщение от Valentyn emailИскать по авторуВ закладки on 21-Мрт-05, 13:06  (MSK)

>Это эмуляция scsi идешным приводом СД. Ранешние ядра (до 2.6) не умели
>писать компашки на иде-устройствах. А как /dev/sr0 монтируется? Обычно append=ide-scsi прописывается
>в lilo.conf, если конечно не запихнуто в ядро. Возможно и как
>модуль грузится.

Такое я уже вычитывал, но при инсталяции вместо lilo мне предложено было grab, а как ему такое указать я чесно говоря нигде не смог вычитать. Точнее в одной умной книжке прочитал про grab.config, но не смог по указанному адресу его найти.

  Рекомендовать в FAQ | Cообщить модератору | Наверх

5. "Проблемы с монтированием CDROM  в VMware"
Сообщение от Valentyn emailИскать по авторуВ закладки on 21-Мрт-05, 13:29  (MSK)

А как /dev/sr0 монтируется?

В /etc/fstab прописал:
/dev/sr0 /cdrom0 iso9660 ro,user,noauto 0 0

И все заработало спасибо (нужно своей конечно головой думать).

  Рекомендовать в FAQ | Cообщить модератору | Наверх


Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Пожалуйста, прежде чем написать сообщение, ознакомьтесь с данными рекомендациями.




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру