The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Compile VLC - уже 2 недели не могу откомпилять"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [ Отслеживать ]

"Compile VLC - уже 2 недели не могу откомпилять"  
Сообщение от William email(ok) on 18-Июл-07, 17:59 
На FreeBSD 5.4 для вещания радио со спутника по сети собрал vlc-0.8.1. Перед сборкой он потребовал собрать ffmpeg. И то, и то собирал из портов. При установки он ругнулся, что ему надо libebml и libmad, которые скачал с сайта производителя. После того, как поигрался с vlc, увидел, что в этой версии нет необходимых мне ключиков. Попытался собрать последнюю vlc-0.8.6c, для чего скачал ее с сайта разработчика. И скачал последний ffmpeg. При компиляции получал кучу ошибок о том, что такой-то и такой-то порт (библиотка) не должен быть старше такой-то версии. По ходу устанавливал их. В итоге уперся, что дальше никак не могу собрать vlc. Причем сборка из портов (vlc-0.8.1) тоже уже не проходила. Видно слишком много всяких либов я задел. Волевым решением сделал portsnap. Продолжил компилять (ffmpeg а далее vlc-0.8.6c) уже из портов. По ходу компиляции он ругался на то, что у меня старые либы, которые я тут же пересобрал командами make && make deinstall && make reinstall. В итоге vlc сказал, что не может собраться с поддержкой HAL, т.е. HAL поддерживается только в 5.5 и выше. Следующим волевым решением сивисапнулся до 5.5 и продолжил компиляции. В итоге из портов нормально собрал ffmpeg. При сборке vlc из порта получаю:
===>  Configuring for vlc-0.8.6.c_1,2
configure: WARNING: you should use --build, --host, --target
configure: WARNING: you should use --build, --host, --target
checking build system type... i386-portbld-freebsd5.5
checking host system type... Invalid configuration `vlc.1': machine `vlc.1' not recognized
configure: error: /bin/sh autotools/config.sub vlc.1 failed
===>  Script "configure" failed unexpectedly.
Решил открыть vlc/work/vlc-0.8.6c/config.log и посмотреть с какими ключами собирается vlc:
./configure --enable-ffmpeg --with-ffmpeg=/usr/local --with-libiconv-prefix=/usr/local --with-libintl-prefix=/usr/local --with-ffmpeg-zlib --disable-gnome --disable-gtk --without-libintl-prefix --without-dv-raw1394 --disable-dv MAN1= vlc.1 vlc-config.1 --enable-gnomevfs --disable-skins2 --disable-loader --enable-wxwidgets --disable-hal --disable-arts --enable-bonjour --enable-vcd --enable-libcddb --disable-cddax --enable-cdda --enable-cddax --disable-corba --enable-dvbpsi --with-dvbpsi=/usr/local --enable-dvdnav --disable-dvdread --disable-esd --disable-faad --disable-fribidi --disable-aa --disable-dirac --enable-x264 --disable-caca --enable-daap --enable-dts --disable-ggi --enable-mp3lame --enable-mkv --enable-a52 --enable-libmpeg2 --enable-real --enable-realrtsp --disable-theora --enable-live555 --with-live555-tree=/usr/local/live --enable-mad --with-mad=/usr/local --enable-mod --enable-mpc --enable-ogg --disable-galaktos --enable-smb --enable-sdl --enable-gnutls --enable-speex --disable-svg --disable-svgalib --disable-tremor --disable-twolame --enable-vorbis --disable-xosd --enable-release --enable-release --prefix=/usr/local --build=i386-portbld-freebsd5.5
Дописал к этому конфигу строку --host=i386-portbld-freebsd5.5. При попытке сделать ./compile со всеми этими ключиками получаю отлуп:
checking target system type... Invalid configuration `vlc-config.1': machine `vlc' not recognized
configure: error: /usr/local/bin/bash autotools/config.sub vlc-config.1 failed
Убрал из ключиков строку vlc-config.1, процесс компиляции завершается так:
./configure: line 43394: syntax error near unexpected token `else'
./configure: line 43394: `else'
Тупо ставлю после строки 43394 комментарий // и все… compile проходит…
Но вот make уже никак не проходит:
In file included from ../include/vlc_common.h:1169,
                 from /usr/local/include/vlc/vlc.h:128,
                 from libvlc.c:38:
../include/variables.h: In function `__var_CreateGetInteger':

libvlc.c: In function `VLC_Create':
libvlc.c:204: error: `VLC_VAR_MUTEX' undeclared (first use in this function)
libvlc.c: In function `VLC_Init':
Куда здесь уже копать, ума не приложу.
Сори, что получился длинный пост, возможно с лишними деталями. Но я уже в панике. Две недели пытаюсь откомпилять vlc. Ну хоть какие-то идеи есть у кого? Спасите, плз!!!!
Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Compile VLC - уже 2 недели не могу откомпилять"  
Сообщение от бусик on 18-Июл-07, 18:46 
>На FreeBSD 5.4 для вещания радио со спутника по сети собрал vlc-0.8.1.
>Перед сборкой он потребовал собрать ffmpeg. И то, и то собирал
>из портов. При установки он ругнулся, что ему надо libebml и
>libmad, которые скачал с сайта производителя. После того, как поигрался с
>vlc, увидел, что в этой версии нет необходимых мне ключиков. Попытался
>собрать последнюю vlc-0.8.6c, для чего скачал ее с сайта разработчика. И
>скачал последний ffmpeg. При компиляции получал кучу ошибок о том, что
>такой-то и такой-то порт (библиотка) не должен быть старше такой-то версии.
>По ходу устанавливал их. В итоге уперся, что дальше никак не
>могу собрать vlc. Причем сборка из портов (vlc-0.8.1) тоже уже не
>проходила. Видно слишком много всяких либов я задел. Волевым решением сделал
>portsnap. Продолжил компилять (ffmpeg а далее vlc-0.8.6c) уже из портов. По
>ходу компиляции он ругался на то, что у меня старые либы,
>которые я тут же пересобрал командами make && make deinstall &&
>make reinstall. В итоге vlc сказал, что не может собраться с
>поддержкой HAL, т.е. HAL поддерживается только в 5.5 и выше. Следующим
>волевым решением сивисапнулся до 5.5 и продолжил компиляции. В итоге из
>портов нормально собрал ffmpeg. При сборке vlc из порта получаю:
>===>  Configuring for vlc-0.8.6.c_1,2
>configure: WARNING: you should use --build, --host, --target
>configure: WARNING: you should use --build, --host, --target
>checking build system type... i386-portbld-freebsd5.5
>checking host system type... Invalid configuration `vlc.1': machine `vlc.1' not recognized
>configure: error: /bin/sh autotools/config.sub vlc.1 failed
>===>  Script "configure" failed unexpectedly.
>Решил открыть vlc/work/vlc-0.8.6c/config.log и посмотреть с какими ключами собирается vlc:
>./configure --enable-ffmpeg --with-ffmpeg=/usr/local --with-libiconv-prefix=/usr/local --with-libintl-prefix=/usr/local --with-ffmpeg-zlib --disable-gnome --disable-gtk --without-libintl-prefix --without-dv-raw1394 --disable-dv MAN1=
>vlc.1 vlc-config.1 --enable-gnomevfs --disable-skins2 --disable-loader --enable-wxwidgets --disable-hal --disable-arts --enable-bonjour --enable-vcd --enable-libcddb
>--disable-cddax --enable-cdda --enable-cddax --disable-corba --enable-dvbpsi --with-dvbpsi=/usr/local --enable-dvdnav --disable-dvdread --disable-esd --disable-faad --disable-fribidi
>--disable-aa --disable-dirac --enable-x264 --disable-caca --enable-daap --enable-dts --disable-ggi --enable-mp3lame --enable-mkv --enable-a52 --enable-libmpeg2
>--enable-real --enable-realrtsp --disable-theora --enable-live555 --with-live555-tree=/usr/local/live --enable-mad --with-mad=/usr/local --enable-mod --enable-mpc --enable-ogg --disable-galaktos
>--enable-smb --enable-sdl --enable-gnutls --enable-speex --disable-svg --disable-svgalib --disable-tremor --disable-twolame --enable-vorbis --disable-xosd --enable-release
>--enable-release --prefix=/usr/local --build=i386-portbld-freebsd5.5
>Дописал к этому конфигу строку --host=i386-portbld-freebsd5.5. При попытке сделать ./compile со всеми
>этими ключиками получаю отлуп:
>checking target system type... Invalid configuration `vlc-config.1': machine `vlc' not recognized
>configure: error: /usr/local/bin/bash autotools/config.sub vlc-config.1 failed
>Убрал из ключиков строку vlc-config.1, процесс компиляции завершается так:
>./configure: line 43394: syntax error near unexpected token `else'
>./configure: line 43394: `else'
>Тупо ставлю после строки 43394 комментарий // и все… compile проходит…
>Но вот make уже никак не проходит:
>In file included from ../include/vlc_common.h:1169,
>            
>     from /usr/local/include/vlc/vlc.h:128,
>            
>     from libvlc.c:38:
>../include/variables.h: In function `__var_CreateGetInteger':
>…
>libvlc.c: In function `VLC_Create':
>libvlc.c:204: error: `VLC_VAR_MUTEX' undeclared (first use in this function)
>libvlc.c: In function `VLC_Init':
>Куда здесь уже копать, ума не приложу.
>Сори, что получился длинный пост, возможно с лишними деталями. Но я уже
>в панике. Две недели пытаюсь откомпилять vlc. Ну хоть какие-то идеи
>есть у кого? Спасите, плз!!!!

порой, в такой системе не только vlc не соберется а еще куча всего. я бы вам советовал поставить сервер заново, 6.2 сразу, обновить порты, и ставить vlc из портов с теми модулями, которые требуются... других вариантов у меня нет :) хотя я понимаю, что рублю на корню, и всё же - попробуйте если есть возможность. на крайний случай - бекап винта этого с рабочей системой создайте ! или в vmware установите :) в общем - на вкус и цвет )

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Compile VLC - уже 2 недели не могу откомпилять"  
Сообщение от William email(ok) on 19-Июл-07, 09:20 
>других вариантов у меня нет :) хотя я понимаю, что рублю
>на корню, и всё же - попробуйте если есть возможность. на


Я боялся, что примерно так мне и ответят. Хотя в душЕ верил, что есть какая-нибудь мега-команда типа "remake allports". Очень не хотелось бы все переустанавливать ;(... Рабочая лошадка как-никак ;(

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Compile VLC - уже 2 недели не могу откомпилять"  
Сообщение от mars on 19-Июл-07, 09:47 
>Я боялся, что примерно так мне и ответят. Хотя в душЕ верил,
>что есть какая-нибудь мега-команда типа "remake allports". Очень не хотелось бы
>все переустанавливать ;(... Рабочая лошадка как-никак ;(

если у Вас установлен portupgrade  то есть такая команда ;)
portupgrade -af

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Compile VLC - уже 2 недели не могу откомпилять"  
Сообщение от William email(ok) on 20-Июл-07, 09:17 
>если у Вас установлен portupgrade  то есть такая команда ;)
>portupgrade -af

Огромное человеческое спасибо!!!
Спустя 16 часов (2 Ксеона 3Ггц) он сказал Press Any Key.
В итоге стоит VLC media player 0.8.1 Janus.
Немного непонятно, почему не 0.8.6с. Ведь в портах же 0.8.6с...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Compile VLC - уже 2 недели не могу откомпилять"  
Сообщение от William email(ok) on 20-Июл-07, 15:48 
Ну, в общем, не так страшен черт, как его рисуют ;)
Решилось все довольно просто:
В /usr/ports/multimedia/vlc/Makefile внес изменения:
В секцию CONFIGURE_ARGS+=
добавил строку --host=i386-portbld-freebsd5.5
И закоментировал
#MAN1=          vlc.1 \
#               vlc-config.1
make clean
make
make install
Вуаля... не прошло и трех недель, как я откомпилировал vlc. Зато хоть узнал, как можно работать с фрей ;)
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Compile VLC - уже 2 недели не могу откомпилять"  
Сообщение от Igor email(??) on 07-Мрт-08, 19:45 
>[оверквотинг удален]
>И закоментировал
>#MAN1=          vlc.1 \
>
>#            
>   vlc-config.1
>make clean
>make
>make install
>Вуаля... не прошло и трех недель, как я откомпилировал vlc. Зато хоть
>узнал, как можно работать с фрей ;)

Ну и повезло ж тебе :D

А все немогу собрать этот VLC , выдает такую ошибку

gmake[4]: *** [gdkasync.lo] Error 1
gmake[4]: Leaving directory `/usr/ports/x11-toolkits/gtk20/work/gtk+-2.12.8/gdk/x11'
gmake[3]: *** [all-recursive] Error 1
gmake[3]: Leaving directory `/usr/ports/x11-toolkits/gtk20/work/gtk+-2.12.8/gdk'
gmake[2]: *** [all] Error 2
gmake[2]: Leaving directory `/usr/ports/x11-toolkits/gtk20/work/gtk+-2.12.8/gdk'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/ports/x11-toolkits/gtk20/work/gtk+-2.12.8'
gmake: *** [all] Error 2

Может кто подскажет , как с ним боротьбся..
Спасибо.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру