The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Не работает vlan"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Открытые системы на сервере (Сеть. проблемы, диагностика / FreeBSD)
Изначальное сообщение [ Отслеживать ]

"Не работает vlan"  +/
Сообщение от hroost email(ok) on 12-Мрт-10, 15:48 
Ув.Спецы.
Помогите, пожалуйста, разобраться почему не работает vlan интерфейс.

FreeBSD 7.2-RELEASE

ifconfig:

em1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=9b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM>
        ether 00:0c:29:83:d3:5x
        inet 83.167.32.166 netmask 0xffffffc0 broadcast 83.167.32.191
        media: Ethernet autoselect (1000baseTX <full-duplex>)
        status: active
vlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=3<RXCSUM,TXCSUM>
        ether 00:0c:29:83:d3:5x
        inet 10.226.9.115 netmask 0xffffff00 broadcast 10.226.9.255
        media: Ethernet autoselect (1000baseTX <full-duplex>)
        status: active
        vlan: 802 parent interface: em1

в фаерволе разрешён любой трафик на vlan0:
allow ip from any to any via vlan0

но трафик не приходит и не отправляется...
--- 10.226.9.116 ping statistics ---
122 packets transmitted, 0 packets received, 100.0% packet loss


Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Не работает vlan"  +/
Сообщение от Deac (ok) on 12-Мрт-10, 15:54 
VLAN_HWTAGGING - вот это выключи
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

8. "Не работает vlan"  +/
Сообщение от hroost email(ok) on 16-Мрт-10, 08:33 
Спасибо всем откликнувшимся :-)

>VLAN ID = 802 не мешает проверить

Проверен, работает.

>Может убрать IP c em1 ?

Не вариант, т.к. через em1 пользователям раздается интернет.

>Попробуй использовать другой номер ВЛАНа

Другой номер влана использовать не могу, т.к. с таким номером тега мне приходит трафик от провайдера.

>VLAN_HWTAGGING - вот это выключи

В другом офисе стоит аналогичная машинка с таким же подключением в влану. и там всё работает с VLAN_HWTAGGING ... Обратил внимание на опции к сетевой карте... там они такие:

options=19b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4>

.. поставил фрибсд на ноут, воткнул шнурок провайдера: инет работает, влан работает. В опциях к сетевой карте:

options=10a<TXCSUM,VLAN_MTU,TSO4>

Может дело в опции TSO4 ... Кто подскажет? :-)

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

9. "Не работает vlan"  +/
Сообщение от Deac (ok) on 17-Мрт-10, 15:00 
ем - драйвер для РЯДА интеловских сетевух.
Для начала - отключаешь все опции, потом добавляешь, по одной и проверяешь работоспособность.
Обычно отключения VLAN_HWTAGGING - достаточно.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

10. "Не работает vlan"  +/
Сообщение от hroost email(ok) on 18-Мрт-10, 09:51 
>ем - драйвер для РЯДА интеловских сетевух.
>Для начала - отключаешь все опции, потом добавляешь, по одной и проверяешь
>работоспособность.
>Обычно отключения VLAN_HWTAGGING - достаточно.

Не помогает ...
И я не сказал главного .. что FreeBSD это виртуальная машина под ESXi. Похоже собака где-то здесь зарыта.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

11. "Не работает vlan"  +/
Сообщение от Deac (ok) on 18-Мрт-10, 11:44 
>>ем - драйвер для РЯДА интеловских сетевух.
>>Для начала - отключаешь все опции, потом добавляешь, по одной и проверяешь
>>работоспособность.
>>Обычно отключения VLAN_HWTAGGING - достаточно.
>
>Не помогает ...
>И я не сказал главного .. что FreeBSD это виртуальная машина под
>ESXi. Похоже собака где-то здесь зарыта.

Ну так надо убедиться, что тэги доходят до FreeBSD, а не разбираются "хозяйской" системой.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "Не работает vlan"  +/
Сообщение от Алексей (??) on 12-Мрт-10, 16:34 
VLAN ID = 802 не мешает проверить


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "Не работает vlan"  +/
Сообщение от ash (??) on 12-Мрт-10, 21:49 
>[оверквотинг удален]
>Помогите, пожалуйста, разобраться почему не работает vlan интерфейс.
>
>FreeBSD 7.2-RELEASE
>
>ifconfig:
>
>em1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
>        options=9b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM>
>        ether 00:0c:29:83:d3:5x
>        inet 83.167.32.166 netmask 0xffffffc0

Может убрать IP c em1 ?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "Не работает vlan"  +/
Сообщение от Аноним (??) on 13-Мрт-10, 07:51 
>[оверквотинг удален]
>>FreeBSD 7.2-RELEASE
>>
>>ifconfig:
>>
>>em1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
>>        options=9b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM>
>>        ether 00:0c:29:83:d3:5x
>>        inet 83.167.32.166 netmask 0xffffffc0
>
>Может убрать IP c em1 ?

Вопрос - а чем отличется тегированный пакет с VLAN ID=0  и не тегированным пакетом?
Ответ - ничем ! АйДи то равен 0 !
Попробуй использовать другой номер ВЛАНа

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "Не работает vlan"  +/
Сообщение от PavelR (??) on 13-Мрт-10, 11:44 
>[оверквотинг удален]
>>>        options=9b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM>
>>>        ether 00:0c:29:83:d3:5x
>>>        inet 83.167.32.166 netmask 0xffffffc0
>>
>>Может убрать IP c em1 ?
>
>Вопрос - а чем отличется тегированный пакет с VLAN ID=0  и
>не тегированным пакетом?
>Ответ - ничем ! АйДи то равен 0 !
>Попробуй использовать другой номер ВЛАНа

Аноним походу промахнулся, тема про фряху, а не про ляликс.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "Не работает vlan"  +/
Сообщение от Аноним (??) on 13-Мрт-10, 11:56 

>>Попробуй использовать другой номер ВЛАНа
>
>Аноним походу промахнулся, тема про фряху, а не про ляликс.

ifconfig:

em1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=9b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM>
        ether 00:0c:29:83:d3:5x
        inet 83.167.32.166 netmask 0xffffffc0 broadcast 83.167.32.191
        media: Ethernet autoselect (1000baseTX <full-duplex>)
        status: active
vlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=3<RXCSUM,TXCSUM>
        ether 00:0c:29:83:d3:5x
        inet 10.226.9.115 netmask 0xffffff00 broadcast 10.226.9.255
        media: Ethernet autoselect (1000baseTX <full-duplex>)
        status: active
        vlan: 802 parent interface: em1
И где я промахнулся?
И что теги во Фре какието другие?
Или там пакеты другие?
Извечная проблема VLAN0 ID  есть но как бы и нету. Вот и не понимает интерфейс чего ему на вход приходит. Толи тегированный толи не тегированный трафик

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

7. "Не работает vlan"  +/
Сообщение от PavelR (??) on 13-Мрт-10, 16:43 

>>        vlan: 802 parent interface: em1
>И где я промахнулся?

обратите внимание на строчку выше ?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру