The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"OS:UBUNTU Пакет libc6 нуждается в переустновке, но найти арх..."
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Открытые системы на сервере (Система. проблемы, диагностика / Linux)
Изначальное сообщение [ Отслеживать ]

"OS:UBUNTU Пакет libc6 нуждается в переустновке, но найти арх..."  +/
Сообщение от DestoySoul email(ok) on 04-Июн-10, 02:20 
Началось все с того, что при поптыке устновить  igmpproxy (./configure), скрипт ругался... по гуглив решил переустновить libc6
apt-get ругался на корявые зависимости. Я попросту удалил libc6, решив что поставить его заново будет проще.
Как следствие: отвалился ssh, nano что-то еще...
Пытаюсь снова устновить libc6: теперь apt-get констратирует, что:  Пакет libc6 нуждается в переустновке, но найти архив для него не удалось
sources.list
##########################################################################################
deb http://packages.linuxmint.com/ helena main upstream import
deb http://packages.linuxmint.com/ helena-lxde main upstream import
deb http://archive.ubuntu.com/ubuntu/ karmic main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ karmic-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ karmic-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ karmic partner
deb http://packages.medibuntu.org/ karmic free non-free

deb http://ppa.launchpad.net/tualatrix/ppa/ubuntu karmic main

deb http://notesalexp.org/debian/karmic/ karmic main contrib non-free

deb http://www.geekconnection.org/remastersys/repository karmic/

deb http://robin.powdarrmonkey.net/ubuntu jaunty/
##########################################################################################
Я в панике, что делать? =)

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "OS:UBUNTU Пакет libc6 нуждается в переустновке, но найти арх..."  –2 +/
Сообщение от Andrey Mitrofanov on 04-Июн-10, 09:17 
>Началось все с того, что при поптыке устновить  igmpproxy (./configure), скрипт
>ругался... по гуглив решил переустновить libc6
>apt-get ругался на корявые зависимости.

Всегда казалось, что: 1) configure-make-make-install в Debian-е использовать... весело и познавательно; 2) для удовлетворения зависимостей сборки пакеты обычно _ставят, а не сносят...

>Я попросту удалил libc6, решив что поставить его заново будет проще.

[...]
>Я в панике, что делать? =)

Ну, сделай ещё чего-нибудь такое же "простое". Наверняка получится также интересно и познаваельно. Обязательно нам расскажи, как оно!...

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "OS:UBUNTU Пакет libc6 нуждается в переустновке, но найти арх..."  +/
Сообщение от DestoySoul email(ok) on 04-Июн-10, 11:38 
>[оверквотинг удален]
>Всегда казалось, что: 1) configure-make-make-install в Debian-е использовать... весело и познавательно; 2)
>для удовлетворения зависимостей сборки пакеты обычно _ставят, а не сносят...
>
>>Я попросту удалил libc6, решив что поставить его заново будет проще.
>
>[...]
>>Я в панике, что делать? =)
>
>Ну, сделай ещё чего-нибудь такое же "простое". Наверняка получится также интересно и
>познаваельно. Обязательно нам расскажи, как оно!...

Андрей, конечно же спасибо Вам что откликнулись, вот только из Вашего поста к сожалению очень мало, что можно подчерпнуть по теме топика. Не будьте флудерастом, иногда лучше промолчать, чем сказать что-то. Желаю удачи!

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "OS:UBUNTU Пакет libc6 нуждается в переустновке, но найти арх..."  +/
Сообщение от anonymous (??) on 05-Июн-10, 18:51 
>Началось все с того, что при поптыке устновить  igmpproxy (./configure), скрипт
>ругался... по гуглив решил переустновить libc6
>apt-get ругался на корявые зависимости. Я попросту удалил libc6, решив что поставить
>его заново будет проще.

скачайте пакет вручную и поставьте через dpkg -i

(на ошибках учатся, это факт)

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "OS:UBUNTU Пакет libc6 нуждается в переустновке, но найти арх..."  +/
Сообщение от DestoySoul email(ok) on 06-Июн-10, 00:41 
>>Началось все с того, что при поптыке устновить  igmpproxy (./configure), скрипт
>>ругался... по гуглив решил переустновить libc6
>>apt-get ругался на корявые зависимости. Я попросту удалил libc6, решив что поставить
>>его заново будет проще.
>
>скачайте пакет вручную и поставьте через dpkg -i
>
>(на ошибках учатся, это факт)

Спасибо что откликнулись!
Пробывал ставить руками. Результат отрицательный, а главное что совсем не ясна суть ошибки.

##########################
(Чтение базы данных ... на данный момент установлено 41426 файлов и каталогов.)
Подготовка к замене пакета libc6 2.11.1-0ubuntu7 (используется файл .../libc6_2.10.1-0ubuntu17_i386.deb) ...
Распаковывается замена для пакета libc6 ...
/bin/sh: /lib/libc.so.6: version `GLIBC_2.11' not found (required by /bin/sh)
dpkg: предупреждение: старый сценарий post-removal возвратил код ошибки 1
dpkg: попытка использовать сценарий из нового пакета ...
/bin/sh: /lib/libc.so.6: version `GLIBC_2.11' not found (required by /bin/sh)
dpkg: не удалось обработать параметр /home/dsl/libc6_2.10.1-0ubuntu17_i386.deb (--install):
подпроцесс новый сценарий post-removal возвратил код ошибки 1
/bin/sh: /lib/libc.so.6: version `GLIBC_2.11' not found (required by /bin/sh)
dpkg: ошибка при очистке -
подпроцесс установлен сценарий pre-installation возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
/home/dsl/libc6_2.10.1-0ubuntu17_i386.deb
############################

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "OS:UBUNTU Пакет libc6 нуждается в переустновке, но найти арх..."  +/
Сообщение от anonymous (??) on 06-Июн-10, 13:53 
>Пробывал ставить руками. Результат отрицательный, а главное что совсем не ясна суть
>ошибки.
>
>##########################
>(Чтение базы данных ... на данный момент установлено 41426 файлов и каталогов.)
>
>Подготовка к замене пакета libc6 2.11.1-0ubuntu7 (используется файл .../libc6_2.10.1-0ubuntu17_i386.deb) ...
>Распаковывается замена для пакета libc6 ...
>/bin/sh: /lib/libc.so.6: version `GLIBC_2.11' not found (required by /bin/sh)

зачем вы ставите более старую версию 2.10, когда у вас уже стоит 2.11 (и от этой версии зависят все остальные пакеты в системе)?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "OS:UBUNTU Пакет libc6 нуждается в переустновке, но найти арх..."  +/
Сообщение от DestoySoul email(ok) on 07-Июн-10, 12:08 
>зачем вы ставите более старую версию 2.10, когда у вас уже стоит
>2.11 (и от этой версии зависят все остальные пакеты в системе)?

Ошибочно выбрал версию пакета. Посмотрел libc6 а на связи не глянул.
Но в целом я таки добил систиему, и закончалось все переустновкой.
До победного конца к сожалению мне уже не дойти. В любом случае любой опыт положителен.
Большое спасибо всем отклинувшимся! Вопрос изчерпан.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Слёрм
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру