The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Незагружаются сайты на Win2003 через маршрутизатор!!!"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Настройка Squid и других прокси серверов (Squid)
Изначальное сообщение [ Отслеживать ]

"Незагружаются сайты на Win2003 через маршрутизатор!!!"  +/
Сообщение от Dj_Gluk email on 06-Май-10, 13:39 
Ситуация такая!!!
Установил Ubuntu 9.10 на ней Squid 2.7 прозрачный, две сетевые карты
1. интернет 10.10.0.10
2. локалка 192.168.4.200
В интерфейсе прописаные маршруты на другие подсети 192.168.42.0, 43.0, 44.0, 71.0

auto lo
iface lo inet loopback

auto eth1
    iface eth1 inet static
    address 192.168.4.200
    netmask 255.255.255.0
        broadcast 192.168.4.255
up route add -net 192.168.1.0 netmask 255.255.255.0 gw 192.168.4.30 eth1
up route add -net 192.168.71.0 netmask 255.255.255.0 gw 192.168.4.30 eth1
up route add -net 192.168.41.0 netmask 255.255.255.0 gw 192.168.4.30 eth1
#
auto eth0
        iface eth0 inet static
        address 10.10.0.58
        netmask 255.255.255.0
        gateway 10.10.0.1
        broadcast 10.10.0.255

В нутри моей подсети (192.168.4.0) все работает нормально, а на остальные в особенности на сервера Win2003 и на некоторых ХР - неработает! (((( В ето й же подсети на  некоторых ХР-хах работает номрально, тоесть 50/50!
Фаервол отключен!
В логах Squid прописывается:
273136373.031    218 192.168.41.1 TCP_MISS/200 7030 GET http://ya.ru/ - DIRECT/213.180.204.3 text/html  - и все, сайт типа грузится минут 5, потом ошибка.

В чтом причина??? Помогите пожалуйста!!!!! (((

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Незагружаются сайты на Win2003 через маршрутизатор!!!"  +/
Сообщение от ipmanyak (ok) on 06-Май-10, 17:47 
>up route add -net 192.168.1.0 netmask 255.255.255.0 gw 192.168.4.30 eth1
>up route add -net 192.168.71.0 netmask 255.255.255.0 gw 192.168.4.30 eth1
>up route add -net 192.168.41.0 netmask 255.255.255.0 gw 192.168.4.30 eth1

Прокси на каких айпи слуашет? Впрочем тут трабла не в прокси.
У клиентов этих подсетей шлюзом кто указан? Какие IP?
Если у клиента указана сеть 192.168.1.0 с маской 255.255.255.0, а  дефолтовый шлюз 192.168.4.30, то это бред.
Смотри - пришел пакет от хоста 192.168.41.13, твой убунту его принял и перекинул на  192.168.4.30, допустим с интерфейса 192.168.4 пакет отправился в сквид и далее в инет и вернулся на 192.168.4.30. А обратно куда его кидать? с 192.168.4.30 куда слать пакет? сеть 192.168.41.0 завернута на 192.168.4.30!  

Рутинг сделан некорректно, подход неверен, вам нужно создать алиасные интерфейсы  для этих подсетей и соответствующие маршруты. Типа:
  
/sbin/ifconfig eth1:0 192.168.1.1 broadcast 192.168.1.255 netmask 255.255.255.0 up
/sbin/route add -net 192.168.1.0  netmask 255.255.255.0 eth1:0

/sbin/ifconfig eth1:1 192.168.71.1 broadcast 192.168.71.255 netmask 255.255.255.0 up
/sbin/route add -net 192.168.71.0  netmask 255.255.255.0 eth1:1

/sbin/ifconfig eth1:2 192.168.41.1 broadcast 192.168.41.255 netmask 255.255.255.0 up
/sbin/route add -net 192.168.41.0  netmask 255.255.255.0 eth1:2

Соответственно шлюзами у клиентов указывать адреса 192.168.1.1 192.168.71.1 192.168.41.1
Тогда всё будет нормуль.
P.S.
Если все эти сети ваши в одной конторе, то стоит подумать о расширении маски сети и убирании подсетей, типа сеть 192.168.0.0 маска 255.255.0.0. Разумеется всё зависит от топологии вашей сети, может вам это и неприемлемо вообще.


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "Незагружаются сайты на Win2003 через маршрутизатор!!!"  +/
Сообщение от Dj_Gluk email on 07-Май-10, 10:11 
>У клиентов этих подсетей шлюзом кто указан? Какие IP?
>Если у клиента указана сеть 192.168.1.0 с маской 255.255.255.0, а  дефолтовый
>шлюз 192.168.4.30, то это бред.

У меня во всех подсетях стоит маршрутизатор (Cisco Systems) 192.168.1.0 шлюз 1.30; 192.168.4.0 шлюз 4.30; и тд... с етим у меня проблем нет!
Проблема в том что на некоторых ПК не работает инет, например 192.168.71.1 (Win2003 Server) не работает, на 192.168.71.2 (Win XP SP3) - не работает, а на 192.168.71.124 (Win XP SP3) - работает нормально! Прокси один и тот же 192.168.4.200:8080! Почему так??!!!

Аналогично и на остальных подсетях, на Win2003 не работает нигде, на ХР работает но 50/50.
В моей подсети 192.168.4.0 - работает без проблем на всех машинах (50 шт - Win2003, Win2008, XP SP3)!
Раньше стоял UserGate - все работало нормально без никаких доплнительных настроек!
Есть еще прокси с 192.168.1.31:3128 тоже Squid только на FreeBSD ну там непрозрачный по лог и пасс - работает нормально на всех машинах и подсетях! Я вот хочу от них отделится и сам по своей теретории роздавать инет!
А у меня почему-то не работает! (((
На сколько я понемаю проблема в самом скиде или в настойках Убунты. Фаервол отключен.
Пробовал ставить Убунту 9.04 и сквид 3.0 минимальные настройки - тоже самое!
Помогите!

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "Незагружаются сайты на Win2003 через маршрутизатор!!!"  +/
Сообщение от Square (ok) on 07-Май-10, 03:10 
>up route add -net 192.168.1.0 netmask 255.255.255.0 gw 192.168.4.30 eth1

а что собой представляет 192.168.4.30? это шлюз из вашей сети к тем трем подсетям?

ваша сеть выглядит так?

192.168.1.0------[192.168.1.х-\            ]
192.168.71.0-----[192.168.71.х-192.168.4.30]----[192.168.4.200--10.10.0.58]--10.10.0.1
192.168.41.0-----[192.168.41.х/            ]

три сети         шлюз к трем сетям..вероятно клиенты:)    этотшлюз       шлюзпровайдера


тогда проверьте что на тех машинках правильно указан дефолтный роутинг
собственно он там должен указывать на внутренний интерфейс компа у которого внешний по отношению к ним  адрес - 192.168.4.30.

а на том шлюзе указать дефолтный роутинг на 192.168.4.200

пинг проверить - если проходит из подсети к 192.168.4.200 - то маршрутизация работает правильно. Проверить пинг на яндекс... если проходит- то маршрутизация и тут работает праивльно, и проблемы вероятно с настройками сквида.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "Незагружаются сайты на Win2003 через маршрутизатор!!!"  +/
Сообщение от Dj_Gluk email on 07-Май-10, 09:10 
>пинг проверить - если проходит из подсети к 192.168.4.200 - то маршрутизация
>работает правильно. Проверить пинг на яндекс... если проходит- то маршрутизация и
>тут работает праивльно, и проблемы вероятно с настройками сквида.

192.168.4.30 - ето у меня маршрутизатор (Cisco Systems) на остальные под сети, в каждой с подсети у меня такие самые маршрутизаторы 192.168.71.30, 41.30 ... связаные тунелями через канал (инет)!
Связь есть, я могу пинговать все подсети с любой подсети. В сквиде в логах прописывается что
есть запрос а страничка всеравно негрузится!
Дело в том что раньше там был инет чере прокси Squid на FreeBSD только непрозрачный - то он работал без проблем!
Проблемма еще в том что на Win2003 допустим на 192.168.71.1 неработает,а на ХР в етой же подсети 192.168.71.123 все работае нормально! ((((((

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "Незагружаются сайты на Win2003 через маршрутизатор!!!"  +/
Сообщение от Square (ok) on 07-Май-10, 09:29 
>FreeBSD только непрозрачный - то он работал без проблем!
>Проблемма еще в том что на Win2003 допустим на 192.168.71.1 неработает,а на
>ХР в етой же подсети 192.168.71.123 все работае нормально! ((((((

забыли на Win2003 прокси убрать из настроек браузера?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "Незагружаются сайты на Win2003 через маршрутизатор!!!"  +/
Сообщение от Dj_Gluk email on 07-Май-10, 10:39 
>>FreeBSD только непрозрачный - то он работал без проблем!
>>Проблемма еще в том что на Win2003 допустим на 192.168.71.1 неработает,а на
>>ХР в етой же подсети 192.168.71.123 все работае нормально! ((((((
>
>забыли на Win2003 прокси убрать из настроек браузера?

Там стоит мой прокси 192.168.4.253:8080.
Пробовал заново на другую машину ставить Убнту 9.04 с сквидом 3.0 - тоже не работает!
Сайт якобы грузит лог в сквиде есть с 192.168.71.1 (Win2003), иногда сайт прогружает процентов на 2-3 и стает. Его что-то останавливает или может блокирует!
Есть еще один прокси тоже на сквиде под FreeBSD на 192.168.1.31:3128 ну непрозрачный - работает нормально на етой же машине. Я вот хочу от них отделится и сам роздавать инет по своему региону! )))
Немогу найти причину!

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

7. "Незагружаются сайты на Win2003 через маршрутизатор!!!"  +/
Сообщение от Dj_GluK email on 03-Июн-10, 09:23 

>Немогу найти причину!

Все, РАБОТАЕТ!!!!
Пробламма была все таки на Циске! ))) Галочку одну обрали и все пошло!
Всем спасибо!
ЗАКРЫТО!!! :)))

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2023 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру