The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Проблема с проприетарным драйвером от ATI"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Открытые системы на рабочей станции (Public)
Изначальное сообщение [Проследить за развитием треда]

"Проблема с проприетарным драйвером от ATI"  
Сообщение от cxpoh (ok) on 26-Окт-07, 10:36 
После того как разобрался с проблемой, указанной тут https://www.opennet.ru/openforum/vsluhforumID15/1491.html
Появилась другая. Иксы не хотят грузиться под драйвером fglrx,  черный экран появляется, а в меню монитора стоит разрешение 1280х1024 85гц.
Грузится, когда я ставлю дравйвер vesa.
В чем проблема может быть?
Прилагаю Конфиг xorg.conf

Section "ServerLayout"
Identifier "layout1"
Screen 0 "aticonfig-Screen[0]" 0 0
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "ServerFlags"

#DontZap # disable <Ctrl><Alt><BS> (server abort)
#DontZoom # disable <Ctrl><Alt><KP_+>/<KP_-> (resolution switching)
# allows the server to start up even if the mouse does not work
Option "allowmouseopenfail"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us,ru(winkeys)"
Option "XkbOptions" "grp:ctrl_shift_toggle,grp_led:scroll,compose:rwin"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
EndSection

Section "Modes"
Identifier "Modes0"
Modeline "1280x1024_76.00" 141.82 1280 1376 1512 1744 1024 1025 1028 1070 -HSync +VSync
Modeline "1024x768_85.00" 94.39 1024 1088 1200 1376 768 769 772 807 -HSync +HSync
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
UseModes "Modes0"
HorizSync 30-96
VertRefresh 50-160
EndSection

Section "Device"
Identifier "aticonfig-Device[0]"
BusID "4:0:0"
Driver "vesa"
#"fglrx"
Screen 0
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device "aticonfig-Device[0]"
Monitor "aticonfig-Monitor[0]"
DefaultDepth 24
SubSection "Display"
# Viewport 0 0
Modes "1024x768_85"
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite"
EndSection

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Проблема с проприетарным драйвером от ATI"  
Сообщение от evg (??) on 26-Окт-07, 10:46 
>[оверквотинг удален]
>SubSection "Display"
># Viewport 0 0
>Modes "1024x768_85"
>Depth 24
>EndSubSection
>EndSection
>
>Section "Extensions"
>Option "Composite"
>EndSection

Modeline править надо

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Проблема с проприетарным драйвером от ATI"  
Сообщение от evg (??) on 26-Окт-07, 10:49 
>[оверквотинг удален]
>SubSection "Display"
># Viewport 0 0
>Modes "1024x768_85"
>Depth 24
>EndSubSection
>EndSection
>
>Section "Extensions"
>Option "Composite"
>EndSection

Modeline "1280x1024_76.00" 141.82 1280 1376 1512 1744 1024 1025 1028 1070 -HSync +VSync попробовать удалить строчку так как он максимальное разрешение пытается ставить

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Проблема с проприетарным драйвером от ATI"  
Сообщение от cxpoh (??) on 26-Окт-07, 11:18 
>[оверквотинг удален]
>>EndSubSection
>>EndSection
>>
>>Section "Extensions"
>>Option "Composite"
>>EndSection
>
>Modeline "1280x1024_76.00" 141.82 1280 1376 1512 1744 1024 1025 1028 1070 -HSync
>+VSync попробовать удалить строчку так как он максимальное разрешение пытается ставить
>

Нашел решение. ПРоблема была в самих драйверах. Зашел под vesa драйвером и в Настройка компьютера-Оборудование-Настройка Графического Сервера
Выбрал видеокарту из списка - и система сама скачала драйвера и установила.
А те, которые я скачал с сайта Ати... чет не катят.
Спасибо за помощь.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Проблема с проприетарным драйвером от ATI"  
Сообщение от cxpoh (ok) on 26-Окт-07, 11:23 
ВОзникает вопрос, где можно посмотреть логи, чтобы узнать ссылку драйверов видеокарты, которая система скачала.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру