The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"OpenSolaris.Не ставится Licq,SIM;проблемы с кирилицей в gedi..."
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Открытые системы на рабочей станции (Public)
Изначальное сообщение [ Отслеживать ]

"OpenSolaris.Не ставится Licq,SIM;проблемы с кирилицей в gedi..."  +/
Сообщение от Glimmung (ok) on 04-Авг-09, 19:27 
1)Не могу поставить licq-1.3.6
На этапе configure выдает такую бяку:

checking for pthread_cancel in -lc_r... no
checking for pthread_cancel in -lpthread... no
checking for pthread_cancel in -lthread... no
checking for pthread_cancel in -lpthreads... no

Please install/update your POSIX threads (pthreads) library. Updates should be
available from either your system vendor, or, for GNU/Linux systems, go to
http://pauillac.inria.fr/~xleroy/linuxthreads/.  GNU Pth can also be used if
configured with --enable-pthread.

2)Не могу поставить sim-0.9.4.3
Ругается на отсутствие библиотек Qt.
Если ничего не указывать в качестве опций configure, или указывать только директорию Qt получается так:


pfexec ./configure --disable-kde --with-qt-dir=/usr/local/Trolltech/Qt-4.5.2/
hecking build system type... i386-pc-solaris2.11
checking host system type... i386-pc-solaris2.11
checking target system type... i386-pc-solaris2.11
checking for a BSD-compatible install... /usr/bin/ginstall -c
checking for -p flag to install... yes
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking where to install... /usr/local (default value)
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes

..............................
..............................
checking for perl... /usr/bin/perl
checking for Qt... configure: error: Qt (>= Qt 3.0) (library qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!


Если указать --with-qt-includes= то так:

pfexec ./configure --disable-kde --with-qt-libraries=/usr/local/Trolltech/Qt-4.5.2/lib --with-qt-includes=/usr/local/Trolltech/Qt-4.5.2/include/Qt/
checking build system type... i386-pc-solaris2.11
checking host system type... i386-pc-solaris2.11
checking target system type... i386-pc-solaris2.11
checking for a BSD-compatible install... /usr/bin/ginstall -c
checking for -p flag to install... yes
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking where to install... /usr/local (default value)
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... a.out
..........................................................
..........................................................

checking for Qt... configure: error: Qt (>= Qt 3.0) (library qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!

Этого qt-mt я действительно у себя findом не обнаружил. Но библиотеки qt я скачивал с офф сайта, и собирал единственное с опцией -nomake examples.
В системе посредством менеджера пакетов установлена последняя sunstudio,gcc

3)gedit отображает вместо кирилицы белеберду
Нагуглил решение - плагин который должен позволять переключать кодировку прямо в программе. Засунул его куда надо - врубаю gedit - в плагинах он появился но не активизируется. Если запускать gedit из консоли то при попытки включить плагин в консоль выводится следущая ошибка:


gedit
  File "/export/home/lisp/.gnome2/gedit/plugins/encodingpy.py", line 35
    enclist_func = lambda i=0: [gedit.encoding_get_from_index(i)] + enclist_func(i+1) if gedit.encoding_get_from_index(i) else []
                                                                                       ^
SyntaxError: invalid syntax

** (gedit:25932): WARNING **: Cannot load plugin 'encodingpy' since file '/export/home/lisp/.gnome2/gedit/plugins' cannot be read.

** (gedit:25932): WARNING **: Error activating plugin 'Кодировка'


Плагин брал вот тут:
http://bugzilla.gnome.org/attachment.cgi?id=108172&action=view
python 2.5,требуемый плагином, в системе установлен.

P.S. Не судите строго - солярис мой первый юникс. Об стол головой бился,много гуглил и ниче не помогает..

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "OpenSolaris.Не ставится Licq,SIM;проблемы с кирилицей в gedi..."  +/
Сообщение от guest (??) on 05-Авг-09, 10:02 
>1)Не могу поставить licq-1.3.6

...
>[оверквотинг удален]
>
>Make sure that you have compiled Qt with thread support!
>
>
>Этого qt-mt я действительно у себя findом не обнаружил. Но библиотеки qt
>я скачивал с офф сайта, и собирал единственное с опцией -nomake
>examples.
>В системе посредством менеджера пакетов установлена последняя sunstudio,gcc
>
>3)gedit отображает вместо кирилицы белеберду

...
>P.S. Не судите строго - солярис мой первый юникс. Об стол головой
>бился,много гуглил и ниче не помогает..

sim-0.9.4.3 только для Qt 3.x, его(sim) пока переносят на Qt 4.x, по остальному ничего не могу сказать.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "OpenSolaris.Не ставится Licq,SIM;проблемы с кирилицей в gedi..."  +/
Сообщение от Glimmung (ok) on 05-Авг-09, 11:30 
>[оверквотинг удален]
>
>** (gedit:25932): WARNING **: Cannot load plugin 'encodingpy' since file '/export/home/lisp/.gnome2/gedit/plugins' cannot
>be read.
>
>** (gedit:25932): WARNING **: Error activating plugin 'Кодировка'
>
>Плагин брал вот тут:
>http://bugzilla.gnome.org/attachment.cgi?id=108172&action=view
>python 2.5,требуемый плагином, в системе установлен.
>

Вот тут https://bugs.launchpad.net/ubuntu/+source/gedit/+bug/67844 человек описывает такуюже проблему:

#3        Lavir the Whiolet  wrote on 2008-09-14:

The plugin does not work. When I install it, I go to "Plugins" tab in settings dialog and select the plugin. It stays not selected and becomes grey (unselectable).
Потом:

#4     Lavir the Whiolet wrote on 2008-09-14:

I just cleaned all my configuration for gedit and everything works.

Какую конфигурацию и где чистить? я удалил-установил gedit  по прежнему не работает ((

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "OpenSolaris.Не ставится Licq,SIM;проблемы с кирилицей в gedi..."  +/
Сообщение от vadik email(??) on 07-Дек-09, 16:11 
>Какую конфигурацию и где чистить? я удалил-установил gedit  по прежнему не
>работает ((

Нужно проверить права доступа к каталогу /export/home/lisp/.gnome2/gedit/plugins
Gedit не может его открыть о чем и сообщает:
file '/export/home/lisp/.gnome2/gedit/plugins' cannot be read.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру