The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Обновление OpenVPN 2.4.8"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Обновление OpenVPN 2.4.8"  +/
Сообщение от opennews (ok), 31-Окт-19, 09:52 
Сформирован корректирующий выпуск пакета для создания виртуальных частных сетей OpenVPN 2.4.8. В новой версии добавлена возможность сборки с LibreSSL и обеспечена поддержка сборки с OpenSSL 1.1 без устаревших API....

Подробнее: https://www.opennet.ru/opennews/art.shtml?num=51783

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


1. "Обновление OpenVPN 2.4.8"  +3 +/
Сообщение от mumu (ok), 31-Окт-19, 09:52 
tun-драйвер уже сделали многопоточным или до сих пор на 64 ядрах полностью забивает только одно и тормозит?
Ответить | Правка | Наверх | Cообщить модератору

2. "Обновление OpenVPN 2.4.8"  +/
Сообщение от Аноним (2), 31-Окт-19, 10:03 
Какая разница, он все равно в юзерспейсе
Ответить | Правка | Наверх | Cообщить модератору

3. "Обновление OpenVPN 2.4.8"  –3 +/
Сообщение от Аноним (-), 31-Окт-19, 10:42 
юзерспейс не нужен
Ответить | Правка | Наверх | Cообщить модератору

6. "Обновление OpenVPN 2.4.8"  –1 +/
Сообщение от Аноним (6), 31-Окт-19, 12:47 
Что за идиотская привычка задавать вопросы про новость?!
Сходи на сайт, почитай и расскажи всем что читал, а не пиши тут тупые вопросы.
Ответить | Правка | К родителю #1 | Наверх | Cообщить модератору

10. "Обновление OpenVPN 2.4.8"  +13 +/
Сообщение от НяшМяш (ok), 31-Окт-19, 13:37 
Задавать вопросы (тем более по теме) - это очень хорошая привычка. Обычно когда задают вопрос - значит не нашёл ответ самостоятельно или нет времени его искать. А так можно понадеяться, что найдётся человек, знающий ответ. Если горит от таких вопросов - просто проходим мимо и не раздуваем ветку своими "полезными" вопросами.
Ответить | Правка | Наверх | Cообщить модератору

12. "Обновление OpenVPN 2.4.8"  +/
Сообщение от hhhg (?), 31-Окт-19, 13:55 
Используйте одноядерный процессор, люк.
Ответить | Правка | К родителю #1 | Наверх | Cообщить модератору

19. "Обновление OpenVPN 2.4.8"  +3 +/
Сообщение от Анони (?), 31-Окт-19, 19:45 
На 12 ГГц
Ответить | Правка | Наверх | Cообщить модератору

4. "Обновление OpenVPN 2.4.8"  –3 +/
Сообщение от Аноним (4), 31-Окт-19, 12:18 
Wireguard рулит
Ответить | Правка | Наверх | Cообщить модератору

8. "Обновление OpenVPN 2.4.8"  –3 +/
Сообщение от Аноним (-), 31-Окт-19, 13:06 
А вот с этим реально быстро настривать
Ответить | Правка | Наверх | Cообщить модератору

14. "Обновление OpenVPN 2.4.8"  +/
Сообщение от Аноним (14), 31-Окт-19, 14:12 
Есть еще такой очень простой https://github.com/jedisct1/dsvpn
Ответить | Правка | К родителю #4 | Наверх | Cообщить модератору

5. "Обновление OpenVPN 2.4.8"  –3 +/
Сообщение от бублички (?), 31-Окт-19, 12:37 
предпочитаю Strongswan (IKEv2), что гораздо шустрее этой поделки
Ответить | Правка | Наверх | Cообщить модератору

7. "Обновление OpenVPN 2.4.8"  –1 +/
Сообщение от Аноним (-), 31-Окт-19, 13:06 
Как с настройкой?
Я попробовал и отошел. Как то непросто все.
Ответить | Правка | Наверх | Cообщить модератору

13. "Обновление OpenVPN 2.4.8"  –5 +/
Сообщение от brzm (ok), 31-Окт-19, 14:03 
Шустрее linux kernel, strongswan там особо ничем не занимается, а вот strongswan это как раз и есть поделка.
Пробовали сделать с ним CI? Мониторить? Логи парсить? Попробуйте. Лучше OpenVPN нет ничего.
Ответить | Правка | К родителю #5 | Наверх | Cообщить модератору

23. "Обновление OpenVPN 2.4.8"  –3 +/
Сообщение от бублички (?), 31-Окт-19, 20:39 
swanctl не осилил, двухкнопочный? в 2008-м году где-то заснул и не проснулся? всё прекрасно мониторится и парсится если руки и голова имеются
Ответить | Правка | Наверх | Cообщить модератору

26. "Обновление OpenVPN 2.4.8"  –2 +/
Сообщение от brzm (ok), 31-Окт-19, 22:11 
> swanctl не осилил, двухкнопочный? в 2008-м году где-то заснул и не проснулся?
> всё прекрасно мониторится и парсится если руки и голова имеются

Давайте как-то повежливее и поконструктивнее. Со strongswan'ом я собаку съел, мысль была в том, что вы судя по всему в вопросе не разбираетесь и дальше "я соединил дом и работу" им не пользовались. Там в логах даже severity нет.
Кто вам вообще сказал что я что-то не осилил? Или вы привыкли только говорить о том, чего не знаете? Всё вышеперечисленное я сделал, работает, используется в крупной зарубежной компании. Вопорос в том что говнище называемое strongswan надо оборачивать в толстый слой брезента чтобы им нормально пользоваться можно было. Вы, судя по всему, просто ничего лучше и не пробовали и тем не менее заявляете.

Ответить | Правка | Наверх | Cообщить модератору

27. "Обновление OpenVPN 2.4.8"  –4 +/
Сообщение от бублички (?), 31-Окт-19, 22:43 
куда уж тут повежливей (тем-более поконструктивней), когда ясно вижу что ты попросту не шаришь и при этом мягко говоря врёшь

> Там в логах даже severity нет.

со всем своим многовековым опытом в крупной зарубежной комрании ты не осилил прочесть 1 страницу документации? вот она: https://wiki.strongswan.org/projects/strongswan/wiki/LoggerC...

мне же остаётся только вежливо и конструктивно хихикнуть в адрес иностранной компании где ты Strongswan настраивал. видел я неоднократно печальные результаты работы таких вот тяп-ляп специалистов, некоторые тоже на OpenNET щёки раздували. минусуй сам себя, за то что не умеешь настроить logger и не знаешь про swanctl

Ответить | Правка | Наверх | Cообщить модератору

30. "Обновление OpenVPN 2.4.8"  –2 +/
Сообщение от brzm (ok), 01-Ноя-19, 15:25 
Всё было тщательно прочитано и сделано. Ещё раз повторяю, вы видимо с трудом воспринимаете печатный текст: всё отлично работает, у нас VPN менеджер может настроить через web-морду которая тут же на Go сделана, а вы дальше документацией размахивайте, считайте себя крутым специалистом и наяривайте на свой swanctl. Обезъяньей работой же должен кто-то заниматься, если в компании нет нормальных автоматизаторов :)
Ответить | Правка | Наверх | Cообщить модератору

35. "Обновление OpenVPN 2.4.8"  +/
Сообщение от бублички (?), 06-Ноя-19, 14:24 
> Всё было тщательно прочитано и сделано. Ещё раз повторяю, вы видимо с
> трудом воспринимаете печатный текст: всё отлично работает, у нас VPN менеджер
> может настроить через web-морду которая тут же на Go сделана, а
> вы дальше документацией размахивайте, считайте себя крутым специалистом и наяривайте на
> свой swanctl. Обезъяньей работой же должен кто-то заниматься, если в компании
> нет нормальных автоматизаторов :)

swanctl (с которым ты совершенно незнаком, хотя ему уже 5 лет) как-раз позволяет упростить автоматику. так-что давай-ка ты сам, наяривай дальше на свои чудо-костыли для парсинга /etc/ipsec.conf через веб-морду. могу себе представить этот ваш чудо-софт, образца 90-х. только на OpenNET и можешь похвастаться - в других местах засмеют

Ответить | Правка | Наверх | Cообщить модератору

31. "Обновление OpenVPN 2.4.8"  –3 +/
Сообщение от brzm (ok), 01-Ноя-19, 15:29 
Ещё раз просмотрел https://wiki.strongswan.org/projects/strongswan/wiki/LoggerC.... Где severity? Пальцем ткни. Нету его там, вы гоните как дышите. Поэтому единственный способ это грепнуть весь сорец и руками проставить северети в парсере. Софт - огонь, ничо не скажешь.
Ответить | Правка | К родителю #27 | Наверх | Cообщить модератору

36. "Обновление OpenVPN 2.4.8"  –1 +/
Сообщение от бублички (?), 06-Ноя-19, 14:26 
> Ещё раз просмотрел https://wiki.strongswan.org/projects/strongswan/wiki/LoggerC....
> Где severity? Пальцем ткни. Нету его там, вы гоните как дышите.
> Поэтому единственный способ это грепнуть весь сорец и руками проставить северети
> в парсере. Софт - огонь, ничо не скажешь.

вы, голубчик, неуч

Ответить | Правка | Наверх | Cообщить модератору

37. "Обновление OpenVPN 2.4.8"  –1 +/
Сообщение от brzm (ok), 06-Ноя-19, 22:57 
Иди сорцы читай https://git.strongswan.org/?p=strongswan.git;a=blob;f=src/li... трепло
Ответить | Правка | Наверх | Cообщить модератору

24. "Обновление OpenVPN 2.4.8"  +/
Сообщение от qwerty123 (??), 31-Окт-19, 21:15 
>предпочитаю Strongswan (IKEv2), что гораздо шустрее этой поделки

он, как и Racoon1/2, занимается только согласованием ключей IPsec.

Ответить | Правка | К родителю #5 | Наверх | Cообщить модератору

9. "Обновление OpenVPN 2.4.8"  +3 +/
Сообщение от Аноним (-), 31-Окт-19, 13:13 
Есть у него будущее? В том ключе, что WireGuard уже встроили в ядро, он быстрее и безопаснее...
Ответить | Правка | Наверх | Cообщить модератору

11. "Обновление OpenVPN 2.4.8"  +3 +/
Сообщение от НяшМяш (ok), 31-Окт-19, 13:40 
Пока ещё есть, например, для клиентов, не поддерживающих WireGuard
(Mikrotik, я смотрю на тебя и жду, когда ты хотя бы OpenVPN по UDP запилишь)
Ответить | Правка | Наверх | Cообщить модератору

15. "Обновление OpenVPN 2.4.8"  +1 +/
Сообщение от 4324 (?), 31-Окт-19, 14:54 
Они снова(т.е. наконец) это пытаются сделать в бетке 7.0
Ответить | Правка | Наверх | Cообщить модератору

16. "Обновление OpenVPN 2.4.8"  +1 +/
Сообщение от Аноним (16), 31-Окт-19, 15:07 
да, у него более гибкие настройки - можно отдать ipv6 клиентам по ipv4, можно маскировать tcp под https...
Ответить | Правка | К родителю #9 | Наверх | Cообщить модератору

17. "Обновление OpenVPN 2.4.8"  +/
Сообщение от Аноним (17), 31-Окт-19, 17:35 
Смотря для кого. Вряд ли прямо так возьмёт и сдаст позиции.
Ответить | Правка | К родителю #9 | Наверх | Cообщить модератору

18. "Обновление OpenVPN 2.4.8"  +/
Сообщение от Аноним (18), 31-Окт-19, 19:24 
В WireGuard есть защита от fingerprint портов? Какой-то аналог tls-auth?
Ответить | Правка | К родителю #9 | Наверх | Cообщить модератору

28. "Обновление OpenVPN 2.4.8"  +/
Сообщение от OpenEcho (?), 01-Ноя-19, 12:00 
Забудьте о tls-auth и используйте tls-crypt если хотите иметь полное шифрование.
Ответить | Правка | Наверх | Cообщить модератору

21. "Обновление OpenVPN 2.4.8"  +/
Сообщение от Аноним (18), 31-Окт-19, 20:01 
WireGuard TCP не поддерживает :-(
Ответить | Правка | К родителю #9 | Наверх | Cообщить модератору

22. "Обновление OpenVPN 2.4.8"  +/
Сообщение от Sinot (ok), 31-Окт-19, 20:30 
На сколько мне известно OpenVPN один из самых простых способов поднять L2-туннель.
Ответить | Правка | К родителю #9 | Наверх | Cообщить модератору

25. "Обновление OpenVPN 2.4.8"  +/
Сообщение от хотел спросить (?), 31-Окт-19, 21:49 
у меня OpenVPN быстрее... намного, где пятая часть от полосы пропускания

а гуард выдал 10-ую часть от этого

Ответить | Правка | К родителю #9 | Наверх | Cообщить модератору

29. "Обновление OpenVPN 2.4.8"  +3 +/
Сообщение от OpenEcho (?), 01-Ноя-19, 12:36 
OpenVPN может:  
- username/password
- two factor authentication
- certificate-based authentication
- plug-in and scripting interface
- support for 2 different cryptographic libraries
- routing - из коробки
- B 2017 прошел аудит инициализирванный OSTIF

Для любителей "нового":
WineGuard - не может то что выше.
- Не отключаемые логи (privacy concern), /dev/null в помощь.
- No dynamic address management(Статические IP в помощь).
(Клиенту необходимо заранее назначить заранее определенный IP-адрес VPN, однозначно связанный с его ключом на каждом сервере VPN (Прощай анонимность))
- клиент не проверяет подлинность сервера (Welcome MITM).
- Соединиться с сервером через прокси - дудки.

Ответить | Правка | К родителю #9 | Наверх | Cообщить модератору

20. "Обновление OpenVPN 2.4.8"  –1 +/
Сообщение от Анони (?), 31-Окт-19, 19:51 
Я на VDSке юзаю Ethersoft VPN (L2TP over IPSec) и стандартным виджетом кедовским подрубаю, так получилось, что он гораздо быстрее работает и фич больше в случае своего протокола. А выбрал, т.к. на работе сеть из сотен компов лагала с сабжем, и то и дело на машинах соединение ни алё, потом всё прошло после замены (правда там вендо-админы-эникейщики всё по дефолту настроили, хоть и просил их, чтобы не использовать бинарный клиент).
Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру