The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Раздел полезных советов: Конвертация Chrome-дополнения для з..."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Раздел полезных советов: Конвертация Chrome-дополнения для з..."  +/
Сообщение от auto_tips (??), 05-Мрт-20, 10:58 
Для установки в Firefox браузерных дополнений на базе API WebExtension, подготовленных только для Chrome или Opera, можно использовать дополнение  Foxified (https://github.com/Noitidart/Chrome-Store-Foxified). Проблема в том, что Foxified не может быть запущен, начиная с Firefox 57, в котором была прекращена поддержка XUL/XPCOM.

В качестве обходного пути предлагается параллельно с основной актуальной версией Firefox установить Firefox 56 и запустить в нём [[https://github.com/Noitidart/Chrome-Store-Foxified/releases Foxified]].  

Перед началом работы следует зарегистрироваться в каталоге дополнений Mozilla  AMO (https://addons.mozilla.org) или войти в существующую учётную запись для последующего формирования цифровой подписи.

Далее нужно скопировать URL Chrome-дополнения из Chrome WebStore и добавить его через меню "add to firefox, available on chrome" в Foxified. После этого во вкладке "chrome store foxified" нужно принять соглашение  Mozilla AMO. После завершения преобразования в верхнем правом углу появится кнопка "add" с предложением установить дополнение.

После этого переходим на страницу about:debugging  и активируем режим отладки дополнений ("enable add-on debugging"). Находим в списке дополнений преобразованное дополнение и определяем его идентификатор
(Extension ID), заданный в форме "*@chrome-store-foxified-*".

Закрываем Firefox 56 и находим в каталоге с дополнениями Firefox (/.mozilla/firefox/*/extensions) xpi-файл с найденным идентификатором.
Запускаем актуальный Firefox и устанавливаем полученный xpi-файл через кнопку с шестерёнкой в менеджере дополнений (about:addons), выбрав в меню "Install Add-on from File".

URL: https://github.com/Noitidart/Chrome-Store-Foxified/issues/12...
Обсуждается: https://www.opennet.ru/tips/info/3138.shtml

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


1. "Конвертация Chrome-дополнения для запуска в Firefox"  +/
Сообщение от Аноним (1), 05-Мрт-20, 10:58 
> В качестве обходного пути предлагается параллельно с основной актуальной

версией Firefox установить Firefox 56 и запустить в нём Foxified.

Какой-то цирк.

Ответить | Правка | Наверх | Cообщить модератору

2. "Конвертация Chrome-дополнения для запуска в Firefox"  +/
Сообщение от Аноним (2), 05-Мрт-20, 18:38 
пожалуй я не знаю настолько нужных дополнений
Ответить | Правка | Наверх | Cообщить модератору

3. "Конвертация Chrome-дополнения для запуска в Firefox"  +/
Сообщение от О (?), 09-Мрт-20, 06:59 
То есть нужно спалить неподдерживаемому расширению учетку мозиллы и потом на время о нем забыть?
Ответить | Правка | Наверх | Cообщить модератору

4. "Конвертация Chrome-дополнения для запуска в Firefox"  +/
Сообщение от X86 (ok), 28-Мрт-20, 08:37 
Расширению надо спалить учетку для этого расширения
Ответить | Правка | Наверх | Cообщить модератору

5. "Конвертация Chrome-дополнения для запуска в Firefox"  +/
Сообщение от mandms (?), 28-Мрт-20, 18:03 
Делал плагин для Firefox 57+, Кто пробовал кто скажет насколько легко Firefox плагин перенести в Chrome?
Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Слёрм
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру