The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Обновление JPype 1.0.2, библиотеки для доступа к Java-классам из Python "
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Обновление JPype 1.0.2, библиотеки для доступа к Java-классам из Python "  +/
Сообщение от opennews (?), 01-Авг-20, 09:28 
Доступен новый выпуск прослойки JPype 1.0.2, позволяющей организовать полный доступ Python-приложений к библиотекам классов на языке Java. При помощи JPype из Python можно использовать специфичные для Java библиотеки, создавая гибридные приложения, сочетающие код на  Java и Python. В отличие от  Jython, интеграция с Java достигается не через создание варианта Python для JVM, а через взаимодействие на уровне обеих виртуальных машин, используя разделяемую память. Предложенный подход позволяет не только добиться  хорошей производительности, но и предоставляет доступ ко всем библиотекам CPython и Java. Код проекта распространяется под лицензией Apache 2.0...

Подробнее: https://www.opennet.ru/opennews/art.shtml?num=53469

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


3. "Обновление JPype 1.0.2, библиотеки для доступа к Java-класса..."  +/
Сообщение от Аноним (3), 01-Авг-20, 10:41 
Чем это лучше py4j?
Ответить | Правка | Наверх | Cообщить модератору

4. "Обновление JPype 1.0.2, библиотеки для доступа к Java-класса..."  +/
Сообщение от Аноним (4), 01-Авг-20, 10:46 
Тем, что в py4j требуется кооперация с разрабом либы дя внедрения в неё GatewayServer. Взаимодействие идёт по сети, что медленно.
Ответить | Правка | Наверх | Cообщить модератору

25. "Обновление JPype 1.0.2, библиотеки для доступа к Java-класса..."  +/
Сообщение от Odalist (?), 06-Авг-20, 20:49 
Жава не нужен тк в тайлинге не применяется.
Ответить | Правка | К родителю #3 | Наверх | Cообщить модератору

5. "Обновление JPype 1.0.2, библиотеки для доступа к Java-класса..."  +1 +/
Сообщение от Аноним (5), 01-Авг-20, 12:15 
Как название библиотеки произносится по русски?
Ответить | Правка | Наверх | Cообщить модератору

6. "Обновление JPype 1.0.2, библиотеки для доступа к Java-класса..."  –3 +/
Сообщение от Аноним (4), 01-Авг-20, 13:12 
Хочешь форкнуть и внести в реестр "российского" ПО свой форк, но двойка по английскому не позволяет даже произнести название?
Ответить | Правка | Наверх | Cообщить модератору

7. "Обновление JPype 1.0.2, библиотеки для доступа к Java-класса..."  +1 +/
Сообщение от trolleybusemail (?), 01-Авг-20, 13:13 
Джейпайп, нет?
Ответить | Правка | К родителю #5 | Наверх | Cообщить модератору

9. "Обновление JPype 1.0.2, библиотеки для доступа к Java-класса..."  +1 +/
Сообщение от Аноним (9), 01-Авг-20, 13:31 
> по русски?

Жипипка

Ответить | Правка | К родителю #5 | Наверх | Cообщить модератору

15. "Обновление JPype 1.0.2, библиотеки для доступа к Java-класса..."  +/
Сообщение от Аноним (15), 01-Авг-20, 22:03 
Можешь читать как "жепупе", если хочешь.
Ответить | Правка | К родителю #5 | Наверх | Cообщить модератору

19. "Обновление JPype 1.0.2, библиотеки для доступа к Java-класса..."  +/
Сообщение от Karl Nelson (?), 02-Авг-20, 00:16 
Согласно "Google переводчик", "JPype" произносится Дж пэ пи. По-английски "JPype" рифмуется с пи-пи, как компромат.
Ответить | Правка | К родителю #5 | Наверх | Cообщить модератору

8. "Обновление JPype 1.0.2, библиотеки для доступа к Java-класса..."  +3 +/
Сообщение от Аноним (9), 01-Авг-20, 13:30 
> доступа к Java-классам из Python

И чего только не придумают, лишь бы на Си не писать.

Ответить | Правка | Наверх | Cообщить модератору

12. "Обновление JPype 1.0.2, библиотеки для доступа к Java-класса..."  +/
Сообщение от Аноним (4), 01-Авг-20, 18:03 
В одном месте уже на си написали, такой говнокод получился ...

struct pkginfo *pkg= (struct pkginfo*)argv[0]; // GPL-2.0+

Почему то почти везде, где чистый Си - там лютый говнокод. Видимо потому, что пишут его те, кого в к энтерпрайзу бы на милю не подпустили. Исключение - ядро Linux. Но IMHO и оттуда надо чистый си выпилить. Хотя бы из-за идиотского неявного приведения типов для указатели на функции, на которое я дохрена времени потратил, выискивая, где у меня memory safety проблемы. Оказалось - в прототипе в хедерах один тип, а в функциях, которые присваиваются в указатели - другой. И компилятор молчит.

В том же проекте: UB и утечки памяти.

Не говоря уже о проблемах, которые можно огрести абсолютно на ровном месте, используя вместо enumов препроцессор, и вместо inline-функций тоже препроцессор, как си-макаки любят. Видимо из совместимости с C89.

Ответить | Правка | Наверх | Cообщить модератору

21. "Обновление JPype 1.0.2, библиотеки для доступа к Java-класса..."  +/
Сообщение от asdasd (?), 03-Авг-20, 08:39 
> где чистый Си - там лютый говнокод

K&R C это чистый C? ANSI C чистый? C89 / 90 / 99 / 14 чистые? Про что вы говорите, это скорее всего какой-то старый код, потому он такой и есть.

> В том же проекте: UB и утечки памяти.

Кривые руки. Есть Valgrind, есть санитайзеры и есть статические анализаторы. C++ это тоже касается. Санитайзер с покрытием тестами находит все проблемы, если они и есть.

> и вместо inline-функций тоже препроцессор, как си-макаки любят

Макака которая это написала видимо даже Википедию не осилила, не говоря уже о стандарте. inline это РЕКОМЕНДАЦИЯ для компилятора, он может как ей последовать, так и забить болт. Плюс решаются проблемы линковки.

Ответить | Правка | Наверх | Cообщить модератору

22. "Обновление JPype 1.0.2, библиотеки для доступа к Java-класса..."  +/
Сообщение от Аноним (4), 03-Авг-20, 10:49 
>Макака которая это написала видимо даже Википедию не осилила, не говоря уже о стандарте. inline это РЕКОМЕНДАЦИЯ для компилятора, он может как ей последовать, так и забить болт.

Так и должно быть. Если имеет смысл заинлайнить - значит заинлайнит. Если не имеет - значит будет функция. Если ты не доверяшь компилятору, то пиши на ассемблере. В специфических случаях, когда надо гарантировать инлайн, используйте аттрибуты. Компилятор не поддерживает аттрибуты? На *** такой компилятор. Единственный компилятор для архитектуры имеет только C89? На *** такую архитектуру, переходите на ARM чипы.

>Плюс решаются проблемы линковки.

Нет никаких проблем линковки.

>Кривые руки. Есть Valgrind, есть санитайзеры и есть статические анализаторы. C++ это тоже касается. Санитайзер с покрытием тестами находит все проблемы, если они и есть.

Ими и нашёл.

  

Ответить | Правка | Наверх | Cообщить модератору

24. "Обновление JPype 1.0.2, библиотеки для доступа к Java-класса..."  +/
Сообщение от ann (??), 04-Авг-20, 20:44 
Сказал бы сразу, что неосилятор. Вместо того позориться сходил бы книжку почитал умную.
Ответить | Правка | К родителю #12 | Наверх | Cообщить модератору

10. "Обновление JPype 1.0.2, библиотеки для доступа к Java-класса..."  +/
Сообщение от Аноним (10), 01-Авг-20, 13:45 
и обратная библиотека Jep - запуск Python интерпретаторов в JVM:)
Ответить | Правка | Наверх | Cообщить модератору

14. "Обновление JPype 1.0.2, библиотеки для доступа к Java-класса..."  +/
Сообщение от Онаним (?), 01-Авг-20, 20:57 
PyJava же
Ответить | Правка | Наверх | Cообщить модератору

13. "Обновление JPype 1.0.2, библиотеки для доступа к Java-класса..."  +/
Сообщение от Аноним (13), 01-Авг-20, 18:04 
Интересно, jdbc через неё можно?
Ответить | Правка | Наверх | Cообщить модератору

16. "Обновление JPype 1.0.2, библиотеки для доступа к Java-класса..."  +/
Сообщение от Аноним (15), 01-Авг-20, 22:08 
Т.е. можно запустить javascript в java и интерпретировать его из python? Мне очень надо исполнять жс в питоне, но биндинги к симанки что-то тухлые и это не в8, приходилось дёргать ноду. Это всё очень медленно работает.
Ответить | Правка | Наверх | Cообщить модератору

17. "Обновление JPype 1.0.2, библиотеки для доступа к Java-класса..."  +/
Сообщение от Аноним (4), 01-Авг-20, 23:40 
Скорее всего вам лучше взять graalvm (node.js поверх truffle - в базовой комплектации) + graalpython, если graalpython имеет всё, что вам нужно.

>биндинги к симанки что-то тухлые

вы наверное имели в виду spidermonkey?

как вариант - firefox + marionette + webdriver + selenium.

Ответить | Правка | Наверх | Cообщить модератору

18. "Обновление JPype 1.0.2, библиотеки для доступа к Java-класса..."  +/
Сообщение от Аноним (15), 01-Авг-20, 23:47 
Да, наверное, оно. Спасибо, посмотрю. От браузера в этой схеме как раз и хотелось бы избавиться.
Ответить | Правка | Наверх | Cообщить модератору

23. "Обновление JPype 1.0.2, библиотеки для доступа к Java-класса..."  +1 +/
Сообщение от Явопитон (?), 03-Авг-20, 17:58 
Давно пора объеденить яву с питоном, присыпать .Нетом полить электроном и отправить всю эту жижу в нежилую галактику. А кто вспомнит их в нашей - рубить голову и запрещать размножаться.
Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру