The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Выпуск Util-linux 2.37"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Выпуск Util-linux 2.37"  +/
Сообщение от opennews (ok), 02-Июн-21, 07:20 
Вышла новая версия пакета системных утилит Util-linux 2.37, в который входят как тесно связанные с Linux-ядром утилиты, так и утилиты общего назначения. Например, в пакете представлены утилиты mount/umount, fdisk, hwclock, cal, blkid, fsck/cfdisk/sfdisk, blockdev, chrt, mkfs, ionice, more, renice, su, kill, setsid, login, shutdown, dmesg, lscpu, logger, losetup, setterm, mkswap, swapon, taskset и т.п...

Подробнее: https://www.opennet.ru/opennews/art.shtml?num=55250

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


2. "Выпуск Util-linux 2.37"  +2 +/
Сообщение от Аноним (2), 02-Июн-21, 07:25 
asciidoctor: Util-linux тепрь зависит от Ruby.
Ответить | Правка | Наверх | Cообщить модератору

5. "Выпуск Util-linux 2.37"  +/
Сообщение от Аноним (5), 02-Июн-21, 07:39 
makedepends
Ответить | Правка | Наверх | Cообщить модератору

6. "Выпуск Util-linux 2.37"  –1 +/
Сообщение от макпыф (ok), 02-Июн-21, 08:32 
можно маны и не собирать
Ответить | Правка | К родителю #2 | Наверх | Cообщить модератору

27. "Выпуск Util-linux 2.37"  +/
Сообщение от Ordu (ok), 02-Июн-21, 10:18 
$ equery uses sys-apps/util-linux | grep doc
$

Может и можно, но на сегодня ебилд util-linux'а собирает документацию принудительно. :(

Впрочем, возможно добавление руби в качестве депенданса спровоцирует мейнтейнеров добавить юз-флаг doc, и сделать документацию опциональной.

Ответить | Правка | Наверх | Cообщить модератору

28. "Выпуск Util-linux 2.37"  –1 +/
Сообщение от макпыф (ok), 02-Июн-21, 10:19 
> $ equery uses sys-apps/util-linux | grep doc
> $
> Может и можно, но на сегодня ебилд util-linux'а собирает документацию принудительно. :(
> Впрочем, возможно добавление руби в качестве депенданса спровоцирует мейнтейнеров добавить
> юз-флаг doc, и сделать документацию опциональной.

ну это только к маинтейнерам генты вопрос

я в лфс никогда маны util-linux не собирал, не через groff не через asciidoc

Ответить | Правка | Наверх | Cообщить модератору

48. "Выпуск Util-linux 2.37"  +/
Сообщение от n00by (ok), 02-Июн-21, 16:00 
> $ equery uses sys-apps/util-linux | grep doc
> $
> Может и можно, но на сегодня ебилд util-linux'а собирает документацию принудительно. :(

Не факт, что вообще собирает, судя по util-linux-2.37.ebuild

if [[ ${PV} == *9999 ]] ; then
        myeconfargs+=( --enable-asciidoc )
else
        # We ship pre-generated man-pages for releases
        myeconfargs+=( --disable-asciidoc )
fi

Ответить | Правка | К родителю #27 | Наверх | Cообщить модератору

8. "Выпуск Util-linux 2.37"  +/
Сообщение от я (?), 02-Июн-21, 08:37 
> Добавлена экспериментальная поддержка сборочной системы Meson.

и Python...
осталось на lua что нибудь прикрутить для полного счастия

Ответить | Правка | К родителю #2 | Наверх | Cообщить модератору

19. "Выпуск Util-linux 2.37"  +/
Сообщение от макпыф (ok), 02-Июн-21, 09:19 
>> Добавлена экспериментальная поддержка сборочной системы Meson.
> и Python...
> осталось на lua что нибудь прикрутить для полного счастия

там месон експериментальный и они говорят что в течении "next years" будут использовать autotools в качестве основной сборочной системы

Ответить | Правка | Наверх | Cообщить модератору

20. "Выпуск Util-linux 2.37"  –3 +/
Сообщение от Аноним (20), 02-Июн-21, 09:43 
Не, для полного счастья не хватает C#.
Ответить | Правка | К родителю #8 | Наверх | Cообщить модератору

38. "Выпуск Util-linux 2.37"  +1 +/
Сообщение от Аноним (38), 02-Июн-21, 11:34 
Хорошо бы, чтобы ещё на JS чего не прикрутили.
Ответить | Правка | К родителю #8 | Наверх | Cообщить модератору

10. "Выпуск Util-linux 2.37"  –3 +/
Сообщение от СеменСеменыч777 (?), 02-Июн-21, 08:50 
кому не нравится, могут сделать форк (лицензия позволяет же ?)
и тыкать им в рожу озвезденевшим смузихлебам.

ps: еще бы раст подключили.

Ответить | Правка | К родителю #2 | Наверх | Cообщить модератору

11. "Выпуск Util-linux 2.37"  +/
Сообщение от Аноним (-), 02-Июн-21, 08:53 
Могут и nodejs прикрутить и java и прочее, лишь бы было красиво
Ответить | Правка | К родителю #2 | Наверх | Cообщить модератору

13. "Выпуск Util-linux 2.37"  +/
Сообщение от Michael Shigorinemail (ok), 02-Июн-21, 09:02 
Тоже первое, что заметил; хотя Ruby изучал ещё по первой книжке с киркой, считаю, что это не менее чёткий признак деградации проекта, чем несколько лет назад появившийся /usr/bin/chmem (который сразу обозначил, что кто-то не пользуется chm<Tab> по назначению и не понимает разницы между восьмой и первой секцией манов, ну и тем, куда соответственно утилиту-то класть).  Увы.
Ответить | Правка | К родителю #2 | Наверх | Cообщить модератору

23. "Выпуск Util-linux 2.37"  +5 +/
Сообщение от макпыф (ok), 02-Июн-21, 09:51 
> Тоже первое, что заметил; хотя Ruby изучал ещё по первой книжке с
> киркой, считаю, что это не менее чёткий признак деградации проекта, чем
> несколько лет назад появившийся /usr/bin/chmem (который сразу обозначил, что кто-то не
> пользуется chm<Tab> по назначению и не понимает разницы между восьмой и
> первой секцией манов, ну и тем, куда соответственно утилиту-то класть).  
> Увы.

понятно, что вы это первым заметите - это же первый пункт чейнджлога ))

Ответить | Правка | Наверх | Cообщить модератору

41. "Выпуск Util-linux 2.37"  +1 +/
Сообщение от Аноним (41), 02-Июн-21, 11:58 
Изучал, но не осилил?
Ответить | Правка | К родителю #13 | Наверх | Cообщить модератору

53. "Выпуск Util-linux 2.37"  +/
Сообщение от Аноним (53), 02-Июн-21, 16:50 
> что кто-то не пользуется chm<Tab>

либо что кто-то пользуется fish

Ответить | Правка | К родителю #13 | Наверх | Cообщить модератору

69. "Выпуск Util-linux 2.37"  +/
Сообщение от n00by (ok), 03-Июн-21, 08:31 
> хотя Ruby изучал ещё по первой книжке с
> киркой, считаю, что это не менее чёткий признак деградации проекта, чем
> несколько лет назад появившийся /usr/bin/chmem

В чём дело с Ruby? Зависимость слишком жирная? Или его нет в LSB (я не знаю, не смотрел: /usr и так "везде" не read-only).

Ответить | Правка | К родителю #13 | Наверх | Cообщить модератору

74. "Выпуск Util-linux 2.37"  +1 +/
Сообщение от макпыф (ok), 01-Июл-21, 22:51 
для такого пакета как util-linux, предоставляющего низкоуровневые системные утилиты - да
Ответить | Правка | Наверх | Cообщить модератору

75. "Выпуск Util-linux 2.37"  +/
Сообщение от n00by (ok), 02-Июл-21, 10:16 
Portage в Gentoo написана на жирном Python. При обновлении Python (с 3.n на 3.n+1) можно умудриться и сломать Portage (если не следовать рекомендациям из eselect read news). Решается подобная "авария" достаточно просто: временным редактированием шебанга в каком-то из скриптов. А вот реально сломать систему при обновлении, когда её спасло лишь наличие открытой сессии ssh (без неё пришлось бы загружать с внешнего носителя), мне удалось прерыванием распаковки архива (бинарного пакета) с архиватором -- поскольку нежирная glibc прилинкована не статически. Но да, без роллинга такая ситуация мало кого волнует, glibc же не обновляется. Да и в самой Gentoo ситуация нетипична, поскольку обновляют пакетами редко.
Ответить | Правка | Наверх | Cообщить модератору

76. "Выпуск Util-linux 2.37"  +1 +/
Сообщение от макпыф (ok), 02-Июл-21, 14:07 
1. Это все дистро специфичные вещи. Я от дистра не завишу т.к. использую LFS

2. Util-linux - необходимый для работы любой GNU/Linux системы пакет, в отличие от portage

3. Python хоть и жирный, но нужен очень многим пакетам, в том числе для сборки ядра, так что в зависимости от него ни чего такого нету. А вот ruby нужен 1.5 пакету и весьма жирный. Хорошо что зависимость опциональная

Ответить | Правка | Наверх | Cообщить модератору

77. "Выпуск Util-linux 2.37"  +1 +/
Сообщение от n00by (ok), 02-Июл-21, 14:20 
Это был пример, когда точкой отказа являются не "жирные" зависимости, а вполне обычные. И никого оно не волнует.
Ответить | Правка | Наверх | Cообщить модератору

78. "Выпуск Util-linux 2.37"  +1 +/
Сообщение от макпыф (ok), 02-Июл-21, 14:22 
> Это был пример, когда точкой отказа являются не "жирные" зависимости, а вполне
> обычные. И никого оно не волнует.

ну про точки отказа я ничего не говорил. Ruby нужен только для _сборки_ манов

Ответить | Правка | Наверх | Cообщить модератору

79. "Выпуск Util-linux 2.37"  +1 +/
Сообщение от n00by (ok), 02-Июл-21, 14:35 
> Ruby нужен только для _сборки_ манов

Вот это меня и удивило. В Альте сборка происходит на сервере. Ruby всё равно приходится собирать, что бы пакеты просто были. Система пользователя не замусоривается, если он не хочет Ruby.

Ответить | Правка | Наверх | Cообщить модератору

80. "Выпуск Util-linux 2.37"  +2 +/
Сообщение от макпыф (ok), 02-Июл-21, 14:45 
> Вот это меня и удивило. В Альте сборка происходит на сервере. Ruby
> всё равно приходится собирать, что бы пакеты просто были.

Ну Шигорин писал про деградацию проекта, не обязательно это только про альт

> Система пользователя не замусоривается, если он не хочет Ruby.

И даже если ему надо собрать Util-linux вместе с манами?

П.С. Я например при сборке лфс ставлю основной целью оптимизацию, но, т.к. у меня мощное железо, производительность мерить не удобно и я мерю по размеру. К счастью маны мне не нужны, но если бы  были нужны то это была бы большая проблема

Ответить | Правка | Наверх | Cообщить модератору

81. "Выпуск Util-linux 2.37"  +1 +/
Сообщение от n00by (ok), 03-Июл-21, 06:47 
>> Вот это меня и удивило. В Альте сборка происходит на сервере. Ruby
>> всё равно приходится собирать, что бы пакеты просто были.
> Ну Шигорин писал про деградацию проекта, не обязательно это только про альт

У него сложилось своё представление "идеальной ОС", к которому Альт стремится и куда зависимость от Ruby не укладывается.

>> Система пользователя не замусоривается, если он не хочет Ruby.
> И даже если ему надо собрать Util-linux вместе с манами?

Ну Вы же сами собираете Линукс. Значит должны знать ответ на вопрос и без меня. В Gentoo где-то берут man-ы.


$ diff -u util-linux-2.36.2.ebuild util-linux-2.37.ebuild

@@ -203,9 +236,16 @@
            $(use_enable tty-helpers write)
            $(use_with cryptsetup)
        )
+        if [[ ${PV} == *9999 ]] ; then
+            myeconfargs+=( --enable-asciidoc )
+        else
+            # We ship pre-generated man-pages for releases
+            myeconfargs+=( --disable-asciidoc )
+        fi
    else
        myeconfargs+=(
            --disable-all-programs
+            --disable-asciidoc
            --disable-bash-completion
            --without-systemdsystemunitdir
            # build libraries


А в Альте и так вообще всё собрано.
Ответить | Правка | Наверх | Cообщить модератору

82. "Выпуск Util-linux 2.37"  +1 +/
Сообщение от макпыф (ok), 03-Июл-21, 08:36 
> +   # We ship pre-generated man-pages for releases

А, если есть pre-generated man-pages - это хорошо

Ответить | Правка | Наверх | Cообщить модератору

84. "Выпуск Util-linux 2.37"  +/
Сообщение от Michael Shigorinemail (ok), 04-Сен-21, 15:59 
> У него сложилось своё представление "идеальной ОС", к которому Альт стремится

Давайте всё-таки за себя я сам говорить буду -- когда коряво, лучше переспросить, вдруг вернусь позже, замечу и отвечу (или если важно, то лучше почтой продублировать).

> и куда зависимость от Ruby не укладывается.

Вот это утверждение неверно.

Сказать пытался, что бездумное обрастание лишними зависимостями видно мало кому (обычно тем, кто либо давно сопровождает проект/пакет, либо тем, кто столкнулся с мусором при бутстрапе) -- но это один из достаточно чётких маркеров, увы.

Ответить | Правка | К родителю #81 | Наверх | Cообщить модератору

85. "Выпуск Util-linux 2.37"  +/
Сообщение от n00by (ok), 04-Сен-21, 18:30 
>> У него сложилось своё представление "идеальной ОС", к которому Альт стремится
> Давайте всё-таки за себя я сам говорить буду -- когда коряво, лучше
> переспросить, вдруг вернусь позже, замечу и отвечу (или если важно, то
> лучше почтой продублировать).

А что в конкретно этом утверждении не так? Странно было бы, если бы представления не было. Кавычки там -- поскольку идеал по определению недостижим.

>> и куда зависимость от Ruby не укладывается.
> Вот это утверждение неверно.
> Сказать пытался, что бездумное обрастание лишними зависимостями видно мало кому (обычно
> тем, кто либо давно сопровождает проект/пакет, либо тем, кто столкнулся с
> мусором при бутстрапе) -- но это один из достаточно чётких маркеров,
> увы.

"Лишняя". Если Ruby нужен для asciidoc, значит не лишняя. До этого генерировали без Ruby, была другая зависимость, потому я грубо сравнил их размер в байтах и назвал новую жирной.

"Бездумное". https://github.com/karelzak/util-linux/issues/1257
Говорится об обеспечении когерентности версий util-linux и мануалов, а так же об интеграции переводов в апстрим. В связи с чем реализовали ранее запланированный переход на новый инструмент. "And besides that, asciidoc is much easier to maintain than *roff". Как минимум, о чём-то они думали и обсуждали в рассылке util-linux@ (не читал). Кроме того, пришли к опциональности зависимости, что (наверное) смягчает неудобства при бутстрапе.

Зависимость от Ruby - она объективна. Сейчас я понял, что моему предположению следовало быть более общим ("новая зависимость не укладывается"). Вероятно, это связано с бутстрапом и Эльбрусом, но уже не важно -- в issues/1257 нашёл на первый взгляд разумное обоснование от разработчиков.

Ответить | Правка | Наверх | Cообщить модератору

83. "Выпуск Util-linux 2.37"  +/
Сообщение от Michael Shigorinemail (ok), 04-Сен-21, 15:55 
>> В чём дело с Ruby? Зависимость слишком жирная?
> для такого пакета как util-linux, предоставляющего низкоуровневые системные
> утилиты - да

Именно.

Ответить | Правка | К родителю #74 | Наверх | Cообщить модератору

7. "Выпуск Util-linux 2.37"  +3 +/
Сообщение от макпыф (ok), 02-Июн-21, 08:36 
> В umount обеспечено отмонтирование всех вложенных точек монтирования при указании флага "--recursive".

А вот это очень хорошо, по мойму. А то когда выходишь из чрута все отмонтировать долго очень.

П.С. Ведь нет ничего плохого в комментировании своих новостей =)?

Ответить | Правка | Наверх | Cообщить модератору

14. "Выпуск Util-linux 2.37"  +/
Сообщение от Michael Shigorinemail (ok), 02-Июн-21, 09:02 
Да; да.
:)
Ответить | Правка | Наверх | Cообщить модератору

39. "Выпуск Util-linux 2.37"  +/
Сообщение от Аноним (38), 02-Июн-21, 11:41 
>П.С. Ведь нет ничего плохого в комментировании своих новостей =)?

Иногда просто что-то забыл сказать. Поэтому такой комент можно рассматривать как дополнение.

Ответить | Правка | К родителю #7 | Наверх | Cообщить модератору

9. "Выпуск Util-linux 2.37"  –1 +/
Сообщение от макпыф (ok), 02-Июн-21, 08:43 
> su

А кстати - откуда эту утилиту лучше использовать - из данного пакета или из shadow ?

в лфс из shadow рекомендуется, а в убунте она из util-linux

Ответить | Правка | Наверх | Cообщить модератору

15. "Выпуск Util-linux 2.37"  –5 +/
Сообщение от Michael Shigorinemail (ok), 02-Июн-21, 09:03 
В альте из SimplePAMApps: http://www.linux-pam.org/pre/applications/
Ответить | Правка | Наверх | Cообщить модератору

17. "Выпуск Util-linux 2.37"  +/
Сообщение от макпыф (ok), 02-Июн-21, 09:05 
> В альте из SimplePAMApps: http://www.linux-pam.org/pre/applications/

ну этого у меня вообще не стоит и в ближайшее время думаю не будет

Ответить | Правка | Наверх | Cообщить модератору

12. "Выпуск Util-linux 2.37"  +1 +/
Сообщение от ryoken (ok), 02-Июн-21, 08:54 
>>  В lsblk предложены новые столбцы FSROOTS и MOUNTPOINTS.

Если всё нужное ставить - и так вывод на километр по ширине получается :).

Ответить | Правка | Наверх | Cообщить модератору

16. "Выпуск Util-linux 2.37"  +2 +/
Сообщение от Michael Shigorinemail (ok), 02-Июн-21, 09:04 
А вот за lsblk, кстати, взявшимся за util-linux{,-ng} и впрямь благодарен: полезная штука.
Ответить | Правка | Наверх | Cообщить модератору

29. "Выпуск Util-linux 2.37"  –1 +/
Сообщение от InuYasha (??), 02-Июн-21, 10:21 
++ без него не едят(ц).
Толко я не понял, в чём нововведение MOUNTPOINT_S_ - он показвает множественные точки монтирования?
Ответить | Правка | Наверх | Cообщить модератору

18. "Выпуск Util-linux 2.37"  +/
Сообщение от Oxyd76 (?), 02-Июн-21, 09:12 
— Доктор, когда я делаю «вот так» у меня болит!
— А вы «так» не делайте!
©
Ответить | Правка | К родителю #12 | Наверх | Cообщить модератору

22. "Выпуск Util-linux 2.37"  –1 +/
Сообщение от Аноним (22), 02-Июн-21, 09:50 
>>  В cfdisk добавлена опция "--read-only" для запуска в режиме только для чтения.

Чем это поможет если fs уже в режиме ro?

Ответить | Правка | Наверх | Cообщить модератору

35. "Выпуск Util-linux 2.37"  +3 +/
Сообщение от Аноним (35), 02-Июн-21, 11:12 
А какое отношение ФС имеет к таблице разделов?
Ответить | Правка | Наверх | Cообщить модератору

36. "Выпуск Util-linux 2.37"  –2 +/
Сообщение от Аноним (22), 02-Июн-21, 11:15 
Не знаю, но когда JFS в режиме ro? Мало, что можно сделать, смонтировать снова fs можно было и c livecd.
Ответить | Правка | Наверх | Cообщить модератору

24. "Выпуск Util-linux 2.37"  +2 +/
Сообщение от Аноним (24), 02-Июн-21, 10:08 
Всё, надоело! Иду делать свой дистрибутив!
Ответить | Правка | Наверх | Cообщить модератору

25. "Выпуск Util-linux 2.37"  +1 +/
Сообщение от Аноним (22), 02-Июн-21, 10:15 
Называться будет Util-linux Linux?
Ответить | Правка | Наверх | Cообщить модератору

30. "Выпуск Util-linux 2.37"  –1 +/
Сообщение от Аноним (35), 02-Июн-21, 10:24 
> В hexdump обеспечено автоматическое включение опции "-C" при вызове в форме "hd".

У меня оно так работает в 2.36.1
При чем повторяет строки в зависимости от количества ключей "-C". Очень странно https://pastebin.com/9izkNGp5

Ответить | Правка | Наверх | Cообщить модератору

31. "Выпуск Util-linux 2.37"  –1 +/
Сообщение от tester (??), 02-Июн-21, 10:35 
> Вышла новая версия пакета системных утилит Util-linux 2.37, в который входят как
> тесно связанные с Linux-ядром утилиты, так и утилиты общего назначения. Например,
> в пакете представлены утилиты mount/umount, fdisk, hwclock, cal, blkid, fsck/cfdisk/sfdisk,
> blockdev, chrt, mkfs, ionice, more, renice, su, kill, setsid, login, shutdown,
> dmesg, lscpu, logger, losetup, setterm, mkswap, swapon, taskset и т.п...
> Подробнее: https://www.opennet.ru/opennews/art.shtml?num=55250

а где утилита из RS232 в raw keyboard input?

Ответить | Правка | Наверх | Cообщить модератору

37. "Выпуск Util-linux 2.37"  –1 +/
Сообщение от tester (??), 02-Июн-21, 11:29 
>> Вышла новая версия пакета системных утилит Util-linux 2.37, в который входят как
>> тесно связанные с Linux-ядром утилиты, так и утилиты общего назначения. Например,
>> в пакете представлены утилиты mount/umount, fdisk, hwclock, cal, blkid, fsck/cfdisk/sfdisk,
>> blockdev, chrt, mkfs, ionice, more, renice, su, kill, setsid, login, shutdown,
>> dmesg, lscpu, logger, losetup, setterm, mkswap, swapon, taskset и т.п...
>> Подробнее: https://www.opennet.ru/opennews/art.shtml?num=55250
> а где утилита из RS232 в raw keyboard input?

час поиска, и на github нашел, вроде то что нужн

Ответить | Правка | Наверх | Cообщить модератору

42. "Выпуск Util-linux 2.37"  +/
Сообщение от Какаянахренразница (ok), 02-Июн-21, 12:47 
Руби?!?!? Пропал калабуховский дом...
Ответить | Правка | Наверх | Cообщить модератору

45. "Выпуск Util-linux 2.37"  +4 +/
Сообщение от yet another anonymous (?), 02-Июн-21, 14:06 
> Для генерации man-страниц вместо groff задействован пакет asciidoctor.

Ну всё, #%$&*%)%_Q@#$, мы потеряли маны. Кто там такой одарённый это родил?

Ответить | Правка | Наверх | Cообщить модератору

46. "Выпуск Util-linux 2.37"  +/
Сообщение от Аноним (-), 02-Июн-21, 14:14 
Третье полуядро Линуха.
А можно все утилс в один пакет утилит, по типу утилит от Нортона для W95? Ну че, слабо ?
Второе glibc.
Ответить | Правка | Наверх | Cообщить модератору

62. "Выпуск Util-linux 2.37"  +/
Сообщение от And (??), 02-Июн-21, 23:25 
Зачем???

Упаковано единым пакетом в виде дистра операционки и - удобно вполне, все всё понимают.

P.S. Посмотри apt-file search...

Ответить | Правка | Наверх | Cообщить модератору

49. "Выпуск Util-linux 2.37"  –1 +/
Сообщение от Мамкин Хакер (?), 02-Июн-21, 16:25 
rename у кого работает?
rename file file1
rename: недостаточно аргументов
и так со всеми вариантами,
mv file file1 работает
Ответить | Правка | Наверх | Cообщить модератору

50. "Выпуск Util-linux 2.37"  +/
Сообщение от Ананимус (?), 02-Июн-21, 16:28 
NAME
       rename - rename files

SYNOPSIS
       rename [options] expression replacement file...

Ответить | Правка | Наверх | Cообщить модератору

52. "Выпуск Util-linux 2.37"  –1 +/
Сообщение от Мамкин Хакер (?), 02-Июн-21, 16:45 
file file1 это не expression replacement file
т.е. у Вас работает,ну спасибо!
Ответить | Правка | Наверх | Cообщить модератору

55. "Выпуск Util-linux 2.37"  –1 +/
Сообщение от Мамкин Хакер (?), 02-Июн-21, 18:25 
работает так
rename file file1 *
подробнее в примерах man
rename из util-linux 2.36.2
Ответить | Правка | Наверх | Cообщить модератору

51. "Выпуск Util-linux 2.37"  –1 +/
Сообщение от Ананимус (?), 02-Июн-21, 16:29 
А документация для ядра собирается... С ПОМОЩЬЮ SPHINX. Все, выкидываем ядро на помойку.
Ответить | Правка | Наверх | Cообщить модератору

54. "Выпуск Util-linux 2.37"  –1 +/
Сообщение от Иваня (?), 02-Июн-21, 16:54 
Как обновиться в Ubuntu? ^_^
Ответить | Правка | Наверх | Cообщить модератору

57. "Выпуск Util-linux 2.37"  –1 +/
Сообщение от Zenitur (ok), 02-Июн-21, 19:02 
sudo apt-get build-dep util-linux
apt-get -b source util-linux
Ответить | Правка | Наверх | Cообщить модератору

56. "Выпуск Util-linux 2.37"  –2 +/
Сообщение от Zenitur (ok), 02-Июн-21, 19:01 
> Добавлена экспериментальная поддержка сборочной системы Meson

Как этим месоном пользоваться без Python3?

Ответить | Правка | Наверх | Cообщить модератору

58. "Выпуск Util-linux 2.37"  +/
Сообщение от Аноним (58), 02-Июн-21, 20:00 
В hardlink не хватает опции оставлять самый старый файл. И по-моему оно параллельно что-то делает, это ок на твердотельных накопителях, но на НЖМД это очень не очень. Ещё хотелось бы ревертить время изменения каталога, если там только файл на хардлинк с другим временем заменён.
Ответить | Правка | Наверх | Cообщить модератору

59. "Выпуск Util-linux 2.37"  –2 +/
Сообщение от нах.. (?), 02-Июн-21, 20:46 
Новая реализация не поддерживает параметр "-f" для принудительного создания жёстких ссылок между файловыми системами

Ура мы создали ущербную в реализации замену, радуйтесь?

Ответить | Правка | Наверх | Cообщить модератору

61. "Выпуск Util-linux 2.37"  +/
Сообщение от And (??), 02-Июн-21, 22:25 
Усчербность могла быть именно в насилии. :)
Ответить | Правка | Наверх | Cообщить модератору

63. "Выпуск Util-linux 2.37"  +/
Сообщение от Аноним (63), 02-Июн-21, 23:27 
"Принудительность" там была очень условная, hardlink(1) просто тихо пропускал такие файлы при указании -f
Ответить | Правка | К родителю #59 | Наверх | Cообщить модератору

67. "Выпуск Util-linux 2.37"  +1 +/
Сообщение от Аноним (67), 03-Июн-21, 03:36 
Как вы себе представляете _жёсткую_ ссылку между ФС?
Ответить | Правка | К родителю #59 | Наверх | Cообщить модератору

70. "Выпуск Util-linux 2.37"  +/
Сообщение от нах.. (?), 03-Июн-21, 10:25 
ну это была такая же костылина как rm -f - не может создать ссылку, просто молча ничего и не делает.

Скрипты завязанные на такое поведение - могут и мала-мала паламалася.

Ответить | Правка | Наверх | Cообщить модератору

60. "Выпуск Util-linux 2.37"  +/
Сообщение от And (??), 02-Июн-21, 22:18 
Новость - прелесть. )
Ответить | Правка | Наверх | Cообщить модератору

68. "Выпуск Util-linux 2.37"  +/
Сообщение от Аноним (68), 03-Июн-21, 06:21 
Busybox для десктопа вполне достаточно.
Ответить | Правка | Наверх | Cообщить модератору

71. "Выпуск Util-linux 2.37"  +/
Сообщение от Ilya Indigo (ok), 03-Июн-21, 21:53 
Чем hardlink лучше symlink?
Никогда не приходилось использовать ln без -s.
Ответить | Правка | Наверх | Cообщить модератору

72. "Выпуск Util-linux 2.37"  +/
Сообщение от Аноним (58), 04-Июн-21, 00:27 
Тем что файлы можно переместить. И ещё симлинки это дополнительный мусор на диске. Вообще, они почти всегда битые в итоге.
Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру