The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Доступен дистрибутив blendOS 3, поддерживающий пакеты из других дистрибутивов"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Доступен дистрибутив blendOS 3, поддерживающий пакеты из других дистрибутивов"  +/
Сообщение от opennews (??), 07-Июл-23, 17:32 
Опубликован выпуск дистрибутива blendOS 3, использующего контейнерную изоляцию для обеспечения сосуществования в одной системе пакетов из различных дистрибутивов Linux. Для установки пакетов предоставляется обвязка, позволяющая ставить пакеты в форматах APK, DEB и RPM из репозиториев  Debian 12, Ubuntu 22.04/23.04, Fedora 38, Arch Linux, Crystal Linux, Kali Linux, AlmaLinux 9 и Rocky Linux, а также устанавливать Android-приложения из каталогов Google Play и F-Droid. Для загрузки подготовлено 7 сборок c пользовательскими окружениями  GNOME, KDE, Cinnamon, Deepin, Mate, Xfce и LXQt (размер iso-образов приблизительно 3.5 ГБ)...

Подробнее: https://www.opennet.ru/opennews/art.shtml?num=59399

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


1. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +3 +/
Сообщение от Аноним (1), 07-Июл-23, 17:32 
It's alive!
Ответить | Правка | Наверх | Cообщить модератору

2. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +3 +/
Сообщение от Анонус (?), 07-Июл-23, 17:38 
10 (уже 13) летние Убунты разрабатывают. 14 летние Теслам мозги вкручивают. Что не так с этими детьми?
Ответить | Правка | Наверх | Cообщить модератору

4. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +3 +/
Сообщение от Аноним (4), 07-Июл-23, 17:42 
Доступность и открытость образования, сыграла свою роль.
Ответить | Правка | Наверх | Cообщить модератору

5. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +1 +/
Сообщение от pashev.ru (?), 07-Июл-23, 17:47 
Эксплуатация деццкого труда.
Ответить | Правка | К родителю #2 | Наверх | Cообщить модератору

13. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +9 +/
Сообщение от Аноним (13), 07-Июл-23, 18:06 
Всё с ними так. Наблюдаю за своим четырнадцатилетним отпрыском, развивается семимильными шагами, на радость родителям. Я в этом возрасте был куда тупее, и интересовался по большей части тем, как в подворотне покурить чтобы мамка не спалила. Да и в целом имел весьма печальный взгляд на жизнь. А эти вон оптимистично настроены, уже какой-то мелкий бизнес пытаются организовать, умные вопросы задают как ценообразование работает и под какие условия я готов инвестировать в их проект триста баксов на инструмент и запчасти. Бальзам на мою иссечённую совковой действительностью и её последствиями душу.
Ответить | Правка | К родителю #2 | Наверх | Cообщить модератору

18. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +8 +/
Сообщение от Аноним (18), 07-Июл-23, 18:30 
Лучше бы пил. Сейчас сделает финтех очередной, и потом будет под хэштегом сидеть
Ответить | Правка | Наверх | Cообщить модератору

43. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +3 +/
Сообщение от Анонус (?), 07-Июл-23, 20:21 
А уж какой бальзам прольется, когда твое чадо сдаст тебя в дом престарелых: "ведь так намного экономнее и рациональнее, чем держать дома немощного бесполезного старика".
Ответить | Правка | К родителю #13 | Наверх | Cообщить модератору

56. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +2 +/
Сообщение от какработать (?), 07-Июл-23, 20:53 
Хорошо, если в дом престарелых. А то сейчас стало модно сдавать в другие органы.
Ответить | Правка | Наверх | Cообщить модератору

84. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от mistiqemail (ok), 10-Июл-23, 01:01 
после подворотни у бедняги органы так себе.
Ответить | Правка | Наверх | Cообщить модератору

62. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +6 +/
Сообщение от Kuromi (ok), 07-Июл-23, 21:16 
На самом деле все просто - для подростка из Индии это возможность впоследствии получить приглашение из города Фашингтонв и визу в Америстан. Всяко лучше чем на поезде зацепером кататься.
Так что пацан малацца, другой вопрос что подобные прожекты имеют обыновение накрываться тазом как только такой вот создатель теряет к ним интерес или ресурсы на сопровождение.

Ну и напомню известный призыв "Хватить делать дистрибутивы, делайте софт"

Ответить | Правка | К родителю #2 | Наверх | Cообщить модератору

75. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Аноним (75), 08-Июл-23, 01:07 
А для Kuromi использование таких слов - это клеймо на всю жизнь.
Ответить | Правка | Наверх | Cообщить модератору

86. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Аноним (86), 10-Июл-23, 14:14 
Внутривидовая конкуренция всё растёт, поэтому снова возвращаются к детскому труду ("А я пахал с пеленок и знаю жизнь, сопляки!")
Ответить | Правка | К родителю #2 | Наверх | Cообщить модератору

87. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Аноним (86), 10-Июл-23, 14:16 
Гонки за успешным успехом
Ответить | Правка | К родителю #2 | Наверх | Cообщить модератору

98. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Neon (??), 12-Июл-23, 23:34 
Ага и ответственность за свой труд тоже детская.)))
Ответить | Правка | К родителю #2 | Наверх | Cообщить модератору

3. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +12 +/
Сообщение от Аноним (4), 07-Июл-23, 17:41 
Даже 13-ти летний  индус понимает каким должен быть нормальный линукс. А до больших корпов всё не дойдет какими надо делать дистры для десктопа.
Ответить | Правка | Наверх | Cообщить модератору

6. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от pashev.ru (?), 07-Июл-23, 17:48 
Как Шива, да?
Ответить | Правка | Наверх | Cообщить модератору

10. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от pashev.ru (?), 07-Июл-23, 17:50 
Или даже Брахма )
Ответить | Правка | Наверх | Cообщить модератору

8. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +4 +/
Сообщение от Аноным (ok), 07-Июл-23, 17:48 
Никто из корпораций для десктопа ничего и не делает, Убунта раньше пыталась, но это было давно
Ответить | Правка | К родителю #3 | Наверх | Cообщить модератору

12. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +2 +/
Сообщение от Аноним (4), 07-Июл-23, 17:52 
Ну вот оказалось что кроме мелкого индуса нам больше не на кого рассчитывать. Новый поттеринг на подходе.
Ответить | Правка | Наверх | Cообщить модератору

28. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Аноним (28), 07-Июл-23, 19:31 
Ну а зато местные эксперты скажут что очередной Болдженосч от Дениски с нескучными обоями не нужен.
Ответить | Правка | Наверх | Cообщить модератору

74. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +1 +/
Сообщение от sin (??), 08-Июл-23, 00:23 
очередной Болдженосч от Дениски с нескучными обоями не нужен.
Ответить | Правка | Наверх | Cообщить модератору

58. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от какработать (?), 07-Июл-23, 20:54 
И это тупик. Очередной.
Ответить | Правка | К родителю #12 | Наверх | Cообщить модератору

64. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Аноним (4), 07-Июл-23, 21:27 
Когда продвигаешься по лабиринту тебя всегда будет ждать тупик. Но если до тупика прошел, значит ты уже явно куда-то продвинулся.  
Ответить | Правка | Наверх | Cообщить модератору

66. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +1 +/
Сообщение от какработать (?), 07-Июл-23, 21:33 
>ты уже явно куда-то продвинулся

Да. В тупик.

Ответить | Правка | Наверх | Cообщить модератору

92. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +2 +/
Сообщение от zog (??), 11-Июл-23, 15:24 
> Даже 13-ти летний  индус понимает каким должен быть нормальный линукс.

Спешу тебя огорчить, подход blendOS совершенно глупый и тупиковый. Linux должен убить в себе фрагментацию - не должно быть 100500 дистрибутивов и не должно быть сторонних маинтейнеров пакетов прикладного софта. Прикладной софт должен собираться их авторами и работать нативно.

Ответить | Правка | К родителю #3 | Наверх | Cообщить модератору

99. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Neon (??), 12-Июл-23, 23:40 
Похоже, этого не будет никогда. Ведь каждый из авторов 100500 дистрибутивов неповторимая и уникальная личность со своим боХатым внутренним миром.))) Все они скорее удавятся, чем договорятся между собой о едином дистрибутиве.
Ответить | Правка | Наверх | Cообщить модератору

106. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Neon (??), 12-Июл-23, 23:51 
Как только не извращаются, вместо того, чтобы договориться и сделать единый один единственный дистрибутив. А не плодить на коленке сотнями. А ведь так никогда и не договорятся. Ведь каждый автор дистрибутива уникальная неповторимая личность во Вселенной со своим уникальным видением мира.))) Опухшее ЧСВ не даст договориться
Ответить | Правка | К родителю #3 | Наверх | Cообщить модератору

110. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Аноним (110), 13-Июл-23, 10:32 
Не нужно один единственный. Нужен референсный. А плодить дистрибы пускай продолжают, если припекает. Просто должен будет быть кто-то, кто потом скажет: этот дистриб референсно-совместимый, а эти вот - нет (авторы дистриба в первую очередь должны быть этими "кем-то").
И тогда софт и игры можно делать под референсный и класть болт на всех референсно-НЕсовместимых (а у референсно-совместимых сфот/игра будет или "работает" или (если не будет запускаться) тогда "ЭТО БАГ, вот вам репорт - идите чините").
Ответить | Правка | Наверх | Cообщить модератору

7. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Chromium (ok), 07-Июл-23, 17:48 
Я предполагаю, что всё это делается при поддержке взрослых людей. Но на месте Google я бы выгнал вечно ноющих токсичных разработчиков из отдела ChromeOS и взял бы Рудру Сарасвата. Он уже реализовал большую часть функционала ChromeOS, но на базе нормальной платформы.
Ответить | Правка | Наверх | Cообщить модератору

89. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  –1 +/
Сообщение от Аноним (86), 10-Июл-23, 14:22 
> Я предполагаю, что всё это делается при поддержке взрослых людей.

100% его ручкой кто-то водит, но дети/подростки - это очень удобный бренд

Ответить | Правка | Наверх | Cообщить модератору

109. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Neon (??), 12-Июл-23, 23:54 
Не только. И ответственности при случае никакой. Детское качество, что же вы хотите. Они же дети.)))
Ответить | Правка | Наверх | Cообщить модератору

17. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +1 +/
Сообщение от Аноним (17), 07-Июл-23, 18:29 
YixOS на минималках?
Ответить | Правка | Наверх | Cообщить модератору

45. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +1 +/
Сообщение от Анонус (?), 07-Июл-23, 20:27 
> YixOS на минималках?

Скорее QubeOS. С Никсом ничего общего.

Ответить | Правка | Наверх | Cообщить модератору

19. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  –1 +/
Сообщение от Аноним (28), 07-Июл-23, 18:35 
>Для установки пакетов предоставляется обвязка, позволяющая ставить пакеты в форматах APK, DEB и RPM

Ничего кроме DEB не нужно. Весь нужный пользовательский софт и так идёт в DEB. RPM ни разу не приходилось ставить. APK на десктопе тем более.

Ответить | Правка | Наверх | Cообщить модератору

21. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +2 +/
Сообщение от ИмяХ (?), 07-Июл-23, 18:52 
Если тебе не нужно, это не значит, что всем не нужно. Андроидовский 2гис в apk, например, гораздо функциональные десктопной версии.
Ответить | Правка | Наверх | Cообщить модератору

23. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Аноним (4), 07-Июл-23, 19:00 
На десктопный 2 гис помоему забили он выглядит как-то древне, хотя его и пытаются омолаживать.
Ответить | Правка | Наверх | Cообщить модератору

24. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Аноним (28), 07-Июл-23, 19:00 
Если мне не нужно, то никому не нужно.
Пусть делают 2ГИС делают десктопную версию такой же функциональной как и мобильную.
Пусть делают Линукс версии игр а не запускают виндовс игры в эмуляции.
Ответить | Правка | К родителю #21 | Наверх | Cообщить модератору

55. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Аноним (4), 07-Июл-23, 20:52 
Вот они и не делают, потому что кто ты такой что ради тебя надо перенапрягаться.  
Ответить | Правка | Наверх | Cообщить модератору

85. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от mistiqemail (ok), 10-Июл-23, 01:04 
с языка сорвал... не только 2GIS. Попался мне в руки ноутопланшет с линуксом и возможностью установки винды... Надо было туда навигацию поставить, желательно с офлайн режимом. Как итог оказалось что ни под венду, ни под линукс навигации нет от слова совсем, угребище нроут даже не предлагать.  maps.me и прочие из эмуляторов не захотели видеть  GPS модуль.
Ответить | Правка | К родителю #21 | Наверх | Cообщить модератору

22. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +7 +/
Сообщение от Аноним (4), 07-Июл-23, 18:59 
DEB для какой версии и какого дистра Убунты или Дебиана? Думаешь что все дебы всегда работают на любой версии? Спешу тебя огорчить это не так. Один деб может нормально только на одном дистре и на одной версии.
Ответить | Правка | К родителю #19 | Наверх | Cообщить модератору

25. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  –3 +/
Сообщение от Аноним (28), 07-Июл-23, 19:01 
Значит пусть своевременно выпускают новые версии пакета, под новую версию дистрибутива. Казалось бы такая простая вещь, а надо объяснять анонимам.
Ответить | Правка | Наверх | Cообщить модератору

27. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +1 +/
Сообщение от Аноним (27), 07-Июл-23, 19:13 
А если автор по каким-то причинам забили, или вообще помер?
У пользователей Windows такой проблемы нет, setup.exe и поехали.
Ответить | Правка | Наверх | Cообщить модератору

29. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +1 +/
Сообщение от Аноним (28), 07-Июл-23, 19:32 
Автор программы для Виндовс не бессмертные? Или все программы для всех версий Виндовс запускаются без проблем?
Ответить | Правка | Наверх | Cообщить модератору

32. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +3 +/
Сообщение от Аноним (4), 07-Июл-23, 19:42 
Блобный софт на 7, отлично работает и в 10 и в 11. Для Линукса это невозможная магия. Линукс из коробки ущербен потому что живет в 1970-ом году.
Ответить | Правка | Наверх | Cообщить модератору

35. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Аноним (28), 07-Июл-23, 19:47 
Ну вопрос к рептилоидам с планеты Нибиру, которые курируют разработку Линукс. Что они такого заставляют ломать в новых версиях. И почему программисты соглашаются на это.
Хотя не удивительно, если даже KDE в каждой новой версии целенаправленно ломают ABI.
Ответить | Правка | Наверх | Cообщить модератору

39. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Аноним (4), 07-Июл-23, 19:52 
Чел давай ты сделаешь релакс? Ущербность пакетов решается контейнерами. Решения даже на мой взгляд не лучшее, но зато рабочее. Всё можно смело выкидывать большую часть ненужных даже тебе деб пакетов.
Ответить | Правка | Наверх | Cообщить модератору

42. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +2 +/
Сообщение от Аноним (28), 07-Июл-23, 19:57 
Рептилоид, давай ты не будешь говорить мне что делать, а я не буду говорить на какую планету тебе пора отправляться? Только рептилии могли придумать в каждой новой версии ломать API, ABI и использовать костыль контейнер и объяснять всем что так правильно.
Ответить | Правка | Наверх | Cообщить модератору

37. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +1 +/
Сообщение от Аноним (27), 07-Июл-23, 19:51 
Блобный софт в 99% случаев работает и времён Win95 (если автор не запихал его в 16-битный инсталлятор, такое тогда нередко бывало).
Ответить | Правка | К родителю #32 | Наверх | Cообщить модератору

46. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +1 +/
Сообщение от Аноним (28), 07-Июл-23, 20:33 
Не работает. Многий софт времен ХР работает на 7-ке но не работает на 10-ке.
Ответить | Правка | Наверх | Cообщить модератору

59. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +2 +/
Сообщение от какработать (?), 07-Июл-23, 20:58 
Многий не работает, но многий и работает. Как уже было сказано выше: для линукс это недостижимая магия.
Ответить | Правка | Наверх | Cообщить модератору

60. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Аноним (27), 07-Июл-23, 21:10 
Многий — в количественном соотношении или в процентном?
Ответить | Правка | К родителю #46 | Наверх | Cообщить модератору

101. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Neon (??), 12-Июл-23, 23:44 
Не работает, если авторы свой опухший ЧСВ чесали и извращались. А при использовании стандартных возможностей работает софт не только XP, но и даже Win95, если авторы специально не выеживались
Ответить | Правка | К родителю #46 | Наверх | Cообщить модератору

47. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Аноним (28), 07-Июл-23, 20:33 
Quake обновление в Steam работает на 10-ке но не работает на 7-ке.
Ответить | Правка | К родителю #37 | Наверх | Cообщить модератору

93. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +1 +/
Сообщение от Аноним (110), 12-Июл-23, 14:48 
Авторы-то, конечно тоже смертные но...
все - конечно не все, но большая часть.
У меня до сих пор  в вин10 запускается большая часть софта из второй половины 90-ых-2000-ого (хотя зачастую в этом нет смысла). Какой-нибудь Winamp 1.0 вышел в 97-ом году и ты до сих пор его можешь найти в инете, скачать, установить запустить и он будет работать и ̶х̶л̶е̶с̶т̶а̶т̶ь̶ ̶з̶а̶д̶н̶и̶ц̶у̶ ̶л̶а̶м̶ы̶  играть музыку. Far и Total Commander (тогда еще Windows Commander) версий из какого-нибудь 99-ого года, IrfanViewer из 96-ого года и т.д. и т.п. И даже игори (если были без DRM). Ты до сих пор можешь без особых проблем (софтварных) запустить Deus Ex из 2000-ого или какой-нибудь первый квейк (вин версию) в венде. У меня с минимальными телодвижениями даже оригинальная Дьябла первая работает (на минуточку, из 1996-ого года родом!).
Я только два года назад перестал юзать одну софтину, которая 2001-ого года выхода, и то только потому, что она не умеет работать с httpS, а http сейчас уже мало где остался. Но сама софтина запускает и работает и свою задачу по прежнему выполняет (если ей скармливать урлы на сайты без https).
А в линуксе несовместимость софта "набегает" уже за пару мажорных версий МАКСИМУМ. За пару лет короче. Так еще и требуется отдельный человек, который будет пересобирать софтину под конкретный дистр и под конкретную его версию. Дичь же какая-то.
Ответить | Правка | К родителю #29 | Наверх | Cообщить модератору

100. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Neon (??), 12-Июл-23, 23:42 
Софт от старых версий винды прекрасно работает на новых. Если авторы свой опухший ЧСВ не чесали. От XP работает да 11. Даже более того, порой 32- битный софт даже Win95 работает на современных ОС.
Ответить | Правка | К родителю #29 | Наверх | Cообщить модератору

38. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от randomize (?), 07-Июл-23, 19:52 
Зато у них другие проблемы.
Ответить | Правка | К родителю #27 | Наверх | Cообщить модератору

77. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +1 +/
Сообщение от Аноним (27), 08-Июл-23, 03:50 
А у пользователей Linux других проблем нет, ага. Но мы тут об одной, конкретной.
Ответить | Правка | Наверх | Cообщить модератору

31. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +3 +/
Сообщение от Аноним (4), 07-Июл-23, 19:41 
Представь себе что это невозможно. Если в дистре больше нет нужных либ, а софту нужны только те что были. Тут то к тебе и приходит понимание что все эти переутруждения мейнтецнеров никому не нужны. Тем более для тебя он делать ничего не обязан. Достаточно просто сделать такой пакет который будет работать всегда. Можно его даже назвать контейнер. Всё проблема решена и не надо стоять с плёткой над паковальщиками пакетов.
Ответить | Правка | К родителю #25 | Наверх | Cообщить модератору

34. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Аноним (28), 07-Июл-23, 19:43 
>Если в дистре больше нет нужных либ, а софту нужны только те что были.

Значит это не поддерживаемые софт. Не поддерживаемый софт не нужен. Нужно писать новый софт.

Ответить | Правка | Наверх | Cообщить модератору

36. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +4 +/
Сообщение от Аноним (4), 07-Июл-23, 19:51 
Зачем его поддерживать он должен просто работать. Герои 3 на шинде продолжают работать в виндоуз 11 вот какие не слыханные тобой технологии.
Ответить | Правка | Наверх | Cообщить модератору

41. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Аноним (28), 07-Июл-23, 19:54 
Ни ты ни я не знаем, какой объём работы проделан индусскими специалистами для этого. Майкрософт изначально ставила целью поддержку софта с предыдущий версий. В Линукс всем плевать, поломают API, ABi и нормально. Я же тебе говорю, заговор рептилоидов с планеты Нибиру.
Ответить | Правка | Наверх | Cообщить модератору

50. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Аноним (4), 07-Июл-23, 20:44 
Новость про то что индусский парень сделал почти всё как надо и красиво.
Ответить | Правка | Наверх | Cообщить модератору

65. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от какработать (?), 07-Июл-23, 21:31 
А вы свидетель? Будете свидетелем? Куда вы, гражданин?
Ответить | Правка | Наверх | Cообщить модератору

103. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Neon (??), 12-Июл-23, 23:47 
А кто мешает проделать соответствующую работу линуксоидам. И кто мешает качественно программировать, как в Героях III ? А не ляп, тяп и так сойдет. Ведь никто никому ничего не обязан в свободном софте.)))
Ответить | Правка | К родителю #41 | Наверх | Cообщить модератору

91. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  –1 +/
Сообщение от Сергейemail (??), 11-Июл-23, 15:03 
Не торопись заявлять. На 11 герои 3 не проверял, а вот на 10 они легли. Установка с лицензионного диска и на лицензионную винду. Зато колотые версии игрушки и винды прекрасно подружились. Так что количество проблем совместимости в винде ничуть не меньше чем в линухе.
Ответить | Правка | К родителю #36 | Наверх | Cообщить модератору

94. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +1 +/
Сообщение от Аноним (110), 12-Июл-23, 14:57 
>Установка с лицензионного диска

Так она у тебя там небось с DRM. Герои 3 работают. DRM из тех времён - не работает. DRM писали другие погромисты, не те, которые писали игру. Такие вот дела.
Берешь версию без DRM (например с GOG) и наблюдаешь, как всё прекрасно работает и твои любимые скелеты множаться как кролики.

Ответить | Правка | Наверх | Cообщить модератору

104. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Neon (??), 12-Июл-23, 23:48 
Прекрасно работают на Win10 22H0 и Win10 корпоративной. У лицензии проблемы видно с системой защиты
Ответить | Правка | К родителю #91 | Наверх | Cообщить модератору

102. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Neon (??), 12-Июл-23, 23:45 
Не поддерживаемый софт))). Каждому софту нужно трусы поддерживать, чтобы он не падал ?))) Сделали, должен работать
Ответить | Правка | К родителю #34 | Наверх | Cообщить модератору

49. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Аноним (49), 07-Июл-23, 20:38 
Ты говоришь про проблему доступности пакетов-зависимостей, а так deb ещё как совместим.
Ответить | Правка | К родителю #22 | Наверх | Cообщить модератору

51. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +1 +/
Сообщение от Аноним (4), 07-Июл-23, 20:46 
А толку от совместимости если прога всё равно не заработает?
Ответить | Правка | Наверх | Cообщить модератору

95. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Аноним (110), 12-Июл-23, 15:02 
Это не должно быть проблемой домашнего юзера. Вот есть программа и она либо запускается (и работает) либо нет.
То, что там какие-то пакеты зависимости-шмамисимости десктопного юзера волновать не должны. Ибо если это начать пытаться фиксить (впендюривая старые пакеты в более новый дистр или еще как) - это крacнoглaзие.
Потому на десктопах линукс и не взлетает а не из-за заговора Билла Гейтса или индусов из мелкософт.
Ответить | Правка | К родителю #49 | Наверх | Cообщить модератору

33. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +1 +/
Сообщение от Аноним (33), 07-Июл-23, 19:43 
https://github.com/open-source-ideas/ideas/issues/50 должно быть лучше.
Ответить | Правка | Наверх | Cообщить модератору

80. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от pashev.ru (?), 08-Июл-23, 18:44 
Всем унифкаторам надо вдумчиво прочитать книгу Докинза «Эгоистичный ген».
Ответить | Правка | Наверх | Cообщить модератору

105. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Neon (??), 12-Июл-23, 23:49 
Хорошие отмазки, чтобы изобретать каждый раз гайки с собственной уникальной резьбой.)))
Ответить | Правка | Наверх | Cообщить модератору

52. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +3 +/
Сообщение от Аноним (52), 07-Июл-23, 20:48 
А если собрать LFS на принципах:
1 У каждой программы есть домашняя папка (которая имитирует /usr/), с её ресурсами и всеми зависимостями, которые ей нужны. Она ищет их именно там, ld-linux теперь знает про относительные пути и $папка_программы/lib
2 Менеджер пакетов создаёт ссылки из домашней папки пакета-зависимости в пакет, который зависит от него. (ln /usr/pkg/libasound_xx/* /usr/pkg/firefox_xx/)
4 Обычно используются общие библиотеки и мы управляем зависимостями, а не забрасываем пакеты. У нас кроме libasound_xx есть просто libasound, общая системная библиотека по умолчанию. И даже абстрактные папки.

Такой NixOS на минималках взлитит, что будет не так?

Ответить | Правка | Наверх | Cообщить модератору

53. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +1 +/
Сообщение от Аноним (4), 07-Июл-23, 20:51 
На сколько я помню относительные пути зависят от рабочей папки. Собственно тут вся твоя система и рушится.
Ответить | Правка | Наверх | Cообщить модератору

57. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Аноним (52), 07-Июл-23, 20:54 
Да, пропатчить глубоко, сделав отдельный вид относительных путей, относительно исполняемого файла. (Но мне не нравится такое усложнение, похоже добавляем уязвимостей)
Ответить | Правка | Наверх | Cообщить модератору

63. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Аноним (4), 07-Июл-23, 21:27 
Вопрос к линуксу и его архитектуры, почему нельзя задать относительный путь относительно исполняемого файла. Но в 70-е годы, когда вся эта система придумывалась, ни у кого никаких проблем с этим явно не было.
Ответить | Правка | Наверх | Cообщить модератору

108. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Neon (??), 12-Июл-23, 23:53 
А может, спустя пол века, стоит все таки новую архитектуру 21 века наконец придумать. А не жить прошлым ?
Ответить | Правка | Наверх | Cообщить модератору

67. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Андрюха (??), 07-Июл-23, 22:01 
Это ты сейчас выдумал шындовс. Или флатпак. А не так будут требования к месту на диске. Гигабайт эдак под 70.

Но самое главное не занимаемое пространство, а то насколько неудобно такой цирк обновлять и вообще им пользоваться.
И кстати, ради чего? Чтобы запускать засохший дедовский софт на актуальных пакетах? Или свежие  приложения на каком-нибудь копролите двухгодичной давности?
Так блин ответ в обоих случаях один и тот же: поставь Арч! Или Манжаро если зассал!

Ответить | Правка | К родителю #52 | Наверх | Cообщить модератору

70. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +3 +/
Сообщение от Аноним (52), 07-Июл-23, 22:25 
Нет, вообще, смотри - обычно всеми зависимостями мы управляем и ссылки ведут на одни и те же файлы. То есть все эти тонны папок - многочисленные дубликаты, а ещё и потенциально связанные именно с абстрактными пакетами "последней версии".
ln /usr/pkg/library.2.5 /usr/pkg/library
ln /usr/pkg/library /usr/pkg/program

Программа обновилась и библиотека в "контейнере" тоже обновилась, если программа не сломается. Фактически это можно заставить вести способом, очень близким к обычным менеджерам пакетов, но мы всё равно можем управлять версиями пакетов, подключать старые репозитории и ставить оттуда ПО. И просто скачивать софт откуда угодно. Это свобода.
А ещё уменьшается дичь со сложностью управления пакетами, разные конфликты и т.п.
На деле наверное не будет очень много места, я надеюсь. Ещё сборка мусора, чтобы удалять пакеты, которые не нужны.
А неудобно почему?

Ответить | Правка | Наверх | Cообщить модератору

72. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +1 +/
Сообщение от Аноним (28), 07-Июл-23, 22:52 
На моём десктопе Дебиан, на моих двух ноутбуках Дебиан, на моих четверых серверах Дебиан. Зачем мне Арч?
Ответить | Правка | К родителю #67 | Наверх | Cообщить модератору

90. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от unnamed player (?), 10-Июл-23, 15:39 
Никто тебе арч не предлагает, расслабся. Арч - не для ленивых халявщиков.
Но на самом деле арчешкольник из Индии понял раньше анонимусов с опеннета linux-way, проникся идеологией слаквари и арча и пытается сделать красивый дистр с системным подходом.
Ответить | Правка | Наверх | Cообщить модератору

96. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Аноним (110), 12-Июл-23, 15:14 
>Но самое главное не занимаемое пространство, а то насколько неудобно такой цирк обновлять и вообще им пользоваться.

Что тут неудобного? Обновляешь софтину и всё. Когда захотел - тогда и обновил. И дистриб когда захотел - тогда и обновил. И они друг другу не мешают в этом.
Только места немного больше занимать будет и трафика чуть больше при обновлении. И не 70 (вот уж где сказочники - сами себя пугают как пионэры с байками о гробе на колёсиках), а реально гигов под 10 максимум (ну или если ты совсем уж упоротый софтособиратель, то ну 20). Зато решается сразу вагон проблем.

Ответить | Правка | К родителю #67 | Наверх | Cообщить модератору

79. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от n00by (ok), 08-Июл-23, 09:43 
> А если собрать LFS на принципах:
> 1 У каждой программы есть домашняя папка (которая имитирует /usr/), с её
> ресурсами и всеми зависимостями, которые ей нужны. Она ищет их именно
> там, ld-linux теперь знает про относительные пути и $папка_программы/lib
> 2 Менеджер пакетов создаёт ссылки из домашней папки пакета-зависимости в пакет, который
> зависит от него. (ln /usr/pkg/libasound_xx/* /usr/pkg/firefox_xx/)
> 4 Обычно используются общие библиотеки и мы управляем зависимостями, а не забрасываем
> пакеты. У нас кроме libasound_xx есть просто libasound, общая системная библиотека
> по умолчанию. И даже абстрактные папки.
> Такой NixOS на минималках взлитит, что будет не так?

А в чём вопрос то? Будут ли какие подводные камни, неучтённые на данном этапе? Наверняка будут. И наверняка все решатся на уровне "сел и написал".

Я пока вижу одну нестыковку: в п.4 "мы управляем зависимостями", а в п.2 "менеджер пакетов". Наверное, правильнее назвать его "менеджер зависимостей", он может искать "пакет", или архив с нужными библиотеками, либо отправить запрос на сборочный сервер для компиляции.

И ещё п.3 потерялся.

Ответить | Правка | К родителю #52 | Наверх | Cообщить модератору

69. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Аноним (69), 07-Июл-23, 22:13 
Рудра перспективный. Уже сделал для СПО больше всех пользователей лора и опеннета вместе взятых.
Ответить | Правка | Наверх | Cообщить модератору

73. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +1 +/
Сообщение от Я (??), 07-Июл-23, 23:04 
Молодой парень экспериментирует. Много хороших идей и он их довел до дистрибутива, который можно показать людям. Молодец. Многие идеи хороши, но один он не сможет это поддерживать.
И наверное не захочет.
Ответить | Правка | Наверх | Cообщить модератору

81. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Аноним (81), 08-Июл-23, 23:33 
Слишком много - Изолировано, контейнеры и прочее...А производительность?. Естественно умалчивают, т.к. просадок по любому идет. Запуск приложений в контейнерах Линукс Тодвальдс уже обдумывает - рассазывал на одной из конференций
Ответить | Правка | Наверх | Cообщить модератору

83. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +1 +/
Сообщение от Аноним (83), 09-Июл-23, 17:25 
Попробовал поставить. Подтверждаю, сделано индийским подростком.
Ответить | Правка | Наверх | Cообщить модератору

107. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Neon (??), 12-Июл-23, 23:52 
Качество детское ?)))
Ответить | Правка | Наверх | Cообщить модератору

97. "Доступен дистрибутив blendOS 3, поддерживающий пакеты из дру..."  +/
Сообщение от Neon (??), 12-Июл-23, 23:33 
Как только не извращаются, вместо того, чтобы договориться и сделать единый один единственный дистрибутив. А не плодить на коленке сотнями
Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Партнёры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2024 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру