The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Доступен WebKitGTK+ 2.4.0"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Доступен WebKitGTK+ 2.4.0"  +/
Сообщение от opennews (??) on 25-Мрт-14, 10:24 
Увидел свет (http://webkitgtk.org/2014/03/24/webkitgtk2.4.0-released.html) выпуск новой стабильной ветки  WebKitGTK+ 2.4.0 (http://www.webkitgtk.org/), порта браузерного движка WebKit (http://webkit.org/) для платформы  GTK+. WebKitGTK+ позволяет использовать все возможности WebKit через GNOME-ориентированный программный интерфейс на основе GObject и может применяться для интеграции средств обработки web-контента в любые приложения, от использования в специализированных HTML/CSS-парсерах, до создания полнофункциональных web-браузеров. Из известных проектов, использующих WebKitGTK+, можно отметить Midori (http://www.midori-browser.org/) и штатный браузер GNOME (Epiphany).


Ключевые улучшения (http://blogs.igalia.com/carlosgc/2014/03/24/webkitgtk-2-4-0-.../) новой стабильной ветки:


-  Поддержка многопроцессной модели работы, позволяющей обрабатывать разный web-контент в отдельных процессах-обработчиках. Отмечается, что мнгопроцессная модель обработки контента будет включена по умолчанию в ближайшем выпуске браузера  Epiphany. В том числе в отдельных процессах теперь выполняются и инструменты для web-разработчиков. Для управления ответвлением и обменом данными между процессами-обработчиками WebKit представлен специальный API;
-  Поддержка обработка событий DOM для сенсорных экранов, что позволило обеспечить возможность использоваться мультитач в браузерах на базе WebKitGTK+;
-  Реализация кэша с информацией о плагинах, позволяющего избавиться от блокировок (https://bugs.webkit.org/show_bug.cgi?id=115650) интерфейса при сканировании плагинов во время открытия страниц с плагинами. При использовании кэша плагины сканируются только один раз при их изменении;
-  API для обработки ошибок TLS.

URL: http://webkitgtk.org/2014/03/24/webkitgtk2.4.0-released.html
Новость: https://www.opennet.ru/opennews/art.shtml?num=39397

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


3. "Доступен WebKitGTK+ 2.4.0"  +1 +/
Сообщение от Zenitur (ok) on 25-Мрт-14, 12:45 
Хорошая новость. Переводчику спасибо.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

4. "Доступен WebKitGTK+ 2.4.0"  +/
Сообщение от Mr_Gentoo (ok) on 25-Мрт-14, 13:36 
На Blink они переходить собираются?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

16. "Доступен WebKitGTK+ 2.4.0"  +/
Сообщение от Аноним (??) on 26-Мрт-14, 00:42 
С Кутей проблем-то нет совсем.
Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "Доступен WebKitGTK+ 2.4.0"  +/
Сообщение от rshadow (ok) on 25-Мрт-14, 13:42 
> Реализация кэша с информацией о плагинах, позволяющего избавиться от блокировок интерфейса

Явно архитектурный баг зализали с помощью алгоритма.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

7. "Доступен WebKitGTK+ 2.4.0"  +/
Сообщение от iZEN (ok) on 25-Мрт-14, 13:45 
Evince требует Yelp. Yelp требует Webkit-Gtk2. Ради просмотра PDF и DJVU зачем-то нужен WebKit... Brasero тоже имеет зависимость от Yelp...
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

8. "Доступен WebKitGTK+ 2.4.0"  +/
Сообщение от Mihail Zenkov (ok) on 25-Мрт-14, 14:26 
Наверное конвертируют pdf/djvu в html перед выводом на экран :)

Нафиг такие viewer'ы жрущие кучу памяти и запускающиеся далеко не мгновенно. Есть же djview/mupdf/etc.

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "Доступен WebKitGTK+ 2.4.0"  +/
Сообщение от NO_ID on 25-Мрт-14, 15:01 
> Есть же djview/mupdf/

zathura!;) хотя жаль, когда zathura с плагином mupdf то жрет памяти также как и с poppler(

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

11. "Доступен WebKitGTK+ 2.4.0"  +/
Сообщение от iZEN (ok) on 25-Мрт-14, 20:12 
> Наверное конвертируют pdf/djvu в html перед выводом на экран :)
> Нафиг такие viewer'ы жрущие кучу памяти и запускающиеся далеко не мгновенно. Есть
> же djview/mupdf/etc.

PDFRenderer.jar - 1,8 МиБ
javadjvu - 268,1 КиБ
Отображают все файлы PDF и DJVU, соответственно, в читаемом виде.

Зачем Evince понадобился WebKit?

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

12. "Доступен WebKitGTK+ 2.4.0"  +/
Сообщение от jj on 25-Мрт-14, 22:01 
> javadjvu - 268,1 КиБ

Пробую запустить, требует ещё 40МБ какой-то ерунды. Чем это лучше того же evince с webkit?

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

14. "Доступен WebKitGTK+ 2.4.0"  +/
Сообщение от iZEN (ok) on 25-Мрт-14, 22:10 
>> javadjvu - 268,1 КиБ
> Пробую запустить, требует ещё 40МБ какой-то ерунды. Чем это лучше того же evince с webkit?

Она требует установленной JRE. А это стандартизованная штука, которая есть почти под все известные компьютерные системы и операционки.


Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

15. "Доступен WebKitGTK+ 2.4.0"  +/
Сообщение от Stax (ok) on 25-Мрт-14, 23:14 
Смотри на вещи шире.

Чем необходимость установить пакеты java-1.7.0-openjdk.x86_64 и java-1.7.0-openjdk-headless.x86_64 отличается от необходимости установить webkitgtk3.x86_64 ? Кстати, занимает как раз порядка 40Mb. Чем 40 Mb диска, затраченные на какой-то webkit отличаются от 90 Mb, затраченных на какой-то JRE?
(и не надо говорить про стандартность - webkitgtk тоже "стандартный пакет" в любом уважающим себя дистрибутиве, а полезность JRE на десктопе довольно сомнительна).

Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

13. "Доступен WebKitGTK+ 2.4.0"  +/
Сообщение от Knuckles (ok) on 25-Мрт-14, 22:04 
Yelp это оболочка для чтения документации, afaik.
Которая, вероятно, поставляется в формате html.
Так что webkit нужен Evince не для просмотра pdf, а для чтения его собственных мануалов.
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

10. "Доступен WebKitGTK+ 2.4.0"  –1 +/
Сообщение от Аноним (??) on 25-Мрт-14, 18:20 
Gnome 2 станет самым долгожиивущим ПО в мире - поддержкка его составит 26 лет за всю историю!
MATE- его продолжатель принят во все долгоживущие дистрибутивы. Windows XP падает на второе место по срокам поддержки. Поздравляем Gnome 2 с победой винды по этому показателю, Windows XP ушла по срокам поддержки на второе место. Браво Gnome 2!

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру