The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"DialUp: Ошибка в конфиге?"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"DialUp: Ошибка в конфиге?"  
Сообщение от BuxpbSN (ok) on 29-Мрт-06, 09:30 
Задача: на AS5350, при работающем VoIp поднять диалап-пул.

Согласно примеру с cisco.com создаю конфигурацию, VoIP работает нормально, а при дозвоне на dialup AS5350 просто сбрасывает звонок. Если несложно, помогите чайнику - укажите на ошибку.

(Примеры конфигураций приветствуются :) )

Моя конфигурация:

Current configuration : 22242 bytes
!
! Last configuration change at 04:35:20 UTC Wed Mar 29 2006 by [удалено]
! NVRAM config last updated at 14:25:04 UTC Fri Mar 17 2006 by [удалено]
!
version 12.3
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname [удалено]
!
boot-start-marker
boot system flash flash:c5350-js-mz.123-13b.bin
boot startup-test power-on
boot-end-marker
!
logging buffered 32768 debugging
enable secret [удалено]
enable password [удалено]
!
!
!
resource-pool disable
spe default-firmware spe-firmware-1
aaa new-model
!
!
aaa group server radius [удалено]
server 192.168.1.35 auth-port 1745 acct-port 1746
!
aaa group server radius H323
server 192.168.1.35 auth-port 1745 acct-port 1746
!
aaa group server radius [удалено]
server-private 192.168.1.35 auth-port 1745 acct-port 1746
!
aaa group server radius [удалено]
server-private 192.168.1.35 auth-port 1745 acct-port 1746
!
aaa authentication password-prompt password:
aaa authentication username-prompt login:
aaa authentication login LocalAuth local
aaa authentication login h323 group H323
aaa authentication ppp default group [удалено]
aaa authentication ppp INNOR group [удалено]
aaa authorization exec default local
aaa authorization exec h323 group H323
aaa authorization exec INNOR group [удалено] if-authenticated
aaa authorization network default group [удалено] if-authenticated
aaa authorization network [удалено] group [удалено] if-authenticated
aaa accounting exec INNOR start-stop group [удалено]
aaa accounting network INNOR start-stop group [удалено]
aaa accounting connection h323 start-stop group H323
aaa preauth
group radius
filter voice
clid if-avail
!
aaa session-id common
ip subnet-zero
!
!
ip host bill 192.168.1.35
!
ip cef
async-bootp dns-server 195.161.15.19
isdn switch-type primary-net5
isdn voice-call-failure 0
!
template XXX
ppp authentication pap XXX
ppp authorization XXX
ppp accounting XXX
!
!
voice hunt user-busy
voice call send-alert
voice call convert-discpi-to-prog
voice call carrier capacity active
!
voice service pots
fax protocol t38 ls-redundancy 5 hs-redundancy 2 fallback pass-through g711alaw
!
voice service voip
fax protocol t38 ls-redundancy 5 hs-redundancy 2 fallback pass-through g711alaw
h323
modem passthrough nse payload-type 98 codec g711alaw
!
voice class codec 1
codec preference 1 g723r53
codec preference 2 g723r63
codec preference 3 g729r8
codec preference 4 g729br8
codec preference 7 gsmfr
codec preference 8 g726r16
codec preference 9 g726r24
codec preference 10 g726r32
!
!
!
!
!
!
!
!
!
ivr prompt memory 16000
!
fax interface-type fax-mail
!
username [удалено] password [удалено]
username [удалено]
!
!
controller E1 2/0
framing NO-CRC4
pri-group timeslots 1-31
!
controller E1 2/1
framing NO-CRC4
pri-group timeslots 1-31
!
controller E1 3/0
framing NO-CRC4
pri-group timeslots 1-31
!
controller E1 3/1
framing NO-CRC4
pri-group timeslots 1-31
gw-accounting aaa
attribute h323-remote-id resolved
!
!
translation-rule 82
[опущено]
!
!
!
interface Loopback0
ip address 10.1.1.100 255.255.255.0
no ip mroute-cache
!
interface FastEthernet0/0
ip address 84.254.209.130 255.255.255.248
delay 1
duplex full
speed auto
no cdp enable
!
interface FastEthernet0/1
ip address 192.168.1.40 255.255.255.0
duplex full
speed auto
no cdp enable
!
interface Serial0/0
no ip address
shutdown
clockrate 2000000
no cdp enable
!
interface Serial0/1
no ip address
shutdown
clockrate 2000000
no cdp enable
!
interface Serial2/0:15
no ip address
encapsulation ppp
dialer rotary-group 1
dialer-group 1
isdn switch-type primary-net5
isdn incoming-voice modem
isdn map address .* plan isdn type unknown
isdn send-alerting
isdn bchan-number-order ascending
isdn sending-complete
isdn outgoing-voice info-transfer-capability 3.1kHz-audio
no fair-queue
no cdp enable
!
interface Serial2/1:15
no ip address
encapsulation ppp
dialer rotary-group 1
dialer-group 1
isdn switch-type primary-net5
isdn incoming-voice modem
isdn map address .* plan isdn type unknown
isdn send-alerting
isdn bchan-number-order ascending
isdn sending-complete
isdn outgoing-voice info-transfer-capability 3.1kHz-audio
no fair-queue
no cdp enable
!
interface Serial3/0:15
description ISDN E1 3/1 signalling channel
no ip address
encapsulation ppp
dialer rotary-group 1
dialer-group 1
isdn switch-type primary-net5
isdn incoming-voice modem
isdn map address .* plan isdn type unknown
isdn send-alerting
isdn bchan-number-order ascending
isdn sending-complete
isdn outgoing-voice info-transfer-capability 3.1kHz-audio
no fair-queue
no cdp enable
!
interface Serial3/1:15
no ip address
encapsulation ppp
dialer rotary-group 1
dialer-group 1
isdn switch-type primary-net5
isdn incoming-voice modem
isdn map address .* plan isdn type unknown
isdn send-alerting
isdn bchan-number-order ascending
isdn sending-complete
isdn outgoing-voice info-transfer-capability 3.1kHz-audio
no fair-queue
no cdp enable
!
interface Virtual-Template1
ip unnumbered FastEthernet0/0
ppp authentication pap XXX
ppp authorization XXX
ppp accounting XXX
!
interface Group-Async0
ip unnumbered Loopback0
encapsulation ppp
no ip route-cache cef
no ip route-cache
no ip mroute-cache
async mode interactive
peer default ip address pool pool-dialup
fair-queue
ppp authentication chap pap callin
group-range 1/00 1/59
!
interface Dialer1
ip unnumbered Loopback0
encapsulation ppp
no ip mroute-cache
dialer in-band
dialer idle-timeout 300
dialer-group 1
peer default ip address pool pool_dialup
no fair-queue
no cdp enable
ppp authentication chap pap callin
ppp multilink
!
ip local pool default 195.161.93.110 195.161.93.115
ip classless
ip route 0.0.0.0 0.0.0.0 84.254.209.129
ip route 192.168.1.0 255.255.255.0 FastEthernet0/1
ip flow-export source FastEthernet0/0
ip flow-export version 5
ip flow-export destination 84.254.206.123 3339
no ip http server
!
!
!
ip access-list extended BUG
deny   53 any any
deny   55 any any
deny   77 any any
deny   pim any any
ip radius source-interface FastEthernet0/0.100
logging trap debugging
logging 192.168.1.30
access-list [опущено]
dialer-list 1 protocol ip permit
no cdp run
!
!
snmp-server community secret_community RO
!
radius-server attribute 6 on-for-login-auth
radius-server host [удалено]
radius-server timeout 30
radius-server deadtime 10
radius-server key [удалено]
radius-server vsa send accounting
radius-server vsa send authentication

call application [ommited]
!
voice-port 2/0:D
input gain 2
output attenuation -4
echo-cancel coverage 16
cptone RU
bearer-cap 3100Hz
!
voice-port 2/1:D
input gain 2
output attenuation -4
echo-cancel coverage 16
cptone RU
bearer-cap 3100Hz
!
voice-port 3/0:D
input gain 2
output attenuation -4
echo-cancel coverage 16
cptone RU
bearer-cap 3100Hz
!
voice-port 3/1:D
input gain 2
output attenuation -4
echo-cancel coverage 16
cptone RU
bearer-cap 3100Hz
!
!
dial-peer cor custom
!
!
!

[Голосовые dial-peer опущены]

dial-peer data 802802 pots
huntstop
incoming called-number 222222
direct-inward-dial
!
!
dial-peer search type data voice
num-exp 810. .
num-exp 8 7
gateway
!
!
line con 0
exec-timeout 0 0
logging synchronous
login authentication LocalAuth
line aux 0
fax rate 9600
ip qos dscp cs5 media
ip qos dscp cs3 signaling
no vad
!
dial-peer data 802802 pots
huntstop
incoming called-number 222222
direct-inward-dial
!
!
dial-peer search type data voice
num-exp 810. .
num-exp 8 7
gateway
!
!
line con 0
exec-timeout 0 0
logging synchronous
login authentication LocalAuth
line aux 0
logging synchronous
line vty 0 4
session-timeout 20
exec-timeout 20 0
login authentication LocalAuth
line 1/00 1/59
exec-timeout 0 0
no flush-at-activation
modem InOut
transport input all
transport output none
escape-character BREAK
autoselect during-login
autoselect ppp
!
scheduler allocate 10000 400
ntp clock-period 17180009
ntp source FastEthernet0/0.100
ntp master
ntp server 192.5.41.41
ntp server 195.2.64.5 version 2
ntp server 194.186.254.22 version 2
ntp server 128.105.37.11
end

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "DialUp: Ошибка в конфиге?"  
Сообщение от citrin email(ok) on 29-Мрт-06, 11:16 
для начала посмотрите через debug aaa проходит ли аутентификация и авторизация
Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

2. "DialUp: Ошибка в конфиге?"  
Сообщение от BuxpbSN (ok) on 29-Мрт-06, 11:44 
>для начала посмотрите через debug aaa проходит ли аутентификация и авторизация

Хм... А разве она может проходить, если нет соединения? Cisco даже трубку не снимает, насколько я понимаю.

debug ничего не возвращает.

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

3. "DialUp: Ошибка в конфиге?"  
Сообщение от pincher (ok) on 29-Мрт-06, 13:11 
Ну для начала нужно правильно диал-пир для модемщиков прописать.

Примерно вот так:
dial-peer voice 802802 pots
application data_dialpeer
incoming called-number 222222
!


Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

4. "DialUp: Ошибка в конфиге?"  
Сообщение от citrin email(ok) on 29-Мрт-06, 13:24 
>Ну для начала нужно правильно диал-пир для модемщиков прописать.
>
>Примерно вот так:
>dial-peer voice 802802 pots
> application data_dialpeer
> incoming called-number 222222
>!

application data_dialpeer не во всех IOS есть, лучше так:

dial-peer data 11111111 pots
description -- Modem pool
incoming called-number 749511111111

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

5. "DialUp: Ошибка в конфиге?"  
Сообщение от BuxpbSN (ok) on 29-Мрт-06, 13:29 
>Ну для начала нужно правильно диал-пир для модемщиков прописать.
>
>Примерно вот так:
>dial-peer voice 802802 pots
> application data_dialpeer
> incoming called-number 222222
>!

не помогло.

Кстати, а почему нельзя прописывать:

!
dial-peer data 802802 pots
incoming called-number 222222
!

Вроде то же самое ведь...

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

6. "DialUp: Ошибка в конфиге?"  
Сообщение от BuxpbSN (ok) on 29-Мрт-06, 13:35 
Использую:

!
dial-peer data 802802 pots
incoming called-number 222222
huntstop
dirext-inward-dial
!

debug dialpeer:

Mar 29 09:33:44:  Inside dpMatchCore:
Mar 29 09:33:44:  destination pattn: 222222 expanded string: 222222
Mar 29 09:33:44: MatchNextPeer: Peer 802802 matched

Матчится вроде... А дальше - тишина.

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

7. "DialUp: Ошибка в конфиге?"  
Сообщение от citrin email(ok) on 29-Мрт-06, 13:41 
>Mar 29 09:33:44:  Inside dpMatchCore:
>Mar 29 09:33:44:  destination pattn: 222222 expanded string: 222222
>Mar 29 09:33:44: MatchNextPeer: Peer 802802 matched
>
>Матчится вроде... А дальше - тишина.

А на вашей 5350 вообще есть плата для работы в качестве модемного пула?

Для 5350 вроде разные платы для VoIP и для Dial-UP

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

8. "DialUp: Ошибка в конфиге?"  
Сообщение от BuxpbSN (ok) on 29-Мрт-06, 13:46 
>>Mar 29 09:33:44:  Inside dpMatchCore:
>>Mar 29 09:33:44:  destination pattn: 222222 expanded string: 222222
>>Mar 29 09:33:44: MatchNextPeer: Peer 802802 matched
>>
>>Матчится вроде... А дальше - тишина.
>
>А на вашей 5350 вообще есть плата для работы в качестве модемного
>пула?
>
>Для 5350 вроде разные платы для VoIP и для Dial-UP

Есть :) Когда-то эта циска работала на dialup. Потом её сконфигурировали под Voip, конфги потеряли.

Может быть, это поможет:

#sh line

   Tty Typ     Tx/Rx    A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int
     0 CTY              -    -      -    -    -      0       0     0/0       -
     1 AUX   9600/9600  -    -      -    -    -      0       0     0/0       -
*    2 VTY              -    -      -    -    -     77       0     0/0       -
     3 VTY              -    -      -    -    -     10       0     0/0       -
     4 VTY              -    -      -    -    -      0       0     0/0       -
     5 VTY              -    -      -    -    -      0       0     0/0       -
     6 VTY              -    -      -    -    -      0       0     0/0       -
I     1/00 Digital modem - inout     1    -    -      0       0     0/0       -
I     1/01 Digital modem - inout     1    -    -      0       0     0/0       -
I     1/02 Digital modem - inout     1    -    -      0       0     0/0       -
I     1/03 Digital modem - inout     1    -    -      0       0     0/0       -
...........
I     1/59 Digital modem - inout     1    -    -      0       0     0/0       -

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

9. "DialUp: Ошибка в конфиге?"  
Сообщение от BuxpbSN (ok) on 29-Мрт-06, 16:23 
Вопрос, вытекающий из темы треда: как узнать причину завершения звонка?
Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

10. "DialUp: Ошибка в конфиге?"  
Сообщение от BuxpbSN (??) on 31-Мрт-06, 09:48 
Решение проблемы:

Для принимающего звонок Serial-интерфейса необходимо разрешить соединения по срабатыванию guard-timer:

interface Serial3/1:15
no ip address
encapsulation ppp
dialer rotary-group 1
dialer-group 1
isdn switch-type primary-net5
isdn incoming-voice modem

isdn guard-timer 1000 on-expiry accept
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
По умолчанию устанавливается параметр on-expiry reject, что приводит к сбросу соединения сервером доступа.

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру