The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Cisco + ADSL + DHCP + Stream + TV"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (VPN, VLAN, туннель)
Изначальное сообщение [ Отслеживать ]

"Cisco + ADSL + DHCP + Stream + TV"  +/
Сообщение от sns (??) on 08-Ноя-06, 12:36 
Прилагаю базовый конфиг для настройки ADSL-ной цыски с поддержкой Стрим + ТВ, а также DHCP.
Конфиг подойдет для всех версий ADSL-ных цысок начиная с 827 и заканчивая 877.
Данный пример для 857/877.
Приставку можно подключать к любому порту встроенного или внешнего свича.
На старых цысках (827) нет встроенного свича, следовательно нет и интерфейса vlan 1.
Соответственно, все настройки с интерфейса vlan 1 плавно копируются на интерфейс eth 0.
Надеюсь, конфиг кому-нибудь пригодится.
Ну а теперь сам конфиг:

!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable password ciscorulez
!
no aaa new-model
!
!
resource policy
!
no ip dhcp use vrf connected
!
ip dhcp pool home
   network 192.168.100.0 255.255.255.0
   default-router 192.168.100.1
   dns-server 212.188.4.10 195.34.32.116
!
!
ip cef
ip name-server 212.188.4.10
ip name-server 195.34.32.116
no ip igmp snooping
!
!
!
bridge irb
!
!
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.150 point-to-point
no snmp trap link-status
pvc 1/50
  encapsulation aal5snap
  pppoe-client dial-pool-number 1
!
!
interface ATM0.191 point-to-point
no snmp trap link-status
pvc 1/91
  encapsulation aal5snap
!
bridge-group 1
bridge-group 1 spanning-disabled
!
interface ATM0.192 point-to-point
no snmp trap link-status
pvc 1/92
  encapsulation aal5snap
!
bridge-group 1
bridge-group 1 spanning-disabled
!
interface FastEthernet0
spanning-tree portfast
!
interface FastEthernet1
spanning-tree portfast
!
interface FastEthernet2
spanning-tree portfast
!
interface FastEthernet3
spanning-tree portfast
!
interface Dot11Radio0
no ip address
!
encryption mode ciphers tkip
!
ssid home
    authentication open
    authentication key-management wpa
    guest-mode
    wpa-psk ascii 0 ciscorulez
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 output-pattern-list 1111
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Vlan1
no ip address
bridge-group 1
bridge-group 1 output-pattern-list 1111
bridge-group 1 spanning-disabled
!
interface Dialer1
mtu 1492
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
no cdp enable
ppp chap hostname your-login
ppp chap password 0 your-password
!
interface BVI1
mac-address dead.beaf.dead
ip address 192.168.100.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface Dialer1 overload
!
access-list 1 permit 192.168.100.0 0.0.0.255
access-list 1111 deny   dead.beaf.dead 0000.0000.0000 ffff.ffff.ffff 0000.0000.0000 0x46 3 eq 0x202
access-list 1111 deny   dead.beaf.dead 0000.0000.0000 0002.0200.0000 0000.00ff.ffff 0x22 4 eq 0x430044
access-list 1111 permit 0000.0000.0000 ffff.ffff.ffff 0002.0200.0000 0000.00ff.ffff 0x22 4 eq 0x430044
access-list 1111 permit dead.beaf.dead 0000.0000.0000 0000.0000.0000 ffff.ffff.ffff 0x22 4 eq 0x430044
access-list 1111 deny   0000.0000.0000 ffff.ffff.ffff 0000.0000.0000 ffff.ffff.ffff 0x22 4 eq 0x430044
access-list 1111 permit 0000.0000.0000 ffff.ffff.ffff 0000.0000.0000 ffff.ffff.ffff
dialer-list 1 protocol ip list 1
no cdp run
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
no modem enable
line aux 0
line vty 0 4
password ciscorulez
login
!
scheduler max-task-time 5000
end

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Cisco + ADSL + DHCP + Stream + TV"  +/
Сообщение от sns (??) on 10-Ноя-06, 11:11 
Я забыл еще добавить, что данный конфиг годится для так называемой "новой" настройки DSLAMов,
где для передачи Stream TV используется только один PVC. Если же у Вас старая настройка DSLAMа где используются оба PVC, то нужно добавить еще 1 аксеслист:
access-list 1112 permit 0002.0200.0000 0000.00ff.ffff 0000.0000.0000 ffff.ffff.ffff
Ну и затем на интерфейсе int ATM0.191 прописать следующую команду:
bridge-group 1 output-pattern-list 1112
Теперь точно всё!


Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

7. "Cisco + ADSL + DHCP + Stream + TV"  +/
Сообщение от Lockcat email on 25-Фев-08, 21:01 
Подтверждаю: конфиг абсолютно рабочий, жаль руки до нормальной настройки моей циски дошли не так скоро как хотелось. Огромное спасибо SNS за предоставленную информацию. Единственное что беспокоит, учитывая что мультикастовый траффик идет на все порты, не влияет ли это на перфоманс работы сети? Ксати попытка развести траффики интернета и ТВ на разные бриджи вланы у меня пока закончилась неудачей.
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

2. "Cisco + ADSL + DHCP + Stream + TV"  +/
Сообщение от Alex email(??) on 12-Янв-07, 21:59 
Спасибо за конфиг,
У меня Cisco 857, прописал всё один к одному, VOD проходит, а вот MULTICAST - нет. Подскажите в чём трабл может быть?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "Cisco + ADSL + DHCP + Stream + TV"  +/
Сообщение от Lockcat email on 01-Апр-07, 12:41 
Попробовал данный конфиг. У меня не работает. А у кого нибудь вообще он заработал?
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Cisco + ADSL + DHCP + Stream + TV"  +/
Сообщение от troy (??) on 28-Сен-07, 22:31 
>Спасибо за конфиг,
>У меня Cisco 857, прописал всё один к одному, VOD проходит, а
>вот MULTICAST - нет. Подскажите в чём трабл может быть?

Конфиг рабочий - точно.
Вероятно, забыли команду no ip igmp snooping.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

5. "Cisco + ADSL + DHCP + Stream + TV"  +/
Сообщение от Mambrix email on 20-Ноя-07, 12:50 
Подскажите, пожалуйста, поддерживает ли Cisco 851 протокол IGMP? У меня сеть Корбина, и хочется иметь возможность просмотра IPTV.. А в качестве железки хотелось бы иметь Циску.

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "Cisco + ADSL + DHCP + Stream + TV"  +/
Сообщение от StarWoofy (??) on 09-Дек-07, 23:44 
>Подскажите, пожалуйста, поддерживает ли Cisco 851 протокол IGMP? У меня сеть Корбина,
>и хочется иметь возможность просмотра IPTV.. А в качестве железки хотелось
>бы иметь Циску.

Up.
Меня тоже вопрос очень интересует :)

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

9. "Cisco + ADSL + DHCP + Stream + TV"  +/
Сообщение от Centurus on 20-Июн-08, 10:47 
>>Подскажите, пожалуйста, поддерживает ли Cisco 851 протокол IGMP? У меня сеть Корбина,
>>и хочется иметь возможность просмотра IPTV.. А в качестве железки хотелось
>>бы иметь Циску.
>
>Up.
>Меня тоже вопрос очень интересует :)

UPUP.
Тот же вопрос.

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

11. "Cisco + ADSL + DHCP + Stream + TV"  +/
Сообщение от Владимир email(??) on 30-Авг-11, 22:14 
> Прилагаю базовый конфиг для настройки ADSL-ной цыски с поддержкой Стрим + ТВ,
>

На дворе август 2011 года. Стрим меняет ТВ приставки на новые, которые к сожалению не работают со старым конфигом.

Нет ли случаем у кого нового конфига? Или пора выкинуть старенький 851й на помойку?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру