The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Автоматическое поднятие VPN тунеля"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"Автоматическое поднятие VPN тунеля"  
Сообщение от TEMOXA email on 05-Июл-07, 08:29 
Доброго времени суток уважаемые спецы.
Прошу помощи вот в таком вопросе, есть два офиса между ними VPN тунель, через инет и разных провайдеров, оборудование 2821 в другом 1841, у одного проваедера по выходным регулярно проблемы с инетом, подвел второго прова, но VPN тунель site-to-site могу подымать только я, не хочется что бы на выходных дергали и прошу помощи. Может есть средства штатные или не штатные Cisco что бы это делать автоматически.
С уважением Тема
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "Автоматическое поднятие VPN тунеля"  
Сообщение от fantom email(ok) on 05-Июл-07, 08:53 
>Доброго времени суток уважаемые спецы.
>Прошу помощи вот в таком вопросе, есть два офиса между ними VPN
>тунель, через инет и разных провайдеров, оборудование 2821 в другом 1841,
>у одного проваедера по выходным регулярно проблемы с инетом, подвел второго
>прова, но VPN тунель site-to-site могу подымать только я, не хочется
>что бы на выходных дергали и прошу помощи. Может есть средства
>штатные или не штатные Cisco что бы это делать автоматически.
>С уважением Тема

если на интерфейсе есть фича backup, попробуй ей воспользоваться.
Суть - если основной интерфейс уходит в down, поднимается бекап, если основной переходит в up, бекап снова отваливается.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Автоматическое поднятие VPN тунеля"  
Сообщение от ViRuZzz email(??) on 05-Июл-07, 15:07 
>Доброго времени суток уважаемые спецы.
>Прошу помощи вот в таком вопросе, есть два офиса между ними VPN
>тунель, через инет и разных провайдеров, оборудование 2821 в другом 1841,
>у одного проваедера по выходным регулярно проблемы с инетом, подвел второго
>прова, но VPN тунель site-to-site могу подымать только я, не хочется
>что бы на выходных дергали и прошу помощи. Может есть средства
>штатные или не штатные Cisco что бы это делать автоматически.
>С уважением Тема

Поднимаешь 2 туннеля, прописыаешь разные метрики через них

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Автоматическое поднятие VPN тунеля"  
Сообщение от TEMOXA email on 06-Июл-07, 05:20 

>Поднимаешь 2 туннеля, прописыаешь разные метрики через них
Уважаемый ViRuZzz а можно поподробнее на этом моменте, если не трудно пример конфига.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Автоматическое поднятие VPN тунеля"  
Сообщение от ViRuZzz email(??) on 06-Июл-07, 09:41 
>
>>Поднимаешь 2 туннеля, прописыаешь разные метрики через них
>Уважаемый ViRuZzz а можно поподробнее на этом моменте, если не трудно пример
>конфига.
ну где-то вот так:
2 провайдера в одном офисе:
- SuperTelecom (10.0.0.2/30) падучий но дешевый (с высоким приоритетом)
- MegaTelecom (10.1.0.2/30) дорогой (с низким приоритетом)
а в другом офисе 1 канал
- CoolTelecom (10.10.1.2/30)

Локалки в 1м офисе
- 192.168.0.0/24
во втором
- 192.168.1.0/24


Адреса тунелей назначим 192.168.3.1-192.168.3.2 через Супертелеком и 192.168.3.5-192.168.3.6 через мегателеком

примерный конфиг офиса с 2мя каналами:
interface FastEthernet0/1
description SuperTelecom
ip address 10.0.0.2 255.255.255.252
no cdp enable

interface Tunnel0
description "remoteOffice via SuperTelecom"
ip address 192.168.3.1 255.255.255.252
tunnel source 10.0.0.2
tunnel destination 10.10.1.2
tunnel mode ipip

interface FastEthernet0/2
description MegaTelecom
ip address 10.1.0.2 255.255.255.252
no cdp enable

interface Tunnel1
description "remoteOffice via MegaTelecom"
ip address 192.168.3.5 255.255.255.252
tunnel source 10.1.0.2
tunnel destination 10.10.1.2
tunnel mode ipip

ip route 192.168.1.0 255.255.255.0 192.168.3.2 5
ip route 192.168.1.0 255.255.255.0 192.168.3.6 10
!1й маршрут имеет метрику 5 и будет иметь больший приоритет чем 2ой с метрикой 10.

с другой стороны конфиг аналогичен, только один провайдер:
interface FastEthernet0/1
description CoolTelecom
ip address 10.10.1.2 255.255.255.252
no cdp enable

interface Tunnel0
description "remoteOffice via SuperTelecom"
ip address 192.168.3.2 255.255.255.252
tunnel source 10.10.1.2
tunnel destination 10.0.0.2
tunnel mode ipip

interface Tunnel1
description "remoteOffice via MegaTelecom"
ip address 192.168.3.6 255.255.255.252
tunnel source 10.10.1.2
tunnel destination 10.1.0.2
tunnel mode ipip

ip route 192.168.0.0 255.255.255.0 192.168.3.1 5
ip route 192.168.0.0 255.255.255.0 192.168.3.5 10

ну где-то примерно так... писал прямо тут, поэтому могут быть опечатки, или мог что-нить где-нить перепутать :)
если что можешь постучаться ко мне в jabber: viruzzz@jabber.whiteants.net

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Автоматическое поднятие VPN тунеля"  
Сообщение от TEMOXA email on 06-Июл-07, 10:55 
!!!ViRuZzz спасибо!!!!
Вопрос только вот еще возник, я прост оне совсем помню возможно или нет IP-Sec на это прикрутить, или такуюже фичу с IP-Sec вским тунелем сделать?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Автоматическое поднятие VPN тунеля"  
Сообщение от ViRuZzz email(??) on 06-Июл-07, 12:57 
>!!!ViRuZzz спасибо!!!!
>Вопрос только вот еще возник, я прост оне совсем помню возможно или
>нет IP-Sec на это прикрутить, или такуюже фичу с IP-Sec вским
>тунелем сделать?

Конечно можно. http://www.cisco.com/univercd/cc/td/doc/product/software/ios113ed/113t/113t_3/ipsec.htm
шифровать надо тарфик протокола ipip между роутерами.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру