The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"помогите с настройкой VPN между d-link и cisco"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"помогите с настройкой VPN между d-link и cisco"  
Сообщение от Kostya email(??) on 14-Сен-07, 07:05 
Привет всем!Ребята срочно нужна помощь!Есть такая схема: d-link и cisco по IPSEC нормально работают ,локальные сети друг друга видят, но в cisco LAN подключена статическим роутингом через третий роутер.
Еще одна сеть,ресурсы которой остаюся для Dlinka недоступными(даже пинг туда не идет и оттуда нету.
Схема :Dlink(LAN 10.145.6.0/24 ip 10.145.6.2)___ISP(VPN)___Cisco(wan 88.88.88.90  lan 10.145.1.64/26 ip 10.145.1.91)___статика(2хпрвод линия)__10.145.2.5
Вопрос:Что мне надо сделать,чтоб попасть из сети 10.145.6.0  в сеть 10.145.2.0?
Заранее благодарен
могу выложить конфиг
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "помогите с настройкой VPN между d-link и cisco"  
Сообщение от RPaha (ok) on 14-Сен-07, 08:48 
Нужно на D-Linке сделать еще один туннель, примерно со следующими настройками:
Local Subnet 10.145.6.0/24
Remote Subnet 10.145.2.5
Remote Gateway 88.88.88.90
KeepAlive Host 10.145.2.5

Ну и роутинг на нем прописать что то типа route 10.145.2.5 <mask> 10.145.1.91
IKE Proporsal  и IPSec Proporsal можно применить теже что и для первого тунелля.
На данный момент у вас просто получается что длинк не знает о том что траффик предназначенный для сети 10.145.2.5 надо пихать в тот же туннель.

Помоему как то так.

Посмотрите пожалуйста мой вопрос https://www.opennet.ru/openforum/vsluhforumID6/14426.html

Дело в том что я настраивал подобные туннели но щас видимо глаз замылился, не могу найти ошибку, нужна помощь

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "помогите с настройкой VPN между d-link и cisco"  
Сообщение от Kostya (??) on 16-Сен-07, 07:50 
>[оверквотинг удален]
>На данный момент у вас просто получается что длинк не знает о
>том что траффик предназначенный для сети 10.145.2.5 надо пихать в тот
>же туннель.
>
>Помоему как то так.
>
>Посмотрите пожалуйста мой вопрос https://www.opennet.ru/openforum/vsluhforumID6/14426.html
>
>Дело в том что я настраивал подобные туннели но щас видимо глаз
>замылился, не могу найти ошибку, нужна помощь

Этот вариант не подходит
спасибо
а есть ли еще какие-нибудь решения


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "помогите с настройкой VPN между d-link и cisco"  
Сообщение от Kostya email(??) on 14-Сен-07, 10:50 
Привет всем!Ребята срочно нужна помощь!Есть такая схема: d-link и cisco по IPSEC
нормально работают ,локальные сети друг друга видят, но в cisco LAN
подключена статическим роутингом через третий роутер.
Еще одна сеть,ресурсы которой остаюся для Dlinka недоступными(даже пинг туда не идет
и оттуда нету.
Схема :Dlink(LAN 10.145.6.0/24 ip 10.145.6.2)___ISP(VPN)___Cisco(wan 88.88.88.90  lan 10.145.1.64/26 ip 10.145.1.91)___статика(2хпрвод линия)__10.145.2.5

Вопрос:Что мне надо сделать,чтоб попасть из сети 10.145.6.0  в сеть 10.145.2.0?

Заранее благодарен
могу выложить конфиг
Конфиг:
crypto keyring vpncli
  pre-shared-key address 0.0.0.0 0.0.0.0 key 1111111
!
crypto isakmp policy 10
encr 3des
hash md5
authentication pre-share
group 2
crypto isakmp profile vpns
   keyring vpncli
   match identity address 0.0.0.0
!
!
crypto ipsec transform-set vpnset esp-3des
!
crypto dynamic-map dynmap 10
set transform-set vpnset
set isakmp-profile vpns
match address 140
!
!
crypto map mymap 10 ipsec-isakmp dynamic dynmap
!
!
!
!
interface Loopback0
ip address 10.145.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly
shutdown
!
interface FastEthernet0
switchport access vlan 2
!
interface FastEthernet1
description LAN
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
description WAN
ip address 88.88.88.90 255.255.255.252
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
crypto map mymap
!
interface Virtual-Template1
ip unnumbered FastEthernet4
no ip proxy-arp
peer default ip address pool TESTWIMAX
ppp authentication pap
!
interface Vlan1
description LAN
ip address 192.168.0.1 255.255.255.0 secondary
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
interface Vlan2
ip address 10.145.1.91 255.255.255.192
ip rip send version 2
ip rip receive version 2
!
interface Vlan3
no ip address
!
router rip
version 2
redistribute static
network 10.0.0.0
!
ip local pool TESTWIMAX 10.145.1.126
ip route 0.0.0.0 0.0.0.0 88.204.156.89
ip route 10.61.2.0 255.255.255.0 10.145.1.100
ip route 10.130.1.0 255.255.255.0 10.145.1.100
ip route 10.145.2.0 255.255.255.0 10.145.1.100
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list Nated-routes interface FastEthernet4 overload
!
ip access-list extended Nated-routes
deny   ip host 192.168.1.17 host 192.168.1.1
permit ip 192.168.1.0 0.0.0.255 any
permit ip 192.168.0.0 0.0.0.255 any
deny   ip any any
deny   ip 10.145.1.0 0.0.0.255 10.145.6.0 0.0.0.255
permit ip 10.145.1.0 0.0.0.255 any
!
access-list 23 permit 88.204.148.14
access-list 23 permit 88.204.158.78
access-list 23 permit 82.200.134.121
access-list 23 permit 192.168.1.0 0.0.0.255
access-list 140 permit ip 10.145.1.0 0.0.0.255 10.145.6.0 0.0.0.255
access-list 140 permit ip 10.145.6.0 0.0.0.255 10.145.1.0 0.0.0.255
access-list 141 permit ip 192.168.10.0 0.0.0.255 any
access-list 141 permit ip any 192.168.10.0 0.0.0.255
access-list 141 deny   ip any any
dialer-list 1 protocol ip permit
no cdp run
!
!
radius-server attribute nas-port format d
radius-server host 192.168.1.17 auth-port 1812 acct-port 1813
radius-server key radkey321
!
control-plane
!
!
line con 0
no modem enable
line aux 0
logging synchronous
line vty 0 4
access-class 23 in
privilege level 15
transport input telnet ssh
!
scheduler max-task-time 5000
ntp clock-period 17175109
ntp server 129.7.1.66
ntp server 130.207.244.240
ntp server 192.5.41.209
end

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "помогите с настройкой VPN между d-link и cisco"  
Сообщение от Kostia on 18-Сен-07, 12:40 
Ну и  лодно сам справился!!!!!!!!
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "помогите с настройкой VPN между d-link и cisco"  
Сообщение от RPaha (??) on 27-Сен-07, 12:54 
>Ну и  лодно сам справился!!!!!!!!

а поподробнее??

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру