The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Вопросы по реализации QoS на Цисках"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Cisco Catalyst коммутаторы)
Изначальное сообщение [ Отслеживать ]
Курсы по Juniper Junos в Москве и Петербурге
"Вопросы по реализации QoS на Цисках"  +/
Сообщение от Luxor email(ok) on 18-Окт-07, 14:34 
Настраиваю QoS на Cisco 3550, собственно появился ряд принципиальных вопросов... очень был бы рад если бы мне дали ответы на них. Поясню сложившуюся ситуацию, к 3550 подходят несколько магистральных линий и несколько сетей на тупых свичах, так вот реализовал модель качества обслуживания в которой интернет траффик был приоритетным, траффик управляющей сети высокого приоритета, а большой траффик файлообменной сети с нулевым приоритетом.
  Делал по документации на Циску по следующей схеме - делаю class map в которых определяю классы траффика через (низкоропритетный траффик, интернет траффик и управляющий), далее делаю Policy map в которой определяется политика  в которой устонавливаю соответсвующий уровень dscp и низкоприоритетный траффик ограничивается до 10 мегабит, далее вешаю эту политику на все интерфейсы, на интерфейсах также определяю в какие очереди что засовывать с помощью команды wrr queue, и определяю ширину канал для каждой очереди. После этого сниффером убедился что каждому определенному мной траффику дается уровенбь dscp какой я и ставил.
  Сразу же возникла проблема что на некоторых портах работает QoS а на некоторых нет, полез читать документацию. В политике мы задаем уровень dscp для опредленного траффика, а в очереди на интерфейсах он засовывает по уровню CoS, для получения CoS я так понял искользуется карта DSCP-To-CoS. Оказывается это поле CoS (Class of Service) есть только в кадрах протокола 802.1q и ISL, это протоколы магистральных каналов, а у тех сетей которые напрямую поключены к Циске поля CoS нет и поэтому очевидно у них QoS и не работал из-за того что уровень dscp ставился у них правильно а в очереди шедуллер запихивает по значению CoS. Вот здесь первые вопросы -  Получается единственный выход ставить еще один управляемый коммутатор и загонять эти сети в магистраль и подавать ее на циску или я не правильно что-то понял и можно сделать как чтоб все без лишнего обрудования можно решить?
Обратил внимание на то что траффик файлообменного сервиса ограниченный десятью мегабитами заваливает циску своим траффиком, очевидно что этот траффик ограничивется 10 мегабит на порт а со всех портов под 100 мегабит набирается... начал читать документацию обратил внимание на agregat policer, поставил его на первую очередь (которая низкоприоритеная) думал что он теперь эту сокрость 10 мегабит будет агрегироват ь между портами но по-моему не работает... очевидно он агрегирует скорость только между классами в одной политике (так было в примере) это так?

И еще есть вопрос. есть команда show policy-map interfac в которой можно посмотреть сколько байт и какой битрейт прошел по классам траффика определнной в политике на данный интерфейс, так вот там по нулям, логично предположить что ничего не работает, НО после того как я еще раз проснифил траффик я убедился что уровни приоритета (dscp) она (политика) ставит как я и задавал... для теста сделал маленьку тестовую политику и посадил ее на выходной интерфейс и цифры какие-то побежали... немогу понять в чем дело, почему цифры никакие не появляются на входной политике ипользуя команду show policy-map interface ???
Помогите решить, у меня такое чувство что я что-то упустил при реализации, может кто сталкивался с подобными проблемами...
Ниже приведены class map, собственно политика и интерфейс на которую навешана политика.

Class Map match-any Queue1
   Match access-group name QoS_Punk

Class Map match-any Queue3
   Match access-group name QoS_Internet

Class Map match-all Queue2
   Match access-group name QoS_WEB

Class Map match-all Queue4
   Match access-group name QoS_Critical

Policy Map QoS-4q-1
    Class Queue1
      set ip dscp default
    Class Queue2
      set ip dscp cs3
    Class Queue3
      set ip dscp cs5
    Class Queue4
      set ip dscp cs7
    Class class-default
      set ip dscp default

interface FastEthernet0/24

switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,20-22,25
switchport mode trunk
ip arp inspection limit none
mls qos monitor dscp 40 0 24 56
storm-control broadcast level 10.00 5.00
wrr-queue bandwidth 10 45 45 1
wrr-queue cos-map 1 0 1 2 4 6
wrr-queue cos-map 2 3
wrr-queue cos-map 3 5
wrr-queue cos-map 4 7
priority-queue out
service-policy input QoS-4q-1

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Вопросы по реализации QoS на Цисках"  +/
Сообщение от Monty email(ok) on 18-Окт-07, 22:35 
Решаю проблемы, похожие на те, которые описал автор. Пока положительного результата от настройки QoS на коммутаторе Cisco Catalyst 3550 не добился.

Народ, отзовитесь, кто реально настраивал qos на 3550 или 3750. Помогите разобраться в тонкостях.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Вопросы по реализации QoS на Цисках"  +/
Сообщение от w0nders (??) on 19-Окт-07, 14:16 
>Решаю проблемы, похожие на те, которые описал автор. Пока положительного результата от
>настройки QoS на коммутаторе Cisco Catalyst 3550 не добился.
>
>Народ, отзовитесь, кто реально настраивал qos на 3550 или 3750. Помогите разобраться
>в тонкостях.

а равзе в class-map нельзя определить интерфейс ?
и далее промаркировать?

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Вопросы по реализации QoS на Цисках"  +/
Сообщение от Luxor email(ok) on 19-Окт-07, 15:06 
>>Решаю проблемы, похожие на те, которые описал автор. Пока положительного результата от
>>настройки QoS на коммутаторе Cisco Catalyst 3550 не добился.
>>
>>Народ, отзовитесь, кто реально настраивал qos на 3550 или 3750. Помогите разобраться
>>в тонкостях.
>
>а равзе в class-map нельзя определить интерфейс ?
>и далее промаркировать?

Нельзя! Class map только определяет тип траффика, а непосредственно маркирует траффик Политика навешанная на интерфейс в которой заданному class map присваивается требуемый уровень dscp.

Я уже прочел цисковскую книгу "Качество обслуживание в сетях IP", но там описываются общие принципы, а тонкости реализации не обсуждаются (((... может у кого-нибудь есть примеры реализации QoS-политики на коммутаторах 3550 или 3750 ? поделитесь пожалуйста или киньте ссылку.

Я слышал что на этом форуме есть юзер с ником Volka у которог есть сертификат CCIE, QoS как раз сдают на этом уровне. Volka помоги пожалуйста с пролемами описанными в первом посте...

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Вопросы по реализации QoS на Цисках"  +/
Сообщение от w0nders (??) on 19-Окт-07, 16:11 
>[оверквотинг удален]
>dscp.
>
> Я уже прочел цисковскую книгу "Качество обслуживание в сетях IP", но
>там описываются общие принципы, а тонкости реализации не обсуждаются (((... может
>у кого-нибудь есть примеры реализации QoS-политики на коммутаторах 3550 или 3750
>? поделитесь пожалуйста или киньте ссылку.
>
>Я слышал что на этом форуме есть юзер с ником Volka у
>которог есть сертификат CCIE, QoS как раз сдают на этом уровне.
>Volka помоги пожалуйста с пролемами описанными в первом посте...

да интересно, но информация CoS содержиться именно в кадре 802.1q, а на access-портах этого не будет...следовательно каким-то образом необходимо "раскрассить" весь трафик по интерфейсу...

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Вопросы по реализации QoS на Цисках"  +/
Сообщение от Luxor email(??) on 19-Окт-07, 16:47 
>[оверквотинг удален]
>>у кого-нибудь есть примеры реализации QoS-политики на коммутаторах 3550 или 3750
>>? поделитесь пожалуйста или киньте ссылку.
>>
>>Я слышал что на этом форуме есть юзер с ником Volka у
>>которог есть сертификат CCIE, QoS как раз сдают на этом уровне.
>>Volka помоги пожалуйста с пролемами описанными в первом посте...
>
>да интересно, но информация CoS содержиться именно в кадре 802.1q, а на
>access-портах этого не будет...следовательно каким-то образом необходимо "раскрассить" весь трафик по
>интерфейсу...

Поставить CoS на интерфейсе можно следующим способом
sw1.len1#conf t
sw1.len1(config)#int fast0/24
sw1.len1(config-if)#mls qos cos <0-7>

Если вы имели ввиду именно это и если я правильно все понял то этот вариант нам не подходит, потому что жестко ставит заданный CoS на ВСЕ пакеты, т.о. интернет и управляющий траффик пойдут на общих правах с большим файлообменным трафиком который забьет как нечего делать полезный трафик и сразу теряется смысл ради чего Качество Обслуживания в сети внедряется...

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "Вопросы по реализации QoS на Цисках"  +/
Сообщение от LILO (??) on 19-Окт-07, 17:01 
>[оверквотинг удален]
>sw1.len1#conf t
>sw1.len1(config)#int fast0/24
>sw1.len1(config-if)#mls qos cos <0-7>
>
>Если вы имели ввиду именно это и если я правильно все понял
>то этот вариант нам не подходит, потому что жестко ставит заданный
>CoS на ВСЕ пакеты, т.о. интернет и управляющий траффик пойдут на
>общих правах с большим файлообменным трафиком который забьет как нечего делать
>полезный трафик и сразу теряется смысл ради чего Качество Обслуживания в
>сети внедряется...

я понял Вас, ситуация интересная.
низкоприоритетный трафик вероятно в большей степени вхоядший ?
тогда может имеет смысл сформировать очередь на вхоядящем интерфейсе к коммутатору?

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "Вопросы по реализации QoS на Цисках"  +/
Сообщение от Monty email(ok) on 20-Окт-07, 00:00 
>[оверквотинг удален]
>>Если вы имели ввиду именно это и если я правильно все понял
>>то этот вариант нам не подходит, потому что жестко ставит заданный
>>CoS на ВСЕ пакеты, т.о. интернет и управляющий траффик пойдут на
>>общих правах с большим файлообменным трафиком который забьет как нечего делать
>>полезный трафик и сразу теряется смысл ради чего Качество Обслуживания в
>>сети внедряется...
>
>я понял Вас, ситуация интересная.
>низкоприоритетный трафик вероятно в большей степени вхоядший ?
>тогда может имеет смысл сформировать очередь на вхоядящем интерфейсе к коммутатору?

Что Вы имеете в виду, говоря об очереди на входящем интерфейсе? Уточните, пожалуйста.

Мне вообще принципиально не понятно, если порт абонентский и кадрам, приходящим на этот порт нельзя установить значение поля CoS, в виду его отсутствия. То как же тогда затолкать пакеты по очередям, если это реализуется с помощью значения поля CoS?..

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "Вопросы по реализации QoS на Цисках"  +/
Сообщение от LILO (??) on 20-Окт-07, 14:50 
>[оверквотинг удален]
>>низкоприоритетный трафик вероятно в большей степени вхоядший ?
>>тогда может имеет смысл сформировать очередь на вхоядящем интерфейсе к коммутатору?
>
>Что Вы имеете в виду, говоря об очереди на входящем интерфейсе? Уточните,
>пожалуйста.
>
>Мне вообще принципиально не понятно, если порт абонентский и кадрам, приходящим на
>этот порт нельзя установить значение поля CoS, в виду его отсутствия.
>То как же тогда затолкать пакеты по очередям, если это реализуется
>с помощью значения поля CoS?..

я имел ввиду "за устройством"  использую классификацию низкоприоритетного трафика, политика работает на исходщий трафик, соответвенно если  Вы устанавливаете на клиентском access-порту политеку QoS то исходящий трафик будет подвергаться механизам QoS

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "Немного конкретики"  +/
Сообщение от Monty email(ok) on 20-Окт-07, 17:48 
Перейду на конкретику. Допустим к интерфейсам FastEthernet 0/1 и FastEthernet 0/2 подключены абонентские сети с тупыми коммутаторами.

Интерфейсы имеют следующие настройки:
interface FastEthernet0/1
description Clients
switchport access vlan 5
wrr-queue cos-map 1 0 1 2 4 6
wrr-queue cos-map 2 3 5 7
service-policy input myqos
!
interface FastEthernet0/2
description Clients
switchport access vlan 5
wrr-queue cos-map 1 0 1 2 4 6
wrr-queue cos-map 2 3 5 7
service-policy input myqos
!

Политика myqos определена следующим образом:
class-map match-any Q1
  match access-group name FTP
class-map match-any Q2
  match access-group name SSH

policy-map myqos
  class Q1
   set dscp default
  class Q2
   set dscp cs3
  class class-default
   set dscp default
!

ip access-list extended FTP
permit tcp any any eq 20 21
ip access-list extended SSH
permit tcp any any eq 22

Допустим, что пользователь, подключенный к порту FastEthernet0/1 качает с FTP-сервера, подключенного к порту FastEthernet0/2. Т.е. основной поток является входящим на порт FastEthernet0/2.
Для пакетов от FTP-сервера, приходящих на порт FastEthernet0/2 срабатывает классификатор, который согласно политике устанавливает 0 значение DSCP (set dscp default).

На порту FastEthernet 0/2 политика QoS установлена следующим образом: service-policy input myqos. Т.е. то, что определено политикой myqos будет оказывать влияние на входящий на интерфейс трафик.

Т.е. трафик входящий на интерфейс FastEthernet 0/2 от FTp-сервера будет помещаться в первую выходную очередь интерфейсас FastEthernet 0/2.

Я правильно понимаю механизм? Поправьте, пожалуйста, если нет.

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

10. "Немного конкретики"  +/
Сообщение от Frozen (??) on 24-Окт-07, 15:21 
Видимо так много думать тут никто не любит :-)
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

11. "Немного конкретики"  +/
Сообщение от Ilya (??) on 24-Окт-07, 22:20 
>Видимо так много думать тут никто не любит :-)

Если молодые даже в простом разобраться не могут, этот QoS L2 уже перелапачен 100 раз в инете в русскоязычном переводе. А Volka  или кого-либо друго не надо просить, никто вам не обязан помогать!Читай cisco.com


Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

12. "Немного конкретики"  +/
Сообщение от Luxor email(ok) on 25-Окт-07, 14:02 

>>Видимо так много думать тут никто не любит :-)
>
>Если молодые даже в простом разобраться не могут, этот QoS L2 уже
>перелапачен 100 раз в инете в русскоязычном переводе. А Volka  
>или кого-либо друго не надо просить, никто вам не обязан помогать!Читай
>cisco.com

  Уж извините что скажу прямо, но от таких "умников" как вы Ilya меня тошнит. ПО ДЕЛУ написать ничего не могут, а на других пальцем показывают что молодое поколение тупое идет. Завал. Писал я здесь от отчаяния, т.к. и на cisco.com читал документацию по теме с красивенькой анимацией как QoS должен работать и книгу прочел Качество обслуживания в сетях IP, теоретическими  знаниями я под завяз накачан, нужны были ответы на вопросы по практическому внедрению QoS на КОНКРЕТНОЙ циске, про реальный опыт внедрения нигде не пишут, только на форуме можно у людей спросить.

>А Volka  или кого-либо друго не надо просить, никто вам не обязан помогать

Этой фразой вы меня окончательно убили. Ясное дело что никто ничем на этом форуме никому не обязан, в интернете вообще никто никому ничем не обязан, я ПРОСИЛ ответить на мои вопросы и если есть желание и время ответить по делу то почему бы не ответить или ссылку кинуть хотябы...
  QoS никогда не был простой темой, наверно по этому ее здают на уровень CCIE, я решил свою проблему с QoS - релизовал классификацию по траффика по Vlan-ам и все заработало, но мои вопросы остаются открытыми и на этом форуме ответить мне никто не смог.

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

13. "Вопросы по реализации QoS на Цисках"  +/
Сообщение от Volosan email on 29-Окт-07, 13:49 
>Настраиваю QoS на Cisco 3550, собственно появился ряд принципиальных вопросов... очень был
>бы рад если бы мне дали ответы на них. Поясню сложившуюся
>ситуацию, к 3550 подходят несколько магистральных линий и несколько сетей на
>тупых свичах, так вот реализовал модель качества обслуживания в которой интернет
>траффик был приоритетным, траффик управляющей сети высокого приоритета, а большой траффик
>файлообменной сети с нулевым приоритетом.
>Ниже приведены class map, собственно политика и интерфейс на которую навешана политика.
>

Добрый день!

3550 имеет только 4 аппаратные очереди (и только на выход). Поэтому делить трафик более чем на 4 класса, включая default, нет смысла.

Сначала вам необходимо раскрасить трафик, навесив DSCP. И делать это нужно на входящих интерейсах layer3 интерфейсах.

>
>Class Map match-any Queue1
>   Match access-group name QoS_Punk
>

Если вы хотите этот трафик пустить как default, то не нужно для него класс создавать и ACL писать. Его красить не надо, у него и так DSCP 0 от рождения стоит.

> Class Map match-any Queue3
>   Match access-group name QoS_Internet
>
> Class Map match-all Queue2
>   Match access-group name QoS_WEB
>
> Class Map match-all Queue4
>   Match access-group name QoS_Critical
>

Классы расписаны нормально.


>Policy Map QoS-4q-1
>    Class Queue1
>      set ip dscp default

Не нужно. У всего трафика и так 0 стоит.

>    Class Queue2
>      set ip dscp cs3

Сделайте set cos 1

>    Class Queue3
>      set ip dscp cs5

Сделайте set cos 2. Cs5 зарезервирован для голоса. В приличных домах вас перемаркируют (а в неприличных что-нибудь оторвут).

>    Class Queue4
>      set ip dscp cs7

Сделайте set cos 3. Окраска по cs7 это вообще отвал бошки. Не столько другим нагадите, сколько себе.

>    Class class-default
>      set ip dscp default

Не нужно, если всё перемаркировывать в 0 не хотите.


Далее, мапу QoS-4q-1 с исходящих инт-сов убираем, а на входящие вешаем.
Всё, трафик покрасили. Теперь начинаем исходящую полосу делить.

>[оверквотинг удален]
> ip arp inspection limit none
> mls qos monitor dscp 40 0 24 56
> storm-control broadcast level 10.00 5.00
> wrr-queue bandwidth 10 45 45 1
> wrr-queue cos-map 1 0 ( убираем 1 2 4 6)
> wrr-queue cos-map 2 3 (меняем на 1)
> wrr-queue cos-map 3 5 (меняем на 2)
> wrr-queue cos-map 4 7 (меняем на 3)
> priority-queue out (не стоит её использовать не по назначению)
> service-policy input QoS-4q-1 (переносим на вход. инт-сы)

Ну и сомтрим, что QoS на свиче включить не забыли (sh mls qos).


Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

14. "Вопросы по реализации QoS на Цисках"  +/
Сообщение от Sunbeam email(??) on 29-Окт-07, 16:17 
Можно спросить, почему Вы считаете что данной командой все перемаркируется на 0 ?

>    Class class-default
>      set ip dscp default

Не нужно, если всё перемаркировывать в 0 не хотите.

Насколько я понимаю этим перемаркируется только то что не описано в остальных классах .Понятно что это не нужно, так как в отсутствии mls qos trus dscp на входе все обнулится итак но все же недопянял Вашу фразу.Вы считаете вся раскраска этим погубится?

Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

15. "Вопросы по реализации QoS на Цисках"  +/
Сообщение от Volosan email on 29-Окт-07, 17:52 
>[оверквотинг удален]
>
>>    Class class-default
>>      set ip dscp default
>
>Не нужно, если всё перемаркировывать в 0 не хотите.
>
>Насколько я понимаю этим перемаркируется только то что не описано в остальных
>классах .Понятно что это не нужно, так как в отсутствии mls
>qos trus dscp на входе все обнулится итак но все же
>недопянял Вашу фразу.Вы считаете вся раскраска этим погубится?

Нет не считаю. Писал быстро, а потому неточно выразился. Этим перемаркируется только то, что не попало в другие классы.


Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

16. "Вопросы по реализации QoS на Цисках"  +/
Сообщение от ddenia email(??) on 26-Июл-13, 13:36 
>[оверквотинг удален]
>>>      set ip dscp default
>>
>>Не нужно, если всё перемаркировывать в 0 не хотите.
>>
>>Насколько я понимаю этим перемаркируется только то что не описано в остальных
>>классах .Понятно что это не нужно, так как в отсутствии mls
>>qos trus dscp на входе все обнулится итак но все же
>>недопянял Вашу фразу.Вы считаете вся раскраска этим погубится?
> Нет не считаю. Писал быстро, а потому неточно выразился. Этим перемаркируется только
> то, что не попало в другие классы.

http://it-admin.org/cisco-systems/qos-kachestvo-obsluzhivani...

Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру