The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"124-18 - route-map:can not set (нежданные грабли)"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"124-18 - route-map:can not set (нежданные грабли)"  
Сообщение от Katana (ok) on 16-Янв-08, 02:14 
Жилось более-менее нормально на rsp-pv-mz.124-12.bin , но поскольку добрый человек подсобил rsp-pv-mz.124-18.bin решился на апдейт. Все бы ничего, но в рабочем конфиге на route-mapах часто использовал конструкцию в стиле

route-map map_fe1.10 permit 10
match ip address 224
set interface Null0

Теперь же на  такие поползновения с моей стороны (surprise!) киска ругается
% Use P2P interfaces for set interface clause
% route-map:can not set interface.

В силу своего скромного разума понял, что теперь данная конструкция катит
только для P2P интерфейсов, но как Null0 сделать таковым или чем заменить
данный actions идей не нашлось.

В гугле по данным ключевым словам ничего не ищется, а новый иос сильно хочется.
Подскажите pls, что нужно теперь здесь писать..  И уже заодно.. Напряжно стало "котов в мешке сравнивать", может кто знает - есть ли какой-нибудь changelog изменений внутри ветки на cisco.com или еще где-нибудь , допустим с 124.13b до 124.18 ? May be в политике партии еще что-нибудь меняется, хочется быть в курсе..

Заранее спасибо за варианты.

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "124-18 - route-map:can not set (нежданные грабли)"  
Сообщение от sh_ email(??) on 16-Янв-08, 15:59 
set next-hop 1.1.1.1
ip route 1.1.1.1 255.255.255.255 null 0

а так работает?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "124-18 - route-map:can not set (нежданные грабли)"  
Сообщение от Sklis (ok) on 17-Янв-08, 15:07 
Столкнулся и я с аналогичной проблемой. Совет sh_ не помог.
Пожалуйста, поделитесь идейками!!!!
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "124-18 - route-map:can not set (нежданные грабли)"  
Сообщение от Katana (ok) on 20-Янв-08, 00:35 
>Столкнулся и я с аналогичной проблемой. Совет sh_ не помог.
>Пожалуйста, поделитесь идейками!!!!

Уважаемый all, не дайте умереть в неведении. Может кто уже решил - отпишитесь

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "124-18 - route-map:can not set (нежданные грабли)"  
Сообщение от CrAzOiD (ok) on 20-Янв-08, 01:13 
>>Столкнулся и я с аналогичной проблемой. Совет sh_ не помог.
>>Пожалуйста, поделитесь идейками!!!!
>
>Уважаемый all, не дайте умереть в неведении. Может кто уже решил -
>отпишитесь

set default interface Null0 не катит?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "124-18 - route-map:can not set (нежданные грабли)"  
Сообщение от Sklis (ok) on 21-Янв-08, 10:14 
>>>Столкнулся и я с аналогичной проблемой. Совет sh_ не помог.
>>>Пожалуйста, поделитесь идейками!!!!
>>
>>Уважаемый all, не дайте умереть в неведении. Может кто уже решил -
>>отпишитесь
>
>set default interface Null0 не катит?

Нет. То-же самое:
crypt(config-route-map)#default set interface Null0
% route-map:can not set interface.
% Use P2P interfaces for set interface clause


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "124-18 - route-map:can not set (нежданные грабли)"  
Сообщение от CrAzOiD (ok) on 21-Янв-08, 11:07 
>[оверквотинг удален]
>>>
>>>Уважаемый all, не дайте умереть в неведении. Может кто уже решил -
>>>отпишитесь
>>
>>set default interface Null0 не катит?
>
>Нет. То-же самое:
>crypt(config-route-map)#default set interface Null0
>% route-map:can not set interface.
>% Use P2P interfaces for set interface clause

именно set default interface Null0
я проверил - проходит (точно так же как твоя конструкция не проходит тоже)
тут только момент относительно ограничений default

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "124-18 - route-map:can not set (нежданные грабли)"  
Сообщение от Sklis (ok) on 21-Янв-08, 16:22 
>[оверквотинг удален]
>>
>>Нет. То-же самое:
>>crypt(config-route-map)#default set interface Null0
>>% route-map:can not set interface.
>>% Use P2P interfaces for set interface clause
>
>именно set default interface Null0
>я проверил - проходит (точно так же как твоя конструкция не проходит
>тоже)
>тут только момент относительно ограничений default

Спасибо, CrAzOiD! Все пошло!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "124-18 - route-map:can not set (нежданные грабли)"  
Сообщение от Макс email(??) on 22-Фев-08, 11:14 
>[оверквотинг удален]
>>>crypt(config-route-map)#default set interface Null0
>>>% route-map:can not set interface.
>>>% Use P2P interfaces for set interface clause
>>
>>именно set default interface Null0
>>я проверил - проходит (точно так же как твоя конструкция не проходит
>>тоже)
>>тут только момент относительно ограничений default
>
>Спасибо, CrAzOiD! Все пошло!

У меня анологичнфя проблема. Блогодаря крманде set default interface мапу то я повесил. Но... вопервых, мне надо ее влепить на Лупбек, а вовторых после того как сесия устанавливается  приходящие данные декапсулируются, но вот назад не инкапсулируются!
Если можете подскажите, заранее спасибо!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "124-18 - route-map:can not set (нежданные грабли)"  
Сообщение от Andrew email(??) on 04-Май-08, 13:29 
У меня аналогичная позиция на SOHO-91 (soho91-k9oy6-mz.124-19.bin).

Пытаюсь сделать NAT на резервный канал:


interface Loopback0
ip address 192.168.251.1 255.255.255.252
ip nat inside
!
interface Ethernet0
! Основной канал
ip address 10.1.4.12 255.255.255.224
no cdp enable
hold-queue 32 in
!
interface Ethernet1
! рабочие станции и резервный канал через выделенку.
ip address 8.1.5.241 255.255.255.128 secondary
ip address 192.168.2.190 255.255.255.240
ip nat outside
ip policy route-map Over44-Map
duplex auto
no cdp enable
!
! Маршрут на резервный канал задан статикой.
ip route 0.0.0.0 0.0.0.0 8.1.5.129 177
!
ip nat pool NAT-OVER44-POOL 8.1.5.241 8.1.5.241 netmask 255.255.255.128
ip nat source list Over44 pool NAT-OVER44-POOL overload
!
!
ip access-list extended Over44
permit icmp any any
permit tcp 192.168.2.176 0.0.0.15 194.85.126.224 0.0.0.31
!
route-map Over44-Map permit 10
match ip address Over44
! match interface Ethernet1 -- это не обязательно
! set interface Loopback0  ---  А вот тут все и случается.
!


На Version 12.4(10a) на команду не возмущался, но не работал.

На Version 12.4(19) - возмущается на команду.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "124-18 - route-map:can not set (нежданные грабли)"  
Сообщение от Andrew email(??) on 04-Май-08, 14:25 
>У меня аналогичная позиция на SOHO-91 (soho91-k9oy6-mz.124-19.bin).
>
>Пытаюсь сделать NAT на резервный канал:

Какой-то обход предлагается вот тут: http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tec...


Надо будет попробовать.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "124-18 - route-map:can not set (нежданные грабли)"  
Сообщение от Katana (ok) on 08-Июл-08, 11:31 
Так и не работает.. И известного решения нет..
У нас через route-map сделано отключение неплательщиков, весь их трафик заручиваем в Null0..

Сейчас извращаюсь через

route-map rtmap_1 permit 10
match ip address 1
set ip next-hop xx.xx.xx.xx

где xx.xx.xx.xx зароутил в Null0

но это видимо все уходит в soft потому как проц резко просел.

Предлагаемая замена set default interface Null0 не прокатывает так как для xx.xx.xx.xx есть route и в Null0 оно дропаться не хочет. Уже подумываю поставить serial интерфейсы в железяку.. чтобы тупо туда все можно было слать..

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру