The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Easy VPN Server over dynamic-map"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Easy VPN Server over dynamic-map"  
Сообщение от FoxTerier (ok) on 11-Май-08, 11:43 
хочу настроить Easy VPN Server, смануалом настроил и все работает(тест сделал), но есть одна проблема, на маршитизаторе, где я должен настроит етот сервак интерфеис сидит на другом crypto map, а я должен создать crypto dynamic-map, как все настроить?

яж должен сделать так:
crypto dynamic-map dynmap 1

но у меня интерфеис сидит на таком
crypto map MYMAP 1 ipsec-isakmp

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Easy VPN Server over dynamic-map"  
Сообщение от bmonk (??) on 11-Май-08, 13:16 
>хочу настроить Easy VPN Server, смануалом настроил и все работает(тест сделал), но
>есть одна проблема, на маршитизаторе, где я должен настроит етот сервак
>интерфеис сидит на другом crypto map, а я должен создать crypto
>dynamic-map, как все настроить?
>
>яж должен сделать так:
>crypto dynamic-map dynmap 1
>
>но у меня интерфеис сидит на таком
>crypto map MYMAP 1 ipsec-isakmp

crypto map mymap 2 dynmap
!! главное для статического тоннеля пропиши
crypto isakmp key tunnel address х.х.х.х у.у.у.у no-xauth

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Easy VPN Server over dynamic-map"  
Сообщение от FoxTerier (ok) on 11-Май-08, 16:02 
>crypto map mymap 2 dynmap
>!! главное для статического тоннеля пропиши
>crypto isakmp key tunnel address х.х.х.х у.у.у.у no-xauth

можно гдето посмотрет мануал об етой теме? статистически ип не могу прописать, потаму что не знаию впн клиент от куда будет зохадить

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Easy VPN Server over dynamic-map"  
Сообщение от bmonk (??) on 12-Май-08, 08:43 
>>crypto map mymap 2 dynmap
>>!! главное для статического тоннеля пропиши
>>crypto isakmp key tunnel address х.х.х.х у.у.у.у no-xauth
>
>можно гдето посмотрет мануал об етой теме? статистически ип не могу прописать,
>потаму что не знаию впн клиент от куда будет зохадить

этот статический ip для постоянного тоннеля, если он есть.
http://www.ciscolab.ru/2007/03/14/router_vpn_stick.html

если у тебя уже есть криптомапа, в твоей случае
crypto map MYMAP 1 ipsec-isakmp - я так понимаю эта криптомапа случжит для связи с др циской, у которой есть статическй адрес??? вот его и надо будет написать вместо х.х.х.х с маской у.у.у.у


то скорее всего есть и такая
crypto isakmp key SSSS address 0.0.0.0 0.0.0.0
ее надо заменить на
crypto isakmp key SSSS address х.х.х.х у.у.у.у no-xauth

и еще тебе надо будет просто создать

crypto dynamic-map dynmap 1
и добавить такую строчку
crypto map MYMAP 2 dynmap

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Easy VPN Server over dynamic-map"  
Сообщение от FoxTerier (ok) on 12-Май-08, 10:27 
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Router-1
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
!
!
no ip domain lookup
ip domain name opennet.ru :-)))
!
!
!
!
!
!
!
!
!
crypto isakmp policy 1
encr aes 256
authentication pre-share
group 5
!
crypto isakmp policy 2
encr 3des
authentication pre-share
group 2
!
crypto isakmp policy 10
crypto isakmp key adasdad 10.10.10.10
crypto isakmp key aqwddad 10.10.10.11
crypto isakmp key asdasdad address 10.10.10.12
crypto isakmp key adadasdasdasd address 10.10.10.13
crypto isakmp key adadadadasd address 10.10.10.14
!
!
crypto ipsec transform-set tra-1 esp-aes 256 esp-sha-hmac
crypto ipsec transform-set tra-2 ah-sha-hmac esp-3des
crypto ipsec transform-set tra-3 esp-3des esp-sha-hmac
crypto ipsec df-bit clear
!
crypto ipsec profile profile-3des-sha1
set transform-set 3des-sha1
!
!
crypto map mymap local-address FastEthernet0/0
crypto map mymap 1 ipsec-isakmp
description hello
set peer 10.10.10.10
set transform-set tra-1
match address blablabla
crypto map mymap 10 ipsec-isakmp
description ciao
set peer 10.10.10.11
set transform-set 3des-sha1
match address blabla
crypto map mymap 11 ipsec-isakmp
description hi
set peer 10.10.10.12
set transform-set 3des-sha1
match address blublu
!
!
!
!
!
!
interface FastEthernet0/0
description LAN
ip address 192.168.0.137 255.255.255.0
duplex auto
speed auto
crypto map mymap
!
interface FastEthernet0/1
description External Interfase
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.7
description UHU
encapsulation dot1Q 7
ip address 19.19.19.19 255.255.255.252
ip nat outside
ip virtual-reassembly
no snmp trap link-status
no cdp enable
!
interface FastEthernet0/1.8
description AHA
encapsulation dot1Q 8
ip address 20.20.20.20 255.255.255.192
ip nat outside
ip virtual-reassembly
no snmp trap link-status
no cdp enable
!
end.

вот ето мой конфиг, потом я добавил вот еты строки, но всетаки нечего :-(((

aaa new-model
aaa authentication login userauthen local
aaa authorization network vpn_clients local
aaa session-id common

crypto isakmp client configuration group vpn_clients
key password
pool ippool

crypto dynamic-map dynmap 1
set transform-set myset
reverse-route
!
crypto map dynmap client authentication list userauthen
crypto map dynmap isakmp authorization list vpn_clients
crypto map dynmap client configuration address respond
crypto map mymap 13 ipsec-isakmp dynamic dynmap
!
!
ip local pool ippool 192.168.0.10 192.168.0.20
!
!
!
end


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Easy VPN Server over dynamic-map"  
Сообщение от bmonk (??) on 13-Май-08, 08:28 

вместо этого
crypto map dynmap client authentication list userauthen
crypto map dynmap isakmp authorization list vpn_clients
crypto map dynmap client configuration address respond
сделай
crypto map mymap client authentication list userauthen
crypto map mymap isakmp authorization list vpn_clients
crypto map mymap client configuration address respond
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру