The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Cisco 2811 как pptp клиент"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Cisco 2811 как pptp клиент"  
Сообщение от l0ki (ok) on 25-Дек-08, 04:08 
Есть роутер 2811XM , ios был c2600-advsecurityk9-mz.124-18.bin, c2600-advipservicesk9-mz.123-13.bin, и еще ipbase-123.8.
Задача - подключить к интернет через провайдера по pptp.
по данной статье http://groups.google.com/group/comp.dcom.sys.cisco/msg/81d58... делаю конфиг.
Конфиг.

service internal
no ip gratuitous-arps
no ip cef
!

!
ip multicast-routing
vpdn enable
!
vpdn-group 1
request-dialin
protocol pptp
rotary-group 1 или 0
initiate-to ip 10.101.0.1
!
!
!
interface FastEthernet0/0
shutdown
description LAN
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1
description Local Prov
ip address dhcp
ip nat outside
duplex auto
speed auto
no cdp enable
!
interface Dialer1
description WAN
mtu 1450
ip address negotiated
ip nat outside
ip pim dense-mode
encapsulation ppp
dialer in-band
dialer idle-timeout 0
dialer string 123
dialer vpdn
dialer-group 1
no cdp enable
ppp pfc local request
ppp pfc remote apply
ppp encrypt mppe auto
ppp chap hostname xxxx
ppp chap password 7 xxxx
!
dialer-list 1 protocol ip permit
!
потом через дебаг смотрю что происходит
*Mar  1 10:42:55.717: Vi1 DDR: place call
*Mar  1 10:42:55.717: Vi1 DDR: Dialing cause ip (s=0.0.0.0, d=224.0.0.13)
*Mar  1 10:42:55.717: Vi1 DDR: Attempting to dial 123
потом дисконект и все по новой.
Подскажите в чем ошибка и куда копать. Мозг уже сломал.

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Cisco 2811 как pptp клиент"  
Сообщение от KiM on 25-Дек-08, 08:58 
>[оверквотинг удален]
>ppp chap password 7 xxxx
>!
>dialer-list 1 protocol ip permit
>!
>потом через дебаг смотрю что происходит
>*Mar  1 10:42:55.717: Vi1 DDR: place call
>*Mar  1 10:42:55.717: Vi1 DDR: Dialing cause ip (s=0.0.0.0, d=224.0.0.13)
>*Mar  1 10:42:55.717: Vi1 DDR: Attempting to dial 123
>потом дисконект и все по новой.
>Подскажите в чем ошибка и куда копать. Мозг уже сломал.

простите но вы ошиблись в роутере может 2611XM?
>*Mar  1 10:42:55.717: Vi1 DDR: Dialing cause ip (s=0.0.0.0, d=224.0.0.13)

почему коннект с юникаста идёт на мыльтикаст адресс?
у меня у самого дома 1711 инет получает по pptp настраивал по тойже инчтрукции всё работает как часы вот как у меня http://darksid.blog.ru/tag/pptp

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Cisco 2811 как pptp клиент"  
Сообщение от l0ki (ok) on 25-Дек-08, 09:56 
>[оверквотинг удален]
>>потом дисконект и все по новой.
>>Подскажите в чем ошибка и куда копать. Мозг уже сломал.
>
>простите но вы ошиблись в роутере может 2611XM?
>>*Mar  1 10:42:55.717: Vi1 DDR: Dialing cause ip (s=0.0.0.0, d=224.0.0.13)
>
>почему коннект с юникаста идёт на мыльтикаст адресс?
>у меня у самого дома 1711 инет получает по pptp настраивал по
>тойже инчтрукции всё работает как часы вот как у меня http://darksid.blog.ru/tag/pptp
>

Да, извеняюсь 2611XM, ваш блог тоже читал. вот эта строчка меня тоже насторожила ip (s=0.0.0.0, d=224.0.0.13)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Cisco 2811 как pptp клиент"  
Сообщение от KiM on 25-Дек-08, 11:01 
>[оверквотинг удален]
>>простите но вы ошиблись в роутере может 2611XM?
>>>*Mar  1 10:42:55.717: Vi1 DDR: Dialing cause ip (s=0.0.0.0, d=224.0.0.13)
>>
>>почему коннект с юникаста идёт на мыльтикаст адресс?
>>у меня у самого дома 1711 инет получает по pptp настраивал по
>>тойже инчтрукции всё работает как часы вот как у меня http://darksid.blog.ru/tag/pptp
>>
>
>Да, извеняюсь 2611XM, ваш блог тоже читал. вот эта строчка меня тоже
>насторожила ip (s=0.0.0.0, d=224.0.0.13)

ip nat outside не там он должен как минимум быть на virtual-template

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Cisco 2811 как pptp клиент"  
Сообщение от l0ki (ok) on 25-Дек-08, 11:09 
>[оверквотинг удален]
>>>почему коннект с юникаста идёт на мыльтикаст адресс?
>>>у меня у самого дома 1711 инет получает по pptp настраивал по
>>>тойже инчтрукции всё работает как часы вот как у меня http://darksid.blog.ru/tag/pptp
>>>
>>
>>Да, извеняюсь 2611XM, ваш блог тоже читал. вот эта строчка меня тоже
>>насторожила ip (s=0.0.0.0, d=224.0.0.13)
>
>ip nat outside не там он должен как минимум быть на virtual-template
>

Там тоже должен быть , т.к. доступ домашней сетки в сетку прова должен быть .

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Cisco 2811 как pptp клиент"  
Сообщение от KiM on 25-Дек-08, 11:27 
>[оверквотинг удален]
>>>>
>>>
>>>Да, извеняюсь 2611XM, ваш блог тоже читал. вот эта строчка меня тоже
>>>насторожила ip (s=0.0.0.0, d=224.0.0.13)
>>
>>ip nat outside не там он должен как минимум быть на virtual-template
>>
>
>Там тоже должен быть , т.к. доступ домашней сетки в сетку прова
>должен быть .

а ты точно адрес на интерфейс получаеш? мошть dhcp не получает адрес и маршруты?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Cisco 2811 как pptp клиент"  
Сообщение от KiM on 25-Дек-08, 11:28 
>[оверквотинг удален]
>>>>
>>>
>>>Да, извеняюсь 2611XM, ваш блог тоже читал. вот эта строчка меня тоже
>>>насторожила ip (s=0.0.0.0, d=224.0.0.13)
>>
>>ip nat outside не там он должен как минимум быть на virtual-template
>>
>
>Там тоже должен быть , т.к. доступ домашней сетки в сетку прова
>должен быть .

ещё возможно маршрута до терминатора нет

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "Cisco 2811 как pptp клиент"  
Сообщение от l0ki (ok) on 25-Дек-08, 11:52 
>[оверквотинг удален]
>>>>Да, извеняюсь 2611XM, ваш блог тоже читал. вот эта строчка меня тоже
>>>>насторожила ip (s=0.0.0.0, d=224.0.0.13)
>>>
>>>ip nat outside не там он должен как минимум быть на virtual-template
>>>
>>
>>Там тоже должен быть , т.к. доступ домашней сетки в сетку прова
>>должен быть .
>
>ещё возможно маршрута до терминатора нет

Адрес получает , так же прописывал статический, т.к. привязка у прова идет по маку.
И маршрут тоже прописывал .

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "Cisco 2811 как pptp клиент"  
Сообщение от KiM on 25-Дек-08, 12:24 
>[оверквотинг удален]
>>>>
>>>
>>>Там тоже должен быть , т.к. доступ домашней сетки в сетку прова
>>>должен быть .
>>
>>ещё возможно маршрута до терминатора нет
>
>Адрес получает , так же прописывал статический, т.к. привязка у прова идет
>по маку.
>И маршрут тоже прописывал .

причина дисконекта?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "Cisco 2811 как pptp клиент"  
Сообщение от KiM on 25-Дек-08, 12:24 
>[оверквотинг удален]
>>>>
>>>
>>>Там тоже должен быть , т.к. доступ домашней сетки в сетку прова
>>>должен быть .
>>
>>ещё возможно маршрута до терминатора нет
>
>Адрес получает , так же прописывал статический, т.к. привязка у прова идет
>по маку.
>И маршрут тоже прописывал .

debug ppp packets

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "Cisco 2811 как pptp клиент"  
Сообщение от l0ki (ok) on 25-Дек-08, 16:11 
>[оверквотинг удален]
>>>>Там тоже должен быть , т.к. доступ домашней сетки в сетку прова
>>>>должен быть .
>>>
>>>ещё возможно маршрута до терминатора нет
>>
>>Адрес получает , так же прописывал статический, т.к. привязка у прова идет
>>по маку.
>>И маршрут тоже прописывал .
>
>debug ppp packets

в ответ полная тишина , на консоль ничего не выводиться.
Привожу реальный конфиг который сегодня заново написал.

Cisco IOS Software, C2600 Software (C2600-ADVIPSERVICESK9-M), Version 12.4(19), RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2008 by Cisco Systems, Inc.
Compiled Fri 29-Feb-08 19:23 by prod_rel_team
ROM: System Bootstrap, Version 12.2(8r) [cmong 8r], RELEASE SOFTWARE (fc1)

service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service internal
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
no ip gratuitous-arps
ip cef
!
ip multicast-routing
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
vpdn enable
!
vpdn-group 1
request-dialin
  protocol pptp
  rotary-group 0
initiate-to ip 10.101.0.1
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
description PROV
ip address 10.7.112.12 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
no cdp enable
!
interface Dialer0
ip address negotiated
ip pim dense-mode
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer in-band
dialer idle-timeout 0
dialer string 123
dialer vpdn
dialer-group 1
no cdp enable
ppp pfc local request
ppp pfc remote apply
ppp pap sent-username xxxx password 7 xxxx
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 10.0.0.0 255.0.0.0 FastEthernet0/1
ip route 10.101.0.1 255.255.255.255 FastEthernet0/1
!
ip http server
no ip http secure-server
!
dialer-list 1 protocol ip permit
!
control-plane
!
line con 0
line aux 0
line vty 0 4
!
end

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "Cisco 2811 как pptp клиент"  
Сообщение от KiM on 25-Дек-08, 16:22 
>[оверквотинг удален]
>!
>dialer-list 1 protocol ip permit
>!
>control-plane
>!
>line con 0
>line aux 0
>line vty 0 4
>!
>end

вот мой работающий конфиг
service internal
!
vpdn enable
!
vpdn-group 1
request-dialin
  protocol pptp
  rotary-group 0
initiate-to ip z.z.z.1
initiate-to ip z.z.z.2
!
interface FastEthernet0
mac-address xxxx.xxxx.xxxx
ip address dhcp client-id FastEthernet0
ip virtual-reassembly
ip route-cache flow
duplex auto
speed auto
!
interface FastEthernet1
switchport access vlan 100
spanning-tree portfast
!
interface Vlan100
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip route-cache flow
!
interface Dialer0
bandwidth 3000
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip route-cache flow
dialer in-band
dialer idle-timeout 0
dialer string 123
dialer vpdn
dialer-group 1
no cdp enable
ppp pfc local request
ppp pfc remote apply
ppp encrypt mppe auto
ppp chap hostname 232323323232
ppp chap password 7 1111111111111
!
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route x.x.x.1 255.255.255.255 z.z.z.254#маршрут до терминатора
ip route x.x.x.2 255.255.255.255 z.z.z.254#маршрут до терминатора
!
dialer-list 1 protocol ip permit

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "Cisco 2811 как pptp клиент"  
Сообщение от sergey_b email(ok) on 25-Дек-08, 17:59 
>[оверквотинг удален]
> ppp pfc remote apply
> ppp pap sent-username xxxx password 7 xxxx
>!
>ip forward-protocol nd
>ip route 0.0.0.0 0.0.0.0 Dialer0
>ip route 10.0.0.0 255.0.0.0 FastEthernet0/1
>ip route 10.101.0.1 255.255.255.255 FastEthernet0/1
>!
>dialer-list 1 protocol ip permit
>!

Попробуй прописать роут в pptp пира 10.101.0.1 не в FastEthernet0/1 а именно в IP-адресс шлюза провайдера, который в сети 10.7.112.0/255.255.255.0

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "Cisco 2811 как pptp клиент"  
Сообщение от l0ki (ok) on 26-Дек-08, 06:20 
>[оверквотинг удален]
>>ip forward-protocol nd
>>ip route 0.0.0.0 0.0.0.0 Dialer0
>>ip route 10.0.0.0 255.0.0.0 FastEthernet0/1
>>ip route 10.101.0.1 255.255.255.255 FastEthernet0/1
>>!
>>dialer-list 1 protocol ip permit
>>!
>
>Попробуй прописать роут в pptp пира 10.101.0.1 не в FastEthernet0/1 а именно
>в IP-адресс шлюза провайдера, который в сети 10.7.112.0/255.255.255.0

Интересно а почему здесь ip route x.x.x.1 255.255.255.255 z.z.z.254 - не 1 а 254?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "Cisco 2811 как pptp клиент"  
Сообщение от KiM on 26-Дек-08, 09:02 
>[оверквотинг удален]
>>>ip route 10.101.0.1 255.255.255.255 FastEthernet0/1
>>>!
>>>dialer-list 1 protocol ip permit
>>>!
>>
>>Попробуй прописать роут в pptp пира 10.101.0.1 не в FastEthernet0/1 а именно
>>в IP-адресс шлюза провайдера, который в сети 10.7.112.0/255.255.255.0
>
>Интересно а почему здесь ip route x.x.x.1 255.255.255.255 z.z.z.254 - не 1
>а 254?

потомучто адрес у меня 1 а шлюз 254:)))) китайцы блин:)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

15. "Cisco 2811 как pptp клиент"  
Сообщение от l0ki (ok) on 26-Дек-08, 09:07 
>[оверквотинг удален]
>>>>dialer-list 1 protocol ip permit
>>>>!
>>>
>>>Попробуй прописать роут в pptp пира 10.101.0.1 не в FastEthernet0/1 а именно
>>>в IP-адресс шлюза провайдера, который в сети 10.7.112.0/255.255.255.0
>>
>>Интересно а почему здесь ip route x.x.x.1 255.255.255.255 z.z.z.254 - не 1
>>а 254?
>
>потомучто адрес у меня 1 а шлюз 254:)))) китайцы блин:)

тьфу слава богу , а то я уж подумал хитрасть какая ! :-)
Сделаю конфиг на основании твоего , ток проверить смогу ток завтра .... корпаративвв.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

16. "Cisco 2811 как pptp клиент"  
Сообщение от l0ki (ok) on 28-Дек-08, 07:08 
>[оверквотинг удален]
>>>
>>>Интересно а почему здесь ip route x.x.x.1 255.255.255.255 z.z.z.254 - не 1
>>>а 254?
>>
>>потомучто адрес у меня 1 а шлюз 254:)))) китайцы блин:)
>
>тьфу слава богу , а то я уж подумал хитрасть какая !
>:-)
>Сделаю конфиг на основании твоего , ток проверить смогу ток завтра ....
>корпаративвв.

Уже все перепробовал , результат одни , вечный реконнект диалера. Уже не знаю что и делать.


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

17. "Cisco 2811 как pptp клиент"  
Сообщение от l0ki (ok) on 01-Янв-09, 11:10 
>[оверквотинг удален]
>>>
>>>потомучто адрес у меня 1 а шлюз 254:)))) китайцы блин:)
>>
>>тьфу слава богу , а то я уж подумал хитрасть какая !
>>:-)
>>Сделаю конфиг на основании твоего , ток проверить смогу ток завтра ....
>>корпаративвв.
>
>Уже все перепробовал , результат одни , вечный реконнект диалера. Уже не
>знаю что и делать.

Разобрался , сейчас хоть в deb ppp packet есть информация.
Сейчас соединение подмается , но сразу падает.
В логах

14:31:09.045: Vi1 PPP: I pkt type 0xC021, datagramsize 12 link[ppp]
*Mar  1 14:31:09.049: Vi1 PPP: I pkt type 0xC227, datagramsize 13 link[ppp]
*Mar  1 14:31:09.049: Vi1 LCP: I ECHOREQ [Open] id 0 len 8 magic 0x39E0FC74
*Mar  1 14:31:09.049: Vi1 LCP: O ECHOREP [Open] id 0 len 8 magic 0x120DD90A
*Mar  1 14:31:09.053: Vi1 EAP: I REQUEST  IDENTITY id 10 len 9
*Mar  1 14:31:09.053: Vi1 EAP: O RESPONSE IDENTITY id 10 len 12 from "HellNet"
*Mar  1 14:31:09.057: Vi1 PPP: I pkt type 0xC227, datagramsize 32 link[ppp]
*Mar  1 14:31:09.057: Vi1 EAP: I REQUEST  MD5 id 11 len 28 from "100"
*Mar  1 14:31:09.065: Vi1 LCP: O TERMREQ [Open] id 3 len 4
*Mar  1 14:31:09.073: Vi1 PPP: I pkt type 0xC021, datagramsize 8 link[ppp]
*Mar  1 14:31:09.073: Vi1 LCP: I TERMACK [TERMsent] id 3 len 4
*Mar  1 14:31:09.081: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
Подскажите сто не так опять , версия ios c2600-advipservicesk9-mz.124-19

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

18. "Cisco 2811 как pptp клиент"  
Сообщение от KiM on 05-Янв-09, 18:53 
>[оверквотинг удален]
>*Mar  1 14:31:09.057: Vi1 EAP: I REQUEST  MD5 id 11
>len 28 from "100"
>*Mar  1 14:31:09.065: Vi1 LCP: O TERMREQ [Open] id 3 len
>4
>*Mar  1 14:31:09.073: Vi1 PPP: I pkt type 0xC021, datagramsize 8
>link[ppp]
>*Mar  1 14:31:09.073: Vi1 LCP: I TERMACK [TERMsent] id 3 len
>4
>*Mar  1 14:31:09.081: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
>Подскажите сто не так опять , версия ios c2600-advipservicesk9-mz.124-19

какието проблемы с согласованием протокола ppp

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

19. "Cisco 2811 как pptp клиент"  
Сообщение от sergey_b email(ok) on 06-Янв-09, 12:32 
>[оверквотинг удален]
>>*Mar  1 14:31:09.065: Vi1 LCP: O TERMREQ [Open] id 3 len
>>4
>>*Mar  1 14:31:09.073: Vi1 PPP: I pkt type 0xC021, datagramsize 8
>>link[ppp]
>>*Mar  1 14:31:09.073: Vi1 LCP: I TERMACK [TERMsent] id 3 len
>>4
>>*Mar  1 14:31:09.081: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
>>Подскажите сто не так опять , версия ios c2600-advipservicesk9-mz.124-19
>
>какието проблемы с согласованием протокола ppp

Попробуй на Dialer0 прописать ppp authentication chap callin

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

20. "Cisco 2811 как pptp клиент"  
Сообщение от l0ki (ok) on 10-Янв-09, 11:32 
>[оверквотинг удален]
>>>*Mar  1 14:31:09.073: Vi1 PPP: I pkt type 0xC021, datagramsize 8
>>>link[ppp]
>>>*Mar  1 14:31:09.073: Vi1 LCP: I TERMACK [TERMsent] id 3 len
>>>4
>>>*Mar  1 14:31:09.081: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
>>>Подскажите сто не так опять , версия ios c2600-advipservicesk9-mz.124-19
>>
>>какието проблемы с согласованием протокола ppp
>
>Попробуй на Dialer0 прописать ppp authentication chap callin

Заработало после добавления таких строчек,
ppp pfc local request
ppp pfc remote apply
ppp encrypt mppe 128
ppp authentication chap callin
ppp eap refuse
ppp chap hostname xxxx
ppp chap password 7 xxxx
ppp ms-chap refuse
ppp ms-chap-v2 refuse
ppp pap refuse
Такая же проблема была и во FreeBSD с mpd5,та же проблема и те же сообщения , mpd5 и помог решить эту проблему.
Всем спасибо.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру