The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Проблема с настройкой VLAN - Cisco C6504 и HP ProCurve 2810"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Проблема с настройкой VLAN - Cisco C6504 и HP ProCurve 2810"  
Сообщение от CPOnix (ok) on 10-Янв-09, 12:19 
Собственно проблема в неполном понимании принципов свитчинга, тегирования и маршрутизации.

Хочу сделать следующее:

ИНЕТ --> ШЛЮЗ с ПРОКСИ (Fedora Core 4 машина) --> НЕУПР. СВИТЧ --> свитчпорт Gi3/2 киски в VLAN 500 --> субинтерфейсы Gi3/1.XX --> транковый порт Trk1 на ProCurve.

С каталиста все в VLAN-ы уходит и NAT-ится, с VLAN-ов виден каталист. Но не хватает изюминки, чтоб ШЛЮЗ виден был =(

Фрагмент   sh run
-------------------------
vtp domain k5
vtp mode transparent
!
!
spanning-tree mode rapid-pvst
spanning-tree portfast edge bpdufilter default
spanning-tree extend system-id
!
!
interface Loopback0
no ip address
!
interface TenGigabitEthernet1/1
description c6k-II305(Ten4/1)
no ip address
no ip redirects
load-interval 30
spanning-tree portfast edge trunk
spanning-tree bpdufilter enable
!
interface TenGigabitEthernet1/1.98
encapsulation dot1Q 98
ip address MM.MM.MM.199 255.255.255.240
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
!
interface TenGigabitEthernet1/1.995
description head
encapsulation dot1Q 995
ip address MM.MM.MM.43 255.255.255.254
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
!
interface TenGigabitEthernet1/2
no ip address
shutdown
!
interface GigabitEthernet1/3
switchport
switchport access vlan 98
!
interface GigabitEthernet3/1
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
!
interface GigabitEthernet3/1.500
encapsulation dot1Q 500 native
ip address MM.MM.NN.6 255.255.255.192
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
!
interface GigabitEthernet3/1.501
encapsulation dot1Q 501
ip address 192.168.0.3 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
!
interface GigabitEthernet3/1.502
encapsulation dot1Q 502
ip address 192.168.1.3 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
!
interface GigabitEthernet3/2
switchport
switchport access vlan 500
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
redistribute static
passive-interface default
no passive-interface TenGigabitEthernet1/1.995
network MM.MM.NN.0
distribute-list prefix adv_city-ix out TenGigabitEthernet1/1.995
no auto-summary
!
router bgp 65205
bgp router-id MM.MM.MM.199
bgp log-neighbor-changes
neighbor MM.MM.MM.193 remote-as 31738
neighbor MM.MM.MM.193 description CITY-IX
!
address-family ipv4
  neighbor MM.MM.MM.193 activate
  neighbor MM.MM.MM.193 next-hop-self
  neighbor MM.MM.MM.193 soft-reconfiguration inbound
  neighbor MM.MM.MM.193 prefix-list adv_city-ix out
  no auto-summary
  no synchronization
  network MM.MM.NN.0 mask 255.255.255.128
exit-address-family
!
ip nat inside source list 10 interface GigabitEthernet3/1.501 overload
ip nat inside source list 20 interface GigabitEthernet3/1.502 overload
ip classless
ip route 0.0.0.0 0.0.0.0 MM.MM.NN.1 name default
ip route MM.MM.NN.0 255.255.255.128 Null0 250 name IVk
!
!
ip prefix-list adv_city-ix description filter network on city-ix
ip prefix-list adv_city-ix seq 10 permit MM.MM.NN.0/25
logging trap debugging
access-list 1 permit MM.MM.MM.0 0.0.0.255
access-list 1 permit MM.MM.NN.0 0.0.0.127
access-list 1 permit MM.MM.KK.0 0.0.0.255
access-list 1 deny   any
access-list 10 permit 192.168.0.0 0.0.0.255
access-list 20 permit 192.168.1.0 0.0.0.255
!

Поясню, VLAN 995 пока не используется, это запланированное прямое соединение по оптике, которое сейчас сделано со ШЛЮЗом. VLAN 98 для служебных целей.

По сути GigabitEthernet3/2 - временное явление. Но как раз до него пакеты не доходят от субинтерфейса GigabitEthernet3/1.500.

Что тут можно сделать? Помогите пожалуйста.

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Проблема с настройкой VLAN - Cisco C6504 и HP ProCurve 2810"  
Сообщение от CPOnix (ok) on 12-Янв-09, 06:06 
Проблему вроде понял, нельзя настраивать одновременно свитчпорты в VLAN-ах и субинтерфейсы, два разных режима, связи никакой не будет..

Создал VLAN-ы, транковый порт на киске, порты в VLAN 500 для соединения с неуправляемым свитчем. NAT-иться, с циски пинг уходит во внутрь, в инет, а вот зато с ProCurve не видать внешний мир.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Проблема с настройкой VLAN - Cisco C6504 и HP ProCurve 2810"  
Сообщение от CPOnix (ok) on 12-Янв-09, 09:45 
Вот что на ProCurve

trunk 45 Trk1 Trunk
ip default-gateway MM.MM.NN.6
snmp-server community "public" Unrestricted
vlan 1
   name "DEFAULT_VLAN"
   untagged 46-48
   no ip address
   no untagged 1-44,Trk1
   exit
vlan 500
   name "MTF_REAL"
   untagged 1-12
   ip address MM.MM.NN.7 255.255.255.192
   tagged Trk1
   exit
vlan 501
   name "APPM_NAT"
   untagged 13-18
   ip address 192.168.0.2 255.255.255.0
   tagged Trk1
   exit
vlan 502
   name "MM_NAT"
   untagged 19-26
   ip address 192.168.1.2 255.255.255.0
   tagged Trk1
   exit
vlan 503
   name "RESERVED"
   untagged 27-44
   no ip address
   exit
spanning-tree Trk1 priority 4
ip ssh
password manager
password operator

ping 192.168.1.3  -- пингуем IP киски в VLAN 501
192.168.1.3 is alive, time = 1 ms

ping 192.168.0.3  -- пингуем IP киски в VLAN 502
192.168.0.3 is alive, time = 1 ms

ping MM.MM.NN.6  -- пингуем IP киски в VLAN 500
Target did not respond.

Думал, что зря поставил IP на ProCurve в VLAN 500, ан нет, без IP ping дает ошибку:
Ping failed: Network is unreachable on this VLAN.

Добавил ещё на всякий случай nonegotiate:

interface GigabitEthernet3/1
description swProcurve
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 500
switchport trunk allowed vlan 500-502
switchport mode trunk
switchport nonegotiate
!

Хоть убей не работает =(

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Проблема с настройкой VLAN - Cisco C6504 и HP ProCurve 2810"  
Сообщение от CPOnix (??) on 12-Янв-09, 11:47 
Такое ощущение, что я пишу самому себе... Игнор игнор...
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Проблема с настройкой VLAN - Cisco C6504 и HP ProCurve 2810"  
Сообщение от gagner (ok) on 13-Янв-09, 17:10 
хоспади, сколько букв и все равно мало-понятная схема. ))

без поллитры в ней не разберешься. я не знаю, что такое ProCurve - но если оно понимает вланы, то, имхо, порт в его сторону должен быть транковым, а не свичевым... ммм?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Проблема с настройкой VLAN - Cisco C6504 и HP ProCurve 2810"  
Сообщение от CPOnix (ok) on 14-Янв-09, 10:32 
HP ProCurve 2810 свитч 2 уровня. VLAN-ы понимает.
Что касается портов, что схема с субинтерфейсами, что транковый свитчпорт - всё работает теперь.

Разобрался, вот место с затыкой:

ip nat inside source list 10 interface GigabitEthernet3/1.501 overload
ip nat inside source list 20 interface GigabitEthernet3/1.502 overload

Вчера выпил как раз с поллитра и нашёл.

Эти записи говорят о том, что NAT-ить адреса из ACL-листа в интерфейс, дык я указал интерфейс из сети, которую надо NAT-ить, а не outside-интерфейс.

Записи

ip nat inside source list 10 interface vlan 500 overload
ip nat inside source list 20 interface vlan 500 overload

дали положительный результат.

P.S. Кстати конфиги не полные привел, там ещё столько же и ещё сверху.. А VLAN-ов будет 23 с NAT-ом и 4 с реальниками. Уровень провайдера хех, машинально и не такое напишешь)))

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру