The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Не проходит multicast traffic"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"Не проходит multicast traffic"  +/
Сообщение от ullex (ok) on 20-Ноя-15, 12:05 
Приветствую!

  Столкнулся с проблемой: имеется маршрутизируемая сеть с OSPF в которой ходят  multicast-каналы (технологическое видео) и ходят без проблем. Появилась необходимость прокинуть еще один канал видео и тут возникла проблема - траффик не ходит.
  Для выяснения причин - настроена cisco1812 на "поиграться" со статической маршрутизацией и то же самое - данные не ходят.

version 12.4
!
hostname c1812
!
resource policy
!
ip cef
!
ip multicast-routing
!
username admin
!
interface Loopback0
ip address 192.168.0.1 255.255.255.255
!
interface FastEthernet0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1
no ip address
shutdown
duplex auto
speed auto
!

!
interface FastEthernet2
switchport access vlan 10
spanning-tree portfast
!
interface FastEthernet3
switchport access vlan 20
!
interface FastEthernet4
!
interface FastEthernet5
!
interface FastEthernet6
switchport access vlan 10
spanning-tree portfast
!
!
interface Vlan1
no ip address
!
interface Vlan10
description incomming multikast stream
ip address 192.168.200.1 255.255.255.0
ip pim sparse-mode
!
interface Vlan20
description outgoing stream
ip address 192.168.50.1 255.255.255.0
ip pim sparse-mode
!
!
!
no ip http server
no ip http secure-server
ip pim rp-address 192.168.0.1
!
!

существующие каналы( udp/rtp) ходят и по реальной схеме и по c1812 нормально.
вывод show ip mroute

c1812#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.255.0.1), 00:09:14/stopped, RP 192.168.0.1, flags: SJC
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Vlan20, Forward/Sparse, 00:01:29/00:02:31
    Vlan10, Forward/Sparse, 00:08:30/00:02:02

(10.1.20.1, 239.255.0.1), 00:02:38/00:00:21, flags: J
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Vlan20, Forward/Sparse, 00:01:31/00:02:30
    Vlan10, Forward/Sparse, 00:02:40/00:02:01

(*, 239.255.255.100), 00:01:54/00:01:05, RP 192.168.0.1, flags: SJC
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Vlan10, Forward/Sparse, 00:01:54/00:01:05

(*, 224.0.1.40), 00:09:37/00:02:34, RP 192.168.0.1, flags: SJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Vlan10, Forward/Sparse, 00:09:37/00:02:34


show ip igmp mem

c1812#show ip igmp mem
Flags: A  - aggregate, T - tracked
       L  - Local, S - static, V - virtual, R - Reported through v3
       I - v3lite, U - Urd, M - SSM (S,G) channel
       1,2,3 - The version of IGMP the group is in
Channel/Group-Flags:
       / - Filtering entry (Exclude mode (S,G), Include mode (*,G))
Reporter:
       <mac-or-ip-address> - last reporter if group is not explicitly tracked
       <n>/<m>      - <n> reporter in include mode, <m> reporter in exclude

Channel/Group                  Reporter        Uptime   Exp.  Flags  Interface
*,239.255.0.1                  192.168.100.222 00:02:36 02:28 2A     Vl20
*,239.255.255.100              10.90.90.90     00:03:00 02:00 1A     Vl10
*,224.0.1.40                   192.168.200.1   00:10:21 02:56 2LA    Vl10

В "плоской" сети этот источник смотрится нормально тем же самым VLC(udp://@239.255.0.1:12345/ ), а через роутеры - никак....
В чем может быть проблема?

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Не проходит multicast traffic"  +/
Сообщение от Stanislav (??) on 24-Ноя-15, 00:06 
Если конфиг ваш полный, то вижу как минимум одну проблему - rpf check у вас не проходит.
На роутере должен быть маршрут на источник 10.1.20.1 или какой-то еще.

>[оверквотинг удален]
>     Vl20
>  *,239.255.255.100          
>    10.90.90.90     00:03:00 02:00 1A
>     Vl10
>  *,224.0.1.40          
>         192.168.200.1  
> 00:10:21 02:56 2LA    Vl10
> В "плоской" сети этот источник смотрится нормально тем же самым VLC(udp://@239.255.0.1:12345/
> ), а через роутеры - никак....
> В чем может быть проблема?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Не проходит multicast traffic"  +/
Сообщение от ullex (ok) on 15-Янв-16, 19:35 
> Если конфиг ваш полный, то вижу как минимум одну проблему - rpf
> check у вас не проходит.
> На роутере должен быть маршрут на источник 10.1.20.1 или какой-то еще.

Да, действительно это я поторопился конфиг выложить. На этом роутере маршрута действительно нет. Но, в любом случае в рабочей сети проблема решилась заменой источника сигнала.
Так что скорее всего проблема была именно в источнике...

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Не проходит multicast traffic"  +/
Сообщение от Stanislav (??) on 16-Янв-16, 16:37 
>> Если конфиг ваш полный, то вижу как минимум одну проблему - rpf
>> check у вас не проходит.
>> На роутере должен быть маршрут на источник 10.1.20.1 или какой-то еще.
> Да, действительно это я поторопился конфиг выложить. На этом роутере маршрута действительно
> нет. Но, в любом случае в рабочей сети проблема решилась заменой
> источника сигнала.
> Так что скорее всего проблема была именно в источнике...

Если источник был заменен на другой с source IP адресом, на который есть маршрут, то да - проблема в источнике ) А так роутеру абсолютно до лампочки что там внутри потока - есть мультикаст IP/MAC на destination - все, форвардим по правилам мультикаста. RPF check если не отключали (не советую) должен работать всегда

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Ideco
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру