The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"настройка маршрутизатора Cisco 877 adsl vpn vlan"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"настройка маршрутизатора Cisco 877 adsl vpn vlan"  +/
Сообщение от Vladsky email(ok) on 12-Май-09, 12:16 
Камрады выручайте!

есть Cisco 877 с адсл модемом...
хочу настроить на ней адсл + впн + vlan - будет заменять на имеющемся узле след конфиг:
2801 + адсл модем Zyxel соединена по впн с моей 2821 вся телефония заходит на мою, потом на внутр номера можно позвонить на 2801 там 3 номера прописаны...
там настройки минимальные, на узле только 3 пк и 3 IP тел 7911... тел внутр прописаны на 2801 но у меня на главном узле стоит 2821 могу там прописать и адреса IP  тел будут получать от 2821...

какие стандартные настройки у 877 ? т.е. я его сброшу как на него зайти..

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "настройка маршрутизатора Cisco 877 adsl vpn vlan"  +/
Сообщение от Vladsky email(ok) on 12-Май-09, 13:59 
>[оверквотинг удален]
>2801 + адсл модем Zyxel соединена по впн с моей 2821 вся
>телефония заходит на мою, потом на внутр номера можно позвонить на
>2801 там 3 номера прописаны...
>там настройки минимальные, на узле только 3 пк и 3 IP тел
>7911... тел внутр прописаны на 2801 но у меня на главном
>узле стоит 2821 могу там прописать и адреса IP  тел
>будут получать от 2821...
>
>какие стандартные настройки у 877 ? т.е. я его сброшу как на
>него зайти..

как сбросить конфиг по умолчанию т.е. есть кнопка ресет на нем, но скока жать ее или может жать при вкл питания?


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "настройка маршрутизатора Cisco 877 adsl vpn vlan"  +/
Сообщение от Vladsky email(ok) on 12-Май-09, 16:33 
>[оверквотинг удален]
>>там настройки минимальные, на узле только 3 пк и 3 IP тел
>>7911... тел внутр прописаны на 2801 но у меня на главном
>>узле стоит 2821 могу там прописать и адреса IP  тел
>>будут получать от 2821...
>>
>>какие стандартные настройки у 877 ? т.е. я его сброшу как на
>>него зайти..
>
>как сбросить конфиг по умолчанию т.е. есть кнопка ресет на нем, но
>скока жать ее или может жать при вкл питания?

не могу к нему подключится никак ( вроде сброс сделал.. ни по ethernet (видимо не настроен) ни по console, шнур взял от 2800 может требуется настройки порта com подкорректировать? подключаться пытаюсь так: telnet com1

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "настройка маршрутизатора Cisco 877 adsl vpn vlan"  +/
Сообщение от Vladsky email(ok) on 12-Май-09, 17:14 
>[оверквотинг удален]
>>>какие стандартные настройки у 877 ? т.е. я его сброшу как на
>>>него зайти..
>>
>>как сбросить конфиг по умолчанию т.е. есть кнопка ресет на нем, но
>>скока жать ее или может жать при вкл питания?
>
>не могу к нему подключится никак ( вроде сброс сделал.. ни по
>ethernet (видимо не настроен) ни по console, шнур взял от 2800
>может требуется настройки порта com подкорректировать? подключаться пытаюсь так: telnet com1
>

такс... по телнет не хотел ... а вот гипертерминалом зашел на него )

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "настройка маршрутизатора Cisco 877 adsl vpn vlan"  +/
Сообщение от Vladsky email(ok) on 19-Май-09, 10:18 
подскажите по настройке адсл соединения на 877...
пишу так:
interface ATM0
description adsl connect UT
mtu 1500
ip address х.х.х.х 255.255.255.192
ip access-group 104 in
ip inspect FIREWALL out
ip virtual-reassembly
no atm ilmi-keepalive
pvc 20/68
  encapsulation aal5snap
!
dsl operating-mode auto

будет ли работать ? и как проверить допустим подключу его как посмотреть лог или статистику?


нашел вот такой конф:
service timestamps debug uptime
service timestamps log uptime
!
hostname 877
!
ip subnet-zero
no ip domain-lookup
!
bridge irb
!
interface FastEthernet0
switchport access vlan 1
!
interface FastEthernet1
switchport access vlan 1
!
interface FastEthernet2
switchport access vlan 1
!
interface FastEthernet3
switchport access vlan 1
!
interface Vlan1
ip address 10.10.10.1 (желаемый IP модема, можно при желании поставить и 192.168.0.1) 255.255.255.0
ip nat inside
!
interface ATM0
no ip address
no ip mroute-cache
no atm ilmi-keepalive
dsl operating-mode auto
no shutdown
!
interface ATM0.1 point-to-point
no snmp trap link-status
pvc X/Y (где Х=VPI и Y=VCI)
encapsulation aal5snap (для RFC 1483 LLC)
no ip address
bridge-group 1
no shutdown
!
interface BVI1
ip address [ваш IP, выданный провайдером] 255.255.255.0
no ip directed-broadcast
ip Nat outside
!
ip nat inside source list 1 interface BVI1 overload
!
ip classless
ip route 0.0.0.0 0.0.0.0 [шлюз провайдера]
 
access-list 1 permit 10.10.10.0 (обозначаем вашу подсеть, можно при желании поставить и 192.168.0.0) 0.0.0.255
 
bridge 1 protocol ieee
bridge 1 route ip
!
end

обязательно делать мост?

у меня просто задача - поднять туннель до моей циски, завернуть весь траф на нее...
к тому же есть IP телефоны нужно их пробросить с 877 ...
делаю VLAN привязываю к порту fa0 допустим, а можно ли несколько vlan прокинуть через один порт fa?


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "настройка маршрутизатора Cisco 877 adsl vpn vlan"  +/
Сообщение от Vladsky email(ok) on 19-Май-09, 12:01 
>[оверквотинг удален]
>end
>
>обязательно делать мост?
>
>у меня просто задача - поднять туннель до моей циски, завернуть весь
>траф на нее...
>к тому же есть IP телефоны нужно их пробросить с 877 ...
>
>делаю VLAN привязываю к порту fa0 допустим, а можно ли несколько vlan
>прокинуть через один порт fa?

да, ответов не густо )
думаю поступить так:
настроить 2 vlan а именно:
vlan 1
ip address 172.16.1.1 255.255.255.0
ip nat inside

данный vlan для лок пользователей, IP 172.16.1.1 будет шлюзом чтоб в рамках одной подсети ходили через него в туннель (инет, др сеть)

vlan 2
ip address 192.168.4.1 255.255.2550

2 vlan для доступа Ip телефонов cisco 7911, у них в качестве шлюза будет данный IP и далее пробрасывать их через тунель на 2821 которая войсовая и где будут прописаны данные телефоны...

теперь каждый vlan привязываю к портам:

interface FastEthernet0
switchport access vlan 1
!
interface FastEthernet1
switchport access vlan 2

и оба порта включаю в простой маршрутизатор куда подключены будут и телефоны и компы...
так будет работать?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "настройка маршрутизатора Cisco 877 adsl vpn vlan"  +/
Сообщение от Vladsky email(ok) on 19-Май-09, 19:57 

адсл настроил, туннель поднял, компы в нет ходят, сети вижу все ок... но как заставить регистрится телефоны через туннель????  конфиг сейчас такой:
........

interface ATM0
description adsl connect UT
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
pvc 20/68
  encapsulation aal5snap
!
bridge-group 1
!
interface FastEthernet0
shutdown
!
interface FastEthernet1
switchport access vlan 1
!
interface FastEthernet2
switchport access vlan 2
!
interface FastEthernet3
shutdown
!        
interface Vlan1
description -- FA1 LAN --
ip address 172.16.1.10 255.255.255.0
ip access-group 23 in
ip nat inside
no ip virtual-reassembly
ip policy route-map tointernet
!
interface Vlan2
description - VLAN 2 VOICE -
ip address 192.168.4.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface BVI1
ip address x.x.x.x 255.255.255.192
ip nat outside
ip virtual-reassembly
!
router eigrp 999
network 10.0.0.0
network 172.16.0.0
network 192.168.4.0
network 192.168.168.0
no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 x.x.x.x
ip route 172.16.4.0 255.255.255.0 172.16.2.1
!
!        
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 1 interface BVI1 overload
!
access-list 1 permit 172.16.1.0 0.0.0.255
access-list 1 permit 192.168.4.0 0.0.0.255
access-list 23 permit 172.16.2.55 log
access-list 23 permit 172.16.2.50 log
access-list 23 permit 172.16.1.11 log
access-list 23 permit 172.16.1.4
access-list 23 permit 172.16.1.7
access-list 23 permit 172.16.2.5 log
access-list 23 permit 172.16.2.110 log
access-list 23 permit 172.16.2.101 log
access-list 104 remark ---firewall---
access-list 104 remark ---private adresses---
access-list 104 deny   ip 10.0.0.0 0.255.255.255 any
access-list 104 deny   ip 172.16.0.0 0.15.255.255 any
access-list 104 deny   ip 127.0.0.0 0.255.255.255 any
access-list 104 deny   ip host 255.255.255.255 any
access-list 104 deny   ip host 0.0.0.0 any
access-list 104 remark ---vpn---
access-list 104 permit gre any host x.x.x.x
access-list 104 permit ahp any host x.x.x.x
access-list 104 permit esp any host x.x.x.x
access-list 104 permit udp any host x.x.x.x eq isakmp
access-list 104 permit udp any host x.x.x.x eq non500-isakmp
access-list 104 remark ---ssh---
access-list 104 permit tcp any host x.x.x.x eq 22
access-list 104 remark ---office---
access-list 104 permit ip x.x.x.x 0.0.0.63 any
access-list 104 remark ---icmp---
access-list 104 permit icmp any any echo
access-list 104 permit icmp any any echo-reply
access-list 104 permit icmp any any time-exceeded
access-list 104 permit icmp any any unreachable
access-list 104 permit icmp any any packet-too-big
access-list 104 permit icmp any any traceroute
access-list 104 remark ---Domain---
access-list 104 permit udp host x.x.x.x eq domain any
access-list 104 permit udp host x.x.x.x eq domain any
access-list 104 remark ---Deny_Any---
access-list 104 deny   ip any any
access-list 170 permit ip 172.16.1.0 0.0.0.255 any
access-list 170 permit ip 172.16.2.0 0.0.0.255 any
access-list 170 permit ip 192.168.4.0 0.0.0.255 any
access-list 190 remark ---for qos---
access-list 190 permit ip host 172.16.1.1 any
access-list 190 permit ip host 172.16.1.2 any
access-list 190 permit ip host 192.168.4.1 any
access-list 190 permit ip any host 172.16.1.1
access-list 190 permit ip any host 172.16.1.2
access-list 190 permit ip any host 192.168.4.1
no cdp run
!
!
!
route-map tointernet permit 10
match ip address 170
set interface Tunnel0
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
no modem enable
line aux 0
line vty 0 4
access-class 23 in
privilege level 15
transport input telnet ssh
!
scheduler max-task-time 5000
ntp logging
ntp clock-period 17179180
ntp server 172.16.2.1
ntp server 130.88.200.98
ntp server 194.87.0.20
end

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "настройка маршрутизатора Cisco 877 adsl vpn vlan"  +/
Сообщение от rassl on 17-Ноя-09, 14:10 
Ещё чуть-чуть и появится статья "Настройка маршрутизатора Cisco 877 adsl vpn vlan" :)))
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру