The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"PPTP VPN доступ на Cisco 1841"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"PPTP VPN доступ на Cisco 1841"  +/
Сообщение от Игорь525 (ok) on 11-Июл-09, 00:10 
Здравствуйте, уважаемые спецы!
Три дня бьюсь над, казалось бы очевидной проблемой.
Не могу войти в локальную сеть через PPTP VPN на Cisco 1841
IOS Version 12.4(22)T (C1841-ADVIPSERVICESK9-M)

Мой конфиг

!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service sequence-numbers
!
hostname Cisco
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
no logging buffered
!
no aaa new-model
clock timezone MSK 3
clock summer-time PCTime date Mar 30 2003 2:00 Oct 26 2003 3:00
!
!
username admin privilege 15 secret 5 ********
username ******* password 0 **********
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1
!
ip multicast-routing
ip dns server
ip name-server 212.188.4.10 195.34.32.116
ip dhcp pool LAN
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 192.168.1.1
!
!
!
ip cef
no ip igmp snooping
no ipv6 cef
!
multilink bundle-name authenticated
!
vpdn enable
!
vpdn-group 1
! Default PPTP VPDN group
accept-dialin
  protocol pptp
  virtual-template 1
ip mtu adjust
!
!
interface Loopback0
ip address 192.168.4.1 255.255.255.255
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/0/0
spanning-tree portfast
!
interface FastEthernet0/0/1
spanning-tree portfast
!
interface FastEthernet0/0/2
spanning-tree portfast
!
interface FastEthernet0/0/3
spanning-tree portfast
!
interface ATM0/1/0
no ip address
no atm ilmi-keepalive
!
interface ATM0/1/0.1 point-to-point
description ISP
pvc 1/50
  encapsulation aal5snap
  pppoe-client dial-pool-number 1
!
!
interface Virtual-Template1
ip unnumbered Loopback0
no ip proxy-arp
peer default ip address pool vpn_pptp
ppp encrypt mppe 128 required
ppp authentication ms-chap

!
interface Vlan1
description LAN
ip address 192.168.1.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1412
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
no cdp enable
ppp chap hostname *******
ppp chap password 0 ********
!
ip local pool vpn_pptp 192.168.4.2 192.168.4.50
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip http server
ip http access-class 23
ip http authentication local
no ip http secure-server
!
!
ip nat inside source list 1 interface Dialer1 overload
!
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 100 permit ip any any
access-list 100 permit icmp any any echo
access-list 100 permit icmp any any echo-reply
access-list 100 permit gre any any
!
dialer-list 1 protocol ip list 1
no cdp run
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
!
scheduler max-task-time 5000
scheduler allocate 20000 1000
end

Соединение PPTP устанавливается, 192.168.4.1 пингуется, в сеть 192.168.1.0 и в интернет через PPTP соединение выйти не могу. Любой адрес 192.168.1.ХХХ даже не пингуется

show ip route connected до соединения

     192.168.4.0/32 is subnetted, 1 subnets
C       192.168.4.1 is directly connected, Loopback0
C    192.168.1.0/24 is directly connected, Vlan1
     91.0.0.0/32 is subnetted, 2 subnets
C       91.78.116.1 is directly connected, Dialer1
C       91.78.116.237 is directly connected, Dialer1

show ip route connected после соединения

     192.168.4.0/32 is subnetted, 2 subnets
C       192.168.4.1 is directly connected, Loopback0
C       192.168.4.2 is directly connected, Virtual-Access4
C    192.168.1.0/24 is directly connected, Vlan1
     91.0.0.0/32 is subnetted, 2 subnets
C       91.78.116.1 is directly connected, Dialer1
C       91.78.116.237 is directly connected, Dialer1

В чем косяк - не пойму

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Одна проблема решена"  +/
Сообщение от Игорь525 (ok) on 11-Июл-09, 09:08 
Одной проблемой меньше
Начала пинговаться внутренняя сеть
Не пинговалась из-за того, что тестовая конфигурация была собрана в том же адресном пространстве, что и основная (включенная в первый ethernet порт компьютера)  и приходила на второй ethernet порт. Естественно компьютер пинговал первую сетку и ничего в ней не видел.
Однако дальше пока дело не идет.
К компьютерам подключиться не могу, выйти в инет через VPN тоже, хотя в настройках VPN на компьютере я вижу name-server удаленного соединения
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Одна проблема решена"  +/
Сообщение от GolDi (??) on 11-Июл-09, 10:07 
>Одной проблемой меньше
>Начала пинговаться внутренняя сеть
>Не пинговалась из-за того, что тестовая конфигурация была собрана в том же
>адресном пространстве, что и основная (включенная в первый ethernet порт компьютера)
> и приходила на второй ethernet порт. Естественно компьютер пинговал первую
>сетку и ничего в ней не видел.
>Однако дальше пока дело не идет.
>К компьютерам подключиться не могу, выйти в инет через VPN тоже, хотя
>в настройках VPN на компьютере я вижу name-server удаленного соединения

access-list 1 измените, у вас натится только одна сетка 192.168.1

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Одна проблема решена"  +/
Сообщение от Игорь525 (ok) on 11-Июл-09, 13:18 
>access-list 1 измените, у вас натится только одна сетка 192.168.1

поменял на access-list 1 permit 192.168.0.0 0.0.255.255

ничего не изменилось


может быть что-то с настройками mtu?

пытаюсь подключиться по afp (из Mac OS), соединение устанавливается в течении 10-15 минут, до конца соединение не доходит, рвется... настолько медленного коннекта я никогда еще не видел :(

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру