The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Catalyst 3550 и ограничение скорости per-Vlan"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (ACL, фильтрация и ограничение трафика)
Изначальное сообщение [ Отслеживать ]

"Catalyst 3550 и ограничение скорости per-Vlan"  +/
Сообщение от zelyukin (ok) on 06-Авг-09, 13:51 
Доброго времени суток!

Можно ли как-то на 3550 каталисте ограничить скорость одному из вланов на 3-м уровне, т.е. на interface vlan X

rate-limit'ов в interface vlan просто нет, а policy не поддерживается:
-8<--------------------------
policy-map test-map
class class-default
    police 128000 8000 exceed-action drop

Switch(config-pmap-c)#int vlan 1
Switch(config-if)#service-policy input test-map
QoS: policymap is not supported on virtual interfaces
Service Policy attachment failed
-8<--------------------------

Что же делать?

С уважением,
Сергей

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Catalyst 3550 и ограничение скорости per-Vlan"  +/
Сообщение от Luxor email(ok) on 06-Авг-09, 22:19 
>[оверквотинг удален]
>Switch(config-pmap-c)#int vlan 1
>Switch(config-if)#service-policy input test-map
>QoS: policymap is not supported on virtual interfaces
>Service Policy attachment failed
>-8<--------------------------
>
>Что же делать?
>
>С уважением,
>Сергей

Можно ограничить police, читайте Vlan-based QoS в мануале на 3550, там только тонкость в определении class-map, c вланами каждый тип трафика описывается двумя class-map читайте мануал вобщем там с примерами.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "Catalyst 3550 и ограничение скорости per-Vlan"  +/
Сообщение от zelyukin (ok) on 10-Авг-09, 16:33 
Спасибо за хороший совет! Почитал "Understanding QoS Policing and Marking on the Catalyst 3550", попробовал port-based QoS - классная штука!
Но... согласно этой же книжке:
...Note:  VLAN-based QoS is currently not supported by the Catalyst 3550...
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "Catalyst 3550 и ограничение скорости per-Vlan"  +/
Сообщение от Luxor email(ok) on 10-Авг-09, 18:16 
>Спасибо за хороший совет! Почитал "Understanding QoS Policing and Marking on the
>Catalyst 3550", попробовал port-based QoS - классная штука!
>Но... согласно этой же книжке:
>...Note:  VLAN-based QoS is currently not supported by the Catalyst 3550...

Вы читаете мануал на старый иос наверно. Я лично настраивал Vlan-based qos на 3550 с иос 12.2 (25), все там есть :), ну да ладно, главное что вы решили свою проблему )


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "Catalyst 3550 и ограничение скорости per-Vlan"  +/
Сообщение от zelyukin (ok) on 11-Авг-09, 11:34 
Да нет... не то чтобы решил :)

у меня IOS:
-8<------------------------------------------------
Cisco IOS Software, C3550 Software (C3550-IPSERVICESK9-M), Version 12.2(44)SE2, RELEASE SOFTWARE (fc2)
Copyright (c) 1986-2008 by Cisco Systems, Inc.
Compiled Thu 01-May-08 16:14 by antonino
Image text-base: 0x00003000, data-base: 0x012A7044

ROM: Bootstrap program is C3550 boot loader

Switch uptime is 1 minute
System returned to ROM by power-on
System image file is "flash:/c3550-ipservicesk9-mz.122-44.SE2.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco WS-C3550-24 (PowerPC) processor (revision J0) with 65526K/8192K bytes of memory.
Processor board ID CAT0741Y0DG
Last reset from warm-reset
Running Layer2/3 Switching Image

Ethernet-controller 1 has 12 Fast Ethernet/IEEE 802.3 interfaces

Ethernet-controller 2 has 12 Fast Ethernet/IEEE 802.3 interfaces

Ethernet-controller 3 has 1 Gigabit Ethernet/IEEE 802.3 interface

Ethernet-controller 4 has 1 Gigabit Ethernet/IEEE 802.3 interface

24 FastEthernet interfaces
2 Gigabit Ethernet interfaces

The password-recovery mechanism is enabled.
384K bytes of flash-simulated NVRAM.
Base ethernet MAC Address: 00:0D:ED:BD:6B:00
Motherboard assembly number: 73-5700-10
Power supply part number: 34-0966-03
Motherboard serial number: CAT074102L8
Power supply serial number: DTH07391JLB
Model revision number: J0
Motherboard revision number: A0
Model number: WS-C3550-24-SMI
System serial number: CAT0741Y0DG
Configuration register is 0x10F
-8<------------------------------------------------

Вроде свежий :) но:

-8<--------------------------------------------------
Switch(config)#int fast
Switch(config)#int fastEthernet 0/3
Switch(config-if)#mls qos vlan-based
^
% Invalid input detected at '^' marker.

Switch(config-if)#mls qos ?
cos Configure interface COS parameters
dscp-mutation Apply DSCP-DSCP map to DSCP trusted port
monitor Collect QoS statistics
trust Configure trust state of interface
-8<--------------------------------------------------

vlan-based qos не поддерживается! Как же так?!

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "Catalyst 3550 и ограничение скорости per-Vlan"  +/
Сообщение от Luxor email(ok) on 11-Авг-09, 16:12 
>[оверквотинг удален]
>% Invalid input detected at '^' marker.
>
>Switch(config-if)#mls qos ?
>cos Configure interface COS parameters
>dscp-mutation Apply DSCP-DSCP map to DSCP trusted port
>monitor Collect QoS statistics
>trust Configure trust state of interface
>-8<--------------------------------------------------
>
>vlan-based qos не поддерживается! Как же так?!

Я ж говорю, читайте мануал на нее :) вы пытаетесь vlan-based QoS реализовать как на 3750, а он там реализован по другому (не забывайте что 3550 динозавр снятый с производства и продаж). накидал для вас примерчик, по аналогии сделаете. Хочу обратить внимание что class-map надо описывать именно так как в примере:


Class Map match-all Traffic
   Match access-group name Test
!
Class Map match-all QoS-test
   Match vlan  2
   Match class-map Traffic
!
  Policy Map Test
    Class QoS-test
      police 128000 8000 exceed-action drop
      set dscp cs2
!
interface FastEthernet0/10
switchport access vlan 20
switchport mode access
wrr-queue bandwidth 10 20 30 40
service-policy input Test

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "Catalyst 3550 и ограничение скорости per-Vlan"  +/
Сообщение от zelyukin (ok) on 11-Авг-09, 17:07 
Спасибо! :)
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

7. "Catalyst 3550 и ограничение скорости per-Vlan"  +/
Сообщение от eucariot email(ok) on 02-Ноя-10, 12:40 
>[оверквотинг удален]
>   Policy Map Test
>     Class QoS-test
>       police 128000 8000 exceed-action drop
>       set dscp cs2
> !
> interface FastEthernet0/10
>  switchport access vlan 20
>  switchport mode access
>  wrr-queue bandwidth 10 20 30 40
>  service-policy input Test

А если мне нужно поставить ограничение не на отдельный физический интерфейс, а полностью на виртуальный L3? То есть чтобы ограничить скорость подсети.
Либо хотя бы на транковый порт, как это можно сделать?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

8. "Catalyst 3550 и ограничение скорости per-Vlan"  +/
Сообщение от Luxor email(ok) on 02-Ноя-10, 13:02 
>[оверквотинг удален]
>>       set dscp cs2
>> !
>> interface FastEthernet0/10
>>  switchport access vlan 20
>>  switchport mode access
>>  wrr-queue bandwidth 10 20 30 40
>>  service-policy input Test
> А если мне нужно поставить ограничение не на отдельный физический интерфейс, а
> полностью на виртуальный L3? То есть чтобы ограничить скорость подсети.
> Либо хотя бы на транковый порт, как это можно сделать?

вешайте политику на все физические интерфейсы куда уходит целевой влан, не забудьте выделить шедуллеру (wrr-queue) соответсвующую полосу под класс трафика в который красите целевой влан.

> А если мне нужно поставить ограничение не на отдельный физический интерфейс, а
> полностью на виртуальный L3?

на платформе cat3550 вы такого не сделаете. На cat3750 можно. Только шейпит police не качественно, я бы даже сказал что для коммерческого применения абсолютно не годно.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

9. "Catalyst 3550 и ограничение скорости per-Vlan"  +/
Сообщение от eucariot email(ok) on 02-Ноя-10, 13:22 

> вешайте политику на все физические интерфейсы куда уходит целевой влан, не забудьте
> выделить шедуллеру (wrr-queue) соответсвующую полосу под класс трафика в который красите
> целевой влан.

Получается, что ограничение в 2 Мб/с, например, будет на конкретном порту. И подсеть теоретически может качать n*2 Мб/с, где n - число портов?

>> А если мне нужно поставить ограничение не на отдельный физический интерфейс, а
>> полностью на виртуальный L3?

Это, насколько я понимаю, действует на входящий трафик. Ограничить исходящий на 3550 не получится вообще?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

11. "Catalyst 3550 и ограничение скорости per-Vlan"  +/
Сообщение от Luxor email(ok) on 02-Ноя-10, 14:49 
>> вешайте политику на все физические интерфейсы куда уходит целевой влан, не забудьте
>> выделить шедуллеру (wrr-queue) соответсвующую полосу под класс трафика в который красите
>> целевой влан.
> Получается, что ограничение в 2 Мб/с, например, будет на конкретном порту. И
> подсеть теоретически может качать n*2 Мб/с, где n - число портов?

Да так и есть.

>>> А если мне нужно поставить ограничение не на отдельный физический интерфейс, а
>>> полностью на виртуальный L3?
> Это, насколько я понимаю, действует на входящий трафик. Ограничить исходящий на 3550
> не получится вообще?

если вы будете строить модель per-Vlan QoS Based на 3550, то ограничить исходящий трафик не сможете, в силу отсутсвия данного функционала на 3550.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

13. "Catalyst 3550 и ограничение скорости per-Vlan"  +/
Сообщение от eucariot (ok) on 02-Ноя-10, 14:50 
Спасибо большое. Буду пробовать.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

10. "Catalyst 3550 и ограничение скорости per-Vlan"  +/
Сообщение от eucariot email(ok) on 02-Ноя-10, 14:16 
И будет ли это работать на транковых портах?
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

12. "Catalyst 3550 и ограничение скорости per-Vlan"  +/
Сообщение от Luxor email(ok) on 02-Ноя-10, 14:49 
> И будет ли это работать на транковых портах?

будет конечно

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

14. "Catalyst 3550 и ограничение скорости per-Vlan"  +/
Сообщение от eucariot (ok) on 02-Ноя-10, 14:52 
Насколько я понимаю, действовать на транковом порту это будет лишь на тот vlan, который указан в class-map?
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

15. "Catalyst 3550 и ограничение скорости per-Vlan"  +/
Сообщение от Luxor email(ok) on 02-Ноя-10, 16:39 
> Насколько я понимаю, действовать на транковом порту это будет лишь на тот
> vlan, который указан в class-map?

Не правильно понимаете, после установки политики на физический интерфейс будет покрашен абсолютно весь трафик, трафик не попавший ни в один из определеных пользователем class-map-ов будет покрашен по умочланию в dscp cs0 (class-map default), это значение можно переопределить в политике. Так что настраивайте шедуллер - определяейте какие классы трафика надо направить в соответсвующую очередь, и какой вес назначят очередям.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру