The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Panasonic KX-TDA200 + Cisco + Avaya IPOffice"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Panasonic KX-TDA200 + Cisco + Avaya IPOffice"  +/
Сообщение от rpaha (ok) on 21-Окт-09, 13:57 
Уважаемые гуру, прошу помощи.

Есть АТС Panasonic KX-TDA200 и АТС Avaya IPOffice 406v2, которые соединенны через роутер Cisco 2821 по IP по H.323 протоколу. Здесь роутер используется как H.323-gateway.
Со стороны и Avaya и Cisco (с IP телефонов, зарегистрированных на циске) звязь с Панасоником есть. А вот с Панасоника можно дозвониться только до IP телефонов, при попытке набора номера Avaya сразу короткие гудки.
Как не странно, дебаг циски ничего интересного не дал. судя по дебагу все проходит гладко.
Вот листинг команд debug voice dialpeer all и debug voip dialpeer all


Звоним с Панасоника (номер 6513) на 1201 (IP телефон)

c2821_shkiperskiy#
Oct 10 20:52:53.373: //-1/00000FA9-0000-1000-0000-C0A8060606B8/DPM/dpAssociateIncomingPeerCore:
Calling Number=, Called Number=1201, Voice-Interface=0x0,
Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
Peer Info Type=DIALPEER_INFO_SPEECH
Oct 10 20:52:53.373: //-1/00000FA9-0000-1000-0000-C0A8060606B8/DPM/dpAssociateIncomingPeerCore:
Match Rule=DP_MATCH_INCOMING_DNIS; Called Number=1201
Oct 10 20:52:53.373: //-1/00000FA9-0000-1000-0000-C0A8060606B8/DPM/dpMatchPeertype:
Is Incoming=TRUE, Number Expansion=FALSE
Oct 10 20:52:53.373: //-1/00000FA9-0000-1000-0000-C0A8060606B8/DPM/dpMatchCore:
Dial String=1201, Expanded String=1201, Calling Number=
Timeout=TRUE, Is Incoming=TRUE, Peer Info Type=DIALPEER_INFO_SPEECH
Oct 10 20:52:53.373: //-1/00000FA9-0000-1000-0000-C0A8060606B8/DPM/MatchNextPeer:
Result=Success(0); Incoming Dial-peer=44 Is Matched
Oct 10 20:52:53.373: //-1/00000FA9-0000-1000-0000-C0A8060606B8/DPM/dpMatchPeertype:exit@5398
Oct 10 20:52:53.373: //-1/00000FA9-0000-1000-0000-C0A8060606B8/DPM/dpAssociateIncomingPeerCore:
Result=NO_MATCH(-1) After All Match Rules Attempt
Oct 10 20:52:53.373: //-1/00000FA9-0000-1000-0000-C0A8060606B8/DPM/dpAssociateIncomingPeerSPI:exit@5932
Oct 10 20:52:53.373: //-1/00000FA9-0000-1000-0000-C0A8060606B8/DPM/dpAssociateIncomingPeerCore:
Calling Number=, Called Number=1201, Voice-Interface=0x0,
Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
Peer Info Type=DIALPEER_INFO_SPEECH
Oct 10 20:52:53.373: //-1/00000FA9-0000-1000-0000-C0A8060606B8/DPM/dpAssociateIncomingPeerCore:
Match Rule=DP_MATCH_INCOMING_DNIS; Called Number=1201
Oct 10 20:52:53.373: //-1/00000FA9-0000-1000-0000-C0A8060606B8/DPM/dpMatchPeertype:
Is Incoming=TRUE, Number Expansion=FALSE
Oct 10 20:52:53.373: //-1/00000FA9-0000-1000-0000-C0A8060606B8/DPM/dpMatchCore:
Dial String=1201, Expanded String=1201, Calling Number=
Timeout=TRUE, Is Incoming=TRUE, Peer Info Type=DIALPEER_INFO_SPEECH
Oct 10 20:52:53.373: //-1/00000FA9-0000-1000-0000-C0A8060606B8/DPM/MatchNextPeer:
Result=Success(0); Incoming Dial-peer=44 Is Matched
Oct 10 20:52:53.377: //-1/00000FA9-0000-1000-0000-C0A8060606B8/DPM/dpMatchPeertype:exit@5398
Oct 10 20:52:53.377: //-1/00000FA9-0000-1000-0000-C0A8060606B8/DPM/dpAssociateIncomingPeerCore:
Result=NO_MATCH(-1) After All Match Rules Attempt
Oct 10 20:52:53.377: //-1/00000FA9-0000-1000-0000-C0A8060606B8/DPM/dpAssociateIncomingPeerSPI:exit@5932
Oct 10 20:52:53.381: //-1/00000FA9-0000-1000-0000-C0A8060606B8/DPM/dpMatchPeersCore:
Calling Number=, Called Number=1201, Peer Info Type=DIALPEER_INFO_SPEECH
Oct 10 20:52:53.381: //-1/00000FA9-0000-1000-0000-C0A8060606B8/DPM/dpMatchPeersCore:
Match Rule=DP_MATCH_DEST; Called Number=1201
Oct 10 20:52:53.381: //-1/00000FA9-0000-1000-0000-C0A8060606B8/DPM/dpMatchCore:
Dial String=1201, Expanded String=1201, Calling Number=
Timeout=TRUE, Is Incoming=FALSE, Peer Info Type=DIALPEER_INFO_SPEECH
Oct 10 20:52:53.381: //-1/00000FA9-0000-1000-0000-C0A8060606B8/DPM/MatchNextPeer:
Result=Success(0); Outgoing Dial-peer=4 Is Matched
Oct 10 20:52:53.381: //-1/00000FA9-0000-1000-0000-C0A8060606B8/DPM/dpMatchPeersCore:
Result=Success(0) after DP_MATCH_DEST
Oct 10 20:52:53.381: //-1/00000FA9-0000-1000-0000-C0A8060606B8/DPM/dpMatchPeersMoreArg:
Result=SUCCESS(0)
List of Matched Outgoing Dial-peer(s):
1: Dial-peer Tag=4

А вот звонок с Панасоника (6513) на аваю (4216)

c2821_shkiperskiy#
Oct 10 21:00:35.485: //-1/00006878-0000-1000-0001-C0A8060606B8/DPM/dpAssociateIncomingPeerCore:
Calling Number=, Called Number=4216, Voice-Interface=0x0,
Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
Peer Info Type=DIALPEER_INFO_SPEECH
Oct 10 21:00:35.485: //-1/00006878-0000-1000-0001-C0A8060606B8/DPM/dpAssociateIncomingPeerCore:
Match Rule=DP_MATCH_INCOMING_DNIS; Called Number=4216
Oct 10 21:00:35.485: //-1/00006878-0000-1000-0001-C0A8060606B8/DPM/dpMatchPeertype:
Is Incoming=TRUE, Number Expansion=FALSE
Oct 10 21:00:35.485: //-1/00006878-0000-1000-0001-C0A8060606B8/DPM/dpMatchCore:
Dial String=4216, Expanded String=4216, Calling Number=
Timeout=TRUE, Is Incoming=TRUE, Peer Info Type=DIALPEER_INFO_SPEECH
Oct 10 21:00:35.485: //-1/00006878-0000-1000-0001-C0A8060606B8/DPM/MatchNextPeer:
Result=Success(0); Incoming Dial-peer=44 Is Matched
Oct 10 21:00:35.489: //-1/00006878-0000-1000-0001-C0A8060606B8/DPM/dpMatchPeertype:exit@5398
Oct 10 21:00:35.489: //-1/00006878-0000-1000-0001-C0A8060606B8/DPM/dpAssociateIncomingPeerCore:
Result=NO_MATCH(-1) After All Match Rules Attempt
Oct 10 21:00:35.489: //-1/00006878-0000-1000-0001-C0A8060606B8/DPM/dpAssociateIncomingPeerSPI:exit@5932
Oct 10 21:00:35.489: //-1/00006878-0000-1000-0001-C0A8060606B8/DPM/dpAssociateIncomingPeerCore:
Calling Number=, Called Number=4216, Voice-Interface=0x0,
Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
Peer Info Type=DIALPEER_INFO_SPEECH
Oct 10 21:00:35.489: //-1/00006878-0000-1000-0001-C0A8060606B8/DPM/dpAssociateIncomingPeerCore:
Match Rule=DP_MATCH_INCOMING_DNIS; Called Number=4216
Oct 10 21:00:35.489: //-1/00006878-0000-1000-0001-C0A8060606B8/DPM/dpMatchPeertype:
Is Incoming=TRUE, Number Expansion=FALSE
Oct 10 21:00:35.489: //-1/00006878-0000-1000-0001-C0A8060606B8/DPM/dpMatchCore:
Dial String=4216, Expanded String=4216, Calling Number=
Timeout=TRUE, Is Incoming=TRUE, Peer Info Type=DIALPEER_INFO_SPEECH
Oct 10 21:00:35.489: //-1/00006878-0000-1000-0001-C0A8060606B8/DPM/MatchNextPeer:
Result=Success(0); Incoming Dial-peer=44 Is Matched
Oct 10 21:00:35.489: //-1/00006878-0000-1000-0001-C0A8060606B8/DPM/dpMatchPeertype:exit@5398
Oct 10 21:00:35.489: //-1/00006878-0000-1000-0001-C0A8060606B8/DPM/dpAssociateIncomingPeerCore:
Result=NO_MATCH(-1) After All Match Rules Attempt
Oct 10 21:00:35.489: //-1/00006878-0000-1000-0001-C0A8060606B8/DPM/dpAssociateIncomingPeerSPI:exit@5932
Oct 10 21:00:35.497: //-1/00006878-0000-1000-0001-C0A8060606B8/DPM/dpMatchPeersCore:
Calling Number=, Called Number=4216, Peer Info Type=DIALPEER_INFO_SPEECH
Oct 10 21:00:35.497: //-1/00006878-0000-1000-0001-C0A8060606B8/DPM/dpMatchPeersCore:
Match Rule=DP_MATCH_DEST; Called Number=4216
Oct 10 21:00:35.497: //-1/00006878-0000-1000-0001-C0A8060606B8/DPM/dpMatchCore:
Dial String=4216, Expanded String=4216, Calling Number=
Timeout=TRUE, Is Incoming=FALSE, Peer Info Type=DIALPEER_INFO_SPEECH
Oct 10 21:00:35.497: //-1/00006878-0000-1000-0001-C0A8060606B8/DPM/MatchNextPeer:
Result=Success(0); Outgoing Dial-peer=11 Is Matched
Oct 10 21:00:35.497: //-1/00006878-0000-1000-0001-C0A8060606B8/DPM/dpMatchPeersCore:
Result=Success(0) after DP_MATCH_DEST
Oct 10 21:00:35.497: //-1/00006878-0000-1000-0001-C0A8060606B8/DPM/dpMatchPeersMoreArg:
Result=SUCCESS(0)
List of Matched Outgoing Dial-peer(s):
1: Dial-peer Tag=11

Привожу также дебаг со стороны аваи (при звонке 6513 --> 4216)

274681mS H323Rx: src=172.18.0.1:35169
H323 Pcol=08(Q931) Reflen=2 ref=12D0(Remote)
Message Type = Setup

274683mS H323Evt: v=0 stacknum=29 State, new=NullState, old=NullState id=-1
274683mS H323Evt: v=0 stacknum=29 State, new=Present, old=NullState id=1
274683mS PRN: Fast Start
274685mS PRN: Media Channel 172.18.0.1, 17554
274685mS PRN: Allow digital call
274688mS H323Tx: dst=172.18.0.1:35169
H323 Pcol=08(Q931) Reflen=2 ref=12D0(Local)
Message Type = ReleaseComplete

274689mS H323Evt: v=0 stacknum=29 State, new=NullState, old=Present id=1
279873mS H323Rx: src=172.18.0.1:63083
H323 Pcol=08(Q931) Reflen=2 ref=12D1(Remote)
Message Type = Setup

279874mS H323Evt: v=0 stacknum=29 State, new=NullState, old=NullState id=-1
279874mS H323Evt: v=0 stacknum=29 State, new=Present, old=NullState id=1
279874mS PRN: Fast Start
279876mS PRN: Media Channel 172.18.0.1, 18676
279877mS PRN: Allow digital call
279881mS H323Tx: dst=172.18.0.1:63083
H323 Pcol=08(Q931) Reflen=2 ref=12D1(Local)
Message Type = ReleaseComplete

279881mS H323Evt: v=0 stacknum=29 State, new=NullState, old=Present id=1

Ну и напоследок конфиг роутера с соответствующими dial-peer

voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol t38 ls-redundancy 3 hs-redundancy 2 fallback none
h323
sip
bind control source-interface GigabitEthernet0/1.1
bind media source-interface GigabitEthernet0/1.1
registrar server
!
!
voice class dualtone-detect-params 711
!
!
interface GigabitEthernet0/1.1
description LAN
encapsulation dot1Q 1 native
ip address 192.168.1.10 255.255.255.0
ip flow ingress
ip flow egress
ip nat inside
ip virtual-reassembly
no ip route-cache
!
!
interface GigabitEthernet0/1.6
description For VoIP VLAN
encapsulation dot1Q 11
ip address 172.18.0.1 255.255.255.0
ip flow ingress
ip flow egress
ip nat inside
ip virtual-reassembly
no ip route-cache
h323-gateway voip interface
h323-gateway voip bind srcaddr 172.18.0.1
!
!
voice class custom-cptone RU
dualtone ringback


voice-port 0/0/0:15
cptone RU
bearer-cap Speech


dial-peer voice 11 voip
description “To_Line”
destination-pattern 4...$
session target ipv4:192.168.4.140
dtmf-relay h245-signal
codec g711alaw
fax rate 14400
fax protocol none
no vad

dial-peer voice 4 voip
service session
destination-pattern 1201$
session protocol sipv2
session target ipv4:192.168.4.7
codec g711alaw


dial-peer voice 8 voip
description To Arkhangelsk
destination-pattern 6...$
session target ipv4:192.168.6.6
codec g711alaw


Подскажите пожалуйста, почему может не проходить звонок с Панасоника на Аваю ??

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Тут приведен пример 1-2.. А 2-3 работает?"  +/
Сообщение от j_vw on 22-Окт-09, 00:16 
>Уважаемые гуру, прошу помощи.
>
>Есть АТС Panasonic KX-TDA200 и АТС Avaya IPOffice 406v2, которые соединенны через
>роутер Cisco 2821 по IP по H.323 протоколу. Здесь роутер используется
>как H.323-gateway.
>Со стороны и Avaya и Cisco (с IP телефонов, зарегистрированных на циске)
>звязь с Панасоником есть. А вот с Панасоника можно дозвониться только
>до IP телефонов, при попытке набора номера Avaya сразу короткие гудки.

Если честно, лень смотреть ваш debag...
Прямые звонки Сisco-Avaya тоже проходят? Или нет?

Попробуйте debug cch323 all
И посмотрите причину дисконнекта (коды в Яндексе)
Сравните "прошедшие" звонки и "непрошедшие".... Найдите 7 отличий ;)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Тут приведен пример 1-2.. А 2-3 работает?"  +/
Сообщение от rpaha (ok) on 22-Окт-09, 00:28 
>[оверквотинг удален]
>>Со стороны и Avaya и Cisco (с IP телефонов, зарегистрированных на циске)
>>звязь с Панасоником есть. А вот с Панасоника можно дозвониться только
>>до IP телефонов, при попытке набора номера Avaya сразу короткие гудки.
>
>Если честно, лень смотреть ваш debag...
>Прямые звонки Сisco-Avaya тоже проходят? Или нет?
>
>Попробуйте debug cch323 all
>И посмотрите причину дисконнекта (коды в Яндексе)
>Сравните "прошедшие" звонки и "непрошедшие".... Найдите 7 отличий ;)

Да, с циски на аваю проходят звонки и с аваи на циску тоже.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Тут приведен пример 1-2.. А 2-3 работает?"  +/
Сообщение от rpaha (ok) on 22-Окт-09, 00:58 
>>Попробуйте debug cch323 all
>>И посмотрите причину дисконнекта (коды в Яндексе)
>>Сравните "прошедшие" звонки и "непрошедшие".... Найдите 7 отличий ;)
>

Посмотрел дебаги, рекомендуемые Вами. Ничего не понимаю, у меня вышло что:
по успешным звонкам Disconnect cause 16 - NormalCallClearing
по не успешным  Disconnect cause 17 - User Busy. Но ведь он не занят, телефон стоит у меня рядом на столе.
Кстати точно такой же cause  я обнаружил в распечатки команды sh dial-peer voice 9, а именно " Last Disconnect Text is "user busy (17)"  это в самой последней строчке листинга.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру