The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"route-map !!! Помогите!!!!"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"route-map !!! Помогите!!!!"  +/
Сообщение от kasper email(ok) on 16-Ноя-09, 10:29 
есть два провайдера... пытался настроить роутинг через route-map.
работает некорректно..перестал роутить локальные сети... если я пытаюсь пинг послать к локальному пользователю... то он у меня уходить в сторону провайдера... немогу понять где косяк.. ткните носом...


конфиг

Current configuration : 9589 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname kazan
!
boot-start-marker
boot system flash c2800nm-adventerprisek9-mz.124-22.T.bin
boot-end-marker
!
logging message-counter syslog
logging buffered 51200 warnings
!
aaa new-model
!
!
aaa authentication login default local
aaa authentication login vty local
aaa authentication ppp default local
aaa authorization exec default local
aaa authorization network default local
aaa authorization network VPN local
!
!
aaa session-id common
!
dot11 syslog
ip source-route
!
!
ip cef
!
!


no ipv6 cef
l2tp-class class1
!
!
multilink bundle-name authenticated
!
!
!
!
vpdn enable
!
vpdn-group pppoe
request-dialin
  protocol pppoe
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!        
!
!
!
!
voice-card 0
!
!
!
!
!
username xxxx privilege 15 secret 5 yyyyyyy
archive
log config
  hidekeys
!
!
!
!
!
!
!
pseudowire-class class2
encapsulation l2tpv2
protocol l2tpv2 class1
ip local interface FastEthernet0/1.3
!
bridge irb
!
!
!
bba-group pppoe global
!
!
interface Loopback0
ip address 10.20.30.40 255.255.255.255
!

!
interface FastEthernet0/0
description $WAN$
no ip address
no ip redirects
no ip unreachables
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/0.1
encapsulation dot1Q 541
ip address 10.1.1.6 255.255.255.252
ip flow ingress
!
interface FastEthernet0/0.2
encapsulation dot1Q 729
ip address z.151.2.91 255.255.255.248
ip flow ingress
ip nat outside
ip virtual-reassembly
!
interface FastEthernet0/0.3
!
interface FastEthernet0/1
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1.1
description $LAN OFFICE $
encapsulation dot1Q 1 native
ip address 192.168.1.254 255.255.255.0 secondary
ip address 192.168.0.254 255.255.255.0 secondary
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip policy route-map ISP
ip virtual-reassembly
!
interface FastEthernet0/1.2
encapsulation dot1Q 2
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface FastEthernet0/1.3
encapsulation dot1Q 300
ip address dhcp
ip nat outside
ip virtual-reassembly
!
interface Virtual-PPP1
ip address negotiated
ip mtu 1350
ip nat outside
ip virtual-reassembly
no cdp enable
ppp authentication chap callin
ppp chap hostname wwwwwww
ppp chap password 7 eeeeeeee
ppp direction callout
pseudowire 10.10.0.5 10 pw-class class2
!
interface Dialer0
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname rrrrrrr
ppp chap password 7 ttttttt
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 z.151.2.89
ip route 10.1.1.0 255.255.255.252 10.1.1.5
ip route 10.1.2.0 255.255.255.248 10.1.1.5
ip route 10.1.3.0 255.255.255.252 10.1.1.5
ip route 10.1.4.0 255.255.255.252 10.1.1.5
ip route 10.1.5.0 255.255.255.252 10.1.1.5
ip route 10.1.6.0 255.255.255.252 10.1.1.5
ip route 172.16.25.14 255.255.255.255 81.25.172.1
ip route 192.168.2.0 255.255.255.0 10.1.1.5
ip route 192.168.3.0 255.255.255.0 10.1.1.5
ip route 192.168.4.0 255.255.255.0 10.1.1.5
ip route 192.168.5.0 255.255.255.0 10.1.1.5
ip route 192.168.6.0 255.255.255.0 10.1.1.5
ip route 192.168.7.0 255.255.255.0 192.168.1.253
ip route 192.168.100.0 255.255.255.0 192.168.1.253
ip route 10.10.0.5 255.255.255.255 FastEthernet0/1.3 dhcp
ip http server
ip http access-class 23
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip flow-cache timeout inactive 60
ip flow-cache timeout active 10
ip flow-export version 5
ip flow-export destination 192.168.1.200 9996
!
ip nat inside source static tcp 192.168.1.37 1123 interface FastEthernet0/0.2 1123
ip nat inside source list 100 interface FastEthernet0/0.2 overload
ip nat inside source list 101 interface FastEthernet0/0.2 overload
ip nat inside source static tcp 192.168.1.253 443 interface FastEthernet0/0.2 443
ip nat inside source static tcp 192.168.1.253 80 interface FastEthernet0/0.2 80
ip nat inside source static tcp 192.168.1.253 110 interface FastEthernet0/0.2 110
ip nat inside source static tcp 192.168.1.253 25 interface FastEthernet0/0.2 25
ip nat inside source static tcp 192.168.1.200 50060 interface FastEthernet0/0.2 50060
ip nat inside source static udp 192.168.1.253 1194 interface FastEthernet0/0.2 1194
ip nat inside source route-map ISP2 interface Dialer0 overload
!
access-list 23 permit 192.168.200.200
access-list 23 permit 192.168.1.200
access-list 23 permit 192.168.1.202
access-list 100 permit ip host 192.168.1.253 any
access-list 100 permit ip host 192.168.1.200 any
access-list 100 permit ip host 192.168.1.180 any
access-list 101 permit ip host 192.168.1.202 any
access-list 101 permit tcp host 192.168.1.37 any eq 2143
access-list 101 permit tcp host 192.168.1.170 any eq 1024
access-list 101 permit tcp host 192.168.1.187 any eq 1024
access-list 102 permit ip host 192.168.1.180 any
access-list 102 permit ip host 192.168.1.182 any
access-list 102 permit ip host 192.168.1.200 any
access-list 102 permit tcp host 192.168.1.163 any eq www
access-list 102 permit tcp host 192.168.1.163 any eq domain
access-list 102 permit udp host 192.168.1.163 any eq domain
access-list 103 permit ip 192.168.0.0 0.0.0.255 192.168.1.0 0.0.0.255
access-list 103 permit ip 192.168.1.0 0.0.0.255 192.168.0.0 0.0.0.255
dialer-list 1 protocol ip permit
!
!
!
!
route-map ISP1 permit 10
match ip address 100
match interface FastEthernet0/0.2
!
route-map ISP2 permit 10
match ip address 102
match interface Dialer0
!
route-map ISP permit 10
match ip address 100
set ip next-hop z.151.2.89
!
route-map ISP permit 20
match ip address 102
set ip next-hop x.25.172.1
!
route-map ISP permit 30
set default interface Null0
!
!
!
!
control-plane
!
bridge 2 protocol ieee
bridge 2 route ip
!
!
ccm-manager fax protocol cisco
!
mgcp fax t38 ecm
!
!
!
!
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
privilege level 15
password 7 qqqqqq
transport input telnet
line vty 5 15
privilege level 15
password 7 qqqq
transport input telnet
!
scheduler allocate 20000 1000
end

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "route-map !!! Помогите!!!!"  +/
Сообщение от j_vw on 16-Ноя-09, 20:27 
>есть два провайдера... пытался настроить роутинг через route-map.
>работает некорректно..перестал роутить локальные сети... если я пытаюсь пинг послать к локальному
>пользователю... то он у меня уходить в сторону провайдера... немогу понять
>где косяк.. ткните носом...

Каша какая то в конфиге...

>!
>interface FastEthernet0/1.1
> description $LAN OFFICE $
> encapsulation dot1Q 1 native
> ip address 192.168.1.254 255.255.255.0 secondary
> ip address 192.168.0.254 255.255.255.0 secondary
> ip address 192.168.1.1 255.255.255.0
> ip nat inside
> ip policy route-map ISP
> ip virtual-reassembly

Вот вижу только один интерфейс с RM.
С адресами, тоже, какая то муть...Я не говорю, что работать не будет, но как то "не по людски"

Роуты и наты не трогаю...Там, тоже, "без пол-литра...."


>[оверквотинг удален]
>route-map ISP permit 10
> match ip address 100
> set ip next-hop z.151.2.89
>!
>route-map ISP permit 20
> match ip address 102
> set ip next-hop x.25.172.1
>!
>route-map ISP permit 30
> set default interface Null0

Ну, так, на вскидку.... Уберите 30 и допишите deny в 101 и 102 вместо permit в 103

Но, честно говоря, как то "кривовато" все это выглядит...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "route-map !!! Помогите!!!!"  +/
Сообщение от kasper email(ok) on 17-Ноя-09, 13:51 
разобрался сам !!! спасибо....

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру