The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"PPTP VPN - клиент подключается, но дальше не идёт"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"PPTP VPN - клиент подключается, но дальше не идёт"  +/
Сообщение от ll75 email(ok) on 17-Ноя-09, 12:34 
Клиент подключается с WinXP к VPN серверу на cisco, получает ip-адрес, но дальше не видит локальную сеть ....
часть конфига:

vpdn enable
!
vpdn-group 1
! Default PPTP VPDN group
accept-dialin
  protocol pptp
  virtual-template 1

interface FastEthernet0
description $ETH-LAN$
ip address 81.90.ххх.х 255.255.255.128
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
ip tcp adjust-mss 1412
duplex auto
speed auto

interface Virtual-Template1
ip unnumbered FastEthernet0
peer default ip address pool tezt
no keepalive
ppp encrypt mppe auto
ppp authentication pap chap ms-chap

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "PPTP VPN - клиент подключается, но дальше не идёт"  +/
Сообщение от Николай (??) on 17-Ноя-09, 12:35 
мало этой части конфига
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "PPTP VPN - клиент подключается, но дальше не идёт"  +/
Сообщение от ll75 email(ok) on 17-Ноя-09, 12:41 
>мало этой части конфига

что добавить?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "PPTP VPN - клиент подключается, но дальше не идёт"  +/
Сообщение от ll75 email(ok) on 17-Ноя-09, 12:54 
>>мало этой части конфига

это всё, что касается PPTP на примере http://www.cisco.com/en/US/tech/tk827/tk369/technologies_con...


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "PPTP VPN - клиент подключается, но дальше не идёт"  +/
Сообщение от ll75 email(ok) on 17-Ноя-09, 14:30 
при подключении с WinXP видно такие маршруты:

Подключение по локальной сети - Ethernet адаптер:

DNS-суффикс этого подключения . . :
IP-адрес . . . . . . . . . . . . : 81.90.xxx.x
Маска подсети . . . . . . . . . . : 255.255.255.128
Основной шлюз . . . . . . . . . . : 81.90.xxx.1

wdf - PPP адаптер:

DNS-суффикс этого подключения . . :
IP-адрес . . . . . . . . . . . . : 192.168.1.2
Маска подсети . . . . . . . . . . : 255.255.255.255
Основной шлюз . . . . . . . . . . : 192.168.1.2


т.е. получается клиенту назначается адрес из пула 192.168.1.2, но маршрута нет дальше в локалку...(( как быть?


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "PPTP VPN - клиент подключается, но дальше не идёт"  +/
Сообщение от blank (ok) on 17-Ноя-09, 14:49 
>[оверквотинг удален]
>IP-адрес . . . . . . . . . . .
>. : 192.168.1.2
>Маска подсети . . . . . . . . . .
>: 255.255.255.255
>Основной шлюз . . . . . . . . . .
>: 192.168.1.2
>
>
>т.е. получается клиенту назначается адрес из пула 192.168.1.2, но маршрута нет дальше
>в локалку...(( как быть?

а трайсер с клиента в локалку что показывает и что за локалка?
вроде все законно, дефолтный маршрут смотрит в тунель, а дальнейшим роутингом должна циска заниматься.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "PPTP VPN - клиент подключается, но дальше не идёт"  +/
Сообщение от ll75 email(ok) on 17-Ноя-09, 15:19 

>а трайсер с клиента в локалку что показывает и что за локалка?
>

tracert на клиенте показывает одни звёздочки...

>вроде все законно, дефолтный маршрут смотрит в тунель, а дальнейшим роутингом должна
>циска заниматься.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "PPTP VPN - клиент подключается, но дальше не идёт"  +/
Сообщение от blank (ok) on 17-Ноя-09, 15:35 
>
>>а трайсер с клиента в локалку что показывает и что за локалка?
>>
>
>tracert на клиенте показывает одни звёздочки...
>
>>вроде все законно, дефолтный маршрут смотрит в тунель, а дальнейшим роутингом должна
>>циска заниматься.

sh ip rout с циски при поднятом впн?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "PPTP VPN - клиент подключается, но дальше не идёт"  +/
Сообщение от ll75 email(ok) on 17-Ноя-09, 15:39 

>sh ip rout с циски при поднятом впн?

gateway#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     213.154.ххх.0/32 is subnetted, 1 subnets
C       213.154.ххх.78 is directly connected, Dialer3
     78.0.0.0/32 is subnetted, 1 subnets
C       78.25.хх.хх is directly connected, Dialer3
     192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.1.0/24 is directly connected, Vlan1
C       192.168.1.2/32 is directly connected, Virtual-Access5
S*   0.0.0.0/0 is directly connected, Dialer3

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "PPTP VPN - клиент подключается, но дальше не идёт"  +/
Сообщение от blank (ok) on 17-Ноя-09, 15:49 
>[оверквотинг удален]
>     78.0.0.0/32 is subnetted, 1 subnets
>C       78.25.хх.хх is directly connected, Dialer3
>
>     192.168.1.0/24 is variably subnetted, 2 subnets, 2
>masks
>C       192.168.1.0/24 is directly connected, Vlan1
>
>C       192.168.1.2/32 is directly connected, Virtual-Access5
>
>S*   0.0.0.0/0 is directly connected, Dialer3

у вас на разных интерфейсах
C       192.168.1.0/24 is directly connected, Vlan1
C       192.168.1.2/32 is directly connected, Virtual-Access5
клиенты в сети 192.168.1.0/24 хост 192.168.1.2 ищут в своем езернете не обращаясь к роутеру.
выдавайте сеть отличную от локальной.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "PPTP VPN - клиент подключается, но дальше не идёт"  +/
Сообщение от Николай (??) on 17-Ноя-09, 15:52 

>[оверквотинг удален]
>     78.0.0.0/32 is subnetted, 1 subnets
>C       78.25.хх.хх is directly connected, Dialer3
>
>     192.168.1.0/24 is variably subnetted, 2 subnets, 2
>masks
>C       192.168.1.0/24 is directly connected, Vlan1
>
>C       192.168.1.2/32 is directly connected, Virtual-Access5
>
>S*   0.0.0.0/0 is directly connected, Dialer3

По идее все ок, пакет должен роутиться в локалку поскольку роутер знает о ней, из локалки если дефаулт гейт эта циска пакет должен приходить. Часом аксес листы на интерфейсах ничего не режут? Попробуй повесить разрешающее правило на ЛАН интерфейс - посмотришь пакеты уходят на клиента ВПН из ЛАН.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "PPTP VPN - клиент подключается, но дальше не идёт"  +/
Сообщение от Николай (??) on 17-Ноя-09, 15:52 

>По идее все ок, пакет должен роутиться в локалку поскольку роутер знает
>о ней, из локалки если дефаулт гейт эта циска пакет должен
>приходить. Часом аксес листы на интерфейсах ничего не режут? Попробуй повесить
>разрешающее правило на ЛАН интерфейс - посмотришь пакеты уходят на клиента
>ВПН из ЛАН.

Ой сори не заметил одна подсеть и там и там.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "PPTP VPN - клиент подключается, но дальше не идёт"  +/
Сообщение от ll75 email(ok) on 17-Ноя-09, 16:01 
>

добавил на циске пул из другой сети - 192.168.7.0 -> то же самое ((

Подключение по локальной сети - Ethernet адаптер:

DNS-суффикс этого подключения . . :
IP-адрес . . . . . . . . . . . . : 81.90.xxx.x
Маска подсети . . . . . . . . . . : 255.255.255.128
Основной шлюз . . . . . . . . . . : 81.90.xxx.1

wdf - PPP адаптер:

DNS-суффикс этого подключения . . :
IP-адрес . . . . . . . . . . . . : 192.168.7.204
Маска подсети . . . . . . . . . . : 255.255.255.255
Основной шлюз . . . . . . . . . . : 192.168.7.204


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "PPTP VPN - клиент подключается, но дальше не идёт"  +/
Сообщение от blank (ok) on 17-Ноя-09, 16:07 
>[оверквотинг удален]
>
>wdf - PPP адаптер:
>
>DNS-суффикс этого подключения . . :
>IP-адрес . . . . . . . . . . .
>. : 192.168.7.204
>Маска подсети . . . . . . . . . .
>: 255.255.255.255
>Основной шлюз . . . . . . . . . .
>: 192.168.7.204

sh ip rout, с клиента tracert 192.168.1.(ип интерфейса влан 1)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "PPTP VPN - клиент подключается, но дальше не идёт"  +/
Сообщение от ll75 email(ok) on 17-Ноя-09, 16:08 
gateway#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     213.154.ххх.0/32 is subnetted, 1 subnets
C       213.154.ххх.78 is directly connected, Dialer3
     78.0.0.0/32 is subnetted, 1 subnets
C       78.25.хх.52 is directly connected, Dialer3
     192.168.7.0/32 is subnetted, 1 subnets
C       192.168.7.204 is directly connected, Virtual-Access5
C    192.168.1.0/24 is directly connected, Vlan1
S*   0.0.0.0/0 is directly connected, Dialer3


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

15. "PPTP VPN - клиент подключается, но дальше не идёт"  +/
Сообщение от ll75 email(ok) on 18-Ноя-09, 15:16 
ПОМОГИТЕ ПЛЗ! не знаю куда копать ((


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

16. "PPTP VPN - клиент подключается, но дальше не идёт"  +/
Сообщение от Аноним (??) on 18-Ноя-09, 16:45 
>[оверквотинг удален]
>
>wdf - PPP адаптер:
>
>DNS-суффикс этого подключения . . :
>IP-адрес . . . . . . . . . . .
>. : 192.168.7.204
>Маска подсети . . . . . . . . . .
>: 255.255.255.255
>Основной шлюз . . . . . . . . . .
>: 192.168.7.204

А почему это у вас ип компьпютера и шлюза одинаковые?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

17. "PPTP VPN - клиент подключается, но дальше не идёт"  +/
Сообщение от ll75 email(ok) on 18-Ноя-09, 17:17 

>А почему это у вас ип компьпютера и шлюза одинаковые?

всё получилось-на клиенте в локалке нужно было явно прописать "обратный маршрут"


route add 192.168.7.0 mask 255.255.255.0 192.168.1.35


при этом внесены изменения в

gateway(config)#interface Virtual-Template1
gateway(config-if)#no ip unnumbered FastEthernet1
gateway(config-if)#ip address 192.168.7.1 255.255.255.0

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

18. "PPTP VPN - клиент подключается, но дальше не идёт"  +/
Сообщение от blank (ok) on 18-Ноя-09, 17:33 
>[оверквотинг удален]
>
>
>route add 192.168.7.0 mask 255.255.255.0 192.168.1.35
>
>
>при этом внесены изменения в
>
>gateway(config)#interface Virtual-Template1
>gateway(config-if)#no ip unnumbered FastEthernet1
>gateway(config-if)#ip address 192.168.7.1 255.255.255.0

что бы обратные маршруты не прописывать нужно пул назначать из сети отличной
от локальной и тогда трафик пойдет в сторону дефолтного гейтвея.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

20. "PPTP VPN - клиент подключается, но дальше не идёт"  +/
Сообщение от ll75 email(ok) on 19-Ноя-09, 09:00 
о бы обратные маршруты не прописывать нужно пул назначать из сети отличной
>
>от локальной и тогда трафик пойдет в сторону дефолтного гейтвея.

192.168.7.204...192.168.7.206 -пул адресов...
192.168.1.0 -локалка
и всё равно без обратного маршрута не шло...
И на клиенте ipconfig:
Подключение по локальной сети - Ethernet адаптер:

DNS-суффикс этого подключения . . :
IP-адрес . . . . . . . . . . . . : 81.90.xxx.x
Маска подсети . . . . . . . . . . : 255.255.255.128
Основной шлюз . . . . . . . . . . : 81.90.xxx.1

wdf - PPP адаптер:

DNS-суффикс этого подключения . . :
IP-адрес . . . . . . . . . . . . : 192.168.7.204
Маска подсети . . . . . . . . . . : 255.255.255.255
Основной шлюз . . . . . . . . . . : 192.168.7.204


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

19. "PPTP VPN - клиент подключается, но дальше не идёт"  +/
Сообщение от AlexDv (??) on 18-Ноя-09, 17:38 
>[оверквотинг удален]
>
>
>route add 192.168.7.0 mask 255.255.255.0 192.168.1.35
>
>
>при этом внесены изменения в
>
>gateway(config)#interface Virtual-Template1
>gateway(config-if)#no ip unnumbered FastEthernet1
>gateway(config-if)#ip address 192.168.7.1 255.255.255.0

Естественно. Если-бы на внешнем интерфейсе не было NAT-а, работало бы и с ip unnumbered FastEthernet1.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру