The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"DNS сервер и коммутатор cisco 3550"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"DNS сервер и коммутатор cisco 3550"  +/
Сообщение от ichtus (ok) on 04-Янв-10, 13:16 
Добрый час, не подскажите как решить следующую проблемму?

Есть одна циска 3550 (все порты оптические) и набор 2950 (два оптических порта, остальные - медь). Хочу подключить их деревом. В вершине 3550, от нее 2950 по оптике. Каждая 2950 - как офисный коммутатор. К 3550 по гигабитному каналу напрямую подключен сервер авторизации, он же ДНС сервер, через него все выходят в инет.

Каждая циска 2950 - отдельный ВЛАН с адресами типа 192.168.10.Х, 192.168.20.Х и т.д., сотрудников садит по DHCP. Каждый 2950 имеет адрес вида: 192.168.10.253, 192.168.20.253 и т.д.

циска 3550 - на разных портах разный ВЛАН настроен, соответственно подключенному коммутатору. На порту гигабит 0/1 настроен транк к линукс-серверу авторизации + ДНС. На сервере виртуальные интерфейсы вида 192.168.10.254, 192.168.20.254 и т.д.

Сервер при подключении раздает адреса вида 172.16.0.0/16

Что работает: клиенты адреса правильные получают, с сервером подключение происходит по pppoe, выдается адрес, все хорошо. Единственно не открываются страницы по именам и не пингуются. По айпи все пингуется и открывается. Непосредственно с самих цисок пингую по именам сайтов - адреса определяет, только пинг не идет потому что заблокировано, т.е. все нормально. Но с компов пингую тот же яндекс - он даже айпи не определяет, говорит нет такого хоста. ДНС рабочий, все нормально - сейчас через него по не управляемым коммутаторам куча народу выходит.

Что не так и почему не выходит не могу понять... может подскажите что?

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "конфиг 3550"  +/
Сообщение от ichtus (ok) on 04-Янв-10, 13:20 
Current configuration : 4752 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname root_network
!
no logging on
enable secret 5 $1$Ul./$pX1.F3ebG84cKq4XT9Bdx0
enable password 7 12170410
!
no aaa new-model
ip subnet-zero
ip routing
ip domain-lookup source-interface GigabitEthernet0/1
ip host phoenix.local 192.168.1.5
!
!
!
crypto pki trustpoint TP-self-signed-1609238784
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1609238784
revocation-check none
rsakeypair TP-self-signed-1609238784
!
!
crypto pki certificate chain TP-self-signed-1609238784
certificate self-signed 01
  30820242 308201AB A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31363039 32333837 3834301E 170D3933 30333031 30303031
  30375A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 36303932
  33383738 3430819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100E94B A5B8E4FE D482D4FB 28B7B833 E8C25FED 1C9ACD4A 9CFB7DD8 666E3F3E
  4CA39EE8 6E6B990C 1F1762E3 C760735C 99D8EB63 31392524 FCFD04C9 D42D1F8E
  F63CD7AD B12A5DA5 550304F1 C5C834C1 C46E4EE9 D34FBC90 71223464 0ABCA082
  015EC330 C5E114A8 295E7C63 B99F6AA6 0005FD5E 1FD161AB EADF9EA8 578E06A5
  B9790203 010001A3 6A306830 0F060355 1D130101 FF040530 030101FF 30150603
  551D1104 0E300C82 0A636973 636F3335 35302E30 1F060355 1D230418 30168014
  D824E828 3FCD3237 3B984D5A 8191711D 36CB95EF 301D0603 551D0E04 160414D8
  24E8283F CD32373B 984D5A81 91711D36 CB95EF30 0D06092A 864886F7 0D010104
  05000381 8100C6D3 F2AE7D16 0A0DBEB8 4827E181 9D73BAAC E90135FB 8730A577
  2CBC061E 26C34690 21BC01FE 08344F42 773A3C27 5D590887 1683CB1A 16A8BDA9
  1CEACB6C DEBEA74A 0092E176 3E332388 357CC050 F7743573 1E275D75 7E462E28
  A3042340 952FBAA3 71CF5489 B9BBC2C7 9AE57243 978BF8AE 55A5A440 FDA8B317
  57A42A30 0B21
  quit
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
!
!
interface FastEthernet0/1
switchport access vlan 10
switchport mode dynamic desirable
duplex full
!
interface FastEthernet0/2
switchport access vlan 20
switchport mode dynamic desirable
duplex full
!
interface FastEthernet0/3
switchport access vlan 30
switchport mode dynamic desirable
duplex full
!
(........)
!
interface GigabitEthernet0/1
switchport access vlan 5
switchport trunk encapsulation dot1q
switchport trunk native vlan 5
switchport mode trunk
!
interface GigabitEthernet0/2
switchport mode dynamic desirable
!
interface Vlan1
no ip address
shutdown
!
interface Vlan5
ip address 192.168.1.254 255.255.255.0
!
interface Vlan10
ip address 192.168.10.1 255.255.255.0
!
interface Vlan20
ip address 192.168.20.1 255.255.255.0
!
interface Vlan30
ip address 192.168.30.1 255.255.255.0
!
ip default-gateway 192.168.10.254
ip classless
no ip http server
no ip http secure-server
!
!
access-list 101 permit udp any any eq domain
access-list 101 permit udp any eq domain any
!
control-plane
!
!
line con 0
exec-timeout 0 0
line vty 0 4
password 7 032071251409284A1F5B
login
line vty 5 15
password 7 123D2F39000D05027B79
login
!
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "конфиг 2950"  +/
Сообщение от ichtus (ok) on 04-Янв-10, 13:23 
Current configuration : 4517 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname network_10
!
no logging buffered
no logging console
no logging monitor
no logging on
enable secret 5 $1$d4Q2$zPHH7aFkCMP8aey/ci27o0
enable password nag
!
username nag password 0 nag
ip subnet-zero
!
ip dhcp pool network_10_pool
   network 192.168.10.0 255.255.255.0
   default-router 192.168.10.253
   dns-server 192.168.1.252 83.149.22.14
   domain-name local
!
ip host phoenix.local 192.168.1.5
ip ssh time-out 120
ip ssh authentication-retries 3
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
switchport access vlan 10
speed 100
duplex full
!
interface FastEthernet0/2
switchport access vlan 10
speed 100
duplex full
!
interface FastEthernet0/3
switchport access vlan 10
speed 100
duplex full
!
(........)
!
interface FastEthernet0/24
switchport access vlan 10
speed 100
duplex full
!
interface FastEthernet0/25
switchport access vlan 10
!
interface FastEthernet0/26
switchport access vlan 10
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan10
ip address 192.168.10.253 255.255.255.0
no ip route-cache
!
ip default-gateway 192.168.10.1
no ip http server
access-list 101 permit udp any any eq domain
access-list 101 permit udp any eq domain any
banner motd ^Cc
#################################################################
#################################################################
^C
!
line con 0
line vty 0 4
login local
line vty 5 15
login
!
ntp server 192.168.1.1
ntp server 192.168.10.1
!
end
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "DNS сервер и коммутатор cisco 3550"  +/
Сообщение от EvilX (??) on 04-Янв-10, 23:49 
При чём тут коммутаторы, если подключение через pppoe?
При подключении выдаётся адрес DNS? А какой выдаётся? А до него связь есть? iptables? no?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "DNS сервер и коммутатор cisco 3550"  +/
Сообщение от ichtus (ok) on 05-Янв-10, 02:38 
>При чём тут коммутаторы, если подключение через pppoe?
>При подключении выдаётся адрес DNS? А какой выдаётся? А до него связь
>есть? iptables? no?

Если вместо цисок ставлю неуправляемый Длинк - все начинает работать... Т.е. похоже проблема все же в настройках циски.

ip DNSа выдается (192.168.1.252) на ПК и мало того все пингуется отлично. Причем внешние ip-адреса пингуются любые (ping 77.88.99.66), а при попытке пинговать по имени (ping ya.ru) - говорит что неизвестный хост...

Т.е. похоже циска не пропускает ДНС траффик. Может там еще чего в настройках нужно указать? В цисках не силен... всегда работал с другими коммутаторами...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "DNS сервер и коммутатор cisco 3550"  +/
Сообщение от EvilX (??) on 05-Янв-10, 09:13 
В конфигурации есть один acl 101, но он никуда не подключен.
Всё-таки DNS. Скорее всего секция allow-recursion.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "DNS сервер и коммутатор cisco 3550"  +/
Сообщение от ichtus (ok) on 05-Янв-10, 11:27 
>В конфигурации есть один acl 101, но он никуда не подключен.
>Всё-таки DNS. Скорее всего секция allow-recursion.

Спасибо за помощь, оказалось ошибка детская была - в разделе
ip dhcp pool network_10_pool
   network 192.168.10.0 255.255.255.0
   default-router 192.168.10.253
   dns-server 192.168.1.252 83.149.22.14
   domain-name local
!

Не правильно указан шлюз по умолчанию, нужно было не его (т.е. 2950 ), а верхнюю циску ( 3550 ), т.е.

ip dhcp pool network_10_pool
   network 192.168.10.0 255.255.255.0
   default-router 192.168.10.1
   dns-server 192.168.1.252 83.149.22.14
   domain-name local
!

и сразу все заработало.

Единственно пинг до ДНСа почему-то 15мс после подключения к серверу ПППОЕ... а без подключения меньше 1мс... Но это скорее уже на самом серваке?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру