The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Настройка Cisco827 ADSL "
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Настройка Cisco827 ADSL "  –1 +/
Сообщение от VichPich (ok) on 16-Янв-10, 11:52 
Задача настроить ADSL на Сisco827 (попытка избавится от DLink 2500). Пров ЮТК выдает при подключении один и тот же IP c 255 маской (впринципе он известен).
Nat и pppoe проблема (не пересекался ранее в работе)  ниже пример конфига - ПК хрюша IP 10.10.10.2/22  Пробовались и CHAP и PAP результат тот же. pvc проверен точно 0/33,
по Ip show route видит только сетку 10.10.*.*.  Все интерфейсы в up.  

Где копать?


vpdn enable
vpdn-group pppoe
request-dialin
  protocol pppoe

interface Ethernet0
ip address 10.10.10.1 255.255.255.0
ip nat inside
hold-queue 100 out
!
interface ATM0
no ip address
no atm ilmi-keepalive
bundle-enable
dsl operating-mode auto
hold-queue 224 in
!
interface ATM0.1 point-to-point
pvc 0/33
  pppoe-client dial-pool-number 1
!
!
interface Dialer1
ip address negotiated
ip mtu 1492
encapsulation ppp
dialer pool 1
ppp authentication chap callin
ppp chap hostname ХХХХХ
ppp chap password 0 ХХХХХ

ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server

access-list 1 permit 10.10.10.0 0.0.0.255

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Настройка Cisco827 ADSL "  +/
Сообщение от AlexDv (??) on 16-Янв-10, 13:53 
>[оверквотинг удален]
> ppp authentication chap callin
> ppp chap hostname ХХХХХ
> ppp chap password 0 ХХХХХ
>
>ip nat inside source list 1 interface Dialer1 overload
>ip classless
>ip route 0.0.0.0 0.0.0.0 Dialer1
>no ip http server
>
>access-list 1 permit 10.10.10.0 0.0.0.255

interface Dialer1
ip nat outside

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Настройка Cisco827 ADSL "  +/
Сообщение от VichPich (ok) on 16-Янв-10, 16:30 
Сделано - эффекта никакого

interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
ppp authentication chap callin

Router#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
Gateway of last resort is 0.0.0.0 to network 0.0.0.0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, Ethernet0
S*   0.0.0.0/0 is directly connected, Dialer1

Router#sh interfaces Dialer1
Dialer1 is up, line protocol is up (spoofing)
  Hardware is Unknown
  Internet address will be negotiated using IPCP
  MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, loopback not set
  DTR is pulsed for 1 seconds on reset

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Настройка Cisco827 ADSL "  +/
Сообщение от AlexDv (??) on 16-Янв-10, 17:48 
>[оверквотинг удален]
>S*   0.0.0.0/0 is directly connected, Dialer1
>
>Router#sh interfaces Dialer1
>Dialer1 is up, line protocol is up (spoofing)
>  Hardware is Unknown
>  Internet address will be negotiated using IPCP
>  MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec,
>     reliability 255/255, txload 1/255, rxload 1/255
>  Encapsulation PPP, loopback not set
>  DTR is pulsed for 1 seconds on reset

Покажите
sh int di1
sh int at0
sh pppo se


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Настройка Cisco827 ADSL "  +/
Сообщение от VichPich (ok) on 16-Янв-10, 18:04 
>Покажите
>sh int di1
>sh int at0
>sh pppo se

Router#sh interfaces Dialer1
Dialer1 is up, line protocol is up (spoofing)
  Hardware is Unknown
  Internet address will be negotiated using IPCP
  MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, loopback not set
  DTR is pulsed for 1 seconds on reset
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 06:49:42
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 42 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes
     0 packets output, 0 bytes

Router#sh interfaces Atm0
ATM0 is up, line protocol is up
  Hardware is PQUICC_SAR (with Alcatel ADSL Module)
  MTU 1500 bytes, sub MTU 1500, BW 800 Kbit, DLY 80 usec,
     reliability 150/255, txload 1/255, rxload 1/255
  Encapsulation ATM, loopback not set
  Encapsulation(s): AAL5  AAL2, PVC mode
  10 maximum active VCs, 1024 VCs per VP, 1 current VCCs
  VC Auto Creation Disabled.
  VC idle disconnect time: 300 seconds
  Last input 00:00:07, output 00:00:07, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/224/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: Per VC Queueing
  5 minute input rate 0 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 1 packets/sec
     252 packets input, 15596 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     226 packets output, 16016 bytes, 0 underruns
     0 output errors, 0 collisions, 4 interface resets
     0 output buffer failures, 0 output buffers swapped out

Router#sh pppoe se
Total PPPoE sessions 1

PPPoE Session Information
UID    SID    RemMAC         OIntf          Intf      Session
              LocMAC                        VASt      state
0      38270  0019.a984.b01a ATM0.1         Vi2       N/A
              000e.84aa.f167 VP/VC:  0/33   DOWN


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Настройка Cisco827 ADSL "  +/
Сообщение от AlexDv (??) on 16-Янв-10, 21:30 
>[оверквотинг удален]
>            
>  LocMAC        
>          
>    VASt      state
>
>0      38270  0019.a984.b01a ATM0.1  
>      Vi2    
>  N/A
>            
>  000e.84aa.f167 VP/VC:  0/33   DOWN

PPPOE должен быть UP.

Смотрите
deb ppp au
deb ppp ne
deb ppp err


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Настройка Cisco827 ADSL "  +/
Сообщение от VichPich (ok) on 17-Янв-10, 12:27 
>Смотрите
>deb ppp au
>deb ppp ne
>deb ppp err

Спасибо Вы мне очень помогли указав направление куда копать. Всё разобрался. Всё работает.
Возник только вопрос кооректного прерывания соединения. А то провайдер какое то время после прерывания отбивает попытки подключения типа "запрещён доступ под данным логином".
Приходится ждать.


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "Настройка Cisco827 ADSL "  +/
Сообщение от AlexDv (??) on 17-Янв-10, 14:12 
>[оверквотинг удален]
>>deb ppp err
>
>Спасибо Вы мне очень помогли указав направление куда копать. Всё разобрался. Всё
>работает.
>Возник только вопрос кооректного прерывания соединения. А то провайдер какое то время
>после прерывания отбивает попытки подключения типа "запрещён доступ под данным логином".
>
>Приходится ждать.
>
>

Так поделитесь, в чем проблема была, может кому пригодится.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "Настройка Cisco827 ADSL "  +/
Сообщение от VichPich (??) on 18-Янв-10, 19:47 
>Так поделитесь, в чем проблема была, может кому пригодится.

Все оказалось прозаично
Вот рабочий конфиг:

interface Ethernet0
ip address 10.10.10.1 255.255.255.0
ip nat inside
hold-queue 100 out
!
interface ATM0
no ip address
ip route-cache flow
no atm ilmi-keepalive
bundle-enable
dsl operating-mode auto
hold-queue 224 in
!
interface ATM0.1 point-to-point
pvc 0/33
  pppoe-client dial-pool-number 1
!
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
ip route-cache flow
dialer pool 1
ppp authentication chap callin
ppp chap hostname XXXXXX
ppp chap password 0 XXXXXX
!
ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server


С помощью одного из debug режимов и консоли я выяснил что используется у прова CHAP авторизация. А вот она и не проходила (логов нет к сожалению, но разобраться там не сложно было) - просто сверил login и pass ошибка была именно там. Как только sh ip rou показал внешнюю сетку - осталось тока DNS компу прикрутить, вот собственно и всё.


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру