The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"DHCP на 2-х Vlan"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Cisco Catalyst коммутаторы)
Изначальное сообщение [ Отслеживать ]

"DHCP на 2-х Vlan"  +/
Сообщение от Babaich email(ok) on 10-Мрт-10, 12:00 
Добрый день,
Есть проблема на С3750.

Описал два пула:

ip dhcp excluded-address 192.168.102.1 192.168.103.1
ip dhcp ping packets 5
!
ip dhcp pool LAN102
   network 192.168.102.0 255.255.255.0
   default-router 192.168.102.1
   dns-server 192.168.1.30 192.168.1.110
   netbios-name-server 192.168.1.30 192.168.1.110
   netbios-node-type h-node
!
ip dhcp pool LAN103
   network 192.168.103.0 255.255.255.0
   default-router 192.168.103.1
   dns-server 192.168.1.30 192.168.1.110
   netbios-name-server 192.168.1.30 192.168.1.110
   netbios-node-type h-node
!
ip dhcp pool User102
   host 192.168.102.27 255.255.255.0
   client-identifier 0100.2421.a432.cc
!
ip dhcp pool User103
   host 192.168.103.27 255.255.255.0
   client-identifier 0100.2421.a432.cc
!
ip dhcp snooping vlan 102-103

И два интерфейса в соответствующих виланах:

interface GigabitEthernet2/0/44
switchport access vlan 102
switchport mode access
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/46
switchport access vlan 103
switchport mode access
spanning-tree portfast
spanning-tree bpduguard enable

И два вилана:

interface Vlan102
ip address 192.168.102.1 255.255.255.0
end
!
interface Vlan103
ip address 192.168.103.1 255.255.255.0
end

Проблема:
Подключаю комп к влан 103(G2/0/46) - получаю адрес
Подключаю комп к влан 102(G2/0/44) - не получаю адрес

Debug говорит:
2010-03-10 10:09:31    Local7.Debug    192.168.0.100    724: Mar 10 10:09:33.055: DHCPD: incoming interface name is Vlan102
2010-03-10 10:09:31    Local7.Debug    192.168.0.100    725: Mar 10 10:09:33.055: DHCPD: DHCPDISCOVER received from client 0100.2264.5fe1.59 on interface Vlan102.
2010-03-10 10:09:31    Local7.Debug    192.168.0.100    726: Mar 10 10:09:33.055: DHCPD: address pool LAN102 is empty.


2010-03-10 10:10:04    Local7.Debug    192.168.0.100    791: Mar 10 10:10:07.079: DHCPD: incoming interface name is Vlan103
2010-03-10 10:10:04    Local7.Debug    192.168.0.100    792: Mar 10 10:10:07.079: DHCPD: DHCPDISCOVER received from client 0100.2264.5fe1.59 on interface Vlan103.
2010-03-10 10:10:04    Local7.Debug    192.168.0.100    793: Mar 10 10:10:07.079: DHCPD: Sending DHCPOFFER to client 0100.2264.5fe1.59 (192.168.103.4).
2010-03-10 10:10:04    Local7.Debug    192.168.0.100    794: Mar 10 10:10:07.079: DHCPD: Check for IPe on Vlan103
2010-03-10 10:10:04    Local7.Debug    192.168.0.100    795: Mar 10 10:10:07.079: DHCPD: creating ARP entry (192.168.103.4, 0022.645f.e159).
2010-03-10 10:10:04    Local7.Debug    192.168.0.100    796: Mar 10 10:10:07.079: DHCPD: unicasting BOOTREPLY to client 0022.645f.e159 (192.168.103.4).
2010-03-10 10:10:04    Local7.Debug    192.168.0.100    797: Mar 10 10:10:07.087: DHCPD: incoming interface name is Vlan103
2010-03-10 10:10:04    Local7.Debug    192.168.0.100    798: Mar 10 10:10:07.087: DHCPD: DHCPREQUEST received from client 0100.2264.5fe1.59.
2010-03-10 10:10:04    Local7.Debug    192.168.0.100    799: Mar 10 10:10:07.087: DHCPD: Sending notification of ASSIGNMENT:
2010-03-10 10:10:04    Local7.Debug    192.168.0.100    800: Mar 10 10:10:07.087:  DHCPD: address 192.168.103.4 mask 255.255.255.0
2010-03-10 10:10:04    Local7.Debug    192.168.0.100    801: Mar 10 10:10:07.087:   DHCPD: htype 1 chaddr 0022.645f.e159
2010-03-10 10:10:04    Local7.Debug    192.168.0.100    802: Mar 10 10:10:07.087:   DHCPD: remote id 020a0000c0a867010f000000
2010-03-10 10:10:04    Local7.Debug    192.168.0.100    803: Mar 10 10:10:07.087:   DHCPD: lease time remaining (secs) = 86400
2010-03-10 10:10:04    Local7.Debug    192.168.0.100    804: Mar 10 10:10:07.087:   DHCPD: giaddr = 0.0.0.0
2010-03-10 10:10:04    Local7.Debug    192.168.0.100    805:
2010-03-10 10:10:04    Local7.Debug    192.168.0.100    806: Mar 10 10:10:07.087:   DHCPD: interface = Vlan103
2010-03-10 10:10:04    Local7.Debug    192.168.0.100    807: Mar 10 10:10:07.087: DHCPD: Sending DHCPACK to client 0100.2264.5fe1.59 (192.168.103.4).
2010-03-10 10:10:04    Local7.Debug    192.168.0.100    808: Mar 10 10:10:07.087: DHCPD: Check for IPe on Vlan103
2010-03-10 10:10:04    Local7.Debug    192.168.0.100    809: Mar 10 10:10:07.087: DHCPD: creating ARP entry (192.168.103.4, 0022.645f.e159).
2010-03-10 10:10:05    Local7.Debug    192.168.0.100    810: Mar 10 10:10:07.087: DHCPD: unicasting BOOTREPLY to client 0022.645f.e159 (192.168.103.4).

В чем может быть проблема?

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

  • DHCP на 2-х Vlan, Babaich, 12:06 , 10-Мрт-10, (1)  
    • DHCP на 2-х Vlan, Vologdin, 12:20 , 10-Мрт-10, (2)  
      • DHCP на 2-х Vlan, Babaich, 12:35 , 10-Мрт-10, (3)  

Сообщения по теме [Сортировка по времени | RSS]


1. "DHCP на 2-х Vlan"  +/
Сообщение от Babaich email(ok) on 10-Мрт-10, 12:06 
Вдогонку еще вопросик:
Надо ли в excluded-address включать адреса, которые я собираюсь раздавать вручную из описанных пулов?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "DHCP на 2-х Vlan"  +/
Сообщение от Vologdin (ok) on 10-Мрт-10, 12:20 
дык ты исключил все адреса 102 влана

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "DHCP на 2-х Vlan"  +/
Сообщение от Babaich email(ok) on 10-Мрт-10, 12:35 
>дык ты исключил все адреса 102 влана

Точно. Вот я лопух. Спасибо.


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру